Optiplex 3050 Intel AMT

So I followed exact steps from both Optiplex 7010 and VPro/AMT/ME discussed method and Clean Dumped Intel Engine guide to flash the ME region.

MEBx appears on the BIOS F12 menu, also hitting ctrl-P does trigger small text during boot ("Preparing MEBx menu), but I cannot access MEBx control panel and it just goes straight to OS booting (also choosing MEBx in F12 menu will make it disappear).

Link (MEGA) for SPI dump (spibak), ME dump (mebak), ME flashed (outimage, generated using the Clean Dumped guide, using 11.8 r14 repo, 11.8.55.3510 Cor H RGN bin file)
https://mega.nz/#F!LBAHWSiI!ylxiot7FQTC8Zj2uMyQgxA

How did you flash the new ME? Did you do power reset either via complete power drain for 1+ minute, or FPTw.exe -greset

This could be the issue? AMT Idle Timeout >> 0x0001 (This setting configures the idle timeout value before AMT enters an OFF state)
Unsure if that is seconds, or milliseconds, but sounds like it’s very short time and then OFF. Unsure if this is not what it sounds like, or what the default should be there.
I also see right above that, “Manageability application initial power-up state” = disabled << This one seems like it’s OK though, help text says “can still be re-enabled through MEBx interface” I would set enabled though, since you want it enabled.

plutomaniac would have best answers for you on this one

Your CSME dump cannot possibly be a clean/unconfigured firmware (RGN). Maybe you mixed the files. The outimage settings are not the same as spibak.bin and in fact AMT is disabled there. Follow the guide again using spibak.bin as input.

The outimage is build from the mebak (me dump) file not spi image. I included the spi image to make sure that there is no discrepancy between the spi and the mebak.

Edit: Just realized that the mebak file uploaded is the renamed one from the repo. Here’s the original dump (same as spibak, but just ME region) file: https://mega.nz/#!3VYkwCDA!SWyz1arjgMF1j…RISve_FUkK9Iu3I

Also i did cmos reset using jumper and remove cmos battery. Greset command is used everytime I flash the ME region.

I only checked outimage.bin initially, AMT is disabled in that as I mentioned, you need to check original vs outimage again and compare settings then make match, or use guide properly and it will transfer the settings.
However, I just checked your ME linked above and AMT is even more disabled in that one that the outimage I looked at from post one. So, AMT is disabled in your original backup, if that is the correct file. You need to enable it before building the image



Wait so aside from the 3 options in AMT tab which other option do I have to enable? (and also remember to close and reopen FIT after opening an image, I assume you opened the SPI dump and open the outimage right after, which will retain info from the spi dump)

I did not open anything before and after each other, and never downloaded SPI Dump. And when I do open some file after another, nothing is retained anyway as I delete all files inside folder before any time I open it.
Even if that is not done, settings are not retained when re-opening, I just checked to confirm. I opened your ME from #4, closed FIT, opened FIT again without deleting files inside folder, all settings reset to stock (nothing from previous file opened was there, not even same SKU)
When I commented above, at post #6, I was only talking about the ME you uploaded and posted at post #4

Please be aware, boot guard is enabled and hash set on that ME, and here is where AMT is disabled

AMT-Disabled.png



plutomaniac I am not sure about the "Timeout" value, what it should be for enabled system, can it be left that way at 0x0001?

Guys, as I said above, follow the CleanUp Guide using “spibak.bin”. To enable AMT, do it while following the guide by enabling any relevant settings as LOST showed above. Leave the Timeout as it is since it has nothing to do with MEBx.



Just realized we didn’t communicate that well… the mebak file is the “initialized”, same as spibak, all dumped BEFORE the BIOS modding (just backed up both of them for keepsake), and outimage is the only modified image and flashed using the guide. I see both you and LOST only checked the mebak and assumed that was the modified file/dump while it is not…

Anyway here’s the outimage using spibak as source image: https://mega.nz/#!6NZDGYAJ!nWyh-uFuMwype…ChrcQgFYVsCNeKs

Flashed it, same results as #1

Edit: Also did greset, removed cmos battery, move jumper to cmos clr for 30 secs, moved it back, still the same thing. MEBx menu appears in F12 menu, disappear when hit enter on it; Ctrl-P at boot invokes: “Preparing MEBx menu”, but it just disappears and goes straight to OS boot.

@n0k0m3 - I initially checked only the outimage.bin from post #1, as I mentioned. Then later checked the other file you uploaded last in post #4.

I checked your latest uploaded outimage-spi.bin, fourth setting in AMT section is still set to disabled, set that to enabled (Manageability Application Initial Power up State), otherwise AMT is disabled until you enable it in MEBx interface
I also checked the actual BIOS settings and "Manageability Features State" and "AMT BIOS Features" are both enabled by default

Reflash the actual BIOS, using stock/normal method now, in case the issue is from some bugged item in BIOS itself.

I think LOST might be right. The default value for the timeout is 0xFFFF so it could be that. Besides that, I have enabled all AMT related options and cleaned the SPI image. Try this one. The link is temporary so keep the file if it ends up working.

@plutomaniac @Lost_N_BIOS Oh dang forgot the 4th option… may be that’s the issue. Gonna fix it asap

Alright reflashed the stock backup BIOS, then flashed with @plutomaniac fix, still same problem.
Modded using FIT myself, the same problem (even with the 4th option enabled and with/without changing 5th option to 0xFFFF).

Video of the problem (literally the same no matter what the method was): https://streamable.com/zdfc1

Did you do a “fpt -greset” via Flash Programming Tool after re-flashing the fixed outimage? If that doesn’t help as well, we can’t do something more on the CSME firmware side of things. In that case the issue is somewhere at the BIOS.

I always do fptw64 -greset after flashing (just as step 15 of the guide)

Ok just researched Dell support page about my pc… Turns out, out of 3 similar product (3050 tower, sff and mini) only my version (SFF) is MEBx disabled by default… Pretty sure Dell also did something else to prevent it from being enabled again.

Thanks for the help @Lost_N_BIOS @plutomaniac . You guys can close the thread now.

@n0k0m3 - show me where you read this, if it’s in BIOS, maybe I can still enable for you. Also, please link me to a BIOS from your similar series where you know it’s enabled from your research, so I have some BIOS settings to compare with.

I find it odd, maybe incorrect, for someone to say that, when Dell left MEBx options in your BIOS, and AMT settings etc.
I see many MEbx settings, and as I mentioned before I checked and see these settings too “Manageability Features State” and “AMT BIOS Features” already enabled by default (This is in your dumped SPI that I’m looking too)
Plus, even if “Disabled by default” that doesn’t mean we can’t enable, much of what I see is enabled, so that’s why I wanted to see what exactly is said where you read this and how they worded it, was it Dell saying it, or some random person etc.

@Lost_N_BIOS https://www.dell.com/support/home/us/en/…desktop/manuals

Mine is the 3050 SFF. If you search for the term “Manageability” or “MEBx” you can see that only my version shipped (by default) disabled.

Also, from dell live chat (ProSupport), Dell Optiplex usually shipped with 6 ME options (dell internal service), but it looks like all mobo shipped with the 3050 SFF only has ME Disabled as the only option.

Since we know that the CSME firmware is now AMT-ready, the only other place of failure is the BIOS. You could do some tests if you like. From what I can see, the latest Optiplex 3050 BIOS Updater from Dell, extracted via Dell HDR Module Extractor, includes two BIOS regions.

1_CombineBiosName1_99.1.45.1_System_BIOS_with_BIOS_Guard[V46]_1.11.0.data.payload → Motherboard model 07A3
2_CombineBiosName2_99.1.45.1_System_BIOS_with_BIOS_Guard[V46]_1.11.0.data.payload → Motherboard model 07CE

You could keep a backup of your current SPI/BIOS image and try temporarily each BIOS in outimage_fix.bin to see if you can access MEBx.