Optiplex 9020 and AMT/ME

Okay everything is sorted now had to do a bios update :stuck_out_tongue:
Thankyou so much for all your help

Ok, I’ll have to assume that AMT is indeed working now. Enjoy your AMT enabled system.

Hi Plutomaniac. This thread is very interesting to me as I am having the same issue as the OP. I have carefully followed the instructions (several times actually) and re-flashed the PC with the cleaned image, however the AMT is still not available. Would it be possible to re-post that link with the fixed 9020 flash so I can test if it is my process that is flawed or something else wrong with the machine?


@frankiekat Which processor?

9020 SFF i7-4790 3.6GHz

@frankiekat i7-4790 3.6GHz should be vpro capable (if it’s not the ‘K’ version- but since you wrote 3.6GHz…)

Post bios and/or me region you created?

@lfb6 as a new user to this forum it is unfortunately not allowing me to post external links yet. I can try again next week… :confused:

It’s BIOS version A25 and used the as the Me Region replacement.

This particular 9020 has the sticker inside the case that says “3 ME Disabled”. Is it still possible to enable AMT in this case?



@frankiekat There are several threads in this forum that describe activating Dells with "3 ME Disabled"

For sharing files- mega.nz is often used, most mail providers offer to share files, shouldn’t be a problem, normally.

@lfb6 I did upload to mega.nz, but the forum software/rules won’t let a new registrant post external links in a message for the first 7 days (understandable I suppose). That said, the (short) link is tinyurl.com slash y65y5n6q.

I’ll do some more searching for the other threads for “3 ME Disabled”.



@frankiekat Which settnigs did you change? In your dump AMT is effectively disabled- see pictures comparing a 9.1 ME with working AMT (on top) and your dump at the bottom.

pic 1 - Service advertisement … Don’t think it’s relevant, but this might be bios dependant, should leave it unchanged.
pic 1 - Manageability application enable/ disable is greyed out, but becomes active when enabling AMT
pic 2 - AMT idle timeout is the time AMT waits until it goes to sleep when machine/ OS entering S* sleep.



@lfb6 yes, that finally did the trick. I must have somehow missed changing those "Featured Supported" in the instructions, but doing that did finally restore the MBEx functionality. I had to re-flash the BIOS with the OEM because something went wrong and it was giving me an "Vesa unsupported video card" error, but after that it seems to be working fine.

Thank you for all of the tips and help!


Nice! Glad it worked

Hello, Ive recently use this forum tutorial, after flashing outimage.bin and restart my optiplex 9020 wont turn on. It orange light without blinking. Pllease help.

Post / attach outimage.bin and the original dump.

this is the link to original dump and outimage

Thank You

You worked on a ME region only- how did you flash it back?

using this command “fptw64 -f outimage.bin” after restart, remove battery, power and service jumper. it stuck on orange light on power button.

last time I remember there are green message that say xx something identical

can this be fixed?

You certainly got a ‘size mismatch’ warning and disregarded it.

fptw64 doesn’t care what it writes where. It compares what it was supposed to write with the content of the chip after flash and gives a ‘task accomplished’ if both are identical. But you overwrote you flash descriptor with the ME thus successfully bricking your system.

You need a CH341a programmer (and possibly a SOIC8 clip and maybe a 1.8V adapter) to flash back your backup.

Thanks lfb6,

where is the chip position that needs to be flashed?

How would I know? I don’t own such a device.

Search the forum and the web, if unsure make a detailed and sharp pic and attach.