Optiplex 9020 and AMT/ME

I just picked up a dell optiplex 9020 SSF with code 3 ME disabled and i"m trying to do what was done in this thread to enable AMT/ME
Optiplex 7010 and VPro/AMT/ME
I need this activated to be able to use full graphics acceleration on a hackintosh project i’m currently working on.
It looks straight forward enough but i was wondering if anyone has the me.bin and amt.bin files already dumped from the A25 firmware as I’ve read you can brick the device and I’m not game to try without the correct files.
Any help would be greatly appreciated

Use your own dump. Set the service jumper, dump via “fptw64 -d spi.bin”, follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on your dump and enable all AMT related settings after step 6. Flash the output back and reset the jumper to its original position.

sorry im really struggling, do i run the command before booting to windows or run it in command as administrator and what files do i need to download to make it work. Im quite proficient on the mac side of things but this is a bit foreign for me and ive spent the last few days reading numerous threads on all your great work but still at a loss

ive tried running the exe in windows and it gets to the point where it shows all the commands but then crashes when i hit any key to begin typing. its on the 9020A25 firmware with an intel i5 4670

Set the SERVICE jumper on the motherboard (consult the manual), download Intel Management Engine: Drivers, Firmware & System Tools > Intel ME System Tools v9.1, run Flash Programming Tool with command “fptw64 -d spi.bin”, compress and attach/link to the generated spi.bin file. Flash Programming Tool is a command line tool so you must first start a command prompt as an administrator before using it. If you don’t know how to do that, a quick google search will help.

okay I managed to do dumps through a freedos bootable USB while in service mode and the files are attached as follows


in the bios as is there is no option for video on the left would this be related to the Disabled ME part of the current BIOS ?

Here is a temporary link to the fixed 12MB SPI image with AMT enabled. Flash it using “fptw64 -f SPI_fix.bin” and, once successful, shut down the system. Remove all power from the system (AC, battery) for 1 minute and press the power button 2-3 times while it’s off. Reset the jumper back to its original position and re-connect all power. Turn on the system and run “fptw64 -greset”. After the forced reboot, AMT should be fully enabled.

okay ive managed to flash it with the files provided and im super greatful for all the time you have put in helping me :slight_smile:
I still dont have the video section in the bios menu is that something that is easy to fix ?
its the section where you can select auto mode of HD4600

Please stay on-topic. You asked to enable AMT, everything else can be posted to the relevant sub-forums. Is AMT now enabled/operational?

Okay everything is sorted now had to do a bios update :stuck_out_tongue:
Thankyou so much for all your help

Ok, I’ll have to assume that AMT is indeed working now. Enjoy your AMT enabled system.

Hi Plutomaniac. This thread is very interesting to me as I am having the same issue as the OP. I have carefully followed the instructions (several times actually) and re-flashed the PC with the cleaned image, however the AMT is still not available. Would it be possible to re-post that link with the fixed 9020 flash so I can test if it is my process that is flawed or something else wrong with the machine?


@frankiekat Which processor?

9020 SFF i7-4790 3.6GHz

@frankiekat i7-4790 3.6GHz should be vpro capable (if it’s not the ‘K’ version- but since you wrote 3.6GHz…)

Post bios and/or me region you created?

@lfb6 as a new user to this forum it is unfortunately not allowing me to post external links yet. I can try again next week… :confused:

It’s BIOS version A25 and used the as the Me Region replacement.

This particular 9020 has the sticker inside the case that says “3 ME Disabled”. Is it still possible to enable AMT in this case?



@frankiekat There are several threads in this forum that describe activating Dells with "3 ME Disabled"

For sharing files- mega.nz is often used, most mail providers offer to share files, shouldn’t be a problem, normally.

@lfb6 I did upload to mega.nz, but the forum software/rules won’t let a new registrant post external links in a message for the first 7 days (understandable I suppose). That said, the (short) link is tinyurl.com slash y65y5n6q.

I’ll do some more searching for the other threads for “3 ME Disabled”.



@frankiekat Which settnigs did you change? In your dump AMT is effectively disabled- see pictures comparing a 9.1 ME with working AMT (on top) and your dump at the bottom.

pic 1 - Service advertisement … Don’t think it’s relevant, but this might be bios dependant, should leave it unchanged.
pic 1 - Manageability application enable/ disable is greyed out, but becomes active when enabling AMT
pic 2 - AMT idle timeout is the time AMT waits until it goes to sleep when machine/ OS entering S* sleep.