PCI Option ROM BIOS mod für Asus P5E64WS Evolution doesn't work

Hey guys,
I hope you might be able to help me with the following problem:
I want to activate the TRIM-Order on ICH9R for Raid on the motherboard named above, but it doesn’t work out like it should.
If I implement Intel RST ROM v11.2.0.1527, the booting won’t complete (Blue Screen: BAD_POOL_HEADER) I also get a blue screen if I start the computer with an USB stick attached, but without attached HDDs/SDDs.
I suspected the ROM was too new a version, so I tried an older one with TRIM support, version: 10.1.0.1008.
If I do that, I get status report “No enough Space to copy PCI Option ROM [04:00:00]”
While working with MM Tool, I found out, that version 10.1 about 40% also is bigger than the ROM in the original Bios (ROM Ver. 8.0) which has about 38%.
In trying to compansate I deleted the OEM Logo module and replaced the Marvell ROM with a newer version, because it´s smaller than the original. Both tries ended up as described above.
I also realised, that even with an update to version 9.6.0.1014 (which doesn’t support TRIM) I won’t get an error but Winduws freezes frequently - without writing something in an Eventlog or elsewhere.
But this happens only when I use max-mem configuration (8GB). With only 4GB it works out perfectly. Cross-exchange of RAM modul and MemTest didn´t show any problem to the memory modules, so I guess, the problem is caused by the modificated BIOS, respectively by the Option ROM.
I also might add the MEMTest86+ of the seperated modules didn´t show any problems, but as soon as I start to use more than 2x2GB, there start to develop problems from test 7(Block move). This test is also Memoryslot-independent. (2x2 GB works out for both rows, 4x2GB doesn´t)
Now, that I’ve got all my ideas tried out, I am grateful for every and any ideas, you lot might come up with!
Please help and kind regards,
Martin

@ Martin_Q:
Welcome at Win-RAID Forum!

I suspect, that the rather “new” Intel RST RAID ROMs v10/v11 have problems to manage an Intel RAID array, which had been created by a very old and outdated Intel MSM RAID ROM.
This is what I recommend to do:

  1. Backup your important data, which you have on your RAID0 partitions, or backup them completely by using a tool like Acronis TrueImage.
  2. Enter the Intel MSM RAID Utility (by hitting CTRL+I) and delete the existing RAID0 array.
  3. Optional: Do a secure erase with both SSDs, which were members of the RAID array.
  4. Flash the BIOS, which contains the TRIM modded Intel RAID ROM v10.1.0.1008.
  5. After having redone your BIOS settings (incl. the RAID mode ones), create a new Intel RAID0 array by using the Intel RST RAID ROM v10.1.0.1008.
  6. Boot off the Win7 or Win8 installation medium (DVD/USB flash drive) and do a fresh install of the OS onto a partition of your freshly created RAID array. If you don’t want to do that, recover your original RAID partitions, but this is not really recommended to do.

Important: During the complete procedure you should only use the secure memory setting (2x2 GB) and no overclocking at all.

Good luck!
Fernando

Hello Fernando!

Thanks for your answer.
The problem is that when I update the Option ROM to 10.1.0.1008 with (or without) TrimSupport (same result with both ROMs) I will get the BIOS-POST message “No enough Space to copy PCI Option ROM [04:00:00]”. When I ignore this error, disconnect all my hdds+sdds and take 2 new ssd’s, create a RAID0 Array and try to install Win7 I will get a blue screen (STOP: 0x0000007E (0xC0000005,0x00000007,0x80B866B4,0x80B86290) at the 1st boot attempt. I secure erased the two new SSDs using GParted.
Because of the “No enough space”-error I think that this Option-ROM-update is not compatible with this X48-Chipset based Mainboard … because this error occurs before the o/s starts booting.

Greets
Martin

Hello Martin,

there is obviously not enough space within your BIOS for loading the OROM while booting.
This is what I recommend to do:
1. Remove the BIOS Logo bmp file from the BIOS.
2. Reflash the modded BIOS, which contains the TRIM modded Intel RAID ROM v10.1.0.1008, but no BIOS LOGO file).

Good luck!

@Martin_Q

Possibly your BIOS can not deal with loading OROMs that are larger than 64k into memory.

Here’s a modded 8.0 you could try. Note that these older ROMs seem a bit more finicky with checksum so added csum correction at end of file padding. I just did a quick test on P45 and seems okay with 11.2 driver. The RAID0 array was not the boot disk so that I have not tried.

8.0.0.1039TMod.BIN.zip (38.3 KB)

@Fernando As i wrote in my 1st post: I already tried this - but thanks.

@CPL0 THIS ROM WORKS ! Thank you ! It doesn’t work perfect, but it works good enough. Means: I got a Win7 setup error - something like “Setup was unable to copy files” - Same error on the same position with a SetupDVD and an USB Installation stick. But when I connect my “old” SSDs where Win7 is already installed in RAID0 mode they work without problems. This is not really a problem for me… Because I don’t reinstall my o/s really often. So if I have to do this I must flash the original BIOS and after this I flash the modded one. - Good solution.
The only test which is remaining is how the mainboard behaves when I put in max. mem (8GB)… This I will test asap (The PC is in a 19inch enclosure which is in a 19" case. On this case there stands an amp-rack which is heavy weight… so it’s not easy to insert some mem.module quickly) But when I finished testing I will reply.
Thanks alot again

I am sorry, I haven’t read your posts carefully enough.

Have you already tried, if TRIM is active within your RAID0 array?
CPL0 has modded the OROM to support TRIM in RAID0.

in command prompt i typed "fsutil behavior query disabledeletenotify"
I got “DisableDeleteNotify = 0” so I think TRIM should be enabled, isn’t it ?

That only means, that the TRIM command is sent by the OS, but not, that it really passes through the Intel RAID Controller into the RAID0 array.
You should run the TrimCheck tool from within the root of drive C (look >here<), but before you do that, I recommend to trigger TRIM. If you are running Windows 8/81, you can do it by running the on-board “Optimizer” (former Defrag Tool). Otherwhise I recommend to use the “Trim trigger” feature of Anvil’s Storage Utilities.

Your’re right… TRIM is NOT working. When I run Anvil’s Storage Benchmarks → Trigger “TRIM” I get immediately the message “All drives do not respond to the “TRIM” command.”

:frowning:

Intel RST Ver. 12.9.0.1001 is installed

@Martin_Q I would not rely on ASU for trim testing, try trimcheck instead. After first run wait 30 seconds then run again, if negative try either reboot or a quick disk check without fixes.

Edit: I just downloaded ASU and this is what I get.

8_Trim.png



Is this the message you are referring too? That just means that “some drives” may not respond as you can see in my own test bottom right which doesn’t trigger trim but actually sends the command, the WDC HDD and Sandisk USB Flash do not support sending trim. Note that ASU reports OROM version but RST 11.2 does not. 0.0.0.0


Regarding installation of W7, did you copy the files from the DVD to the USB drive? Might be worth downloading the ISO from digitalriver (MS agent) and try again.

According to my experience it is not a good idea for users with an Intel ICH9R/ICH10R chipset system to install any Intel RST(e) driver v11.5 or higher.
You should better install a "conventional" (without additional SCSI filter driver named iaStorF.sys) Intel RST driver like v11.2.0.1006.

Probably a good idea. It is an old board but FWIW I tried 12.9 RST on the EP45 (ICH10R) and trim still worked with 8.0 OROM. Only strange thing I noticed is that 12.9 now reports the OROM version and ASU doesn’t ! Opposite of RST 11.2.

I could see how the message from ASU could be misinterpreted into thinking that trim does not work on any drives.

Yes, i referred to this message from Anvil’s Storage Benchmarks. While testing there were no additional drives than the 2 Raid-0 ssd’s connected.
But ok, when you say it’s better to test with trimcheck, I tested it with this program… but… same result (see attachment). I also restarted the pc after the 1st step.
I also installed the older RST Version 11.2 - same result

The W7 Installation stick/DVD are both ok, I already installed other pc’s from this installationsource without getting errors. - But this is the least important issue on my checklist :slight_smile:

no-trim.jpg

Just to avoid any misunderstanding: My suggestion to run an RST driver instead of an RST(e) one had nothing to do with the TRIM support.
The actual Intel RST(e) drivers from v11.5 up were neither designed nor optimized for Intel 3- or 4-Series chipsets.

Thank you for trying that Martin. If you are not understandably fed up by now I would like to know which SSD’s you are using.

Hi CPL0! Thank you for helping me. The SSD’s are 2x 64GB Samsung MMCRE64G, also known as PB22-J.
I bought this SSDs in 2008. At this time Trim was not supported. But I think I made a firmwareupdate to Ver. VBM19C1Q which supports RAID a few years ago, but I’m not sure. Is there any possibility to check the Firmware Version within the RAID array ? In the RAID BIOS I only see the serial numbers, and in the device manager → drives → Hardware id’s I only see IDE\DiskBOOT1.0.00__ … so nothing interesting there…

@ Martin_Q:
According to >this< thread the Samsung PB22-J do support TRIM since the last Firmware Update from the end of 2009. Unfortunately the download link to the Firmware is dead. It seems, that Samsung doesn’t support these old SSDs anymore. Even the “Search” function of Samsung’s support pages didn’t find your SSD.

The easiest way to check the Firmware will be running Samsung’s SSD tool named Magician (actual version: 4.3), but I do not know, if your SSDs are still supported.

@Martin_Q

Use latest BIOS 0802. In BIOS -> Advanced -> Onboard Devices Configuration disable LAN Boot Rom (NOT Gigabit LAN) and also IDE/eSATA Boot Rom from Marvell. If you don’t have anything connected to Marvell ports, disable all together Marvell IDE/eSATA. Try again with 10.1.0.1008. You had too many devices with boot capabilities in limited shadowing space.


You could try HWInfo32 or CrystalDiskInfo.

SSDVer.png