[Problem] ADATA XPG SX2800 on an M.2>PCIe NVMe adapter

Hi, NVMe v1.3 drives are working properly?
I have a problem with the ADATA XPG 8200 drive. BIOS sometimes freezes, once in a few boot.
There was no problem on other disks. I noticed that the working models are Gen3 x2 / x4 NVMe v1.2
I don’t know if it’s the fault of this disk model, adapter or support for NVMe v1.3 driver.
Tested on three XPG models.

@pako :
Yes, all NVMe SSDs, which support the NVMe standard up to v1.3, are working properly with the NvmExpressDxe modules, which we are offering within the start post.
So it must be the SSD itself, which may be faulty.

I just have this driver in the GA-X79S-UP5 motherboard. These disks work without any problems on other motherboards with the m.2 port.
Now I don’t know whether to replace the disk or the adapter. NVMe v1.3 support is just a change in the driver, new commands only?
I am surprised that different models of drives with NVMe v1.2 work properly.

Yes I had same issue, even on my Schenker S506 Laptop, that firmware freezes entirely (CPU fan spinning faster and faster), suddenly when selecting booting WIndows-Bootmanager a boot entry on a faulty HDD drive (bad sectors) (connected via SATA-USB-adapter-HDDD dock externally). Problem was reproducible. Maybe it’s similar issue with your ADAT M.2 SSD.
If not, let’s hope, maybe ADATA has a firmware update.

And i heard issues e.g. on M.2-nVME-to-USB 3.1-Gen2-USB-C enclosures, that some ADATA series might cause problems.
Maybe the XPG 8200 Series is also affected.

After Christmas I will check if there is a new disk frimware. However, I have a PCI adapter, not USB.
For me, after restarting / turning on the computer, the BIOS freezes, the screen is black, there is no POST information.

I will buy another disk with NVMe 1.3 standard and see if it will be the same again. I am thinking about Silicon Power P34A60c or PNY XLR8

@pako - I agree with Fernando, no issues with that drive, I use that same exact one, and other users here too, no issues - Installing Clean Win7x64 on M2.2280 PCIe Gen3x4 SSD A-DATA SX8200 Pro
Firmware update is done through the ADATA SSD Toolbox software, you can download it at Adata site. I use it with a $4 adapter - https://www.amazon.com/gp/product/B07GPBBCGS/

I bought another Delock adapter and still the same, tested on another ADATA SX8200 drive. The latest frimware, why other NVME v1.2 drives work and this model does not? Unfortunately, I have no other drives with NVMe v1.3 I’m afraid to buy the next one.
Anyone have any idea why I have such problems? The BIOS turns on once every 4/5 of the computer turns on.


I’m sorry the computer doesn’t turn on/start correctly.

Maybe your computer “just” won’t boot from those two SX8200-drives in those two Delock-adapters. That it is NOT detected to boot (even with modded firmware on that computer, where other M.2-nVME SSD boot), does NOT imply automatically , that the SSD was broken.

I’d recommend you, to boot a Knoppix-Live-Linux_System from a USB-flash drive, and then check if the ADATA-SY8200 drive is detected from a running system.:
[EDIT] If you get computer to turning on in 4 of 5 cases, use the chance and boot Knoppix-System from USB right away, and check if the SSD is recognized at least from running system.
Later you can diagnose problem, why computer is not booting reliably with and/or without the adapter.

E.g. I bought an Samsung SM-951-nvme used from a person picking up from home. It didn’t boot in his Mac M.2 nvme-slot, but was detected in a running system from other booted media (on another machine). It probably would have been detected on his MAC Desktop from an already running Knoppix, but the person of course didn’t want test it, (“why test it if I cannot boot from it anyways” - at least it might have helped to find out if the SSD was broken or kind of firmware-boot-issue only)

Sometimes B+M-Key adapter could make problems on some M-Key SSDs, or B+M-Key SSDs in a M-Key-adapter.
(yes on some USB-to M-Key adapters, there was some information from seller its page, that some ADATA-SSD models wouldn’t work, and some say that B+M-Key SSDs wouldn’t work in M-Key adapter. Mattering USB-M.2 adapter or a PCIe-M.2-adapter, I wouldn’t exclude that possibility that this could also happen on latter one(!), at least not to boot, or not detected entirely, on some adapters, even though the mainboard’s firmware detects other M.2 SSDs perfectly.
Yes that shouldn’t happen at all, it’s not logic, but it’s not new that many built hardware/firmware/software is not really tested carefully by manufacturers nor looked through well for bugs etc.
Yes I know SX8200 is M-Key, but still an adapter could have some kind of bug or too bad signal level, and or s.th. is a bit slightly different with the adapter compared to a native M.2 slot, which causes some kind of bug either in SSD’s firmware or M.2 adapter.

Here for your case, may I ask back, is your Delock PCIe adapter B+M Key? (Is the adapter active/passive ?)
Which model?

Even though pure M-Key SSDs are standardiced to work in B+M-Key-slots/adapters and vice versa, sometimes it strangely would not.

If you’ve bought enougher adapter, is it the same Delock-adapter? If it’s just another sample of the same PCIe-M.2 adapter’s model, maybe that kind model makes issues with the ADATA SX8200 or vice versa.
Perhaps testing with another model of PCIe-M.2-(M)-Key or PCIe-(B+M)-Key adapter helps (but NOT using the same type of product)

But before I’d test in e.g. a Knoppix-Live-Linux-System, before potentially buying anything new for nothing (!)
And it helps the community to know of issues with the nVME-mod an/or adapter.
Even when testing in Windows, I’d also check the SSD is detected in Linux/Knoppix on that machine. If yes, then it’s a firmware issue, that the nVME-mod is not always so reliable.
You can also try with remodding with “NvmExpressDxe_4.ffs” or “NvmExpressDxe_Small.ffs”. Maybe one of other works better.

And yes, NVME 1.0, 1.1 ,1.2, 1.3 protocl version should be upward- and backward-compatible to each other (just NOT to AHCI), and PCIe 3.0/4.0/5.0 uses other coding than PCIe 2.0/1.1/1.0, but an up- and backward compatibility is built in.

Maybe the SX8200 SSD has a bug on PCIe 2.0. Try installing grpahics card in PCIe 2.0 x4 Slot (mechanical x16 long), and the PCIe-M.2adapter+SX8200 in PCIe 3.0 x16 slot. And yes you can use the PEG (PCI Express for graphics) PCIex16 slot also for PCIe-USB adapter and most certainly also for PCIe-M.2 adapters. Tested working. The name “PEG” is a bit irritating as it implies to use only for graphics card (which is not correct).

@pako @Vincent12 @Lost_N_BIOS
Since this specific NVMe SSD problem has not much to do with the topic of >this< thread, I have moved your contribution into a separate thread and tried to give it a meaningful title.
I hope, that this is ok for you.

@pako - Did you modify the BIOS? If yes, send me copy of the BIOS, maybe bad BIOS mod causing these issues? And you confirm, this does not happen at all, if you remove the NVME drive?

Before you did this topic I created a new one here
ADATA SX6000PNP on a PCIe NVMe adapter

The computer was at work so after the weekend I will check the nvme disk on unmodified bios.

@pako - Send me your mod BIOS + Copy of unmodified BIOS, or link to stock BIOS download from manufacturer
You can’t check NVME disk on unmodified BIOS, at least not bootable, but you can put it in there as a spare drive while booting to some other disk while on stock BIOS. Then you will see if NVME or adapter is issue, or if mod BIOS is issue (I suspect mod BIOS may be the problem)

* Edit - Never mind, I see you already uploaded your modified BIOS and they have been checked in other thread. Not sure why you made another thread?

Fernando recommended to set up a separate topic. I did it because I didn’t know you would do it for me. Tomorrow I will check if the computer turns on on the original BIOS with the adapter. It would be wise to continue the thread in one topic, can it be merged?

@pako :
I can do it for you. Which threads do you want to be merged? Do you mean your 2 threads about ADATA NVMe SSDs? Are the problems quite similar?
If not, the problem may occur, that it is not clear which post belongs to which specific ADATA SSD.