[Problem] Apple SSD doesn't work with Windows

Hi Lorenzo, I’m having the same problem as you are, my Apple SSD cannot be a bootable disk in my Dell Optiplex 7010. Was your problem finally solved?

Please try to get the SSD bootable >this< way and don’t forget to report your result.

Hi Wangyu

I never managed to get it working with the Dell BIOS unfortunately. I did manage to get it working with the HP Compaq Pro’s BIOS, which I understand may be an AMI derivative. My best guess is the Dell BIOSes use some special sauce that makes the AHCI mod incompatible. In the end I bought a Samsung NVMe drive and PCIe adapter, but haven’t got around to modding the Dell BIOS with the NVMe module to test this just yet. Judging by the popularity of the Tachytelic article, I would imagine this would be successful.

I tried contacting both Apple and Marvell (the controller manufacturer) further to Fernando’s suggestion, but never heard back from them. I also dumped the BIOS of the MacBook Air the AHCI drive came from to see if I could locate and extract the relevant module, but I don’t know how to find it.

If you do find a way to get this drive booting with a Dell BIOS I’d be very interested to hear.