[Problem] Attempt to flash Mod UEFI BIOS: 18 - Error: Secure Flash Rom Verify Fail.

Hi!
Sorry if my English is not the best, I am using Google Translate.

I have an MSI CX41. That I previously made modified BIOS to unlock all options, they worked perfectly. The detail is that all these modified BIOS were made with a previous version (402 according to the MSI page) which was Legacy BIOS

I was curious to install Stock UEFI BIOS (50J) and was able to upgrade from Legacy to UEFI amazingly, but with the 50J I cannot upgrade the modified BIOS based on it. It always throws the error "18 - Error: Secure Flash Rom Verify Fail". (Image attached to publication)

It should be noted that if I try to flash the Stock 50J BIOS if I can do it without problems, likewise the Stock 60H BIOS of the MSI CR41 (Same computer, but without dedicated GPU) I can flash it without problems. But when trying to flash some modification of the 50J or 60H they all throw the same error.

Also, I cannot downgrade to 402 as I get the error: "1e - Error: Secure Flash feature does not support this file."

All this I am doing from AFUWIN with the option "Program all the blocks" and "Do not check Rom ID". (Image attached to Post) I have not tried AFUDOS or AFUEFI because I do not know how to use them, I have tried it before but I do not get any results.

Any solution to this? Thanks in advance

Captura de pantalla 2020-11-18 100250.png

Captura de pantalla 2020-11-18 100318.png

Expected…read it here

@RyuDragon2017 - What kind of CPU does this use, AMD or Intel? MSI Spec page does not load
I think from Google search it looks like Intel. Best way to do this would be via FPT, dump the BIOS region, disable any locks stopping you from flashing back mod BIOS, then flash back mod BIOS region via FPT
Do not use AFU DOS, referring to old one w/ GAN option, unless you have flash programmer, backup made with that and it’s confirmed by someone to be OK, so you are ready to recover if bricked. Same, do not use AFU anything, with /RECOVERY or /CAPSULE

Do this, link me to your correct BIOS download page (not the BIOS), and send me file from step #1, and tell me what error you get at step #2 (Do nothing here, with your modified stock BIOS, and do not use anything stock with FPT)

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below


If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required
> CLICK HERE TO DOWNLOAD CMD PROMPT REGISTRY ENTRY <

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hello @Lost_N_BIOS Thanks for your answer!!

Yes, it is an Intel, HM76 chipset. The MSI CX41 info page has been down for months. Sorry not to show more information

I didn’t quite understand the AFUDOS part… as I said, I don’t know how to manipulate it. I have only used AFUWIN

The direct download link for my exact BIOS is: https://download.msi.com/bos_exe/nb/w8_E1485IMS50J.zip
You can get it at this link: https://www.msi.com/Laptop/support/CX41#down-bios alongside version 402 Legacy.

I fixed the ME FW just yesterday thanks to “plutomaniac” in this post: Intel ME FW: N/A After BIOS reprogramming. So I will manipulate the MEI a bit. Anyway

The file you asked me from step one: https://drive.google.com/file/d/14wjdCHD…iew?usp=sharing

PD: Excuse me if my english is broken :C

EDIT: I hadn’t realized that biosreg.bin had to be obtained with the 32-bit FPT. I did it with the x64

I just edited the download link of the biosreg.bin in a .zip obtained with the 32-bit FPT. I also had no errors doing step two

Oh, excuse… I forgoted.
Flashing the biosreg.bin again i don’t have any error

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
 
Intel (R) Flash Programming Tool. Version:  8.1.60.1561
Copyright (c) 2007 - 2014, Intel Corporation. All rights reserved.
 
Platform: Intel(R) HM76 Express Chipset
Reading HSFSTS register... Flash Descriptor: Valid
 
--- Flash Devices Found ---
EN25Q64 ID:0x1C3017 Size: 8192KB (65536Kb)
 
PDR Region does not exist.
GBE Region does not exist.
 
- Reading Flash [0x800000] 3072KB of 3072KB - 100% complete.
- Verifying Flash [0x800000] 3072KB of 3072KB - 100% complete.
RESULT: The data is identical.
 
FPT Operation Passed
 

@Lost_N_BIOS What happens if I edit biosreg.bin with AMIBCP? He reads it perfectly.

Let me explain, I just unlock some BIOS options. Nothing else, not that I can do too much with an old MSI laptop model… So I just want to change Access/Usage from "Default" to "USER" so I can manipulate it.

Is it possible to edit the biosreg.bin with AMIBCP and then flash using FPT?

Captura de pantalla (41).png

I did the modifications of the biosreg.bin in the AMIBCP, I did the command in the FPT and it flashed without problems. I already have the unlocked options I wanted. Thank you!

Now I want to do something else, but I will do another post so as not to saturate this one.