Problem: DX79TO not booting properly

My black one you can’t tell, crystal is unlabeled, but my green one I can see 12.000Mhz

Sorry for the dimensions of the images but from the smartphone I don’t know how to resize them. Anyway, the exact model of the chip is: Winbond 25Q64CVSIG1221
Anmyway, I’m currently switching between all the versions of the program you gave me and a few others. I tried reinstalling and changing drivers numerous times

246CDB1A-541B-4330-B763-673D34393854.jpeg

0FA01DA2-06B7-4AE9-8F12-F3121E273E9D.jpeg

A5C437CA-0133-471B-A69E-7AEE2FD2C2D2.jpeg

5447810F-C528-4175-80E5-8F29AD4FF5AE.jpeg

09BA735E-9D82-4245-83DC-05E2705B19FE.jpeg

3BE22A46-A062-4988-B1A0-9B67FA62F503.jpeg

Thanks for new images. Try not identifying chip, or only selecting W25Q64 or W25Q64FV since BV is failing after identifying
Flip green PCB over, so that #1 is showing on top and lined up with red cable, and is on lever side of the adapter with #1 showing right along lever side.

Did you solder those pins to the green PCB? If not, that could be part of the problem, most are so loose I doubt that would ever work without solder, but I’m sure many have used them without soldering.
Seems like this might possibly be the issue since you are having such a tough time with this working/detecting properly. Maybe try to put pressure on that area as you use it, to keep good connection with the pins and PCB.
Or remove the PCB and only use the pins/cable, but if you do that make 100% sure you have orientation correct.

Please make sure you have them all in correctly before soldering if you do solder


That PCB doesn’t have numbers on it. I can swap it out for one that has numbers, but nothing changes.
They are not soldered, because I don’t have the tools and the skill to solder/desolder ;(
I think one of the problems could be the drivers. The ones that I installed from your package are from 2009, and the 1.29 version of the software tells me “Wrong driver installed”

See my edit above, remove the PCB then to rule that loose connection out, make sure pins go into correct positions, red wire down to programmer at the lever corner.

Drivers, I am not sure about, all versions in my package open fine on my PC, including 1.29 and I am using those same drivers. Try 1.18 version if latest 1.31/1.40 is giving you issues

Uninstalled and reinstalled 2009 drivers and now they works.
The thing is the PCB goes into place with the lever and it’s kinda strange, it bents a bit. I managed to get a detect succesfully and to a read. Not too confident it will work to be honest, but I’ll upload it there in a few seconds. I’m pretty sure the position of the PCB is right, anyway. https://www.sendspace.com/file/43ogte

Did you have some old computer cases where you can cut some cables off? It´s better to use the header next to the ziff socket.


Oh wow man
Unfortunately I haven’t…
You look WAY good at this, do you have any ideas on why I’m not managing to do anything?

As you said, your connectors not soldered, this will cause contact issues. If you have time buy a set of these cables. They are cheap and you can use the header without all these additional contact from socket to pcb.

https://www.ebay.de/i/173133837623?chn=ps

Another question, why are your leds on the motherboard enlighted? Did you power on the mainboard or did they light up after connection spi programmer? don´t switch on the mainboard if you add external vcc!

You’re getting there, or are there? That dump above is correct and partial BIOS, that may be all there is due to the corrupted BIOS (Source of the problem), or software versions still, lets be sure.

See if you can get a few more dumps like you did above, using the different versions of softare but make same chip ID choices. Then I will compare tonight and fix a BIOS for you. Luckily the one above contains NVRAM section which has your user data, hopefully all in tact

I can order them, I don’t really need the motherboard, I would just like to go for over 5Ghz on my E5 1650 V2 C2 and that is really it.
I have the power supply connected to the motherboard and that cause the green light to be on. I hoked it up because in this way it the software will at least recognize the SPI.
The red lights turn on when I connect properly the clip to the SPI. Kinda strange, isn’t it?

MAN, it’s such a great thing you are saying. Gotta do more of them immediatly.

Yes, you got it finally! What you dumped might be all that’s left on there, but we need to check to be sure before I send you new file to write tonight.
So, before you write anything to the chip, have you figured out the cause now of all the issues today, connection not good enough, or software/drivers or what?


Well, the thing is:
I currently have 2 SPI programmers, both black ones. One of the two does not make the RED-led of the mobo to power on, so I decided not to use it. The other one managed to do that little dump I sent you and always manage to read something different from FF.
The mobo NEED to have the CMOS battery and to be connected to the PSU, I think the CH341A can’t provide enogh power for all the board.
I have two little PCB and the one with the numbers on it seems to work better, mainly because the other I don’t know how should be placed.
I swapped out laptop in the meantime, just to make sure.
I reinstalle the drivers.
All of the versions of the software recognize the chip now, but some of them will give me error when selecting the name of the bios. They will read different kind of code, again not sure why.
I will do like 2-3 dump for the versions of the software I trust the most and then upload them. Give me 10 minutes and I will upload them.


There we are https://www.sendspace.com/file/m8im93

Sorry I didn’t ask this earlier today, before I send back BIOS for you to program in, do you need any BIOS mods done to the BIOS such as CPU microcode updates or NVRAM module inserted?

1-4 all same, so this is valid complete backup, as it is on the chip now, very nice! Did you ever, after the recovery, set the jumper back and try flashing latest Intel .BIO file using their original method? Just curious if all this could be fixed with a BIOS update (Without recovery mode enabled), or had you already tried that

Working on BIOS now

Here, lets see if we can get you up and running, then if you need any changes I asked about above I can do in another round of mods.

ME version has been cleaned, settings transferred and updated version.

Put jumper back to default non-recovery position and leave there.

Take this BIOS file and do the following with your programmer.
1. Erase chip
2. Blank Check
3. On auto button up top, uncheck erase, & blank and leave write/verify.
4. Open BIOS file
5. Press Auto
6. When you get “All operation completed chip and buffer same” then it’s verified write was OK, if they do not match write again using same steps, or user same steps with another software version

Hopefully this gets you going more smoothly and not have to do that dance you mentioned! If this still has issue, and ME shows up properly, we can try further BIOS region fixes or you can see if official update will then correct the issue via BIOS flashing
https://www.sendspace.com/file/of5396

After you program the chip and all shows OK. Please unplug the power supply from the wall, remove the CMOS battery, press and hold the power on button on the case (Or short power on pins on board) for 10-20 seconds.
Then let it sit without power for 1+ minutes, this will ensure the ME state is cleared. I am not certain if this is required when you do a re-programming like this, but good habit to follow when fixing ME issues?
@plutomaniac , can you confirm or deny if draining power to clear ME state is required when programming in BIOS w/ ME, thanks!


Thanks a lot, now I’m gonna flash it. I will keep you updated.
To address your questions, I tried to do the standard flash after the recovery process, the problem was that it required a reboot and as we know the motherboard cannort reboot. Even the update method from windows required a reboot, and so nothing to do there.
I don’t think I need any mods to be honest, I’m all about overclocking and the bios already looked pretty solid to me, unless you have anything to suggest. If there is something that can improve OC I would love to use it :wink:

Even after you put back jumper, same applied?

Sounds like you are set, nothing I can add to the BIOS options anyway due to how Intel makes their BIOS (ie no tools for us to play with or view settings etc). The only thing I can do is update CPU microcodes for you I think.
Hopefully the BIOS and reset ME gets you all sorted out!


WORKING! Man you are insane ahahaha
Even with a corrupted Intel bios, of which you couldn’t find another copy and there aren’t many tools for you managed to fix it!!!ù
I’m impressed. Very impressed.
Anyway yeah, even with the jumper. I tried everything I could before asking your help ^^
Do you know if with this programmer is possible to flash Vbioses? Because at this point the only thing that does not work in my house is a GTX 970 and soooo… ahaha
I’m getting greedy

Great all is fixed!! And no problem, you are very welcome!

I did have another unknown state dump to use in case I needed to fix any other BIOS regions, almost sent you a BIOS with fixed region swaps first, but your initial description of the issue sounded like it was maybe all Intel ME problems.
So I only used your dump, then put in a new clean ME w/ settings transferred from your old ME to the new ME version. So basically that was all you needed, ME fixed. Of course, manufacturers make stuff like that so hard, locking people out, that to fix you have to purchase tools.

Glad all is sorted out now though, sometimes fixing Intel BIOS can be a huge hassle, but this one was smooth sailing once you had a good dump. If you need any BIOS help you know where to find us!

Yes, with programmer you can program vBIOS, but you can do that on your 970 with software tools too.