Problem to get the CPU Microcodes updated

So I tried modding my bios today using MMTool. Loaded the bios into MMTool, added new microcodes for my CPU and deleted the older ones. Saved the file and tried to flash the modded bios onto bios chip #2. It was a no go. Loaded an unmodded bios onto the drive and flashed it no problem. It wasn’t all that hard to do so I must be doing something wrong. I did reopen the modded bios in MMTool and the changes were indeed there and the old microcodes were gone. Id there a guide I can follow? All I want is an older microcode in a newer bios.

EDIT by Fernando: Thread title specified

No ideas or input? Perhaps the microcode I am trying to use is too old? Maybe saving the image wrong?

@Rich_Knecht :
You cannot expect help wiithout having read the related guides and without giving the required information about your specific system.
Please do a look into the start post of >this< and >this< thread. If you still should have a question or run into a problem, post it into the matching thread. Don’t forget to mention the manufacturer and model of your mainboard!
Good luck!

@Fernando I am now trying to use the UEFI tool and can update microcodes no problem, but there is no option to replace them. I want to replace a microcode with an older version with less security mitigations. Board is a Asus Rampage VI Omega running bios 3006 with microcode 2C. I want to replace 2C with 29.

@Rich_Knecht - MMTool “Should” do this properly, but may mess up FIT table after edit, I have not checked.
But, you need to extract the BIOS body from capsule, modify it, then insert back, before you rename the BIOS to USB Flashback name (R6EO.CAP) and flash it via USB Flashback
Here’s how to do that (Post 5904) - [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS (394)

If you cannot get it, let me know and I will do the edit for you
I do suggest you stick with MMTool on this one because BOTH microcode volumes that need changed are in PEI volumes
AND, you need to use MMTool v5.0.0.7, because 4.50 only shows you one microcode volume.

What CPUID is your CPU? If 50654, I did mod for that already here (Post #362) - This is 50654 - 2006906 downgraded to 2000049, but sounds like maybe you have other CPUID, 50656 maybe?
I also did mod BIOS (3006) to add HPET, TCO, and SPD Write option to BIOS PCH Section here, if you want to use this as your base BIOS (post #29), this has stock microcodes - ASUS ROG RAMPAGE VI EXTREME OMEGA-Modded Bios?? (2)

@Lost_N_BIOS OK, trying to follow your instructions, but getting lost :frowning: CPUID is 50657

@Lost_N_BIOS OK, I THINK I got it. The hex editor thing made me a little nervous, but after copying and pasting and then opening the “new” bios up in MMTool, it loos like the microcodes have been replaced. Now I just need the guts to try flashing it.

@Lost_N_BIOS Thank you for the help in putting me in the right direction. My modded bios flashed right away without a hitch! Now, let’s see how it performs :slight_smile:

@Rich_Knecht - You’re welcome! Great to see you got it, nice job!
Yes, sorry, I only mentioned 50656 CPUID because it had 2C microcode in the BIOS (3006) I was looking at, 50657 has >> 502F01
So, unless you are using other BIOS version than 3006, windows is loading the 2C mcirocode you were seeing and unless you stop that, you wont be able to use older microcode because windows will loads it’s own still.

You should have been able to see the new microcodes in MMTool directly when you replaced them, I mean you don’t need to check that after putting BIOS back into capsule (but you can, if you wanted)
Anyway, great you were able to follow along with what I mentioned and get your mod BIOS finished and flashed