Problems flashing Biostar BTC-PRO bios onto W25Q64FV

Long story short I purchased a Biostar BTC-PRO that was somehow flashed with the non pro BIOS.

The onboard flash utility didn’t work so I’ve picked up a usb ch134a programmer, but I still can’t seem to get the bios onto the chip.

When I try to flash the chip, I get: "Verification error on address: 00000010"

Flashing the backup that I made also doesn’t work, so essentially I’ve bricked my board in the process of trying to correct the bios.

I’m not sure if maybe it has to do with the .bss extension? I’m just hoping someone here can point me in the right direction, any help would be sincerely appreciated.

The chip is a Winbond W25Q64FVAIG.

I am using AsProgrammer_1.4.1 and I have UEFITool_0.28.0 if I need it.

Setup should work, it’s mostly clamp position. Did you check the backup of the first bios for structure/ content? Did you backup the chip at east twice and got a 100% identical results?

I’m not using the clamp since the chip is not soldered onto the board, it is socketed.

Unfortunately, I was not as meticulous as I should have been when backing up the chip. I only backed it up once, the file size is 8,192kb and ( is what I get when I pop the backup into UEFITool.

TB250-BTC PRO Ver. V6.3 support
latest bios version is B25DF222.BSS (2018-02-22)

is this your board? if so,could you try flashing updated version with programmer

updated bios


[Guide] Using CH341A-based programmer to flash SPI EEPROM
[GUIDE] The Beginners Guide to Using a CH341A SPI Programmer/Flasher (With Pictures!)
[SOLVED] Need help modifying BIOS with device info from backup

Updating management engine firmware also recommended
Intel (Converged Security) Management Engine:Drivers, Firmware and Tools

As rule of thumb,keep your OS,apps,bios and drivers updated

OK if it’s a socketed chip there’s less risk for contact problems. Dump doesn’t show error messages, I’d try to compare staic bios regions to stock bios if in doubt.

Do you know which way the last bios was flashed/ is there a posibility that there’s board specific data left like serial or Mac address and would you anyway be interested in those?

Did you blankcheck?

What do you read from the chip after writing? 00000010 is just the first byte that’d be different from FF…

Thank you for the responses! I was actually able to flash it successfully about 30 min ago, after a bunch of trial and error.

When I tried again this morning(USA est), with AsProgrammer 1.4.1, I couldn’t even erase the chip successfully. Sections were full of 0s instead of Fs for some reason. I saw some posts by Lost n Bios that mentioned flashing as a W25Q64BV so I tried that but I still no luck.

I found “CH341A Mini Programmer (Black Edition) By_NSC” in the description section of a youtube video, downloaded it yesterday, before I found this forum and I didn’t have any success with it either. Not until I tried again using name W25Q64BV, like suggested. And voilà! Chip erased successfully, BIOS flashed successfully, Motherboard booted up, and posted, successfully!

After erasing and blank checking I was getting verification errors in different positions, 0s instead of Fs. Very weird but I’ve since managed to fix the chip. Thank you!