Problems with 2 Corsair Force GT 3 as RAID0

I recently upgraded my ASRock Fata1ity Z77 Professional-M (Intel Z77) with the latest UEFI BIOS (P1.90), integrated the SataDriver module and the Legacy OROM.

As a result Windows 7 x64 can’t find the boot (\BCD\EFI\BOOTX64.EFI) with the Efi driver (csm disabled). Haven’t tested this with 11.6.x.xxxx or the other branches. (Further ahead)

Windows 8 x64 appears to have an I/O problem:

Using “dism.exe” to mount and dismount .wim files from the Windows installation I noticed the entire system “locking up” in 5 second intervals, blocking my keyboard and mouse actions.
I previously had sucessfuly using this combination in Windows 8 x64, but now it doesn’t work.

Believing it is a flash problem / corruption, I will remod the BIOS e integrate again the modules.

I’m posting pictures of AS SSD Benchmark with this combination in a Windows 8 fresh install and Fernando’s benchmark of the same branch for reference.
If anyone has the same problem, even if with a different branch, let’s compare notes.

I’ll try to keep you posted.

P.S.: Using RAID0 with 128kb strip size and standard NTFS format (4kb cluster size)



Flashed the original 1.90 rom and extracted the module SATADRIVER module. Opened with hex editor and came up with:

The OROM is

If I undestood right, my UEFI revision is 2.3.1. With CSM enabled, I have as main rom. Disabling CSM, the driver changes to the

Still no impact in AS SSD Benchmark, same bad readings. I’m starting to doubt my disk configurations.

Got 2xSSD Corsair Force GT 3 120Gb in RAID0 on the 2 SATA6 ports. And 2x WDC Black 640Gb (No RAID) on the SATA3 ports. Both in the Intel Z77 controler. Plus a DVD+RW on another SATA3 port on Z77.

Getting late, tomorrow I will try a batch of SataDrivers with fresh win 8 install for each, along with benchmarks and lockup tests.

I’ll update later. o/

@ Mazzocato:
Welcome at “Win-RAID Forum” and thanks for your contribution!

I don’t think, that your problem has anything to do with the Intel RAID ROM resp. SataDriver version of your mainboard BIOS.


  1. Have you ever tried to temporarily disconnect your HDDs and the optical drive?
  2. Which OS are you running now (Win7/Win8 or both) and has it been a fresh install onto the system after having done the BIOS update?
  3. What about the write cache settings (look >here<)?

By the way: garikfox is offering >here< the latest BIOS for your ASRock mainboard with updated Intel RAID ROM and EFI SataDriver version (both are now v12.6.0.1867).

Hey Fernando,

1. No. Will try today.
2. Windows 8, Fresh install. Yes. I updated the BIOS, restored CMOS settings and started a fresh/clean install right away.
3. Tried from read to write-brack. No noticeable difference.

Thanks for the link, going to try it. I’ll post the results as soon as I can. o/


After over 12h of tests I came to a conclusion: The SSDs are the problem. Why? Well…

Tested all stripe sizes (4k, 8k, 16k, 32k, 64k and 128k). Ranged from RST 11.6 to 12.6.
RAID0 and Single (each one).

As of that, I was tired, so decided to check for other RAID setups like mine, and single ssd performance. The result:…20gb-ssd-raid0/

I still get better performance, but that as far as the SSDs will go. So I’m limited by the disks.
I assume Fernando’s benchmark was runned in a RAID0 of SSD without de SD-22xx controller, wich seems to be “my problem”.

So, RST and SSD performance are off the hook.
My responsiveness problem must be another thing; a configuration, another peripheral or add-in card hanging on me.

Sorry to bother you Fernando and who esle saw this thread.

“We know that nothing we know!”

@ Mazzocato:

Thanks for your report about your test results.
Yes, the benchmark scores are quite different from one RAID0 system to another and my 2x256 GB Samsung 840 Pro have a better performance than your 2x120 GB Crucial Force GT 3.

Since your performance "problem" obviously is SSD and not motherboard related, I have changed the title of this thread.
I hope, that is ok for you.

@ Mazzocato:

I just have found >this< article at AnandTech with the topic “Sandforce TRIM Issue & Corsair Force GS Review”, which may be interesting for you too.
Please let us know, if your RAID0 is affected by this TRIM issue.