Reading BIOS chips (2 x MX25L6473E) with CH341A Programmer & Software

@macmac - Sorry for the late reply! your comment on #19 makes me think you may have a bad clip or cable.
Chip does not need removed from the board? I assume you have and are using SOIC8 / SOP8 test clip with cable, from your comment at post #19, but maybe not?
You need one of these -
Guide with images how to use - [GUIDE] Flash BIOS with CH341A programmer

Some boards need 24/8pin PSU connected, some need them removed, only way to know is lots of testing and once you figure out then you know.
Clip may need reclipped 10+ times before it’s perfect, they are a pain sometimes, especially the cheap ones. Make sure you have both boards close together, so the cable is not stretched where it would easily move, then keep at it and you will get it.
All this is probably the issue you had with ASProgrammer and erase/unprotect too. Bad connection

Lost-N-BIOS: Many thanks for your reply, it is greatly appreciated.

That’s why I asked if there’s a more reliable way to repair my bios, such as outlined in this post:
Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip
…where, instead of the clip, he uses a connector on his mobo,
(and Flashrom ? What is Flashrom ? Is it hardware or software?)
So would this work on my gigabyte GA-Z87-HD3 mobo?

To answers the points that you have raised:

I am using the exact same clip, programmer, etc, etc, as shown in your guide, and which I have outlined in my original posts.
I have even purchased a second set, (eg: clip, programmer, etc, etc) and still get the same problems.

I have read your guide, and a great deal of other posts on this website & others.
I have tried all the previous advice.
I see that many people are struggling with the exact same problem.
Now I may be wrong, but I don’t think it all boils down to a bad clip connection.

My posts 18 & 19 summarize my situation to-date:
My 2nd current clip seem to fit perfectly, but only seems to read the chip, when I purposely make it fit badly!

I’ve not connected the PC-PSU because:
a: I have studded the PSU-outputs;
And if the PSU was attached to the mobo & switched on (eg: in standby, fans not running) I cant see any way that this could supply 3v (or any volts) to the 2 BIOS chips, because the only voltage supplied in standby is the 5v that powers the soft-start-circuit.
Which makes sense, because the bios chips don’t need any power until-after the soft-start-button as been pressed, and all of the power-rails are established.

So if connecting the PSU actually does make a difference, for some people, then it must be because of some other reason?
and …

b: The original bios-file that I read and sent to you, which you repaired, was done without my PSU connected.
So logically, I should still be able to read the chip now, without my PSU connected.

So what do you think, I await your reply.
Many thanks,

Using the first version of the BIOS file, that you repaired for me eg: M-BIOS_V1_31-MEVol3-M1.bin

I was able to detect, write, and verify the chip,
but only after connecting the PC PSU to the mobo,
and grounding its PS-On, and then switching on the PSU,
(eg: so that its fans are running)

Then I switched-off the PSU, removed its PS-On grounding, and removed the clip.

Next I inserted my 2 memory-sticks,
connected the case speaker,
connected the monitor, mouse & Keyboard.

Then I started the PC normally,
then a faint click, fans spin, fans stop,
which repeats, and repeats.

So I switched-off the PSU,
removed one of the memory-sticks.

Then I started the PC normally, and got one bleep.
The screen attempted to display something, then it when back to the same failed routine
(eg: faint click, fans spin, fans stop)

Basically I repeated this many times,
and eventually it displayed a BIOS message saying ‘no drive was detected/ I needed to set a drive to boot from’ etc

I connected a SDD, and the W10 OS on a stick in the USB socket, and rebooted.
Again it took several attempts, but eventually, it started to install W10 onto the SSD.

Windows installed OK without any problem,
even though, during the install, Windows had to stop and reboot the PC a few times.

After the install:
I closed down, and rebooted the PC a few times, without a problem.
Then, for a few hours, I left the PC on playing a looped video.
Then I shut down the PC, and switched-off the PSU.

The next day I switched-on the PSU, and powered ON the PC,
and I got the same failed routine as before,
(eg: faint click, fans spin, fans stop)
but eventually, it started OK & I reopened W10.

Basically what I’ve found:
It usually reboots OK: if the PSU main switch was left ON.
But the failed-routine returns: if the PSU main switch was switched-OFF, and then back ON.

Any ideas?

So does anyone have any ideas of how to solve my above problem?
Many thanks

Can anyone help with these queries:

Q1: Should I now, renew the BackUp-BIOS?
Q2: If so, how do I renew the BackUp-BIOS?

Q3: Is it advisable to renew the BackUp-BIOS?
(…if my current problem is due to the main_BIOS still not being right)

Q4: As I can now get W10 to boot (with difficulty, see post 23)
should I use Q-Flash to re-update the BIOS with the original Gigabyte BIOS-File?

Q5: If so, which version should I update to?
NB: I believe the current BIOS is the last one available, eg: F8, so should I update the F8 or F7 etc?
Q6: …Will Q-Flash let me update the F8 or F7 etc?

Q7: …and should I renew the BackUp-BIOS first?

NB: According to the manual you can’t flash the backup BIOS “manually”.

Many thanks

Hi @Lost_N_BIOS

Since your last reply 28 days ago:
I have continued to follow all of your advice, but I’m still having problems that I have outlined in my 4 unanswered posts above.

I appreciate that you must be very busy:
But I would grateful for your reply, only if it’s to say that you are not able or willing to help.

Many thanks.

@macmac - Sorry I’ve missing your post so long!! Sounds like you may have a dead or dying CMOS battery, or bad CMOS battery socket. When you switch off the PSU and wait 1 hour, when you turn it back on is the BIOS Clock 1 hour behind?

For Q1-Q2 - When system is in good known working and stable state, yes, go ahead and make backup match main BIOS using PS/2 keyboard and ALT+F10 hotkey at bootup (If you get boot menu instead, reboot and try again, you’ll get it, it’s tricky sometimes)
Q3 - Up to you, but yes, It’s generally best to have backup matching main, once you know main is good and stable

Q4 yes, I would do this! Use latest BIOS, and yes, it will let you - Do this first, then fix the backup (ignore manual, you can update backup)