Reading BIOS chips (2 x MX25L6473E) with CH341A Programmer & Software

@Lost_N_BIOS - I’ve been trying to read the BIOS chips (2 x MX25L6473E - M-BIOS & B-BIOS) on my Gigabyte mobo GA-Z87-HD3, because it wouldn’t boot.

I couldn’t get the software to detect the chip (when you click the [Detect] button)
I was just about to give up on this CH341A Programmer & Software V:1.34, when I decided to have one last attempt.

First I cleaned the contacts on the test clip, and then the (B-BIOS) chip.
Then I clicked the [Detect] button, and the chip was detected, then I clicked the [READ] button, and it read OK.
Then I clicked the [SAVE] button, and saved it to a file.

So what do I do next?
Could you please advise, I’ve attached some images & the file, can you tell if the BIOS info in the file is OK?

NB: This website wouldn’t let me upload my .bin file, it says it was bigger than 6KB (at: 8MB)
So I compressed as a .rar but it wouldn’t accept that type of file either.
So you can find it here: http://www.mediafire.com/file/v6rxlqb55pvm2f3/read_1.bin/file

Hope you can help.
Many thanks

Pic_1.png

Pic_2.png

Pic_3.png

read_1.rar (5.54 MB)

@macmac - For (Macronix aka MCIX) MX25L6473E Download this package - http://s000.tinyupload.com/index.php?fil…695330485827902
Use - CH341A v1.31(1.4) (CH341AFree) - choose 8MB/64Mbit - then read, verify, and save once you get "Chip and buffer or main memory match"

You can also try MX25L6465E ID in 1.30, or 1.34 with exact ID

Or ASProgrammer 1.41 has the exact ID also if you want to use that instead - https://github.com/nofeletru/UsbAsp-flash/releases/

Anyway, above is for info or future dump purposes, your dump may be OK, let me check
Looks like you attached rar file OK

Looks like you already attempted programmed in stock BIOS, correct? Or, is this backup chip dump? Please dump main, or confirm you already attempted to program in stock, then I will get you fixed BIOS to program in tonight.
Please look at sticker on board near, or on LAN metal block, and give me your MAC ID

@Lost_N_BIOS - Thank you for you prompt attention.
This is all new to me, so I may not understand some of your terminology.

When I clicked on your 1st link, I get this error message:
‘Vodafone Content Controls: Access blocked, You won’t be able to access this page because it’s been blocked by your content control settings.’

Q1: What is it for?

When I originally purchased & installed this Gigabyte GA-Z87-HD3 mobo,
its BIOS Version was: F4 / Dated: 16/05/13
Later, I downloaded & installed their latest (at that time) Firmware,
eg: BIOS Version: F7 / Dated: 20/01/14

The F7 BIOS was working OK until about a year ago, when the mobo would no longer boot.

My mobo has 2 BIOS chips (2 x MX25L6473E)
on the board they are labeled M-BIOS & B-BIOS

I don’t know which is the master/backup and which the board normally runs from?
The bin file I sent you was from B-BIOS

Q2: Do I have to ‘repair’ both of them?

If the M & B stand for Main & Backup, then my bin file was from the BACKUP.
Q3: So do you need a bin file from the MAIN ?

Q4: Is this my mobo’s MAC ID ?
This 12 digit number was on a label on-top of the LAN metal block: ************

Many thanks.

@Lost_N_BIOS - After checking further:
I think I also updated the BIOS again to: BIOS Version F8 / Dated: 08/12/14
So it was this F8 BIOS that was working OK until about a year ago, when the mobo would no longer boot.

@macmac - Sounds like you can’t download what I linked, due to your ISP or company rules etc? So you need a mirror, correct? If yes, what file hosting sites can you download from, I will upload there instead.
Here, see if you can download package from here - https://ufile.io/8l3oejqj

M = Main BIOS, B = Backup BIOS - System runs from M-BIOS, unless recovering or reflashing backup then backup BIOS would be in use during either of those processes.
Since you dumped Backup that would explain what I see and answer my questions there You need to dump main chip and send to me. No, you should only need to fix Main, and then if you want I can tell you how to copy main to backup once you have main working properly.
That can be done with PS/2 keyboard and certain hot-key combo, or you can use programmer, up to you. Sometimes Qflash will offer to flash both, but if you don’t see checkbox/option and it’s not major BIOS Update or one with new Qflash in it, then backup will not be flashed.

Yes, that looks like it’s probably MAC ID, you can edit it out now, I have saved in txt.

I’ll get you updated to latest BIOS again (F8)



Many thanks for your explanation, so I tried this new download link, and I just get the usual Windows error page, eg: 'Unable to connect, can’t establish a connection to the server at ufile.io.

And nothings shown in a (https://ufile.io) search either?
Can you put it on mediafire.com ?

-------------------


Please see the 3 attached files.
I read the M-BIOS chip twice, and saved each one in their own file, & I took SS of each of them.
Many thanks.

---------------
@Lost_N_BIOS - Hi, I appreciate you are busy, but have you had chance to read my last 2 posts, and the attached files?
Many thanks.

Read_M2.rar (5.77 MB)

M-BIOS_SS.rar (365 KB)

Read_M1.rar (5.77 MB)

@macmac - Odd that you can’t download from tinyupload.com or uploadfiles.io - But, I know how it is, I can’t download from Google or Mega.z often too.
Here is package uploaded to mediafire - https://www.mediafire.com/file/tt95sd0kn…A_Tools.7z/file

In your images, I see you did not use the information I gave you These are corrupted dumps, due to incorrect read and invalid size as well, sure there may be corruption from the bricked chip too but this is aside from what I see.
Please redo the dumps using 1.34 and the ID I mentioned. I do not need to see images, just dump it and send to me, and I do not need two dumps from same chip with same software (waste of time there)
Additionally, I would like a 2nd dump with this >> CH341A v1.31(1.4) (CH341AFree) - choose 8MB/64Mbit
And if you’re bored, go ahead and make third dump with ASProgrammer 1.41 and exact ID too, that way I can compare them all.
Please zip/rar all three into single max compressed archive, thanks. You will have to upload to some file host site and send me link, will probably be too large to attach here even if you use 7zip and max compress

Best we know which ones read your chip OK, that way less chance it will fail when you do the write, otherwise it’s not going to boot if you can’t do a proper write to the chip.



NB: I couldn’t do the following before, because previously, I wasn’t able to download your package of software.

Many thanks for your further help, but I’m a little confused,
so could you please confirm that I have understood you correctly, as follows:

My 2 BIOS chips are: MX25L6473E
And using that ID (file number) you want me to READ/VERIFY/SAVE my M-BIOS chip,
using these 3 different software versions, in the following 3 folders…
(that Ive now been able to download from your mediafire-link) eg:
a: CH341A v1.31(1.4) (CH341AFree)
b: CH341A programm v1.34
c: Ch341a AsProgrammer_1.4.1

d: ALSO in software version: CH341A programm v1.30
You want me to READ/VERIFY/SAVE my M-BIOS chip,
BUT using this ID (file number): MX25L6465E

And save these 4 saved files in 1 compressed file, and upload that to mediafire.

NB: I already have a copy of (CH341A programm v1.34) installed, that I’d downloaded from elsewhere, that I used to send you my earlier files.
Q: So can I use that, or do you want me to install your copy?

Q: Driver for all versions of CH341A:
I assume I use the drivers in folder: Driver-Install-First-Always ?
BTW: What does ‘Driver-Install-First-Always’ mean,
do I have to install the driver before I install the programs?

Q: Driver for: Ch341a AsProgrammer_1.4.1
Its driver folder: CH341-Drivers / eg: CH341Parallel_driver_support WIN7
says they are WIN7, will these work in WIN10?

Many thanks for your patience.

@macmac - Only for the MX25L6473E chip use what I mentioned. I do not want you to use 1.30 at all, unless you want to try adding in an additional copy for us to check, using the ID I mentioned
Use what I sent of 1.34, it may not be the same thing you have installed (especially since what I send is not install-able), people edit these often so sometimes different files out there with same version #

There is only one driver, install it from the package I’ve sent, the folder name means install this first then you’re good to go
Yes, works in Win10



Please download my two latest M-BIOS bin files from mediafire - here:
http://www.mediafire.com/file/bqobspyiis8y2f3/M-BIOS.rar/file

I think I’ve done as you asked, but let me know, if you need anything further.

OK: So here’s the two latest M-BIOS bin files,
both taken with with the programmes that you provided.

M-BIOS_V1_31.bin / taken with: CH341A v1.31(1.4) (CH341AFree)
M-BIOS_V1_34.bin / taken with: CH341A programm v1.34

I READ & VERIFIED each file, and then SAVED them,
after the programm displayed the a popup saying: Chip main memory & buffer same

Re: CH341A v1.31(1.4) (CH341AFree)
I couldn’t set the chip type to: MX25L6473E
because there was no options shown that would allow me to select it.
But I set it to: 8MB/64Mbit

Many thanks.

@macmac - Re: CH341A v1.31(1.4) (CH341AFree) - 8MB/64Mbit = Expected << I mentioned to do that at post #2
This is the only valid dump you’ve sent = M-BIOS_V1_31.bin / taken with: CH341A v1.31(1.4) (CH341AFree) - So use this to write back

Here is fixed F8 BIOS with your original NVRAM in place M1, if this fails, then erase and write in M2 instead this same but with only stock NVRAM in place (so BIOS profiles will be gone)
http://s000.tinyupload.com/index.php?fil…436402412780150


Thanks, but I couldn’t have done that at Post 2, because I was unable to download your programs until you put them on Mediafire at Post 7


Sorry, but again, I cant download from that location, becuase my ISP has blocked it.
So can you put it on Mediafire.
Many thanks.

@macmac - Yes, I was just saying that I mentioned you would not be able to pick by ID at post #2
Very sorry about the upload to tinyup, I forgot!! Here is re-up to mediafire
https://www.mediafire.com/file/tv4ihxhf9…c-Fixed.7z/file




Hi Lost_N_BIOS:
I downloaded your ‘repaired’ BIOS files.
Then I tried to Erase the contents of my M-BIOS (MX25L6473E) chip on my mobo.
But it wouldn’t fully erase, so now I have either…
a: a partly erased chip, or…
b: a partly corrupted chip.

This is what I did:

NB: See the attached doc file of screenshot images + copy of the file current, here:
http://www.mediafire.com/file/r6soyjcbsknezm4/After_Erase.rar/file

I opened program: CH341A v1.31(1.4) (CH341AFree)
set it to: 25SPI Flash ~ 8MB/64Mbit
Plugged in the Programmer, that’s connected to the M-BIOS (MX25L6473E) chip on my mobo.
Clicked: Detect:
Chip Info: C2201716
Clicked: Read
and the first page of contents seems the same as before.
Clicked: Erase
it said it was erased.
Clicked: Read
and the first page of contents seems the same as before, eg: not erased.
I repeated the erase several times, and nothing seemed to have changed.

Clicked: Open
and opened the original bin-file that I’d saved before the erase,
eg, the one I sent to you: M-BIOS_V1_31.bin
Clicked: Verify
and it said they (still) matched. (so it had not been changed or erased)

So I opened program: CH341A programm v1.34
Clicked: Detect:
And chip identified correctly as: MX25L6473E
Clicked: Read
and the first page of contents seems the same as before.
Clicked: Erase
it said it was erased.

Clicked: Read
and it has not erased, but the first page (or more) of contents, now seems to have changed.
I repeated erase several times.


See the attached images & file.

I re-opened program: CH341A v1.31(1.4) (CH341AFree)
Again…
I read the chip.
I opened original bin-file that I’d saved before the erase,
eg, the one I sent to you: M-BIOS_V1_31.bin
Clicked: Verify
and now it said: Chip with the contents are in disagreement
I tried to erase again, but it still doesn’t erase (or change) in this program.

So what the problem, and what do I do know?
Many thanks

@macmac - First, you need to do things little differently, no matter what version you are using.
Erase, then blank check, then open BIOS file and write/verify. This is the steps to do to write to chip, you do not need to read or erase then read anything, you already have made backups so that is waste of time and maybe messing you up
You can however, go ahead and read once I guess, if you feel you need to be sure it’s connected properly? If you do that, I’d close program and re-open once you’re sure contents looked like it’s connected and able to read chip.

Use - CH341A v1.31(1.4) (CH341AFree) - choose 8MB/64Mbit - Then erase, then blank check, then open BIOS file and write/verify - This version and your chip ID confirmed to be 100% working in other threads

Or use MX25L6465E ID in 1.30
Or 1.34 with exact ID
These two versions (1.3/1.34) may fail for write, not 100% sure, so probably not ideal here ^^

Or ASProgrammer 1.41 has the exact ID also if you want to use that instead

ONLY do this on the MAIN BIOS Chip, backup chip we can do later via hotkey or it will auto-recover on first bootup


Hi Lost_N_BIOS:
I getting nowhere with this program, I’m still getting the same sort of problem.


This doesn’t work either:
The ERASE-Icon has a red X over it, and the UnProtect-Icon has a LOCKED padlock.

If I click on ERASE-Icon:
It appears to erase, in the text box below, it says: erasing memory DONE
But above that, a red error message says:
Possible protection is enabled, Press Unprotect, and check data sheet

If I click on PROGRAM-Icon the barometer goes thru the motions of programming, but the same red error message is displayed.

----------

@Lost_N_BIOS
So what can I do to resolve this, any ideas?

@macmac - This means you are not connecting, or are loosing connection due to some reason. That could be movement during read/actions, cable stretched too tight thus loose/not connected fully, or you need to have power connected to the board and you didn’t etc
I suspect a bad connection, or wore out clip etc, or you need to leave power connected (or not) if you never had power connected before then it should be OK since you dumped once, if you had it on before but not now put it back some boards require it)
In ASProgrammer, erase only has an X over it when there is no chip connected - Unprotect always has a lock icon, that’s normal


Hi
In my first post (when I found I was able to read the chip) I left the clip on the chip.
So I didn’t remove it or disturb it.
Then eventually you received a usable copy of my bin file,
(using software: CH341A v1.31(1.4) (CH341AFree)
that you made the ‘repaired’ bin file from.

So I tried to erase my chips current contents, using the ASProgrammer, which wouldn’t work, due to the X over the [erase] button & the lock on the [Unprotect] button.

Up to this point, I have not removed or disturbed the clip, and I was still able to Read the chips contents.

So I removed the clip and refitted it many times,
and tried again using the ASProgrammer, but I still got the X and the Lock.

So I tried: CH341A v1.31(1.4) (CH341AFree):
and eventually the display changed to FF’s everywhere.

But now in: CH341A v1.31(1.4) (CH341AFree)
When I click its [Detect] button: I can no longer detect the chip.
I did briefly see ‘Chip Info: C2201716’ appear for a fraction of a second, but nothing since.

So Now: I don’t know if the clip is making contact or not, or if the chip is damaged.

So I would appreciate any help or advice you (or anyone else) can give, because at this stage it looks like binning the mobo is the only option.

Has anyone else had this problem & found a solution?
Is there another (better) way of connecting to the chip?

BTW: This chip is VSOP, ie, the type with the ‘feet’ that are soldered directly to the mobo, so there’s not much area for the clip to attache to.
The clip was new, when I first tried to connect this, but it took many attempts, before I could get the software to detect the chip.

Now: It seems in good order, except that I noticed that the tip of its plastic molding, where it grips the chip is starting to get a bit dog-eared.

Many thanks.



OK: I have purchased a new clip which seems to fit perfectly and snugly onto the chip, but it’s still not detected.
But I can get it detected if I rock the clip slightly over to one edge, but the programming still fails.

So is there any other way that I can reprogram the BIOS without having to remove the chip?

Would the method used in this post: Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip

…which seem to use a connector on the mobo, work on my mobo?
If so, can you explain what I would need to do?

Many thanks


Hi
So does anyone know of any other way that I can reprogram the BIOS without having to remove the chip?

Would the method used in this post:
Flashing BIOS chip (MX25L3205D) with CH341A progammer - can’t detect chip
…which seem to use a connector on the mobo, work with my gigabyte GA-Z87-HD3 mobo?
If so, can you explain what I would need to do?

Many thanks.