[Release] Resizable BAR BIOS EFI Module

If you want to know how to get a modded UEFI BIOS flashed into a Dell PC, I recommend to look into >this< thread or into >this< post.

1 Like

Having issues getting this to work on an ASRock Z77 OC Formula. The DXE driver inserts and appears to work fine, but there are issues with some of the patching. When the BIOS is patched fully, attempting to enter BIOS configuration results in freezing with an “A9” debug code. If I just allow the OS to boot, it actually functions, but the BIOS is stuck at default settings.

The following patches do not cause issues:
PciHostBridge | Remove <4GB BAR size limit in SubmitResources (Ivy Bridge)
PciBus | Remove <16GB BAR size limit (Ivy Bridge/Haswell)
Runtime | Remove 4GB limit for CpuIo2

The following do cause issues:
PciHostBridge | Replace 16GB MMIO region with complete use of physical address space (Ivy Bridge).
PciHostBridge | Remove 4GB limit for PciRootBridgeIo.Mem

Additionally, I believe there’s something going on similar to some Haswell/Broadwell motherboards involving downgrading 64-bit BARs to 32-bit. When I look in Windows, “large memory” does not show “PCI bus.”

Above 4G decoding is enabled, CSM is disabled. DSDT is patched.

Unmodified BIOS and my modifications are attached.
modZ77OCF2.zip (5.5 MB)
Z77OCF2.zip (5.5 MB)

when i try to flash with flash programming tool it keeps onn giving me error 167 i will try the ubu tool now

I’ll give you a tip using this forum…
There’s a search box on the forum…
Now lets try to use the correct search term you got: “error 167 protected range registers”

There you go: Search results for ‘error 167 protected range registers’ - Win-Raid Forum (level1techs.com)

But wait… you know what tool you’re using… its Intel Management Engine related:
Front page: Latest Special Topics/Intel Management Engine topics - Win-Raid Forum (level1techs.com)

Oh you found it…
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com)

I followed this guide : Enabling hidden 4G decoding · xCuri0/ReBarUEFI Wiki · GitHub

I was able to find the “4G Decod” and extract it using the latest UEFITool. After I extract the content using
IRFExtractor, I couldn’t find the “4G Decod” anymore. I hope someone can help me.

Sorry for my english

Hello @elmo89 ,

What board are you trying to modify?

Thanks for the tip but i already found a way to do it

Thanks for replying, and sorry for the late reply. I’ve been really busy these last couple days. My board is a Gigabyte GA-Z87X-D3H. I already tried adding ReBarDxe and ran the DSDT patch, but Rebar is still disabled in GPU-Z.

Hi @elmo89,

Can you post a picture of the ReBAR Tab in GPU-Z?

Like this

Is this effective for Intel’s iGPU? For instance, the integrated graphics HD610 on the G4560.

This is after I flash the bios and rebardxe. I tried both eufitool and mmtool to insert the ReBarDxe.ffs , but still had no luck. Resizable Bar is still disabled.

Hi @elmo89,

I’m not sure the Z87 Gigabyte boards had Above 4g. Not even hidden deep in the options.

Have you set the BAR size using ReBARState.exe from the command line?

You might be able to get 1GB or even 2GB working without the Above 4G

I am new here. I have 2 Motherboards Asus Z97 Deluxe & Asus Maximus VII Hero (Z97). I’ve Enabled “Above 4G Decoding” in both the BIOS but unable to Enable the “Resizable BAR” option in BIOS. Can anyone please help me by Modding these 2 BIOS File with ReBAR Enabled & all Required Patches applied?

My Build:

Z97 Maximus Hero VII
Asus ROG RX5700XT Gaming OC 8GB
(4x8GB)32GB 2400Mhz G.Skill TridentZ
Antec 1000w 80 Plus Platinum


Asus Z97 Deluxe
Asus ROG RX5700XT Gaming OC 8GB
(2x8GB)16GB 1866Mhz HyperX Fury
Corsair 750w 80 Plus Gold

Using BIOS :
Z97-DELUXE-ASUS-3503.zip (5.5 MB)

Resizable BAR works on Turing it’s complicated to setup though.

@68k-dude gave the link for it



Having trouble getting this to work on my asus z9pa-d8 with a580. Patched vs unpatched, UEFItool vs MMtool, I can never get rebar enabled through rebarstate. Rebarstate will show me the UEFI variable is active however. Anytime set over 512 (still showing rebar disabled in gpuz) I get black screen. The motherboard already has 4g decoding as option under PCIE settings in bios. I use afuwinx64 to flash the modified bios.

Any help would be greatly appreciated!

This is my large memory

Hello @homeomorphic ,

Are you sure it applied the latest patches file?

I applied the patches.txt that was updated 2 months ago. 42 lines. 3.09KB.

Uncommenting the Extend MMIOH limit to fix Above 4G Decoding (X79) yields the same result.