[Release] Resizable BAR BIOS EFI Module


Wow, she’s a lovely looking board. I’ve never seen it before.

What memory configuration is she using?

128gb 1866 ECC in quad channel. She’s a lot of fun to play around with. Trying to keep her a little longer.

HI,everybody…i try to install with uefitool the rebar.ffs,in my asus x99-e ws…i did insert,but i still cant enable…i think all is in uefi mode…and inserted …if anyone can help me ,please?
another thing,is…i try to undervolt the mobo,with the ultimate patcher tool(dont know if works on asus mobos,delete the microcodes f2…but after flashing,with eeprom programmer(socketed bios,very easy)…is on error debug 02…wich means problem with microcodes…anyone can help me with this please?thanks…i attach bios modded by me…
X99EWS.rar (7.2 MB)
X99-E WS ORIG4001.rar (7.2 MB)

Hello @andreu69 o/

Did you make a backup of your chip before flashing these modified files?

The chip might have held the MAC address, Serial Number and UUID.

As for the mod:

Can you post a GPU-Z screen shot of the ReBAR tab? It will look like this,

Best regards,


1 Like

Hi,mate…thanks to reply to me…i attached a cpuz-screenshot of rebar …can you have a look on the new attachment,i did,please?i did unlock bios already,and insert rebar…i didnt delete cpu codes,as freeze windows,no matter what…cheers…

X99EWS.rar (7.2 MB)

i attached as well a modded bios,made by me…please,check the bios,and possible correct all the mistakes i did,please?cheers mate

Hello, try these:

I updated them to lates with Rebar enabled.

You just need to load them onto a freedos usb and run the bat file.

Let me know if you have any issues.

I patched the bios and flashed it per the guide to enable ReBar, but after running ReBar State, the mobo won’t boot, the keyboard and mouse light up, fans spin up, but no video output.

Has anyone successfully modded the sabertooth bios, and can share their experiences or their modded bios file?

Would this method work on an asus z97-a 3.1? I went through the guide GitHub - xCuri0/ReBarUEFI: Resizable BAR for (almost) any UEFI system

And have modified the bios, but when attempting to flash through bios it says: “Not an appropriate bios”

I don’t see anyone else having done this (yet) on this list:

There is no USB Flashback feature that I can tell on this motherboard.

Hello @Echeese63 ,

You can clear the CMOS and she will boot.

After that, try a BAR size of 512MB, then 1GB , then 2GB then … .

If she works at 1GB and falls over above, she may need patching

Hello @Greenapp ,

Z97-a 3.1 may work if we can get Above 4GB decode to work.

-EDIT: Just looked into the latest BIOS file and there is an Above 4GB option in the “Boot” menu of the setup. \o/

Flashing a modified bios may require the use of a different flash utility.

Check the Asus section on this page for help with flashing.

I notice when flashing my bios the command in the bat does not work, you have to shorten the file name of the .rom and .cap so here is an example of the command that successfully ran in free dos.

afudos.exe Z97-DEL~.rom /gan

The file name had to be shortened, just type afudos.exe then M or Z depending on which bios you are flashing, just the first letter of the file name and press tab until it shows the right file name, then type /gan and it will work.

I hope that makes sense, I am really bad at explaining things.

When this happened for me it was because I had 32GB RAM, I dropped to 28GB and all was working ok.

Just a thought to add. :slight_smile:

I am at best passingly aware of the more technical aspects. Just aware enough to know that I don’t feel confident doing this mod myself.

What the Github describes is… well outside of my comfort zone and i fear capability. Only after getting here do I see that there’s a chipset ‘issue’ limiting things to PCI-E 2.0 speeds instead of 3.0

And n ow I’m wondering how much would be helped if that could be resolved, andy es i"d alreayd looked on the prior topic explainign ‘intended behavior’ and i’m wondering ‘can it be done anyway?’

I have the latest bios installed from there.

There are other questions but both because i’m making a request ot begin wit hand I’m a newbie I feel i’m already pressing luck, but…

Are there any other mods that would help/improve the hardware platform?

Would someone be able to add it to the Asus Maximus V Gene? I’ve tried to follow the guide on the Github page using the already NVMe enabled BIOS mod as a base but I’m getting pad changes whenever the bios is changed.
ReBarUEFI - Github

Hello @labrosf o/ Did you get it working?

I did, basically I modified the bios, run the rebar exe and after the restart it wouldn’t boot. First I removed mobo battery to clear cmos and still it didn’t boot. Yesterday I proceeded to flash the original bios with a chip programmer multiple times to no avail. And alas today after flashing like 3 more times basically the same original bios I saved I let it rest without a battery for 20 minutes and voila it worked. I don’t really thing I need rebar I was just experimenting, I’m happy as is. Thank you for your reply!

Hey there,

I wanted to try out the ReBAR mod for my old trusty Asus B250 plus mobo. Since I’m using Arch Linux only, and my BIOS already supports “Above 4G Decoding” I should only need to add “pci=realloc” to enable BAR. But I’ve got no luck so far. I wonder if anyone of you guys can shed some light (btw. this is a stock bios with above 4GB decoding)

[    0.309600] pci 0000:03:00.0: BAR 2: assigned to efifb
[    0.340882] pci 0000:00:1c.0: BAR 14: assigned [mem 0xc8000000-0xc81fffff]
[    0.340885] pci 0000:00:1c.0: BAR 15: assigned [mem 0x2000000000-0x20001fffff 64bit pref]
[    0.340887] pci 0000:00:1d.0: BAR 14: assigned [mem 0xc8200000-0xc83fffff]
[    0.340889] pci 0000:00:1d.0: BAR 15: assigned [mem 0x2000200000-0x20003fffff 64bit pref]
[    0.340892] pci 0000:00:1c.0: BAR 13: assigned [io  0x2000-0x2fff]
[    0.340894] pci 0000:00:1d.0: BAR 13: assigned [io  0x3000-0x3fff]
[    0.444767] caller get_primary_reg_base+0x4f/0xb0 mapping multiple BARs
[    4.338331] i915 0000:03:00.0: BAR 0: releasing [mem 0xf6000000-0xf6ffffff 64bit]
[    4.338334] i915 0000:03:00.0: BAR 2: releasing [mem 0xe0000000-0xefffffff 64bit pref]
[    4.338351] pcieport 0000:02:01.0: BAR 15: releasing [mem 0xe0000000-0xefffffff 64bit pref]
[    4.338353] pcieport 0000:01:00.0: BAR 15: releasing [mem 0xe0000000-0xefffffff 64bit pref]
[    4.338360] pcieport 0000:01:00.0: BAR 15: no space for [mem size 0x200000000 64bit pref]
[    4.338362] pcieport 0000:01:00.0: BAR 15: failed to assign [mem size 0x200000000 64bit pref]
[    4.338365] pcieport 0000:02:01.0: BAR 15: no space for [mem size 0x200000000 64bit pref]
[    4.338367] pcieport 0000:02:01.0: BAR 15: failed to assign [mem size 0x200000000 64bit pref]
[    4.338369] i915 0000:03:00.0: BAR 2: no space for [mem size 0x200000000 64bit pref]
[    4.338371] i915 0000:03:00.0: BAR 2: failed to assign [mem size 0x200000000 64bit pref]
[    4.338374] i915 0000:03:00.0: BAR 0: assigned [mem 0xf6000000-0xf6ffffff 64bit]
[    4.338452] i915 0000:03:00.0: [drm] Failed to resize BAR2 to 8192M (-ENOSPC)
[    4.338456] i915 0000:03:00.0: BAR 2: assigned [mem 0xe0000000-0xefffffff 64bit pref]
[    4.338488] i915 0000:03:00.0: [drm] Using a reduced BAR size of 256MiB. Consider enabling 'Resizable BAR' or similar, if available in the BIOS.

And my kernel parameters

initrd=\intel-ucode.img initrd=\initramfs-linux.img root=PARTUUID=10bb84f5-9d43-4ee2-9292-cfbed46d4a18 zswap.enabled=0 rw rootfstype=ext4 quiet splash loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0 pci=realloc

Btw. I already got my DSDT extracted according to Arch Wiki and as suggested by ReBarUEFI. But unfortunately the forum does not let me upload the dsl file.


hi all so im back here with another question about enabling rebar on some workstation i love to play with. now it’s time for a lenovo thinkstation p520c. this workstation works pretty well with my rtx 4070, but some game go really bad in dx11 (like tarkov) and to see if it can improve i would like to enable rebar. on bios i have already 4g decode, mmio set to 2g and 24t (i seee no change effect when changing those values). result is always the same; rebar not active in bios even if i use the rebar.exe and set it to 16gb or any other value.
so after some days i decided to full mod my bios by desoldering chip, program with my external programmer and solder it back, but for 2 times i had no luck.

1° i see that if i use exe, it say value is stored in variable, but my vga still remain in normal range and not in large memory.
i tried the uefipatcher and it did some apply.
i took that uefipatched bios and flashed to my chip, but when i start the pc, it beep 2 times endless meaning no post. the only way to make it work again is do a recovery bios with usb (yes on that lenovo u can restore bios if it get corrupted).
is that some secure guard protection or what is the right problem?

i was also abtle ( tnx to a post in here ) to fully unlock me, bios , desc, gbe. read/write

Screenshot 2024-02-12 215712

Hello I got a ASUS M11AA (H61) and I really need above 4G decoding and rebar. I tried modding the BIOS but it complains about it not being verified and refuses to install the new bios patch