[Request] ACER 1825PTZ

Dear All,

I just setup an old ACER 1825PTZ with 8GB RAM - Now I like to modify the Video Memory from 64MB. The section in the BIOS is in brakets [64MB] but greyed out.

BIOS is a insydeh20 rev 3.5 with ACER BIOS Version V1.3127 (from 2010): https://www.acer.com/ac/en/ID/content/support-product/2111;-;

I tried already some keys like: Fn+Tab+A -> F10 - No success so far. I also tried H2OEZE Version but I’m not able to enter [Others]. The application crashes because I guess my BIOS-File (ZE8X64.fd) is to old not fully supported by H2OEZE.

PLEASE - could somebody help me? Thanks a lot. Best would to be a unlocked BIOS

@michaelpr - You linked BIOS >> Aspire 1425P << Is that the correct BIOS?

@Lost_N_BIOS - Thanks a lot for your reply. Yes, it seems to be correct. It is the direct link from the ACER 1825PTZ support site:


Hope you can help me to unlock :slight_smile:

Best Regrads

I cannot see for sure unlock method on this BIOS, for Advanced/Power unlock, so if you want full menu unlock you will have to ask the guys at BIOS-mods.com forum, they are pro’s at Insyde BIOS.
However, I can unsuppress the setting you want to change the video memory, if we can flash in mod BIOS on this system (may take a few tries, and I will first need you to test flashing and then show me the error you get on screen)
If in the end we cannot flash mod BIOS, I can help you to directly change this to 256 or 384MB by helping you to dump and then send to me vars and I will edit then you flash it back.
Here is test BIOS flash package, show me the error you get on screen when trying to flash, then I will try to bypass that by sending you modified .dll file to replace in this package.

But, if you really just need to change that one setting, we can do below and it will be much easier and quicker
Please download the following package, and run the command below from each versions folder that directly contains it’s exe.
Once done, copy the entire folder somewhere, delete everything but any created vars.txt and then repackage this and send to me, this way all created vars.txt remain in place in the folders of the version that created them.

Thanks a lot - I’ll try as soon as possible and come backt to you. The second package I couldn’t download because a virus was reported and the download was canceled

@michaelpr - Sorry about that, turn on add blockers, or reload page and maybe different add wont be so bad? If you still can’t get it, let me know and I will re-upload to a different host
Or, it’s possible that you’re getting false positive from the downloaded package? Actually, someone else reported some possible issue too, I will repackage it now just in case someone messed with the upload after it left me, new link below!

@Lost_N_BIOS - Thanks so much for spending time at this issue! Same as before. Chrome (with Adblock) says H20UVE-Get2.7z is dangerous so Chrome has blocked it. If I bypass the block, the MS Defender reports that something is wrong. By the way, may I asked you what do you guess how dangerous it is to flash the BIOS you’ve sent within the first package? Is there a risk to brick the ACER? I’m asking because my so it using it for HomeSchooling, currently.

Best Regards

@michaelpr - sorry to hear! Can you please download these one by one and tell me which one of these is causing that? Thanks!
Then I will remove it, or replace with a clean version, if I can find one, and if you will test for me and tell me it’s OK?

H20UVE_100.00.16.08 (This one I use vars from most often, but next one can be used instead if it’s this one causing it) - http://s000.tinyupload.com/index.php?fil…926982638193595
H2OUVE_100.0.9.2 - http://s000.tinyupload.com/index.php?fil…283365510498100
H2OUVE_100.00.16.11 - http://s000.tinyupload.com/index.php?fil…850583326867660
H2OUVE_100.00.18.04 - http://s000.tinyupload.com/index.php?fil…564895923792354

The first BIOS test above is no risk to flash, and you will probably get blocked from flashing it anyway, this is why I need to see the error and get your vars dump, so we can bypass the lock blocking you to flash via FPT

@Lost_N_BIOS , unfortunately all archives seems to be causing that issue. The last one I also tried with MS-Edge and got the following: H2OUVE_100. contained a virus and was deleted

Analysing with the “Defender” says:

App found - action needed
04.06.2020 18:59

Status: Active
Active threats have not been remediated and are running on your device

Threat detected: Program:Win32/VulnInsydeDriver.A
Alert: Severe
Date: 04.06.2020 18:59
Category: Potentially Unwanted Software
Details: This program has potentially unwanted behavior.

Affected items:
containerfile: C:\Users\Michael\Downloads\H2OUVE_100.

Just did a quick research… maybe I’m wrong better I’m save:

From Insyde themselves:

If you are updating your system’s BIOS firmware using the BIOS flash package downloaded from the hardware manufacturer’s website or running software tools formally released by Insyde, please go ahead and finish the tasks you would like to do.

If not, your computer could be compromised. You are suggested to delete this application and scan your system with antivirus software to clean up your system and make sure that your system is free of malware.


@Lost_N_BIOS , I tried the first flash package and - hhmm let me say the error messages was unexpected. It says “InsysdeFlash do not support this platform. Please use IHISI flash”. Exchanging both modified files “platform.ini” and “ZE8X64m.fd” against the original ones in the same folder… and the tool does its job and flashes the V 1.3127.

@Lost_N_BIOS , I’ve created the vars dump and uploaded it: http://s000.tinyupload.com/?file_id=90626110279368968436

Three tool versions were working and the result is pretty much the same. Can you deal with it? I excepected samething like a “hidden section” I can enable with patching the right address… or at least a VGA-Section I can see the 64MB (0x40)… but nothing :frowning:


@michaelpr - Windows defender is likely false positive anyway, I would ignore that. Many programs may see these tools as issues because they can read and write to BIOS, ie “potentially unwanted behavior” I assumed you were using something better than defender, and seeing some virus issue not “potentially unwanted behavior”
They can’t all be infected, many people use these for years, and I send and receive back vars from 100’s of users over the years.

To your second post, now merged - these tool packages are not meant for you to flash anything, only to do as I mentioned.
Insydeflash is not something I sent you, it’s not part of these packages either, nor did I tell you to use it here (at least not as of now, since post #4 anyway, we’re past that and doing something else now)
The Insydeflash I sent you is your original stock one, but we’re not messing with that right now anymore, we’re dumping vars with H20UVE Since you only need one setting changed this is much quicker and easier than flashing in a mod BIOS.

Yes, some packages will error, some will not work etc. This is why I send several versions, to find one that works and maybe two, so I can pick and choose which to edit and send back
If three versions worked to dump vars great, do as I mentioned make a copy of entire folder with all versions inside, and leave all those vars in place in the folders that created them, delete everything else, and then send back to me.

* Edit - Here, flash back this modified vars using command below using the version tool package, put vars_100.00.16.08M.txt in folder with exe.
There will be list of errors/success, this is normal and expected. Reboot once done, then check again, video memory should now be 128 instead of 64MB

H2OUVE.exe -sv vars_100.00.16.08M.txt
^ If that gives you error, rename file to shorter name, with no Underscores, such as >> Varsm.txt

Sorry, forgot link! - https://ufile.io/n5msnge7
@michaelpr - refresh page for edits

Hi @Lost_N_BIOS , Thanks for your reply. I I guess I wasn’t very clear with my post. You are right, I also thought they can’t be infected all - so I downloaded and scanned via Linux. As you said - just warnings because of read/write to BIOS.

The 2econd post: I talked about your 1st testpackage "Here is test BIOS flash package, show me the error you get on screen when trying to flash, then I will try to bypass that by sending you modified .dll file to replace in this package.
http://s000.tinyupload.com/index.php?fil…8314987097&quot; So if I start it I get this message “InsydeFlash do not support this platform. Please use IHISI flash”. This is easly to reproduce at any system. If exchanging the both modified files, the tool starts. Of course on "Non-Insyde-Systems with an error message - on the ACER with flashing the V 1.3127 (because the package is 100% idencial to the original ACER then). So don’t worry - with the PTZ1825 everything is fine and the original file is flashed with the (ACER) provided tool.

At least - I uploaded all three (identical) var dumps as I wrote in my last post - here: http://s000.tinyupload.com/?file_id=90626110279368968436

I guess the the patch for changing the Video-memory has to somewhere in this data-section (with offset 0x2BC), right?

[012] “Setup”
GUID: A04A27F4-DF00-4D42-B552-39511302113D
Attributes: 0x7
DataSize: 0x2BC

or here:

[003] “Custom”
GUID: A04A27F4-DF00-4D42-B552-39511302113D
Attributes: 0x7
DataSize: 0x2BC

Thanks you so much and sorry for confusing you with many post :wink:

By the way, the most intesting thing for me is is furthermore to unlock the BIOS if possible

*edit: @Lost_N_BIOS , I refreshed page for edits and found your link - will try it :slight_smile:

Yes, sorry, I was confused a little there and forgot I sent you that test flash BIOS package, since we were now talking about just changing that one setting
As for flashing the other with test package, yes, I may be able to modify the .dll to flash, but I’ll have to dig into that in assembly. Much easier and quicker to just change the exact setting you want

See my edit above, I already made you modified vars with the video memory changed from 64 to 128

What menu sections can you see by default now? Can you see Advanced or Power? Or only Info, Main, Security, Boot, Exit?
I can unlock Power/Advanced, but flashing in mod BIOS may prove to be an issue without a flash programmer

Sorry, forgot to answer you, yes, both of those areas will be edited to change BIOS defaults
Video Memory:, Variable: 0xF1 << Offset F1 in each section is edited to change this from 01 default
Setting: Video Memory:, Variable: 0xF1[1] {05 09 F1 00 01 1B 00 31 00}
Option: 32MB, Value: 0x0 {09 09 E7 00 00 00 00 00 00}
Option: 64MB, Value: 0x1 {09 09 E8 00 01 00 01 00 00}
Option: 128MB, Value: 0x2 {09 09 E9 00 02 00 00 00 00}

Please do the following and tell me what error you get at step #2

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Thanks a lot. I don’t know why but I got a little mess up. The version didn’t work anymore after writing back your vars_100.00.16.08M.txt (unfortunately no log-file). Read back generates following:

D:\H20UVE-Get\H20UVE_100.00.16.08>H2OUVE.exe -gv vars100.00.16.08_ReadBack.txt
Now parsing Variable Information.
LoadDeviceDriver fail, GetLastError = 0x2
Failed to get bios data!
Fail to get Variable Information.

So I used version to write back the original data, re-flashed the BIOS with the ACER original package to original V 1.3127 - entered the BIOS with F2 and load the default settings. After that - still the same with version so I read out (vars dump) again with and modified the variable 0xF1 to 0x2 and wrote back with Success (I’ve 128 MB video-memory, now): see varedit.log

But read out again and compare shows a very different picture: vars_100.0.9.2_mod.txt <-> vars_100.0.9.2_ReadBack.txt

Not only the sections are in a different order (what should be fine) also some variables changed :open_mouth: - Here are the files: http://s000.tinyupload.com/?file_id=35291419766611370789

Do you know what happend and if it is fine?

By the way changing 0xF1 to 0x3 means 256MB or is 128 the max.?

With Dump BIOS and step #2 I’ll have a look later - I just read your last post. And I see only Info, Main, Security, Boot, Exit :frowning:

* Edit: I just read “Please do the following and tell me what error you get at step #2” - Dumo BIOS Region w/FTP - has it really to do with my ACER and Insyde BIOS? To be honest I can’t follow

You’re welcome! Odd about that other version! But, good to see you sorted it out yourself with
Yes, this is normal that readback is different, sometimes it remains that way due to the way NVRAM/Vars is resorted after you update it (write back in), and other times it remains the same.
I think some systems, or some versions may edit in place while others update and rebuild NVRAM/Vars as it’s updated (this is normal, usually what you update goes to end/last, pushing everything else up to above)

I am not sure about 03 (yes, it would be 256MB if it works), you can test, if you have another graphics card to use instead if it fails, so you can flash it back to 02.
That secondary section with that option may be be suppressed if you have one CPU type or another, but it may be tied to another setting, I can’t find or tell for sure.

Yes, if you have Intel CPU (Sorry I forgot to say that), the FPT stuff applies directly do you This, if we can get around error at step #2, is the easiest and safest way to flash in mod BIOS, unless you get flash programmer and SOIC8 test clip.

Yes, thanks a lot! Regarding the 0x3 I’ll think about it… currently I do not have a second graphics adapter and I’m not sure what is possilbe regarding headless access. So, it sounds risky for me even because the graphics card is a Intel Graphics Media Accelerator (GMA) 4500M - so I’m not really sure if I see a big effect with 256MB shared graphics memory.

OK, now I understand FTP - Yes, it’s an Intel CPU (unfortunately a weak SU4100 (Intel Pentium Dual Core)). I hope I have some time next weekend to go a bit deeper into it. By the way, at home I don’t have a programmer and as far as I remember, the BIOS-EEPROM is soldered on the Mainboard - same with the SU4100/GMA4500M :frowning:

Best Regards

@michaelpr - You’re welcome! Best to not test it then until you do have a programmer, in case there is no display out if it fails. You’d need CH341A + SOCI8 test clip with cable.
We can unlock if we can get past error you get at step #2 w/ FPT, sometimes it’s not a problem, other times we can’t and you’ll have to get flash programmer