[Request] Acer Aspire A315-32 Unlocking "Legacy Boot Mode Option"

~!Greetings Dear Sir/Madam/Members/Respected Win-Raid Administration_Team!~

Let me sorry for disturbing in first…

If possible please, then I need some advices,tips,hints and help in case of unlocking “Legacy Boot Mode Hidden Option” in “Acer Aspire A315-32 ver.1.15” bios file…

I want to install older operating systemm, but without unlocking of legacy boot option its not possible…only UEFI mode is actually available in settings…

And I’m sure,there must be hidden option in BIOS that somehow possible to reveal to change UEFI mode to LEGACY mode…

Already Extracted (Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi) from BIOS dump file,and its atached to my post with some of pictures about bios menu also!

With “IRFExtractor” extracted from (Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi) the file String Packages…


What’s next please?

Excuse Me For Grammatical Fouls!
Appreciate Any Crumbles of Tips,Hints and Help!

Have God Blessed Nice Day!
God Blessing To All!

EDIT by Fernando: Thread title shortened and unneeded blank lines removed

Section_PE32_image_DriverSampleDxe_SetupUtility_body.EFI.zip (125 KB)

Section_PE32_image_DriverSampleDxe_SetupUtility_body IFR.TXT.zip (49.8 KB)






~!Greetings Dear Members and Win-Raid_Administration Team!~

If it needed then no problem at all desolderin the eeprom, or writing/reading eeprom with SOIC8_Clip!

Thanks For The God I have both accessories at my hand…External chip programmer with ZIF+SOIC8_socket and CH341A+SOIC8_Clip also…

The problem is that this type of WINBOND Chipset is 1,8V based…and the cheap Chinese Chip Programmer With SOIC8_Clip CH341A is cause over-voltage came from wrong design…so i need to de-solder eeprom and read it in external programmer,i think that is the right way…but it’s OK,if not happen anything wrong in soldering procedure…

“I think” I need help only in disassembling process…because I’m stuck with that…I don’t know where I start with it…analyzed donovan older posts on his blog about bios unlock procedure,but i feel and i think its outdated howto and there is a bit more tricky or complex this procedure…


Attached V1.15 Extracted BIOS Binary from update executable just for analyzing and disassembling purposes…(isflash.zip)

Attached datasheet also about bios chip if somebody need it in future…(Winbond_W25Q64FW_Datasheet.zip)

Attached pictures about chip and motherboard for helping purpose of others if it needed in future…(EEPROM.jpg / MOTHERBOARD1.jpg / MOTHERBOARD2.jpg)

Attached Windows OS Based BIOS/UEFI Dumper Tool, only for this notebook model, if somebody need it in future to make/read bios dump without soldering…(Local_BIOS_Dumper_Win_x64.zip)-(!!!ONLY_FOR_READING_BIOS_CHIP_CONTENT…DO_NOT_USE_IT_FOR_WRITING…!!!USE_IT_FOR_YOUR_OWN_RISK!!!)-(!!!TESTED_WORKING_FOR_ME!!!)…


(GUID FE3542FE-C1D3-4EF8-657C-8048606FF670 = Section_PE32_image_DriverSampleDxe_SetupUtility_body.efi)


Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!


isflash.zip (4.18 MB)



Winbond_W25Q64FW_Datasheet.zip (1.45 MB)


Local_BIOS_Dumper_Win_x64.zip (3.15 MB)

insyde bios edit software h2ouve: https://easyupload.io/ivdzey
I am muslım and I live in turkey
Have God Blessed Nice Day!

God Blessing To All!



Ekran Al?nt?s?.PNG

~!Greeting Sir!~

Thank You So Much For Great Tip!

Unfortunately It’s not working…

When I change 0x79 from 02 to 01…after reboot the notebook stay on black screen a bit longer than usually… After that the CMOS Settings Was resetting to default and then it’s boot on default settings in UEFI mode…

I was tried to change other settings with this method like Touch-pad or GPIO Driver Brigthnes or TCO Lock,FN_Key_Function and so…all these thing working properly over this H2O_UVE…Only Legacy Boot Not…

What Do You Think Sir,there is any other settings limitate the Legacy Option…

So I need to change more settings until possible to use it properly?

Or from the UEFI/BIOS there is Missing Part Of CSM/Legacy Module?? And when it’s Missing, possible to Inject/Patch from other Acer modell to this one ?

I’m offering “reward” if somebody realy start working on this issue please…This is so abnormal what dirty game notebook manufacturers play with their customers…

Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!


InsydeH2O-UVE_TEST.zip (3.46 MB)


A04A27F4-DF00-4D42-B552-39511302113D.zip (1.37 KB)


hello I want bios dump You send me.






~!Greetings Sir!~

Thank You So Much For Your Fast Reaction And Respect for Your Useful Helping hand!!!

Requested Information Attached!
Use 7-zip.org for unpacking!
Access Sent Over PM by security reason!

In short:

My Goal Is With This Notebook Model is a “Liberation” And Get Rid Of That Vulnerable Junky NSA SpyDows_10 OS…

Absolutely clean it remove it,because the notebook was unusable in original factory default form…

And Install proper OS-es like Windows 7 with Linux Dual Boot…But for this I need CSM/Legacy Boot Option Mode…

With Simple World Low Cost Notebooks From Acer and Asus Use Cheap And Limited Junky Greedy Hardware Design…With ahead considered intention of LIMITING UEFI/EFI/BIOS options…nevermind…

I was fixed some of them, like replacement of old mechanical HDD and insufficient RAM…So Bought proper M.2_Disk and More RAM Memory…

Because Acer manufacturer decided to sell his soul for “dark_side”…That does not mean people need to accept this…

A Lot of Acer customers suffering from these issues that came from limitation of UEFI/BIOS and Hardware…We need to do something…

If this forum mean something for people then let’s do what we need to do for freedom,there is a time!!!

Another story: (…message for those whose know why i write this)…

There is a lot of strange and “fastidious” people on this and on other forum also whos not really accept critic or straight talk…nevermind…

I Don’t want to name them but I HOPE they read this…nevermind…

I hate that when somebody “brake” me, or not honest with me…Say Yes! or No!, but don’t be dummy/mute/dumb…nevermind…

And Yes,I Accept That Every Time and Effort Equal With Financial Cost…Nothing is free in this world…NEVERMIND…

>>> “The mother of a silent child does not understand her word either!” <<<

Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!


Aspire_A315-32_H2O_UVE_TEST_READS.zip (3.82 MB)

hello it doesn’t open with h2ouve as there is a problem in your bios dump file


Easy to install windows 7 or older operating systems on uefi


~!Greetings Sir!~

Thank You So Much For Your Fast Reaction And Respect for Your Useful Helping hand!!!

H2O_UVE Is a Beta Tool…I was recognized more faults with it…it’s cannot open its own dump.fd or direct RAW chip dump binaries…

Maybe this is why the tool are public…Because it’s just beta with some limited functionality…


Follow please my instructions on pictures to successfully open binary…


When You unpack bios update executable and load the “iflash.bin” file,then its load without any problem…just check attached screenshots please…

“iflash.bin” contain same as raw bios dump…only additional code included in header that help in secure flashing after reboot the system when the flashing procedure was rolling…nevermind…load “iflash.bin” and check the menu!

Also can compare the “iflash.bin” with the “h2o_uve_dump.fd”…contain same code…

Another problem with H2O_UVE…U cannot save BIOS.FD file after any of modifications…so it’s just a “viewer”…

First Must edit binaries manually with UEFI_Extractor/IDA_Pro/IFR_Extractor/Hex_Editor etc…

After that repack the BINARY and check the success again over H2O_UVE viewer…

So it’s really a limited software…This is why its public…

Real and usable things very hard to obtain and these things are expensive, valuable…

Problem with UEFI/GPT is that there not working Win7LoaderDaz…

And hard to get valid license for these old OS-es…Not talking about that Microsoft Black-hammered Win7 at 2020.January…So maybe there is problem with official activation too…

I was thinking about SLIC Inject and replace Win10 LIC with Win7 Lic Retail Key from ebay too…but I’m not sure it’s possible or how/what/where start…

Never tried edit SLIC etc…Its one of the last possible solution when there isn’t any possibility to unlock CSM/LEGACY…nevermind

Also some OS wont work properly in pure UEFI mode…so i need legacies…

So if possible then really better to use CSM/Legacy Boot…

But i understand that our knowledge is limited…

Maybe the unlocking is more complex…wee need to extract first CSM/Legacy modules from older model…and then inject it to this new Acer BIOS…

But i’m afraid about very small chances for sucess…unfortunately my knowledge and possibilities are my limits…this is why I need help and offer “reward”…

First and bigger problem is the knowledge of assembler…this is the key for success and the proper BIOS menu emulator…(Now Maybe H2O_UVE helping in this emulating…)

This model also not possible to READ/WRITE with CH341A and SOIC8_Clip…

It’s use 1,8V based EEPROM…And The resistors or some other component on PCB short direct read/write…because chip programmer software wont detect the chipset in soldered form on PCB…

De-soldering and Re-soldering isn’t working infinite time…maybe 3-4± times maximally then the PCB wires will destruct…so this is amateur method…not the right one…

Better to play first with software part…think twice, edit once…

But for a try it’s worth me a cost/time/effort…maybe not I’m the first and last person who want to use this notebook model as proper normal notebook…

Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!








download this https://www.majorgeeks.com/files/details…up_toolkit.html and send me the bios dump file isflash.bin = bios + ec
but i just need the bios file because there is only bios inside the bios chip if ec is on another chip

windows7 activator last version

~!Greetings Sir!~

Thank You So Much For Your Fast Reaction And Respect for Your Useful Helping hand!!!

Sir Please…Don’t Offend on my reaction…But You Are A Bit Wrong With Win Loader…

In First:

This post is wrong:
windows7 activator last version…(old 2.2.0 - TOUCHED/MODIFIED!!!)

Last version is >>> 2.2.2 … (please check the picture attached as evidence Test_9.jpg)

So Your download link with file (Ldr_-_programindir.cafe.rar) contain older 2.2.0 touched! version of Windows 7 Loader by DAZ…(please check the picture attached as evidence Test_7.jpg)

As I Said, DAZ Loaders NOT WORKING with UEFI GPT partition table…Only MBR!!! And MBR boot only in CSM/Legacy Mode…(please check the picture attached as evidence Test_8.jpg)

So again please…If we cannot unlock CSM/Legacy Mode Then Maybe the Only way is a legal license bought on ebay/amazon with the SLIC Injection in BIOS with UEFI/GPT mode…but i dont know the microsoft activation server still in work for win7…Unfortunately loaders isnt working with GPT/UEFI…(please check the picture attached as evidence Test_8.jpg)


Next…H2O_UVE >> not working with raw chip dump…at least i cannot open with it…Check the picture please, what i was already attached in my previous post…(Test_6.jpg)

But ok…lets try to play with raw chip dump…
Requested Information Attached "DUMP_TEST.zip"
Use 7-zip.org for unpacking!
Access Sent Over PM by security reason!

Btw. …with unpacked bios update executable is possible to read chip dump also…check my previous post how…included the dumper package also…(Local_BIOS_Dumper_Win_x64.zip)

“H2OFFT-Wx64.exe BACKUP.BIN -g”

…Local_BIOS_Dumper_Win_x64.zip better than this “infected malicious” “Universal BIOS Backup ToolKit 2.0.zip”…this is really old tool…and not really useful as i seems…




Excuse Me For Grammatical Fouls!

Appreciate Any Crumbles of Tips,Hints and Help!


Have God Blessed Nice Day!

God Blessing To All!


DUMP_TEST.zip (4.87 MB)




modeled and updated bios: https://ufile.io/b4d03nd4


Have God Blessed Nice Day!

God Blessing To All!


~!Greetings Sir!~

Oh, This Is Unbelievable!

Thank You So Much,God-Bless For This!!!

Please Give Me A Time, Until I’m Able To Test!

Because It’s need a bit hardware work,desoldering/resoldering,flash writing on external chip programmer…etc…

Ill Back To You With Result Feedback Documented In Photos As Soon As Possible!

A Question if its not a secret and if You don’t offend…because here we are for learning and helping others also…

Is there additional modifications included in bin or just this?


0x4BE7B - One Of Option: UEFI, Value (8 bit): 0x2 {09 07 94 01 00 00 02}
0x4BE82 - One Of Option: Legacy, Value (8 bit): 0x1 (default) {09 07 95 01 10 00 01}

I must ensure myself because i cannot soldering/resoldering too much time…I think PCB Wires maximally 3-4± time accept heating…

Excuse Me For Grammatical Fouls!

Thank You So Much For Any Crumbles of Tips,Hints and Help!

Have God Blessed Nice Day!




I updated some modules using the uefi update tool and then updated the intel microcode and opened the legacy option
If you have ch341a device and SOIC8 SOP8, you can write without removing the chip

tutorial video:

~!Greetings Sir!~

Thank You So Much For Your Informations,Time And Patience With Me!

I’m back now with the result as i promised!

In first…

Skipped the soldering part…because it’s look too risky actually for just a “try”…

So I was boughst 1,8V adapter for my CH341A programmer…

Because as i wroted many time the wrong design of CH341A cause over-voltage…and the chip was not detected in software without proper voltage level…

So i must reduce the 4,7V to 1,8V for ability to detect and read it…there is a converter panel for that…(picture attached…CH341A_1.8V-Adapter.jpg)


I was traced back the changes for informative purposes of course!

First Your Change:

Intel_MicroCode - Offset #7B000h/7B040h from rev.2A to rev.32 was updated as You said in your previous message and it’s looks OK…notebook accepted it and not end with brick!

Second Your Change:

Section_Patch_Rtk_2_037_x64_EA30CFA7-90B4-452C-A6BF-EABCA43885A4 - Offset #8B6A70h (EFI Realtek UNDI Driver 2.037>2.052) also was updated properly…notebook accepted it and not end with brick!

Third Of Your Change:

Try Patch For CSM Legacy Boot Option Menu Unlocking…

Unfortunately this Will End With fail…nothing was changed…still not unlocked the option menu and it’s not boot from MBR also…

So all things stay as before…so unfortunately it’s still need the proper unlock… :frowning: :frowning: :frowning:

Any new idea please?

I’m attaching another Acer Aspire IFR Code for compare purposes where the option menu is already present and visible…

Also attaching a pictures about that visible menu and about locked Acer menu…

(Reward Offer Still Available For Proper Unlocking Patch Just For Motivation Because Time And Effort is Value!!!)

Excuse Me For Grammatical Fouls!

Thank You So Much For Any Crumbles of Tips,Hints and Help!

Have God Blessed Nice Day!



Acer_V5-591G_Legacy-OK_IFR.TXT (2.92 KB)

Acer_A315-32_Unlock_Needed_IFR.TXT (3.14 KB)




back to oldest bios version may be legacy in oldest version acer completely removed legacy support but may be in oldest bios version