[REQUEST] Acer Predator G3-572

Bios Dump: http://s000.tinyupload.com/?file_id=85572431345875147803


;—; i tried myself too with some internet guides but was not able to do a little thing if someone can mod and give some help too how you did it or some info i can try and try to learn something too :slight_smile:

You do have flash programmer, correct? I ask because I am not 100% sure on this edit, so may take 2-4 BIOS and some may brick, or do nothing etc, but just want to be sure you can recover in case edit = brick.

Yes i do have flash programmer

@adeveloper79 - OK, good, hopefully no bricks, but just in case good you have! And, I assume you have dumped and written to this exact chip before, correct? So you know what software/version writes to it correctly?
First edit test coming shortly

i used AsProgrammer 1.4.1 software to dump but havent tried writing into it yet i used fpt info
W25Q64FV ID:0xEF4017 Size: 8192KB (65536Kb)
and chose it in the software and dumped it

@adeveloper79 - OK, please make new dump with software 1.30 and W25Q64BV ID from this package, this is only confirmed method I know to write to W25Q64FV chip (unsure about Asprogrammer write)
Also, please confirm that is the chip ID with your eyes, FPT info is not always correct
http://s000.tinyupload.com/index.php?fil…213094641136166

And I was not 100% sure your dump looked OK either << Due to this, please link me to the stock BIOS download page for your model, and provide me with FPT BIOS region dump >> FPTw.exe -bios -d biosreg.bin

origin bios : https://global-download.acer.com/GDFiles…C=ACER&SC=AAP_2

fpt ; http://s000.tinyupload.com/?file_id=01395943977403355986

checked the name of chip it says “winbond 25Q64JVSIQ 1722”
;–;

EDIT: disassembled lappy and tried to use 1.30 after hitting detect to verifiy its connected it shows me access violation at address …
should i ignore and make a dump
--------------------------

heres the dump with 1,.30 http://s000.tinyupload.com/index.php?fil…430096999339655

For W25Q64JV ASProgrammer and BV ID should write OK, if it fails try 1.30 and BV ID _ Battery and Power may need removed from the board, if not already
Please link me to the stock BIOS Download Page Thanks

Results package? Why are you giving me this, and why if you have that did you not get help with this at BIOS-mods?
Anyway, dump looks like OK read now that I see a FPT Dump, so we’re good there.

Here is BIOS edits to try round one - http://s000.tinyupload.com/index.php?fil…440815470599173
Please test in following order
1. FDM1
2. FDM2

If both BIOS boot OK, but neither BIOS shows menu changes, then round two begins. If both BIOS = brick, and you can’t program back in dup.bin and start system, then writing method being used is incorrect (try other)
Then once you find method that works to write back dup.bin and system boots, then re-test FDM1/2 using that same method - Then if no menu changes, round two.

As for your 1.30 dump above, what ID did you use? Ignore access violation error, carry on

Stock bios page : https://www.acer.com/ac/en/IN/content/su…roduct/7310?b=1

can you give some more info on fdm1 and 2 ;-; edit: nvm my fault :stuck_out_tongue:

for 1.30 dump i used the id u stated “BV”

------------------------

did i fk up .___.
asprogrammer is stuck at not responding
should i close and start writing again or wait

EDIT:
with ID “BV” it crashes asprogrammer at 50%
with ID “FV” it crashes it at 98% maybe

-------------------



Was able to flash back dup with ID "FV" with erase then writing
so "FV" is what i think is correct method

FDM1 if started to write hangs up the Programmer with same "FV" ID
Fdm2 boots with advanced menu too

Screenshot (3).jpg

Please use edit button instead of making multiple posts in a row, thanks
None of these programs should “Crash” and writing to chip successfully does not always mean success, sometimes even verify can be false if software/version or ID used is not compatible with chip

So, did you ever write FDM1 yet, or not? If not, please test that, thanks! That way we know if FDM1 method works, or only FDM2.
FDM1 write fail has nothing to do with the BIOS contents, only with programmer method, software/version or ID etc
You may need to connect battery and or PSU cable, some systems need this for best read/write, some need them removed, so you need to test other way than you are not since it’s crashing or stalling on you.

Good to see FDM2 has advanced at least, no other menu too, just new advanced?

Yes, once we confirm which edit method is required, I will tell you the edits made and how etc.



I had removed AC connector and battery connector
i tried FDM1 it wont flash with any of the both IDs only FDM2 flashes successfully nor with 1.30 of CH341A tool
I am sorry for multiple posts
I see DEBUG,ADVANCED,Power in BIOS
The working ID is FV

Again I’m sorry for multiple posts

BIOS will flash, try some more, you can write completely blank BIOS contents to chip, or any random data you want, programmer does not care and will not stop due to file contents.
It’s OK about the multiple posts, I was just saying that to you as I merged, part of my duties

Thanks for info about the three new menus with FDM2, need to know results of FDM1 flashed in first though, they were in order for a reason
FDM2 may have unnecessary edits in it vs 1, and those may cause random issue you run into later, so need to know about FDM1 is working menu-wise or not
Flash it in with the known working method you flashed in FDM2 with, same version software same ID etc - don’t try other things, you already know what works.
Standard method to write should be as follows >> Erase chip >> blank check >> Open BIOS file >> Write >> Verify

* Edit - @adeveloper79
I’ll be back later, maybe 6-7 hours from now, if not, then later tonight about 14-15 hours from now

*** WARNING - To ANYONE with laptop and unlocked BIOS!!! ***
DO NOT try to enable this graphics card or disable that card, switch cards etc. Otherwise you will end up with no display output (ie black screen) and no way to recover except by blind flash or with flash programmer.
You can change graphics related settings, like changing memory sizes, or core speeds etc, just don’t try to disable one card or change which is main etc.

Additionally, be very careful when trying to undervolt CPU, you can leave BIOS unbootable due to CPU voltage too low (Sometimes even 0.05 is too much)

Ok will try again flashing it in some hours and report

OK, see my edit above

UPDATE: Was able to flash FDM1.bin
AsProgrammer hangs at 50% used your provided tool version 1.30 and was able to write it
It boots to menu too with same 3 tabs

@adeveloper79 - Great to hear FDM1 works as well, it’s better anyway due to less edits done, I only made FDM2 just in case FDM1 did not get it.
Can you see >> Advanced >> Overclock Performance Menu? If yes, inside it, can you see AND change the option “OverClocking Feature” or is that grayed out? If that is missing, or grayed out, then one more edit is needed

So, here’s how to do that exact edit from FDM1 - You need hex editor + UEFITool version 25.0 (don’t user newer)

1. open BIOS in UEFITool
2. Search >> GUID >> FE3542FE-C1D3-4EF8-657C-8048606FF670
3. Expand FE3542FE-C1D3-4EF8-657C-8048606FF670 / DriverSameplDXE / SetupUtility (aka “Setup”)
4. Select PE32, right click, choose "Extract Body"
5. Open PE32 body in hex editor >> Edit at offsets shown below
90B: >> 70 >> Change to >> 00
943: >> 38 >> Change to >> 00
97A: >> 75 >> Change to >> EB (JNZ >> JMP)

6. Save modified setup P32 body
7. In UEFITool, select setup PE32 body again same as step #4, right click, choose “replace body” and browse to your modified setup file and select it as replacement.
8. Go to File >> Save Image As >> modfilename.bin

Done

And, here is what that edit looks like in assembly, which is how we find this to do the actual hex edit >>

Assembly-Flow.png

Assembly-Code.png

Overclocking feature isnt greyed out on both mods

Thank You for explaining too

@adeveloper79 - Great to hear Overclocking Feature is already ungrayed, nice!
And you’re welcome, it may or may not be same on next BIOS version, if it looks exactly the same then it probably is but if any digit is not same then I’ll have to check it for you to be sure.

Thanks :smiley: <3

Is it okay to have some options doing nothing like numlock state while booting and some having no info like in oc<memory it shows values of latencies and infos as 000000

and is it possible to add some options from other bios with same insyde and laptop lineup like in 8th gen of predator they have an option in bios to turn off keyboard backlight after sometime while being plugged to AC which my 7th gen doesnt have it only goes off if on battery

Sorry if i asked in wrong sub forum