[Request] Acer VN7-791G unlock Advanced BIOS settings & NVMe support

I have an Acer Aspire VN7-791G V 17 Nitro - Black Edition with a GeForce GTX 960M GPU and a i7 4720HQ CPU. Chipset is Intel HM86 (Lynx Point), Intel ME Version is 9.1, Build 1010, Hot Fix 2. Here are screenshots from HWinfo:

The motherboard has a M keyed M.2 slot and in the past @Lost_N_BIOS has successfully modified other users’ BIOSes in this post: /t7303f54-Acer-VN-G-NVMe-1.html , so that:
1. NVMe SSDs are recognized in BIOS and in Windows setup during install from bootable USB stick;
2. Windows 10 can be installed as only/primary OS on the NVMe SSD drive and successfully boot from there.

Unfortunately, Lost_N_BIOS seems to have moved on and is no longer frequenting this forum :frowning: What I have done so far is:
1. Enter BIOS and set Supervisor password on Security tab. ‘abc’ is good example.
2. Switch to Boot TAB and disable Secure Boot. Switch back to Security tab, enter current password ‘abc’ and both fields for new password leave blank. Press enter. Save and Exit.
3. Open HWInfo64 and under Motherboard-ME area find out which version of ME is on the system (mine is 9.1).
4. Download corresponding ME System Tools Package from /t596f39-Intel-Converged-Security-Management-Engine-Drivers-Firmware-and-Tools.html (section C.2), unpack it and copy the “Flash Programming Tool” subfolder to the root C:\ drive.
5. Run Command line as admin, navigate to C:\Flash Programming Tool\Win32 folder.
6. Type command “FPTw.exe -bios -d biosreg.bin” (without quotes) to read and backup the BIOS content to a file.
7. Type command “FPTw.exe -bios -f biosreg.bin” (without quotes) to try writing this content back to the BIOS. That failed with Error 28.
8. Successfully exploit the S3 sleep bug, which allows writing the content to BIOS after the machine has been in sleep state for more than a minute. So I just put my computer to sleep (not hibernate) and woke it a minute later, then run the “FPTw.exe -bios -f biosreg.bin” command again and had success. Screenshot here: mega(DOT)nz/file/lPglWayI#vt6RSH6nb37OgGyv9ZJMWbdMTHEMdsvM2MOcTphETbI

The backup of my current, stock Acer v1.14 BIOS, created using the “FPTw.exe -bios -d biosreg.bin” command in step 6. above can be downloaded here: mega(DOT)nz/file/VOpzzILI#AF0hg7_11fAn3CJvKwR6CUHwLzzpVRhDx4ueyPMXcak

What I would need help with:
A. Someone to download my current BIOS dump file (download link above, replace “(DOT)” with “.” as I am a new user and cannot post actual links), extracted using Flash Programming Tool as described above, and modify it so that the “Advanced” tab becomes visible in BIOS and NVMe support is enabled. Eventually then kindly re-upload it for me to flash it back to my laptop. My stock BIOS v1.14 currently has 4 tabs: Information; Main; Security and Boot (I can provide screenshots if required). Judging by @bajticzek 's excellent tutorial in this thread: /t7303f54-Acer-VN-G-NVMe-1.html , after successful modification of the BIOS the following options become available in the “Advanced” tab:


B. Someone to help me find the necessary resources/materials, so that I could explore options for modifying my BIOS myself and hopefully not brick my computer when I flash it back in :slight_smile:

Any help would be greatly appreciated!

Hi friend,
I will unkock your bios and replace the original NvmExpressDxe module with the NvmExpressDxe_4 one, but to make this to work
then you have to modify your motherboard (hardware patchs) :

Acer VN7-791G NVMe. (2)

So you are sure to want to do that ?

We can do 2 modifies type :

1. OpCodes Setuputility Module PE32 Code

Menu Tabs Unlock Mod :

FE3542FE-C1D3-4EF8-657C-8048606FF670_949.ROM Setuputility

1395 : 0F 84 D6 00 00 00 to 0F 84 00 00 00 00 jz loc_180001471 to jz $+6

13C9 : 0F 84 A2 00 00 00 to 0F 84 00 00 00 00 jz loc_180001471 to jz $+6

Or Intel Page :

2. EFI IFR OpCode modify , we make to show the Hidden Pages wirh a byte 46 >> 47 , then you have to change default to x01 , F10 Save and reboot.

0xA76E3 Suppress If {0A 82}
0xA76E5 True {46 02} >> 47 02
0xA76E7 One Of: Intel Page, VarStoreInfo (VarOffset/VarName): 0x258,
VarStore: 0x1234, QuestionId: 0xC, Size: 1, Min: 0x0, Max 0x1,
Step: 0x0 {05 A6 6B 01 E2 00 0C 00 34 12 58 02 00 10 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0xA770D One Of Option: Disabled, Value (8 bit): 0x0 (default) {09 0E FD 00 10 00 00 00 00 00 00 00 00 00}
0xA771B One Of Option: Enabled, Value (8 bit): 0x1 {09 0E FE 00 00 00 01 00 00 00 00 00 00 00}
0xA7729 End One Of {29 02}
0xA772B End If {29 02}

About the Nvme Module , i will change the original with that is posted by Fernando

GUID 5BE3BDF4-53CF-46A3-A6A9-73C34A6E5EE3 NvmExpressDxe

GUID 5BE3BDF4-53CF-46A3-A6A9-73C34A6E5EE3 NvmExpressDxE_4

Let me know

P,S, I don’t know if Lost_N_BIOS have done the same , but i hope it will work :wink:

Here You go , i made 1st Mod only with Intel Page for Advanced Menu, 2nd added support for NVME module too :


To get the Advanced / Power Menu, you have to choice the Intel Page variable under Configuration and set to 0x00 , then F10 Save and Reboot into bios.

Let me know

P.S. there is a ReadMe txt file to explain what is been done , hope all will be ok !

Hi BDMaster,
Thank you so much for this and sorry I took a while to reply, it is a national holiday (Easter) where I live.

To answer your question from your first post - yes, I am planning to go down the hardware mod path described in the original thread.

One question about the modified BIOS you kindly provided: If I flash the second version (both Advanced/Power menu unlocked and NVMe module support) by using FPTw.exe in Windows 10 cmd prompt, will I no longer be able to boot into Windows after I restart? Said Windows is installed on a M.2 SATA SSD plugged in the M.2 slot, so will flashing the 2nd BIOS (containing NVMe module support) make the board no longer recognize any SATA SSDs?

Hi friend,
I didn’t removed support module for sata, just added support for M.2 Nvme, so it will be work yet with it, but both it’s not possible and sisncerly ,
I haven’t same laptop to try this experience , I made only for you , as none replied here to help you.
For the unlocked version i prefer to use the simple one, so you boot into bios change settings on Intel Page and F10 save reboot and you look the Adavanced.
So i suggest to try the first one, ulnlock the menu advanced and try it , when all il cleared, then try the second.
By Fptw it’s a minute …
Let me know

Hi BDMaster,
I was finally able to test your quality work. Both versions flashed successfully, as suggested first I tried the “Intel Page only” version. The result in BIOS (same as with “Intel Page + NVMe module” version I tested later) was that a new “Intel Page” option/row appeared under the “Main” tab. It was initially set to Disabled, as soon as I enabled it two additional options/rows appeared in the “Main” tab: 1. “xHCI Support” with a default value of “Enabled” and 2. “Function Key behavior” with a default value of “Special Keys”. I did not change any of those 2, just hit F10 (Save changes).
After the reboot I got straight back into BIOS (F2) and the “Advanced” and “Power” tabs/menus were now both available. Here are screenshots of the successful flash of both versions under Windows 10 x64 20H2, using FPTw (Win32) from the “Intel ME System Tools v9.1 r7” suite:

Once again thanks to BDMaster for the top quality work and the detailed instructions! I will now order the 1TB Samsung 980 Pro M.2 NVMe SSD, then proceed with the hardware mods to the mainboard and get back to report the results.

sorry to jump on your thread, but i am trying to complete the same task as yasosim, and i have my biosreg.bin file extracted.

could i kindly ask that you apply the same modifications to my bios file to add intel hidden menus and nvme support?

i was also hoping it might be possible to add boot from sd card option to my bios too? maybe not possible but i can only ask.

here is my biosreg file if you have the time:

https :// www. mediafire.com/file/qm6h0gndlzzmf8i/biosreg.zip/file


Please can you make the Bios Menu Tabs you can see , so i can see too ?
There is a boot option to boot from USB, then it’s possible to boot from sd too …
You see this option or it’s hidden ?
Here is your Bios Mod :


Let me know

P.S. i will wait the photos to get here and help all the users as you … thanks

0xA61D8 Suppress If {0A 82}
0xA61DA True {46 02}
0xA61DC Gray Out If {19 82}
0xA61DE QuestionId: 0xC equals value in list (0x2, 0x3) {14 8A 0C 00 02 00 02 00 03 00}
0xA61E8 QuestionId: 0xB equals value 0x1 {12 06 0B 00 01 00}
0xA61EE And {15 02}
0xA61F0 End {29 02}
0xA61F2 One Of: USB Boot:, VarStoreInfo (VarOffset/VarName): 0x5C, VarStore: 0x1234, QuestionId: 0x5, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 A6 2B 01 2C 01 05 00 34 12 5C 00 00 10 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00}
0xA6218 One Of Option: Enabled, Value (8 bit): 0x0 (default) {09 0E FE 00 10 00 00 00 00 00 00 00 00 00}
0xA6226 One Of Option: Disabled, Value (8 bit): 0x1 {09 0E FD 00 00 00 01 00 00 00 00 00 00 00}
0xA6234 End One Of {29 02}
0xA6236 Guid: [0F0B1735-87A0-4193-B266-538C38AF48CE] {5F 15 35 17 0B 0F A0 87 93 41 B2 66 53 8C 38 AF 48 CE 00 0D 10}
0xA624B End If {29 02}
0xA624D End If {29 02}

Hi again,
That didn’t go well…
I just tried flashing the new biosreg with advanced pwr menu and nvme, and it bricked my laptop. No bios, just black screen and high speed cooling fan.
I’m just looking for a copy of the bios to try and ezflash to recover.

Otherwise my laptop is dead :neutral_face:

Not looking good.
I can’t get the laptop to recognise the .FD file on the usb stick to recovery flash.
I’ll have to find another usb stick to try.

I think it’s gone. I managed to get the usb .FD file to flash I think as the usb led flashed then the laptop switched off. But it still isn’t booting, no post, no Acer logo, just blank screen and fans.

Hi friend, something is gone wrong really as it’s the same modify as before …
Let me look if there is omethiing to do to recovery bios, otherwise, let buy the SPI Programmer CH341A and Pomona climp and we will get it back !
I will reply quickly you.

Recovery name bios file is "PoseidonX64.fd" then the Procedure is :

1) Create blank USB flash drive formatted with FAT32 (use Rufus)

2) Copy the latest VN7-591G BIOS file to the drive USB

3) Rename it PoseidonX64.fd

4) Remove AC plug and battery

5) While holding Fn + Esc, get AC plug into and power on the laptop with the USB flash drive plugged in.

6) BIOS screen does not appear; fans spin up; USB drive flashes a couple of times.

7) After perhaps 30 seconds, the laptop powers down.

Try this, i hope it will works …

Thanks for replying bdmaster.

I had managed to find the guide for usb flashing today and tried it many times. The usb drive flashes and laptop powers down but still no boot.

Now I buy the flash device you suggested with clip and also buy two pre flashed spare bios chip as backup :laughing:

Ok , i will wait your news about it and we will make the recovery firmware … i hope quickly for your laptop …

Hi again,

Happy to report the hardware mod of my mainboard went really well and I am now booting Windows 10 from the new NVMe SSD drive (1TB Samsung 970 Evo Plus).
So I followed exactly the mainboard mod described by @bajticzek in this post. Although my mainboard make (Poseidon MB 14203-1M) was not exactly the same as bajticzek’s (Poseidon 860 3D MB 14243-1), I ended up desoldering 4 x SATA-lane related capacitors: C6001, C6002, C6003 and C6004 and soldering on 4 x 0 Ohm PCIe-lane related resistors: R6009, R6010, R6013 and R6011. Funny thing, the NVMe SSD never appeared in BIOS device list (still doesn’t, neither in Legacy or UEFY mode) but when I booted from my Windows 10 installation USB it showed up straight away. Once again, thanks to @BDMaster for providing me with the “Intel Page for Advanced Menu + added support for NVME module” modification of my BIOS file.

Also special thanks to @Fernando and @plutomaniac for their excellent threads, which I followed closely when installing Windows 10 from scratch on the new NMMe SSD drive:
1. How to boost AHCI & NVMe performance on Intel systems
2. Intel ME: Drivers, Firmware and Tools

Before installing Windows, I created a MS DOS bootable USB from my other PC and used the tools and images from thread 2. above to update my Intel Management Engine firmware to the latest available version
I also installed all the latest/recommended for my system Intel RSTe, SATA, NVMe, Management Engine, USB, Chipset etc. drivers and followed all other BIOS and Windows setting recommendations from thread 1. above.

Below I will provide a little Before vs. After NVMe mod comparisons, including CrystalDisk and Anvil performance benchmarks.
Before (left) - 256 GB Transcend M.2 SATA SSD. After (right) - 1TB Samsung 970 Evo Plus NVMe M.2 SSD

1. HWInfo - motherboard main screen, notice how an additional “1xPCIExpress x4” appears in “Motherboard slots” after the mod: Before vs. After

2. HWInfo - Intel ME Version (firmware) update: Before vs. After

3. HWInfo - Bus -> PCI Bus #0, notice an additional “PCI Express Root Port 5 (PCI Express x4 Bus #9)” appear after mod: Before vs. After

4. DriveControllerInfo - SATA SSD before and NVMe SSD after: Before vs. After

5. CrystalDiskMark: Before vs. After

6. Anvil’s Storage Utilities: Before vs. After

Benchmark score improvement aside, everyday tasks/work on the laptop seems much faster & smoother after the upgrade, well worth the hassle!

WOW you’re Great !!!
Thanks for your report , it will be usefull to help many others users here …

Hello again BDMaster. I am finally back…

I had a bit of a nightmare with my laptop. the usb flashing device i got to flash my bios was a cheap chinese one that had the dreaded 5v flahing problem, and sure enough it fried my bios :frowning:

so i managed to desolder the old bios chip and resolder one of the replacements i had, and it worked! i then updated the bios from 1.11 1.14 and that worked.

then i tried dumping my biosreg.bin file and immediately flashing it to check it had dumped correctly. That was also sucessful!

So now i am back to square one. i have my biosreg.bin file and i know it works, so i am wondering if i should try to modify it again…