[Request] Add support for e-2286m CPU (now on Socket 1151) for Asrock Z370 Pro4

Hello! I am new to the bios modding world, and keen to learn.
Background story: I bought a second hand modded CPU/motherboard combo (e-2186m CPU and MSI Z370M Mortar/S1) a while back. This made me want to learn more in order to try do this myself as a hobby, and also to update the previous mentioned setup.
Here is my current situation, and me parading my ignorance(!): I have an Asrock Z370 Pro4 motherboard (second hand), and I have a Xeon e-2286m modified CPU. I was provided with a .bin file for this motherboard with the modifications done so that it supports the re-socketed e-2286m CPU.
I have also ordered a EZP2019 programmer, and my intention is to flash the new bios directly on the motherboard with a SOP-8 CLIP cable.
I have read quite a bit of guides, and videos, but I am still hesitant on the right steps:

  1. Read and save the current bios
  2. Check the Mac Address stick and check if it is actually in the bios or directly in Ethernet adapter
  3. Check the motherboard uuid and S/N, not sure how to do the first one
  4. Re-inject (?) the above 3 information in the .bin file provided with the CPU for my motherboard

Could I ask some of the veterans out there if the above plan makes sense at all, and if there is anything else that I should consider before drilling down into more details?
Please not that I do not have any CPU “normally” supported "out of the box by the motherboard, so all I can do is via the SPI programmer.

The forum is to share info not to request without reading topics and learning first.
All you need exists on the forum, start looking and learning, or ask the chinese who is enjoying your money.
All them, say that will deliver a “compatible bios”…sell, sell, sell… so they must know what they’re doing humm?
Sorry for the straight words… take as you want, no need to reply, good luck.

No expert but i’ll throw in my 2c.

After you’ve completed Step 1 - use the FD44Editor tool from the developer named LongSoft on github. You can use it read your MAC, UUID, S/N from your original BIOS and write them to your provided bin file

Last time i checked the tool is intended for ASUS bioses… so can you share with us the opened method on that MSI bios file?

My bad @MeatWar you’re right FD44 is only for Asus. It won’t work on MSI, Asrock etc.

The better tool to use would be CoffeeTime which can read the same info from the original bios dump and re-apply it to the new bin file.

Started scanning a bunch of my bios files with CoffeeTime v99 and only Asus files would enable the UUID/MAC/SN write functionality. Afaik this isn’t a necessary step unless it’s an Asus board.

Thanks for your replies, I still waiting on the spi programmer to further test and learn on this Asrock motherboard.

Sounds like fun. I’ve been looking for more info on updating UUID/MAC/SN on non-Asus boards because I want to be able to do this myself.

So far, found two methods that use the UEFITool from LongSoft

  1. Find the exact body in the bios containing the UUID/MAC/SN. Then extract and replace the matching body in the new/clean bios file.
    How to transplant MSI motherboard's UUID\SN\MAC from programmer backuped BIOS to new BIOS ?

  2. Same as above, but replacing the entire volume
    hp DMI fixed in Bios files before using it to flash the bios chip using Hxd & UEFITool - YouTube

1 Like

first.zip (8.1 MB)
second.zip (8.4 MB)
if you do not have a spi programmer, you can follow my step:
use f6 instant flash to flash the first bios file.
when you boot into os, use intel fpt to backup the bios region and flash bios region of the second bios.
you can use hex editor to search ascii “dmivar”(case-insensitive) on your backup file, and you will find your mb sn.
then use amide(you can get it in lenovo m910x’s bios update) to write it. it’s not necessary.
or you can read mb sn via this:

if you have spi programmer and you can use it properly, make a spi backup and transfer gbe region to the second bios, then flash the second bios directly.
when you boot into os, write your mb sn back.

the first one is the official bios with modified flash descriptor and me region.
when you using asrock’s f6 instant flash, it do not check fd and me, it only check whether bios region is modified. and if you put a higher version me in bios file with untouched bios region, you can write fd and me without other unlock method.
the second one is totally modified bios with xeon e-2286m support.

@dsanke, many thanks for this, it is very appreciated.
BTW, the current motherboard that I am currently using had its BIOS modded by yourself apparently :grinning: (Z370M-S01 (MS-7B54) , Version 1.0 American Megatrends Inc., Version 2.B2 Modified by dsanke, BIOS dated: Mon 21 Mar 2022), so you are the reason that poked my curiosity and desire to learn about BIOS modding !
I do not have a normal CPU to boot the Asrock z370 Pro4 MB with an OS.
Good news is that the programmer has finally passed customs on my side, so it should be here very soon.
I have checked the MB stickers and the S/N, UID and MAC stickers are readable, so I will use this information. Many thanks again for providing all the information and the BIOS files.
I will report here when I have finally gone through the reprogramming.

Ok, I have received a EZP2019+ SPI programmer as I was told NOT to use a CH341A programmer with Asrock mobo… Anyway, I have tried to read (only for now) the existing bios content, I was able to extract something where I was indeed able to retrieve my MAC Address (7085C26CDF9B) in with HxD using the method from above.
Then I wanted to open the extracted bin file with UEFITool to see if the Gbe is indeed showing the same MAC Address, but it is says “UEFI volume not found”, which makes me think that something is not right as when I try to load the files from @dsanke it loads fine these files.
Likewise when I try load my extracted file with MMTool it throws an “Error Loading Firmware Image”. So I do not have confidence that my programmer is working correctly. Normally a correctly extracted bios image with a programmer can be opened correctly with MMTool and UEFITool, isn’t it ?

I think you have just read only the head part.
may caused by unstable connection.
try disconnect the vcc pin of spi flash when you using cable or clip to a asrock motherboard.

Quick update, I still cannot get consistent reads with the EZP2019 programmer, I tried to slow it down by reducing the frequency to 3MHz and also I tried to recreate a device template for the Winbond W25Q128JVSQ with a bigger delay value (doubling it). Still I cannot get 2 successive consistent reads with the dumped file content… So I have ordered a CH341a programmer to see if it somehow works better.
The other alternative may be to get a cheap i3-8300 CPU to start into an OS and do the dump from there as already proposed to me earlier.

Other things I have tried: plug/unplug the motherboard ATX and CPU power supply cable, add/remove the BIOS battery, and basically all combinations of that. What I have noticed is that the EZP2019 does not detect the flash model when power is applied to the motherboard, but even manually selecting the right flash model did not help, I get the “flash is empty” with power connected to the mobo.

I will update once I receive the other programmer.

If you aren’t getting consistent reads, the cheap clips are usually the main issue i’ve had. It’s hard to get them lined up properly and may take a few attempts to attach properly.
I even had one ship with a broken lead hidden under the heatshrink.

OK, I have given up on waiting the CH341a, it is still between China and New Zealand !
So I have found a I5-8500 CPU to go with your proposed steps (hence assume that I do not have a SPI programmer…).
I have done step 1: use f6 instant flash to flash the first bios file (was 1.50, is now 4.30 modded - first zip file)
I have installed windows 10, but it looks like the Ethernet Adapter is not working correctly.:
Intel Ethernet Connection I219-V
This device cannot start (Code 10)
I checked with a live Linux distro, and the adaptor is not available either, so not a windows driver issue, I guess. Is that normal at this stage? Still learning, did the first bios had a region for Intel Integrated LAN (GbE), or is it an issue that was on the motherboard from start (I have never used this motherboard before)? If not, is it something that will be in the second bios file, I am confused now ?

In addition, I though I should ask @dsanke before doing step 2 “when you boot into OS, use intel fpt to backup the bios region and flash bios region of the second bios.”
Step 2.1 => use intel fpt to backup the bios region, I use this command: FPTw.exe -bios -d biosreg.bin
Step 2.2 => and flash bios region of the second bios., still with FPT I use this command: FPTw.exe -bios -f secondbios.bin (named Z370 Pro4 4.30B.bin in the zip file)

###EDIT 1###
I have done step 2.1 using FreeDOS and FPT (using CSME v11, version indicated by MEAnalyzer for the BIOS version).
I have also checked my (/BS)Baseboard Serial number with AMIEDOS, it matches what the Hex editor finds next to “dmivar”, with the HEx editor I could also check the Mac Address (just after the MB S/N).
However, I am still trying to understand why I do not have a working Integrated Ethernet NIC… (It is enabled in the Bios menu).

###EDIT 2###
Step 2 done successfully, my 2 re-socketed CPUs (e-2286m and e-2176m) work on the Asrock Z370 Pro4, many thanks to @dsanke !
After that I tried to drill into my Integrated NIC issue with some method found here, and I could find the following:

Intel(R) Ethernet Flash Firmware Utility
BootUtil version
Copyright (C) 2003-2022 Intel Corporation

Option ROM area in the flash is not supported for this device on port 1

Port Network Address Location Series WOL Flash Firmware Version
==== =============== ======== ======= === ============================= =======

  • 1 FFFFFFFFFFFF 0:31.6 Gigabit N/A FLASH Not Present*


I am now thinking that the NIC might not have worked before I embarked on the bios modding journey…, has any of you any idea of what is (or went) wrong here?
All in all happy about the outcome, I will still try to find how I can recover the integrated NIC, else a PCIe NIC will have to do :slight_smile:
Thanks again to all for your guidance.

###EDIT 3###
For those who have an issue with your integrated NIC on ASRock motherboards with the following symptoms:

  • In Windows 10 (probably Win11 too):
    • The network adapter shows with an exclamation mark in the Device Manager
    • Error/Status details says: “Intel(R) Ethernet Connection (12) I219-V, This device cannot start. (Code 10)”
    • Event viewer shows:
      Device PCI\VEN_8086&DEV_15FA&SUBSYS_86721043&REV_11\3&11583659&0&FE had a problem starting.
      Driver Name: oem61.inf
      Class Guid: {4d36e972-e325-11ce-bfc1-08002be10318}
      Service: e1dexpress
      Lower Filters:
      Upper Filters:
      Problem: 0xA
      Problem Status: 0xC0000001
  • In Linux, the network adapter is coming up, the driver cannot attached to it.

Then it is most likely that the Mac Address was lost during a past BIOS update, all I did was to use the Asrock MAC Tool available here, and then I used the DOS version for my Asrock Z370 Pro4 with a Freedos bootable USB key, and followed the steps as per instruction.

After using the tool, just reboot into Windows and everything should work normally :slightly_smiling_face: