[REQUEST] Alienware laptop M17 R2 BIOS Unlock

Its possible to unlock the hidden options on this BIOS? Specially the wake on lan option because it seems disabled by default on BIOS but the option its hidden.

BIOS: https://dl.dell.com/FOLDER05951877M/1/Al…17_R2_1.3.1.EXE

Thanks in advance

@TugaPower - Please do the following and let me know what error you get at #2, and send me file from #1

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Hi @Lost_N_BIOS , thanks for answering my request.
All files are in attachment.

biosreg.zip (5.07 MB)


@TugaPower - You’re welcome! Before we do anything else, please run this command from the MEINFO/Win32 folder >> MEInfoWin.exe -verbose
Show me image of the bottom of the report. We’re checking to see if Intel Boot Guard is enabled with key burned into the PCH or not.
If you see Measured or Verified Boot Enabled at left/FPF side then we cannot edit menu but would only be able to directly change settings in place (current applied only, hidden or not)

Additionally, show me image of this command output from FPT >> FPTw.exe -i

Also, please put system to sleep (S3, not hibernate) for one minute or more, then wake it up and try FPT step #1 and then #2 again and see if same error or not. (Delete or overwrite first file from step #1)

I checked the Wake on Lan option for you, it’s already enabled by default in all possible locations (setup, AMITSE/SetupData, and NVRAM)
So, if it’s not working for you then you may need other drivers, or other LAN roms etc.

After S3 state it still trow up the same error as before.
Find in attachment the 2 pictures about MEInfoWin.exe -verbose and FPTw.exe -i
Thanks @Lost_N_BIOS



@TugaPower - Can you please crop the MEInfo image less, so I can see the name of the columns for those three bottom rows, thanks

Measured boot and Verified boot have enabled on the 3 rows. Gonna try on mobile phone to crop the original one.

About WoL, noticed that on S3 state the WoL its working, if shutdown completely it does not work. Maybe on BIOS it’s setup only to S3 state?

@Lost_N_BIOS changing the Acess/User from default to USER it’s not possible being enabled the Measured and Verified boot?


@TugaPower - Sorry, not sure what your meaning about Wake on LAN? S3 sleep was our goal to use for the FPT, so if you think it’s set to S3 for sleep, then all was tested correctly.

Ohh! As for actual Wake on LAN function, I don’t use that so am not sure how any of that works, I can only tell you that it’s already enabled, and this exact setting there is only enable/disable
If it relies on some other settings to be set to something else also, you’ll have to tell me what those are. if you need a text file to scroll through of all the BIOS settings here - https://ufile.io/47vnl0m5
Let me know what else to check, and while you’re in there, also make out a list of what settings you want changed and what you want them changed to.

BIOS settings Access Level has nothing to do with Intel Boot Guard. Please show me the image, NOT cropped, so I can see top of the rows/columns to read their names.
Our goal to check here is if Measured or Verified Boot is enabled on FPF side, but in V14 I’ve not seen yet if FPF column is left most one or not. But yeah, all three columns kinda sorts that all out, since it’s enabled in all anyway
If either is enabled at FPF column, then there is nothing you can do to disable it, except replace the PCH chip with a clean un-keyed one (key is burned into PCH fuse)
If this is the case, and Measured or verified is enabled at FPF, then we cannot edit menu at all, only directly change live/current applied settings in NVRAM/VSS

Full image attached



Thanks! Yes, Measure+Verified Boot enabled at FPF column, so we cannot edit menu, only directly change currently applied settings (hidden or visible)

@Lost_N_BIOS thanks for having a look at this, its a no go then and too risky in case something goes wrong.

@TugaPower - You’re welcome! Yes, it’s sad that companies can charge so much for stuff, then lock you out of it!
I’m Very surprised by Alienware for this to be enabled, it’s usually more Dell or HP thing, but it’s a general security thing too so I can see why Dell did here too. But, still, this is their high end non OEM stuff, it shouldn’t be locked down like that!

It’s no risk and nothing will go wrong, to change current applied settings directly, this is not covered by boot guard.
Check the IFR txt I sent you above (post #8) and make me a list of what you want changed and what you want it changed to, and I will show you how to change

@Lost_N_BIOS sorry to digging this again, was to try undervolt and its showing locked cpu volt on ThrottleStop program, can unlock this var to be hable to use program on windows to undervolt ? Can add again the IFR file you submited long time ago.