[Request] Asrock X99M Killer Bifurcation BIOS Mod


I got an X99M Killer by Asrock and suffered a lot from limited PCIe slots (only two!) with my 40-lane cpu. So I’m so desperate to get one of the x16 splitted into 2x x8 to run one more graphics card and nvme ssds together.
On the board, I got three IOUs, and IOU0 and IOU1 are x16 slots.
The riser card I got is a cheap chinese card that splits x16 into 2x x8 without PLX chip. I tested the card by restoring anything bifurcation option to Auto and put my GTX1070 directly onto the riser’s first slot and it worked normally despite in HWiNFO it says Max Bandwidth x16 but running on x8. I think it means at least the first slot works fine?
I’ve tried some modding methods but none of them worked:
[Guide] - How to Bifurcate a PCI-E slot
I followed the steps and changed either IOU0 and IOU1 to x8x8, but in HWiNFO the graphics card never shows up, nor could I use it, while only one of the two buses appeared as “PCI Express x8 Bus #2”.
[GUIDE] Adding Bifurcation Support to ASUS X79 UEFI BIOS
I also tried the method in this post but the IOU menu failed to show up.
Another weird thing is that when I have one of the x16 slot unused, it wouldn’t show up in the HWiNFO, while another unused PCH slot (a 2.0 x4 slot) will always show up no matter whether it’s used or not. I’ve tried to change this setting: “power down unused pcie slot” to “no” but nothing changed.
It seems, from my search, that the method for Asrock boards should be relatively easy, and this board X99E-iTX already proves that with a modified bios it should work.

So, I’m wondering if anyone could help me to turn on the bifurcation. Thanks SO MUCH!!!

I attached the bios file and user manual.

Btw, I also tried a Dell riser card of the same kind, and the problem is completely the same: bios can recognize one x8 slot instead of two, and my graphics card on neither slot can be detected.