[Request] Asrock Z370 Pro4-CB BIOS

I’ve tried every method possible to updating my bios aside from the bios Cyberpower is offering on their website which is the Z370 Pro4-CB 1.12. Z37P4CB1.12 is the bios file.
I’ve tried every method possible to modify the bios, or modify the most recent ASRock bios and to no avail I’ve been unsuccessful.

Is there anyway to modify a bios so that I can use the latest updated bios from ASRock? Or is there a modified bios out there?

I may want to add I have an i7-8700k, Vulcan 16gb DDR4 2400mhz gaming ram, 500gb ssd, 1TB HD

EDIT by Fernando: Thread title customized to make clear, that it is a BIOS modding request

@Likashots - this post is not very clear, what you actually want or need etc. Please link me to the Cyberpower BIOS download, and then also link me to the Asrock BIOS download page for the board you say is same.
What is your general goal?? Update the BIOS itself, if yes, we can do to the Cyberpower one no problem. If that is what you want, what did you need updated?

Also, please do the following, since this is Intel board, and if you just need updated or mod BIOS this is often easiest way to flash mod BIOS (unless built in BIOS flash tool/method allows mod BIOS flash)

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C.2” download the matching ME System Tools Package
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder.
Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required

Cyberpower only offers one Bios update for the ASRock Z370 Pro-4.
The link can be found here.

I feel like Cyberpower is gimping their consumers by restricting them from having an up to date bios for their motherboards (I.e. ASRock Z370 Pro 4)
I was hoping if possible to mod the Cyberpower Bios version L1.12 to the Asrock Z370 Pro4 most up to date bios version. 4.30.


So I have the biosreg.bin. No errors FPT Operation successful for the memory dump and FPT Operation Successful for the second part will rar the bin file

EDIT: The file is to big to add, do you have an e-mail address I can send it to?

Here’s the images from the CMD prompt.
I’m not sure if I’m supposed to put the newest ASRock bios in the command line, or if you are wanting me to send the bios file created from doing step 1.

Here’s the bios dump my good man. Sorry about all the extra posts: http://s000.tinyupload.com/index.php?fil…414837126324601
Here’s the Cyberpower bios i’m currently using: http://s000.tinyupload.com/index.php?fil…206202401769068
And here’s the Z370 Pro4 Bios i’m looking to upgrade to for now. The most recent bios from ASRock will not let you flash back so I figured it’d be safe to start here: http://s000.tinyupload.com/index.php?fil…309498186933341
HWiNFO64 Screen shot: https://prnt.sc/ro8w0b
HWiNFO64 Screen shot 2: https://prnt.sc/ro8wm5
Better screenshot of the 2 separate CMD commands you suggested: https://prnt.sc/ro8yst

EDIT by Fernando: Recent posts merged (for better readabiliity) and unneeded blank lines removed (to save space)


Hey Lost,

I wanted to thank you for all the help thus far, I feel I’m right in the cusp of being able to use the manufacturers bios (ASRock) and not being stuck with an old outdated bios that CyberPower decided to lock from users upgrading.

I’ve provided links to the Cyberpower bios I currently am using L1.12.
I provided the link to my manufacturers motherboards bios ASRock I’m looking to flash to Version 3.30.
Also I provided images to both steps from running CMD as administrator
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin


Right after you do that, try to write back the BIOS Region dump and see if you get any error >> FPTw.exe -bios -f biosreg.bin
If you do get error, show me image of the command entered and the error given.

Everything went smooth as butter, no errors to report.

Also I provided links for:
The Bios.bin created from step 1.
Provided screen shots for both step 1 and 2.
And provided the screen shots for all my motherboards functionality from HWiNFO 64.
I know you are a busy man and more than likely inundated with messages.
I really do appreciate all your knowledge, expertise and help along the way.
What are next steps for me?



@Likashots - Wow, calm down, go slow here or something could go wrong Please edit your posts if you need to add more thoughts, info, questions etc and no one has replied yet, thank you

Good to see FPT flash back of BIOS region is OK without error, this makes it easy to flash back in mod BIOS. Is it critical for you to use Asrock BIOS, or is your main concern simply updated or modified BIOS? I can update and or modified your BIOS as-is, no problem
I ask because it’s much easier, and much safer, for me to update your current BIOS vs getting you cross-flashed over to the Asrock BIOS. This is for a few reasons, I assume you do not have flash programmer, so if something goes wrong you wont be able to recover from brick until programmer arrives.
And, unless you have compared the boards side by side directly you can’t be 100% sure they are the same board. If you checked this, same PCI/PCIE layout, same VRM/Mosfet layout, same USB front and back, same I/O at rear, same SATA layout, then all my be OK/Same but above applies

My main concern is simply and updated / modified bios. It doesn’t have to be specifically from the manufacturer website. I just wanted to have the most up to date features available for my board.

OK, thanks! Then it’s best we leave you on original BIOS and just update/modify that.
Please give me a zip of all the main pages of your BIOS (like main, advanced, chipset, boot, exit etc), and then also scroll up/down if needed inside advanced so I can see what all submenus are visible there for you.
You can probably use F12 to screenshot to USB for the BIOS images. If not, please set your camera to take small images or resize them before you package up for me, I don’t need to see 2-6MB images, 100-300kb per is more than plenty

Do you use RAID? Do you use Wake on LAN or Boot on LAN?

Here’s all the images from my BIOS in a Rar. Image size scaled down as requested!
If that doesn’t work I added them individually to tiny upload


Biosimages.zip (2.22 MB)

What!? If Rar attached, why would you upload 100 separate uploads to tinyupload, instead of rar there as mirror?
Thanks for rar, single archive is all I need, attached or download linked + answers to the questions I asked

Tiny upload RAR with bios images. Not sure on the Do you use RAID? Do you use Wake on LAN or Boot on LAN? I’m assuming I use boot on lan.

If you used RAID you would know, same as if you used Wake or Boot from LAN. So, due to your comments on this, I assume you do not use either, so BIOS RAID and LAN Modules do not need updated / you do not use
I already have images from your attached zip above

Amazing work man! Thanks for all your hard work. Can’t wait to get the new bios up and running!

"Haha! Hey! That’s too funny! I heard that in Hulk Hogan’s voice as soon as I read it"

Had me in tears man, thanks!.

I successfully overclocked my board to 5GHZ i’ll show you the settings, let me know if you think it’s safe. CPU is running at about 35° to 40° on 5GHZ all cores. I think I’m stuck with my ram at 3000MHZ until I get a new power supply. Supposedly the power supply Cyberpower provides is garbage.

So if you wouldn’t mind taking a peep at a new .rar im going to add from my tweaked settings in UEFI for 5GHZ and if you have any suggestions / feedback that’d be great. Also on my HWMonitor in UEFI Its on CHFan3 but I can put it on Waterpump. My PC is water-cooled but I don’t even know if I’m using it. You can view it on HWMonitorCHfan3orWpump.jpg
And on Chassis fan 3 control mod I have it set on PWM Mode, although it gives me an option of DC mode which you can view on HWmonitorDCorPWM.jpeg

Here’s a link to the rar.

System: Intel Core i7-8700K 3.7GHz | Intel Z370 Express Chipset | 16GB DDR4 | 120GB SSD | 2TB HDD | Genuine Windows 10 Home 64-bit
Graphics: NVIDIA GeForce RTX 2060 6GB Video Card | 1 x HDMI | 2 x DisplayPort
Connectivity: 6 x USB 3.1 | 2 x USB 2.0 | 1 x RJ-45 Network Ethernet 10/100/1000 | 802.11AC Wi-Fi | Audio: 7.1 Channel | Keyboard and Mouse
Special Feature: Liquid Cooling | 802.11 AC Wi-Fi | Dual Tempered Glass Side Case Panel | Custom RGB Lighting | RGB 7 Color Gaming Keyboard

@Likashots - Here, please test and confirm all OK, this has following changes only, will get into menu modifications next

1. Update all CPU microcodes to latest + Add 906ED + Fix FIT Table
2. Update ME FW from to latest version - This not even in Asrock BIOS
3. Update EFI GOP Driver SKL-AML - 9.0.1082 >> Update to 9.0.1102
4. Update OROM VBIOS SKL-AML - 5191 (invalid/improper/Non-Official) >> 1059 >> Update to 1062
5. Update EFI Intel Gigabit UNDI - 0.0.19 >> Update to 0.0.27
6. Update OROM Intel Boot Agent CL - 0.1.10 >> Update to 0.1.16
7. Update EFI Intel RST for SATA - >> Update to
8. Update OROM Intel RST for SATA - >> Update to


Flash via FPTw.exe -bios -f Z37P4CB1.12

Or, see below first! If your BIOS has Instant Flash within BIOS, try flashing that way first!

The ME FW update will not be applied via previous discussed FPT command. First we need to see if you can read/write ME Region with FPT or not, if not I will help you to apply the ME Update using ME FW Update too.
Do this FPT command same as before, send me the created fd.bin file >> FPTw.exe -desc -d fd.bin

Or, if BIOS has built in BIOS Update method (In the BIOS itself, Asrock calls this “Instant Flash”), you can try to flash this BIOS using that, and it may update the ME FW Region, if it will allow the mod BIOS flash.
Rename the file to stock BIOS name.extension for best chance of success here (I did this for you, so wasted words here, make sure you don’t mix this up with stock one)

So the instant flash was unsuccessful, although it looks like the

went off with out a hitch. I’ll attach both images.
Does this mean the bios updated VIA command prompt?
Where do we go from here Brother!!! Ohhhhhh, yeahhhhh!

Z37P4CB1.12 Instant Flash.jpg

FPTw.exe -bios -f Z37P4CB112.jpg

@Likashots - Ohhhhh Noooo Brother!! That’s an Instant Flash Fail, surprising since I removed the mechanism that it checks to confirm this
I guess I forgot they’ve implemented something new past Z270 and no one has found work around yet
Ohh well, at least we know it’s out for this variant too

So, please do the second FPT command I gave you above in post #12 and send me that fd.bin file.

And yes, BIOS region was written via FPT, this we knew would be no issue, so you’re all set there. So everything in the change log above is now in your BIOS, except for the ME FW change I mentioned, we’ll get that sorted here next.
Then, later I’ll send you new BIOS to reflash BIOS region again via FPT with actual BIOS menu changes. For this, there may be a few interim BIOS I need you to quick test and let me know things about before I do the full menu unlock.

Yessir!!! Will get started on this first thing in the morning stayed dup until 5am playing APEX Legends… lol Fiancee will be waking me up in 3 hours. I’ll do the second FPT command then. I also spent quite some time making my own gaming performance zip with a few programs and task scheduler programs I want you to take a peek at and see what you think.!

Time for 3 hours of sleep.


Hope this morning finds you well sir. Here’s the

my good man. Have been working from home the last 2 weeks so i’ll be off and on through out the day.

Have a great morning brother!, will talk to you soon!


Here’s my own little “Ultimate Gaming Performance Increase Programs, guides and images on how to set up.zip” if you were interested in checking out the set up I made for gamers / power users.

fd.zip (444 Bytes)

@Likashots - Hey! Good morning to you!

Can you please shorten the title of your new thread, thanks!
I don’t game, but I’m sure other gamers will appreciate it and find all that useful being in one place

Thanks for FD, it’s a match to stock provided one, which I expected. FD is locked for ME region Write, so you will have to use ME FW Update tool instead of FPT
This tool is provided in the ME System Tools package that you’re using FPT from, it’s in FWUpdate folder (use Win32). Run it from CMD Prompt in the same way as FPT.
Place the following file into the FWUpdate/Win32 folder, then run Admin CMD Prompt from there, use the following CMD >> FWUpdLcl.exe -f

@Likashots - What a mess of a BIOS Please test these two BIOS and let me know which, if either, shows PCH-IO Configuration & System Agent (SA) Configuration inside Root of Advanced, and please test both and let me know outcome of each

Yeah, sorry i’ve been hit and miss lately. Have been doing just a ton of custom configuring with windows instead of gaming and once i start doing something i get like hyper focused… lol…

Building my own Windows 10 i’ve literally increased the speed of my PC / Graphics Card / Lowered my overall latency by like 25%
I used to spend 5-7 hours a night gaming… now it’s just tweaking windows and bios lol.

NTLite was interesting with modifying the iso.

@Likashots - it’s OK, I’m never in a hurry and always buried and behind, so don’t feel rushed to reply to me, whenever you get to it then we’ll get it done
Hopefully soon you will have windows all done the way you want, and then you’ll have more time to game and mess with BIOS


Alrighty here’s test #1 SetAMITSD-S!!

The myth, the man, the legend. At his finest again!

Round 2 -
So both worked.
I just attached the jpgs