[Request] ASRock Z77 Pro3 BIOS Mod

https://www.asrock.com/mb/Intel/Z77%20Pro3/#BIOS

This board only has Offset Mode Voltage in BIOS



Is it possible to know if there’s some sort of hidden setting to have fixed voltage instead?
And if Turbo Boost can be also disabled?

bump

just want to know if this is possible

@aiocr - Yes, there is a setting hidden from you that controls if CPU voltage is >> Auto, Fixed, or Offset
I can make this visible to you if you want? And yes, same on turbo, there is a turbo boost setting to enable/disable too. If you want these made visible to you, please give me images of the section you are in above, from top to bottom so I can see everything visible to you in that section.
Please try F12 to screenshot to USB, if it does not work, then use camera and resize images to 800-1000 px wide, then put all images in a zip and upload for me, thanks.

@Lost_N_BIOS

1.jpg


2.jpg


3.jpg



In the “Turbo Boost” option when i click nothing happens, no prompt, etc. It’s like a “greyed out” setting.

I’d definitely appreciate if you did that, just one question though. Is there any risk in “bricking” the motherboard by modding such settings? I don’t understand much about the subject and as this is the only PC i have i just want to be safe. Hope you understand. Ty

bump

@Lost_N_BIOS

new year bump

don’t worry @Lost_N_BIOS i know you have been busy

bump

@aiocr - Only real risk is if you have a bad flash, this is easy edit, nothing to go wrong or risky here.
What CPU are you using?? And I assume you want 2.20 BIOS edited, correct?

Which “Turbo” are you specifically talking about, that “Does nothing”??
Here’s how those (Asrock Specific ones) work on this BIOS
https://forums.tomshardware.com/threads/…tuning.1768017/
https://www.anandtech.com/show/6089/asro…cy-bites-back/3

Intel Turbo will enable or disable Turbo, no way that does not work, unless maybe your ME FW is messed up?
Can you change CPU multiplier and or memory speeds? If yes, ME FW probably OK, and especially more-so probably OK if you can see ME FW version w/ HWINFO64 as shown below

So, as of now, this is the requested edit you need, correct?
CPU Voltage >> Auto, Offset << Hide
CPU Voltage >> Auto, Fixed, Offset << Make visible

+ I will also make visible >>
DRAM Config Mode >> Performance, Compatibility Mode (hidden from you now)

Which “Load Line Calibration” can you see? Do you see 100%, 50%, 0%, OR Level 1-5? I can switch if you want the one with more options. OR, do you want me to leave this as it is now?

HWINFO-MEFW-New.png


CPU is i5 3570K
BIOS 2.10

I’m not really interested on the most recent version which got updated because of the Spectre/Meltdown issues


I’m talking about this option:

hd.png



When clicked it does nothing like the other settings which show a dropdown with “Enabled/Disabled”. My idea was to disable turbo and to always run the CPU @4.5 but i think it’s probably not possible since higher frequencies are only “allowed” with Turbo technology, but really don’t know, that’s why i would like to see and option to disable it in order to test.


Yes i can do both


Correct, plus the Turbo option if possible


Sounds good :slight_smile:


I see 0%, 50%, 100%
This LLC option is really weird because after so much time digging online a lot of users saying that in these motherboards the option is "inverted" meaning that for example 0% actually equals to 100%. I always kept this setting at 50%
You can switch to the one with more options, yep.

me.png

So, edit 2.10 BIOS then? I can put any microcode you want into 2.20, if you want new BIOS without spectre/meltdown microcodes, or I can just edit 2.10, up to you?
But, unless you disable Windows (10 I assume) from loading it’s own latest microcode, then what’s in the BIOS does not matter at all and windows will load it’s own and BIOS one will not be used
Here’s how to do that in post #272

Turbo is for use w/ stock speeds, ie CPU running at stock 3.4Ghz and then this applies when you enable Turbo you mentioned (w/ the other one disabled, not on auto)
Maximum turbo frequency 3800 MHz (1 or 2 cores)
3700 MHz (3 cores)
3600 MHz (4 cores)

Since you want to OC much past stock speed, and Intel Turbo stock limits, you should disable Turbo as it’s no use to you w/ an overclock and unlocked CPU anyway.
You should be able to disable both “Turbo” features, and then manually set whatever CPU multiplier you want.

You said changes I mentioned + Turbo made visible, yet you can already see turbo and commented it’s not working… So what do you mean make it visible, it’s there already?
Disable this, you are overclocking anyway, so useless. Unless, Asrock has something configured to where you can’t OC CPU Multi without it enabled, if that is the case then leave enabled and set your 45 multi for CPU ratio
Some systems, to use Turbo, C3 or C6 has to be enabled, I forget which and or if this is a thing on Asrock and or Z77. But, it should be no problem to run at 4.5Ghz always, since you have unlocked CPU (Disable speedstep, C1E, and EIST first)

On LLC, so you want to try the one with 1-5 level? OK, will do Either way, you can tell which is giving you more/less under load, but keep an eye on idle amount too as that’s affected sometimes as well.
To see which gives you more/less under load, set 0, 50, or 100 and test CPU under load using CPU-z benchmark tab with a second CPU-z open, or other voltage monitor, so you can watch idle/load voltages, then you’lll easily see which gives what you want.


Well, i guess you can do that if it’s an easy task for you, i’m just not sure what microcode it should be?! bit of a noob on the matter, so i’ll just say put the 2.10 microcode on the newest 2.20 so it doesn’t have the spectre/meltdown fixes like you mentioned.

I know about that Windows trick (mcupdate_GenuineIntel.dll) that’s why i didn’t want BIOS updated with those fixes because if for whatever reason i need them in the future i can always rely on Windows to update it for me. But as i said, noob on the matter and it’s always good to hear your opinion, so if you think you can leave the fixes out of the 2.20 version i’m fine with it.


The thing is, i can’t disable Turbo Boost, that setting does not allow me to interact with it, if i click above that “Enabled” it does nothing, i’m stuck with it enabled because of that. I have all C-States disabled, Speedstep too (that screenshot was from an old image i had on my disk).
Also, the “Additional Turbo Voltage” does not have a “Disabled” option either, only “Auto” and then the voltage increments.


I will try to do this and see if i can learn something

If you think i’m better with the 0%, 50%, 100% then you can leave them at that, i’m sure you are more informed about the matter than me.

Edit:

I tested those 3 LLC settings and CPU-Z reported the following:

0%
1.344 > idle
1.352 to 1.360 > load

50%
1.328 to 1.336 > idle
1.312 to 1.320 > load

100%
1.320 > idle
1.280 > load

The fact that i’m forced to use Offset voltage and Turbo Boost i think it mess this up even more, it’s really confusing to me.

Leaving some more info.

About microcode:

I remember few years back messing around with UBU tool and seeing a microcode recommendation. I took a look and still had that version on my HDD. In newer versions this recommendation cannot be seen anymore as the procedure/menus have changed a bit since then.

mc.png



Version 19 was listed as "best overclocking" so maybe go with that?! Currently running 2.10 BIOS with version 12.

mcc.png




So, in short, the “To-do” list would be:

Edit BIOS 2.20 to have microcode Version 19 instead of the most recent one with spectre/meltdown fixes;
CPU Voltage >> Auto, Offset Make option “Fixed” visible;
Intel Turbo Boost Technology Make this option interactable, currently i cannot disable this, as “Disabled” isn’t reachable as explained before;
DRAM Config Mode >> Performance, Compatibility Mode Make this visible;
Load Line Calibration Switch to Levels instead (Level 1-5)

As always, open to any recommendation you might have on the matter. :slight_smile:

@aiocr - Yes, I can put in whatever microcode you want
2.10 BIOS has (for 3570K/906A9) >> Rev 12 4/12/2012
2.20 BIOS has Rev 1F 2/7/2018 (post Spectre/Meltdown)

Latest actual microcode that is non-spectre/meltdown = cpu306A9_plat12_ver0000001C_2015-02-26_PRD_2F737D45.bin

Intel Turbo Boost tech setting should let you enable/disable, but it’s possible that the Asrock 30 Turbo at top is stopping you, if you have that on auto or enabled etc.
Or, this may be a BIOS bug with version 2.10? I suggest you test with 2.20 now and forget about microcodes for a second until we’re done

Or, you may need to load optimized defaults, save/apply and reboot back to BIOS, do not touch anything else, except disable Intel Turbo, then save/apply and reboot back to BIOS to make rest of your changes
Some BIOS (brands) require you to have C3 or C6 or C1E enabled to even use turbo, so having those disabled may also be what’s causing you to not be able to change it? Hard to say without having the board here myself to check it out.
On this, before we do anything else here, please do as I mentioned above with Optimized, and let me know what happens. Then, it still same, I will send you BIOS with edit to this setting only to see if Nulling the suppress and gray out if constraints on this then allow you to change it.

It’s greyed out if by the two following things = True >>
QuestionId: 0x2D equals value 0x1 {12 86 2D 00 01 00} >> Which = >> Offset voltage = -0.005V, Value (8 bit): 0x1 (Which to me, seems like this would be a bug, no reasoning for this to be a thing)
QuestionId: 0x41A equals value 0x1 {12 06 1A 04 01 00} >> Which = >> CPU Ratio = All Core, Value (8 bit): 0x1 << So, due to this, please set CPU Ratio to Auto (which should be default after you do above), then test again.

And suppressed if the following = True (in which case, you should not see the setting)
QuestionId: 0x3 equals value 0x0 {12 86 03 00 00 00} = Intel SpeedStep Technology = Disabled
QuestionId: 0x41A equals value 0x0 {12 06 1A 04 00 00} >> CPU Ratio = Auto
QuestionId: 0x3D equals value 0x0 {12 06 3D 00 00 00} = Limit CPUID Maximum = Disabled

So, if any of the above = True, Intel Turbo should be hidden from you, and or may be grayed out etc.
I’ll Null ALL of this in test BIOS for you if we can’t sort via optimized testing mentioned above

Turbo voltage would not need disabled, auto or a voltage increase would be all you’d need, if you wanted to use this. I checked, and that is all this contains, Auto + Voltages
Voltage applied here would not affect enable or disable of turbo.

Yeah, we’ll make you a BIOS with manual voltages first + 1-5 LLC and one with 0%, 50%, 100%, then you can test like that and see which you like better
That UBU info on microcode may be outdated, about which is “Best for Overclocking”, but I did check for you on the latest version that is like that (old style 1.69.17) and it still says same ver 19 (6/13/2013) is best for OC.
But again, that may be dated info?

I’d suggest using 1C from 2015 for best stability and likely same OC as 19 too, you never know unless you test and tweak and test and tweak while comparing both on your exact system with your own personal tweaking skills.
But it’s your system, so yes, up to you!

OK for now, we’ll go with 2.20 + Rev 19 microcode + >>
CPU Voltage >> Auto, Offset – Make option “Fixed” visible;
Intel Turbo Boost Technology – Make this option interactable
DRAM Config Mode >> Performance, Compatibility Mode – Make this visible;
Load Line Calibration – Switch to Levels instead (Level 1-5)

@Lost_N_BIOS

A lot of useful info, ty!

And you were absolutely right, i did some tests as you suggested (on 2.10 but i remember that on newest version the behavior was the same):

Loaded “optimized defaults” rebooted and Turbo became interactable > can select “Disabled”;
As soon as i set “CPU Ratio” from “Auto” to “All Core” Turbo Boost becomes “Greyed out” again;
If instead of “All Core” i select “Per Core” Turbo becomes interactable once again > can select “Disabled”;
And here’s a weird thing though, if after that, i select “All Core” again, Turbo Boost is still interactable > can select “Disabled”;

Anyway, i guess we’re good in this front after all, Turbo is apparently reachable to change, so off the list it goes. TIL

About the microcode, i thought about that and you’re probably right, info is most likely outdated. I’ll take your suggestion and pick the 1C which seems to be the best choice as you explained.

Would then go like this:

BIOS 2.20 + 1C microcode + >>
CPU Voltage >> Auto, Offset – Make option “Fixed” visible;
DRAM Config Mode >> Performance, Compatibility Mode – Make this visible;
Load Line Calibration – Switch to Levels instead (Level 1-5)

@aiocr - Nice to see Turbo is sorted and figured out now!! Yes, that is a bit funky how they have it set up, poor decisions/implementation by BIOS engineers?
I guess they want to keep in line with “Intel Spec” since you can’t “All core” Turbo to max multi, so it’s kinda trying to tell you no by doing it that way, but it’s not ideal without explaining that to user upon hover/select of these settings

I can (will) null all that suppres/grey if on Turbo, but the actual application of how it all works (or not) will still be same.
Meaning you can’t all core turbo, but you would be able to change this setting no matter what, whenever you wanted (invalid selection would be ignored and or changed on reboot possibly)

OK then, I will make you mod BIOS per outline above now I’ll make you two BIOS, one with 19 and one with 1C, then you can compare

* Edit - @aiocr - Here, please test and let me know if all is as it should be menu-wise, then if so you can go ahead and test 1C vs 19
If it’s not all proper menu-wise, let me know what’s wrong/missing etc.
http://s000.tinyupload.com/index.php?fil…018239226795285

Change Log >>
1. CPU Voltage switch to Auto, Fixed, Offset
2. Dram Config Mode Made visible (Maybe, iffy to edit this one in some regards)
3. LLC switch from 0, 50, 100% to Levels 1-5 mode
4. Null Suppression/Grey regarding “Intel Turbo Tech”

Dual BIOS Package above + Below
1 BIOS with 306A9 Rev 19 6/13/2013
1 BIOS with 306A9 Rev 1C 2/26/2015

** Sorry - I thought I hit save on these changes last night before I left, seems I did not **

@Lost_N_BIOS

Upon further testing, this bit of info i shared before seems to be false:


I’ve mixed some settings and thought that was right but apparently not.
What i can do is the following: Select “Per Core” or “Auto” on the CPU Ratio and set Turbo Boost to “Disabled” and then if i select “Advanced Turbo 30” as “Enabled” the CPU Ratio goes back to “All Core” and turbo stays as “Disabled” (“Greyed out”).
So, i’ll probably have to stick with the “Per Core” setting, as it’s almost the same as “All Core” as far as i know, i just need to enter the multiplier i want three more times instead of just one. I say this because i’m not really sure about that “Advanced Turbo 30” setting, if it enables some unwanted settings behind the scenes or something. Or if it’s actually disabling it, since i can’t All Core Turbo and then it’s suddenly possible by enabling this setting, it sounds weird, idk.

It really feels of poor decisions/implementation


You really don’t have to do this, for real, i will gladly accept just the 1C microcode. It’s the most recent without the spectre/meltdown fixes so it seems the best bet, no need to waste more time modding different versions.

@aiocr - See edit on #15, sorry about that!




No problem at all.

One question before i commit testing those. Should i follow any sort of safe procedures or just flash and test? I ask this because i’ve read before some threads where you recommend flashing > turn PC off > clear CMOS > load defaults and then apply desired configs, for example.

Just to be sure, and safe. And thank you for doing those, it was not needed to do the 19 version as i said before though. So, extra thanks!

EDIT:

I ended up flashing it, if needed i’ll reflash later with given instructions.

Here are the menus:

210111021729.jpg

210111021746.jpg



It seems O.K, just a question though, is it ok for that “Offset Voltage” to still be there?! Won’t it affect the other “Fixed Voltage” set?!

I ask this because, and giving as example, i’ve set a fixed voltage of 1.300v and LLC to level 1 and when measuring with CPU-Z i get an idle voltage of 1.312v and when in load it fluctuates between 1.312v and 1.320v
Shouldn’t it be the fixed voltage we set in BIOS? This always confused me, i thought it was because of Turbo Boost/Offset Voltage but apparently not

@aiocr - You’re welcome! Nice to see “Dram Config Mode” showed up, I was worried about a further edit on that may give us hassles if we had to go there
Best practice on flashing is to flash, clear CMOS, then load optimized, but it’s not always something you’ll have issues with if you don’t
Loading optimized after a flash, then save/apply and reboot back to BIOS to make changes should always be done though.
For this kind of edit, just menu changes, just load optimized is fine

Sorry about that on Offset Voltage, I wanted it to appear only if you selected offset!
Looks like I unsuppressed it too much or Access Level Change makes it always visible, don’t worry, we’ll sort it out

The “other Offset” is hidden from you now, this is the new one that is tied to the setting above.
Both Offset and Fixed voltage should be hidden at Auto, and then only one should appear based on your selection away from Auto to Offset/Fixed.
Here, please test this BIOS and let me know if it acts as outlined above, if so I will make another set of both for you
If not, I will make another follow-up for you to test
http://s000.tinyupload.com/index.php?fil…261039796353251

And no worries about making two BIOS for the microcode testing, swapping in microcode only takes a second

On vCore and LLC - You know how LLC works, correct? Of course all boards are different, and each “level” or % the other way will be different.
But the general way they work is to add more voltage under load to keep stable, some may add more at idle too.
Some may add a lot more than others under load, this is why there is level. You’ll have to try them all and see which works best for you
Some people like set voltage + more at idle too, or less at idle and a lot more at load, you need to find what is your happy medium
Only testing will show you how each reacts, then you compare that to what you had before with % and decide which you want to use.
I’ve not used this board, so I can’t tell you what is what, you’ll have to test each one and see.
If you want, once you’re done testing LLC 1-5, I can make you another set too, with the fixed voltage + % LLC type setting like stock had so you can compare those

Voltage will never be exactly what you set in BIOS, there is always vDrop (what’s lost/less than you set at idle) and vDroop (what’s less than under load)
This is by design, some boards do it all better than others, and Intel prefers it to be much more vdroop than what users what, that’s why they add LLC control for users in BIOS

@Lost_N_BIOS

Appreciate the info about the best practices on flashing the bios, keeping that in mind for future needs.

All seems fine with the new test version, menu-wise:

210111175442.jpg

210111175450.jpg

210111175455.jpg



To be honest, i always struggled to comprehend LLC, i thought if we set a fixed voltage it should be that no matter what, at least at idle and then on load it would fluctuate a bit depending on the level/% used. Good to know that is by design though, so thank you for sharing the info!
I’ve also heard back in the day that we should use the LLC setting that gives us the most closer voltage to what is reported by the BIOS.
And giving a look at HWiNFO, i can see VID lower than actual Vcore, which confuses me even more because i always thought that VID should always be higher than Vcore.
Of course, i’m here talking about these things but i don’t expect you to help me with all of those, just really discussing.

Now, it appears this bios isn’t working properly. I’ve set CPU Ratio to 45 (frequency that i always ran in the past) with fixed voltage to 1.35v (voltage that i always ran in the past) LLC to Level 1 and rebooted. It locks on the ASRock logo and doesn’t boot, had to clear CMOS several times now (even with load defaults after CMOS > load defaults > reboot and apply changes). Leaving Turbo Boost untouched doesn’t matter either, it still locks. This behavior is the same when we don’t apply enough voltage and so the PC doesn’t boot. It seems like despite i’m using that “Fixed Voltage” it does not assume it and is still looking at the “Auto” or “Offset Voltage” in which case it does not have enough voltage set for that frequency?!

And speaking of Turbo, it appears this setting cannot be really disabled outside of the “Auto” CPU Ratio. I’ve checked with this program called “Quick CPU” and the only time Turbo Boost becomes unchecked is when i disable it with CPU Ratio set to Auto:

cp.png



When i use “Per Core” or “Advanced Turbo 30” and disable Turbo Boost in BIOS it still appears as checked in Quick CPU.
Maybe there’s more hidden settings controlling Turbo?! It’s exactly the same as this user reported here: [Request] How to Access Locked/Hidden BIOS Menu Settings (3)
In my case i also already disabled “Intel SpeedStep Technology” but when i use those programs (Quick CPU, ThrottleStop) it’s still reported as enabled, as can be seen in the screenshot above. Maybe there’s also an EIST hidden setting?