[REQUEST] ASUS Maximus VII Gene Z97 BIOS rebuild


long story short im trying to update the BIOS on a Maximus VII Gene to properly support Broadwell but the ASUS Tool wont run because management engine driver wont install and ME version in BIOS is "N/A"
I’ve tried flashing most official BIOS’ from asus website but not a single one has flashed the ME part and trying to do literally anything in that “FTK” tool just returns some error about a host CPU not having read access.
i also have a CH341 flasher on hand if thats any use here.
can someone advise me on what i should be doing here?


Better start here: [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization, u may have a corrupted ME

im trying my absolute hardest to even read what that guide is telling me to do… i can’t even get that ME analyzer to even open…

can i not just flash this .bin file for the ME version with the 341 programmer?

If/when you can’t install ME Drivers, you use tools in DOS instead, no driver needed there.
NO, you cannot simply flash in the stock ME FW, it’s not configured. And due to locked FD, you cannot use FPT to flash ME anyway
FTK should not be used, all would be outdated, plus you can’t use FPT for this due to locked FD, and ME FW update tool cannot work when ME FW corrupted, so nothing to do here with FTK or FPT/ME FW update tool

Link to the BIOS version you are using for starters would help here.
Dump BIOS with CH341A, but only if you know what software is compatible for your BIOS chip ID to read and write.
If you do not know, tell us the chip ID and read if off the chip yourself, then someone will tell you what software/version would be best to dump
Then you dump BIOS, and fix the ME FW per the guide above, then program it back. OR, you can dump BIOS, swap stock BIOS ME FW via UEFITool into your dump, then program it back.

I checked latest stock BIOS 3801 and ME FW is included, so you can do as I mentioned above (easiest thing to do)
DO NOT program in stock BIOS!!! Dump BIOS chip, edit with UEFITool to swap in extracted stock ME FW region, then program back.
As mentioned, if you are not 100% sure what software works with your chip ID, wait, or you will end up with a bad dump, bricked BIOS and all your system info lost.

Sorry i mistyped my motherboard, its the Maximus VII Gene, the Z97 one, i only need ME to run the asus tool that prepares a BIOS for proper broadwell support to then flash that because for some reason bios updates dont give support for things like the iGPU…

The BIOS versions i tried using are 3003 which was the last stable one as well as the 3503 beta which i think has that vulnerability patch…? i’ve flashed literally every single BIOS version listed on ASUS’ website and not a single one has done anything with the ME

I’ve already dumped the BIOS as a .bin file (the 3503 BIOS the motherboard has booted already) using the program found here :[Guide] Using CH341A-based programmer to flash SPI EEPROM
the chip itself is a 25Q64FVA, its a replacement chip as the original was dead

i did try that guide above and got all the correct tools/files but i can’t get the Me Analyzer to open, i got the python part but its missing some module- i’ve no idea how to use python or how to install said module so im stuck here

!! Wrong board !! OK, so I checked that BIOS now (3003), same as above - All comments above apply exactly the same as I mentioned above.
Yes, flashing BIOS will not touch ME FW, especially now that it’s corrupted.

W25Q64FV, best to use 1.30 or 1.34 and 25Q64BV ID, but if you have already dumped and wrote to this chip using one of the two versions of software at the guide you linked, then you know which one works OK so use that.
1. Dump current BIOS contents.
2. From stock BIOS, open in UEFITool, expand capsule, select ME FW region, extract as-is save as ME.BIN.
3. Open dumped BIOS in UEFITool, select ME region, right click, choose replace as-is and replace with the stock extracted ME FW region
4. Save as fixedbios.bin
5. Then program back to chip.

Here, I suggest you use version 25.0 of UEFITool - https://github.com/LongSoft/UEFITool/releases/tag/0.25.0

After that, remove ALL power from the board for 1+ minute. You can either turn off PSU, or remove the cables, then press board/case power on button for 10-15 serconds, then let board sit for one minute
Then you can start system after that full 1+ minute without power, this will reset ME State.

ME Analyzer is not required for anything here, unless you’re simply wanting to look at your dumped ME FW, which you already know is corrupted.
For help to use ME Analyzer, and python issues you’ll have to ask in the thread where it’s provided. You downloaded the zip correct, not the source?
You can also find info on making it work at the main github page - https://github.com/platomav/MEAnalyzer

okay so i did what you stated above down to the T, it make no difference… still POST’s in a 1/10 chance and ME is still N/A

i take it i was supposed to do something else beforehand…?

Sounds like you didn’t do it correctly, or the software as I mentioned is not compatible with that chip and you’re getting a false write/verify
What do you mean posts 1/10 chance? Sounds like you may have faulty memory, or some other stability issue.
But, I highly suspect the above, and you’ve never yet erase/wrote anything proper to the chip yet (incompatible version will corrupt, and or do nothing, and false verify like it did everything OK)

Use 1.30 and BV ID, here - http://s000.tinyupload.com/index.php?fil…213094641136166
Dump chip again using this, make new fixed BIOS >> Read >> Verify >> Save << Then edit this.
To program >> Erase chip >> Blank check >> Open BIOS file >> Write >> Verify.

After you are done, remove ALL power from the board, unplug PSU Cables, or switch it off. Then short power on pins, or push power button if cable connected, for 10-15 seconds
Then let system sit for one minute without power, to reset ME FW state

If you can’t get it, send me your 1.30 dump, using BV ID, and I will unlock FD for you, then you program back, and we can fix via FPT
But really, if you edited file how I outlined, and you get a good write to chip, then there is no way this can fail.

You can manually confirm your write if you want! BEFORE you power on system after write.
Close program, open again >> Read >> Verify >> Save. Then compare this file in hex editor with what you wrote, if it’s not 100% match, then it’s a failed write

right, tried again using the specified tool and ID, same again, tried using a different ME version, one slightly newer and older, still N/A…

been up since 3am trying to figure out how to get this board to work properly… it isn’t worth the effort in continuing this fruitless attempt at fixing its BIOS, sorry for wasting your time and thanks ♪

Did you do the process I mentioned, about 1+ minute power drain? AND, did you do the write How I mentioned >> Erase >> Blank check >> Open file >> Write >> Verify?
If yes, then something in file is wrong. Send me your current dumped BIOS contents with software version and ID I mentioned, I will fix for you.
Then once you program back, do a manual dump to compare how I mentioned above, to confirm if write is actually OK or not.

This is a simple thing to fix, especially since you have a programmer! So, some step you are doing is not correct, otherwise this is a painless quick write and it will be fixed.
Then get some sleep, and wait, I will send you file back later on when I get back in, unless you send right now then I can send right back real quick.

yup, i did it exactly as you wrote it down to the letter and yet, either im just an idiot doing something wrong most likely or this board is toast.

I only have the tools and version you linked and those are the ones i’ve been using since.

dumped.zip (5.65 MB)

I linked MANY versions of tools in a single package
Board is toast is not a possible thing here, unless it’s not booting due to CPU or memory failure etc. Messed up ME FW wont cause it to not work
I will rebuild your entire BIOS, using stock base as region, put back in your details, clean and update ME FW to latest RGN version, and unlock FD.
Once you program the file back, DO NOT Power on system. Close program, open program again and do >> Read >> Verify >> Save.
If it does not match the file I sent you that you write, then write process is failing, and you need to adjust something (add/remove power cables, some systems need both connected, some need both removed)

For all writes, always >> Erase >> Blank Check >> Open BIOS file >> Write >> Verify.

I will edit BIOS into this post once I am done, and I’ll tag you then

* Edit - The file you sent is bad, broken FIT table, due to microcode edit I assume
Also, your LAN MAC ID is wiped from GbE region, due to you wrote in stock BIOS with FPT or programmer at some point (I assume) <<< Also, due to this same thing, your system info is wiped from certain areas too, not good!
I will fix this, in part of stuff described above

* Edit @Latios - Do you have ANY previous BIOS backup from programmer, or software (ANY) from ANY point in time, even years old, that is from before you edited anything in the BIOS?
If yes, send me this. If you do not have, send me images of ALL stickers on the board so I can fix everything missing. Look on side of 24 pin, and top/bottom sides of PCI/PCIE slots too, and don’t forget the long white sticker on side of PCB too.
Put all images in a max compressed zip

Due to all this, obviously this will not be a quick fix. So feel free to get some sleep, and we’ll fix this later today/tonight etc.
Don’t stress about it, we’ll fix it, and there is no rush

Unfortunately i don’t have any previous backups as the old chip was completely dead, not even able to get any readings in the programmer. I honestly didn’t know the BIOS would be messed up this badly

i can send a photo of all the stickers i’ve found on the box and the board if it helps at all

stickers.zip (4.05 MB)

Anytime you replace the BIOS with stock BIOS, then you loose all this system specific data if you don’t put it back in when you program the chip (Serial, UUID, LAN MAC ID For Ethernet, Windows key etc)
Yes, I will use stickers to fix all this But, I am leaving now, so I can’t do until later, sorry.
Missing sticker on top/bottom side of PCI/PCIE slots, unless maybe that is one they moved to back of board on this model? << Yes, I think so, no worries!

Learned a lot today, honestly thanks for the help, really appreciated ♪

You’re welcome! Microcode update was done very badly here too, luckily it boots, sometimes (padding comment next) causes bricked BIOS! Padding file added twice + broken FIT Table
It’s a mess in there, this and the ME Stuff, possibly other stuff I’m not even looking at, all may be why it’s messed up so badly for you.
I’ll fix all this. I see you/someone updated GOP as well, do you need that done again too? And on microcodes, do you want stock, the 2018 ones you put in, or the latest versions as of now?

That probably explains why my POST chances were so low even though the board works fine.

Well my end goal was to get the full Broadwell Support so i can use my i7 5775C with its built in graphics, but i needed to use a “BIOS updater for 5th Gen Intel Core Processors” to modify the BIOS to do that since just updating to the latest BIOS wouldn’t do that automatically

I’d prefer it if everything was fixed/updated to the latest as of now if thats even possible at this stage

@Latios - On this >> “BIOS updater for 5th Gen Intel Core Processors” Do you mean from Asus? If yes, link me to this, so I can see what it’s actually doing


Yes its the one from ASUS although it’s quite hard to find this program officially now but this is the one i’ve been using, has worked on two of my boards so far.
This is the same file i used to update the BIOS file on both my Z97 Gryphon and Sabertooth Mark S to support the i7 5775C fully, since updating to the latest BIOS on its own doesn’t have full support, the .CAP needs to be modified with this program or something inside of it, but it wont run without ME or on a different system to the one thats intended for

So, this is probably what’s breaking the microcode update, paddings, and FIT stuff I mentioned! I will check, thanks.
I assumed maybe you had been editing microcodes with UBU or something

I assume it edits microcode, but may also be editing or updating ME FW too during the process.
So you run this, select stock BIOS, and it then updates and flashes in BIOS all right then, correct? Or does it output file for USB Flashback?
* Edit, I see, it’s an update in place program. Let me dig in and see what’s going on

* Edit 2 - Looks like this just first updates ME FW to, then flashes the BIOS you give as source, then reboots.
I do not see anything in regards to microcodes, or editing the given BIOS. So, did you touch microcodes in the BIOS you had been using, with something like UBU or manual methods?