[Request] Asus P9x79 BIOS with NVMe support

A post was merged into an existing topic: AMD and Nvidia GOP update (No requests, DIY)

I know this is an old tread but I would like to use my Asus_P9X79_LE With an NVMe boot drive if possible. My current configuration is a i7 4960k, 32 GB RAM & an Nvidia GeForce 710. I would kie to use it with a legit version of Windows server 2016 in a home lab. I would like a 4 tb NVMe drive if Possible. I don’t know if the BIOS above works with my variant & don’t want to learn the hard way. I would appreciate any info on this and adapter compatibility. I don’t know much about this and any help would be appreciated. Thanks in advance Berg

Hi Any chance this could be modified for a P9X79_LE I would be most greatfull

Hello @Berg ,

I will PM you so that we can work through the procedure.

Best regards,


Bios flashed, can see the ps option…

however when I try to do a fresh install no matter what options I choose it freezes… any ideas? I can access the drive under my normal windows install on a ssd.

[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Point#4 for OS installation, nevertheless the guide should be read in full to understand whats behind the mod and procedures for testing/settings.

1 Like

I successfully Flash my BIOS with the two modded ones available on this post:

  1. P9X79_4701_NVMeStd_(08-2021).zip from @ hancor
  2. P9X79_4801+NVMe_MOD.zip from @chuckbam

So I thought OK I can try this out and bought an EVO 970 PLUS plugged in a 1x slot SABRENT PCIe interface

Thanks to @shawn I’ve decided to migrate my existing Win7 OS from MBR to GPT
So I did install the Windows6.1-KB2990941-x64.msu to see the MVMe in Win7 + cloned my system with AOMEI BackUp with option convert MBR to GPT

At BIOS boot menu I was able see the EVO 970 PLUS but without being able to reboot on it:

Eventually I used AOMEI Partition Assistant Pro to convert my SATA system from MBR to GPT with the intention of cloning after reboot.
But I can not reboot anymore
I must have miss something…
Thanks for your help!

Hi Hancor,

I am using your modded BIOS with a windows 7 system installed on a SATA drive. I did convert the SATA drive from MBR to GPT with AOMEI (Windows PE) and then I have cloned it to an NVMe drive installed on the last PCIe port of my P9X79 board.
I’ve followed you advise on disabling CSM in BIOS but I do not manage to boot on the "Windows Boot Manager (Samsung SSD 970 EVO Plus 2TB S4J4N)
I have the same result when I am activating CSM and set “Boot from PCI-E/PCI Expansion Devices” to UEFI
Would you have any tip to help me progress on this?

You cloned a LEGACY OS…just that.
You converted the legacy OS disk from MBR file system to GPT and cloned it to another disk, simple as that, you didnt have a UEFI ready OS and even worst…the good old 7, that received support for NVMe later on, with hotfixes.
Take the guide advice, getting the most performance of a NEW CLEAN OS Install/

@lotny @MeatWar is correct
You will also need Win7 hotfixes as mentioned.

Thxs for your feedback Gents! @MeatWar & @hancor

My goal is to avoid reinstalling a new OS and all the software install hustle that goes with it (on an offline PC). Thus the win7 OS migration is my goal.

I sure I did install hotfixes for win7 prior to cloning:
Windows6.1-KB2990941-x64.msu and windows6.1-kb3087873-v2-x64.msu

I even tried out the Samsung NVM Express Driver 3.3 + the data migration tool that goes with it (I am using a EVO 970 PLUS)

But I can not boot after various cloning attempts (AOMEI Backupper):

  • Disk Clone from MBR to GPT
  • Disk Clone from GPT to GPT
  • System Clone from MBR to GPT

Also for each clone attempt I tried the set the CSM BIOS parameter “Boot from PCI-E/PCI Expansion Devices” to “UEFI driver first” (while “Boot Device Control” is set to “UEFI and Legacy OPROM”, “Boot from Storage Devices” set to “Both, UEFI first” and “Secure Boot” on “Windows UEFI mode”)
But not much success either…

Here are my boot options:

I must be missing something to make Win7 UEFI ready but don’t see what.
Any tips would help, thxs!

Eventually I did update my win7 to win10 and was able to keep my program installed and runnin’.
Hats down to you guys @hancor, @Fernando and All from WinRAID Forum for prolonging the life of our hard earned PC hardware with modern performances. You rock.


Should just note that it’s easier to use a samsung nvme drive vs crucial (which would need the bootloader software)… my crucial couldn’t work properly even with the bootloader option offered… so, I bought a samsung 970 that addressed the issue and is now working no problem and no need to mess with the bootloader stuff

Im not sure what you’re talking about here, a boot loader is used when the user doesn’t want to mod and flash the bios with the NVMe mod, like Clover for ex. that can load the DXE NVMe driver.
Now if you’re talking of a Boot Rom, the 970 EVO also doesnt have one, as long i can remember, only the 950 Pro and for this model, bios mod is not an obligation.
Anyway, glad you succeed

1 Like

sorry when I meant boot loader I mean using something like clover to boot… for the crucial p5 plus no matter what you did it would freeze the system… I flashed the other bios’s in this thread as well to try and address it. It just wouldn’t take. I believe the samsungs have a chip that helps booting idk for certain I saw it on a different forum somewhere. In any case thanks its been great ever since… the crucial is gonna end up in my buds laptop for Christmas so thats a win win

1 Like

@lotny @MeatWar @cobra11murderer
Given the interest here’s the latest mod BIOS with updated NVMeDxe5.Ffs insert.

ROM EFI updates

Microcode updates

Compressed BIOS/UEFI file below:

P9X79.rar (4.2 MB)

As always back up your data & enjoy! :innocent:

1 Like

Does it fix problem with Crucial P5 Plus? Is any way to fix it available yet?

It’s not confirmed or denied by any other user besides cobra11murderer
We would like to see some other reports to really confirm this “issue” with the P5 Plus.
Since the board has USB BFB feature and maybe you have a different adapter model/brand, why dont you give it a try, regards.


Ok, if you’re willing try this one mod P9X79_4701 after this if still the same behaviour, we’ll backlist this Crucial P5 Plus NVMe as non-candidate to NVMe DXE/Guide in the forum.

EDIT: Thank you for having performed the additional tests with the 4701, this will give future users of the ASUS P9X79 a warning about this Crucial model.
Still we need more motherboard models to confirm this issue on the P5 Plus NVMe.

Then I herby confirm that Crucial P5 Plus nvme ssd does not work with Asus P9x79 on both stock bios and modded one posted by hancor at Oct 23. Mere presense of Crucial P5 Plus ssd in pci-e slot causes freeze when loading OS from sata. After removing it everything comes back to normal.

Same thing with bios mod P9X79_4701

  • windows 10 from sata ssd freezes during load when Crucial P5 Plus NVMe is in PCIe slot.
  • windows 10 installation freezes during initial load when Crucial P5 Plus NVMe is in PCIe slot (all sata drives were disconnected)
  • linux ubuntu from pendrive started ok. Crucial P5 was visible although I did not test it, initialize it as I need to return it to shop.