[REQUEST] Asus/Pegatron IMISR-VM OC Unlock

I posted this in Bios Mods but got no response so joined here to see what I could find.
I will repeat what I said there here.
I am doing a super low budget build and picked one of these up very cheaply. I cannot find any proper settings in the BIOS (it’s an OEM not surprised) so wondering if you could help me out by cracking the BIOS to add overclock functionality, ability to overvolt higher than 1.25V (if that’s possible) and support for PGA478 Penryn quad core microcodes (especially Q9100 as I’m planning an upgrade as even the T5800 I overclocked to 2.6Ghz using FSB increaser is not fast enough). I don’t really have experience at all of even updating my BIOS so if anyone could point me towards a guide or something that’d be brilliant.
Reading off msinfo32 my BIOS is American Megatrends Inc. 0114 06/02/2009 and SMBIOS is 2.4. I could not find my BIOS file anywhere, but the closest I got was the update file for 0117 version of my BIOS from RM’s website (company who had OEM made for them). I will attach that here.

Many thanks in advance for helpers!!

IMISRVM_v0117.zip (955 KB)

Do you have DESKTOP Version, or RMONE Version? Not sure what that is, but I see in BIOS flasher batch file it has one BIOS for each in the download you provided.

Never mind, I checked both, neither have any settings hidden, so there is nothing to unlock in regards to overclocking, sorry.


Microcdes can be updated though, so at least there’s that I am not sure if your chipset supports quad core, or the updated FSB speeds, have you seen others on same chipset using quad core CPU’s or higher default FSB if it is higher?
I did not look up chipset, only asking and assuming you’ve already read some about this during your research. I know sometimes 1066 default users can’t use 1333 FSB speeds, so that is why I asked, I see this is 800 vs 1066.
If you have GM965 you may need to do this mod, not sure since microcodes for these CPU’s are already in yoru BIOS. Best to verify for sure which chipset you have, either tool mentioned below will tell you

I found this, if same as your board (Could be old spec, or different OEM etc), you will need to do the mod linked above

CPU Microcode for retail Q9100 (1067A) is already there, so as long as yours is not ES/QC CPU it’s already supported.

Once you answer above about the version I can update the microcodes for you, but that’s all that can be done for this BIOS.
Here is updated BIOS, updated both versions to latest microcodes.



Please research to find which version you are suppose to use (Desktop/RMONE).
If you are unsure how to check, I’d start by looking at motherboard + BIOS info with AIDA64 or HWINfo and see what it shows for the currently flashed BIOS, if anything.

Thanks Lost_N_Bios for the update.

I also have an Asus IMISR-VM motherboard bought cheap from UK Ebay. As I didn’t know where it originated from, I initially flashed the desktop version which seems to have problem booting 4GB of ram where as the ONE version works flawlessly. Only other difference I could tell was the bootscreen logo if you have it enabled.

I currently have a T8300 spare on it.

You’re welcome, and thanks for reporting back that both BIOS boot OK! Did either of those boot screen logo’s match your original? If it did, I’d say the matching one is the one you should use.
4GB ram boot issue could have been a random glitch, did you try switching ram sticks around in same slots just switch?

Ohh! I just noticed you are not the original poster, for that you get an extra thank you for posting back report on BIOS working or not, thanks bud!

Hopefully @thatubuntuguy also had a successful flash!

Thanks for the update Lost_N_Bios,
I can confirm I have the same motherboard as tonysparos. According to hw info it’s an OEM board from RM. I flashed the BIOS I attached with AFUDOS on freedos stick and works fine, and I will try and flash your BIOS and see if that works OK.
tonysparos did yours come with a T5800?
I have GM965 chipset with ICH-8M which apparently only supports maximum 4gb ram… Any possibility of getting more as I have some sticks lying around?
So LOST_N_BIOS will the Q9100 work out of the box with BSEL 1066>-800 FSB with your Bios?
Thanks for your help

I am trying to flash bios but my keyboard doesn’t work!! I can’t select option…
Please advise

You’re welcome @thatubuntuguy - I can look at ram possibilities, but that’s usually a chipset limitation, if there is some fake limit put there maybe I could change not sure?

I can’t say for sure about the Q9100, only know that the microcode is already there. Normally for that chipset the BSEL mod would be required, but I would try without it first and see what happens.

On your DOS keyboard issue, not sure, sounds like some file is missing for your DOS. I always use win98SE with a full copy over of the files the USB installers skip over, then go from there.
Like this I outlined and packaged up for another user - <Request> Flagship X470 Gaming 7 Wifi Motherboard BIOS Fix

Thanks for the quick reply,@Lost_N_BIOS
So to flash the BIOS I provided I used rufus to make freedos usb. I’ll try remaking the freedos stick and get back to you…
You can try, I don’t know what you would need to do but like I said I have some ddr2 sticks lying around which I can test with immediately…

It seems it is a BIOS problem actually as my keyboard does not work for selecting windows ‘start windows normally’ either like it does nothing… But it works in bios setup and for selecting boot menu…Very odd.
Please advise @Lost_N_BIOS

I always disable boot screens as I prefer checking if all my memory and devices were recognised, so I couldn’t remember the first boot.
Yes. I have 2GB Sticks one from Samsung, the other one from Hynix. Maybe it could be a SPD issue because they are 800MHz/CL6 running at 667MHz/CL5.

No. I opted for Celeron and 1gb of memory because I had lots of spares lying around.

As far as I have googled, there might be chance to work as HP and DELL sold back then 8GB configurations.
You could try them on and see if it boots.
I won’t spend any penny on it but for a q9100 if it works for you.

Enable Usb keyboard from Bios. Most of the times it is disabled by default.

@tonyspanos ,
How would I go about that? I look in usb configuration and it says nothing about enabling keyboard. You have same bios as mine apart from the microcode modification so could you give me your settings?
I put in an extra 1gb ddr2 and it posts which is great… I don’t know if it can use it so I will need to check that next… Now I have 5gb ram.

I opened 135 tabs of Firefox and mem usage went to five gb.
It can use more than 4gb

I think it is named Legacy USB inside the Chipset Configuration > South Bridge Configuration. I will be sure in 4 hours when I get home.

Right that’s currently on auto so should I turn it to on?

It seems I also have it on auto. Try it on.

My Usb Dos Disk was made using HP USB Disk Tool

I put it to on but my keyboard still doesn’t work when either selecting the start windows normally thing or in FREEDOS… Weird! I’ll try tinkering with the batch file to not require keyboard input and see where that gets me - Hoping I don’t brick it
I’ll try your tool tommorow as it is late now and get back to you.
Thanks for your help

Did you try the USB Win98 version I posted? If not, give it a shot, should get it all sorted out for you.

If not, move your keyboard around to different ports, that may help. If it’s a USB Wireless keyboard that may not work always, you might need to dig out a wired keyboard for this, should be OK after that if it was fine before.

If worse comes to worse, we can make you a autoexec batch file. If you end up needing that route and are not sure how to do it, post for me the exact line or lines in order that you normally would enter once you hit the DOS prompt

Do you have the processor to try it? I’ve found one and I’m waiting for your tests to buy it!

Hi @Lost_N_BIOS
It still didn’t work… I have a wired keyboard - tried all the ports but no luck.
Here are the contents of the autoexec file: I can probably edit myself but I don’t want a brick !!
@echo off
echo Launching BIOS Flash For Asus IMISR-VM Ecoquiet 3 Mainboard
echo Type 1 to flash an Asus IMISR-VM Mainboard DESKTOP Version.
echo Type 2 to flash an Asus IMISR-VM Mainboard RMONE Version.

choice /C:123 /N Please choose an option or type 3 to Quit [1=DESKTOP,2=RMONE,3=QUIT] ?


echo Now setting default CMOS Settings
BLAT72FF p6base.cfg
echo Setting RM String
setdmi /SM "RM plc"
echo Please reset the system and check CMOS settings
goto END

echo Now setting default CMOS Settings
BLAT72FF P6base.cfg
echo Updating Settings
settings /SM "RM plc"
echo Please reset the system and check CMOS settings
goto END

@tonyspanos I have to convince my dad to buy the CPU and he wants me to get rid of my T5800 first before purchasing the Q9100. As there is no guarantee it will work is it possible for you to test it? It would be a big help in convincing my dad if you can get it working!
Anyway there may be some complications as I stumbled across this when seeing if anyone else had managed it…
It shows some thinkpad modders shoehorning Core 2 Quads in their GM965 T61 laptops - maybe we will need to mod our motherboards too. Obviously we need to try without cutting pins first or any BSEL thing and see if it POSTS.
Sorry about that!!

Well, you should not end up with a brick at all, since tonyspanos already confirmed both BIOS are OK and booting.
All you have to do is figure out which BIOS you need, then edit the autoexec, removing all reference to the other BIOS you don’t use.

Which one of the following logos do you see during boot, whichever, that’s the one you want to leave in the autoexec