[Request] Asus UX481FL Laptop Bios Unlock

Hi guys, could someone help me unlock the advanced bios settings on my laptop? I mainly want to change fan speeds, but would prefer to have other options as well.

The following are my laptop details:
Bios version: 305
Bios Date:12/17/2019
Bios Vendor: American Megatrends
System Bios Version: 5.15
ME Version: 14.0 Build 1061

I have included my biosreg.bin and the error when trying to write back the dump file. Thanks guys!

Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

biosreg.zip (3.66 MB)

@RogueDragon - Follow this guide
[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Rename .efi file to >> Shell.efi or Shellx64.efi
Unsure which is correct, since I can’t see your BIOS exit page, selecting this item and reading help text there will tell you which

RTC Memory Lock variable to disable >> 0x16
BIOS Lock Variable to disable >> 0x17
Force unlock on all GPIO pads variable to disable >> 0x18
FPRR variable to disable >> 0x6DA

So, at grub prompt, type the following one line at a time, enter between each (case sensitive)

setup_var 0x16 0x00
setup_var 0x17 0x00
setup_var 0x18 0x00
setup_var 0x6DA 0x00

After that, reboot to OS, make a new FPT BIOS region dump using new name (like biosregnew.bin) and then try to write it back and see if you still get error 167
If you have success, upload biosreg.new for me, if you still get error 167 you will have to get flash programmer (CH341A) + SOIC8 test clip with cable to put unlocked BIOS on this system

I am stuck on step two, what am I supposed to be looking for?[[File:Screenshot (3).png|none|auto]]

Screenshot (3).png

@RogueDragon - Sorry, I forgot to tell you!! You can start at step #6, I’ve done 1-5 for you above, sorry I forgot to mention!!

No worries! For step 6, do I need a bootable usb or just a normal usb? Sorry for all the question, I am a total noob.

Just normal FAT32 USB, bootable or not does not matter, or should not, I think I’ve used both ways. But maybe it could cause issues possible, so if you try with and have problems, format it to just normal

got it, thanks!

Following the guide, I was able to disable secure boost by just clearing key management. I didn’t have the option to change OS type. Do I have to create a new boot option? Disable secure boot control? Disable fast boot? Disable launch CSM?


Following the guide, after I select Launch EFI Shell from filesystem drive, my computer goes to black screen with one dash on the top left corner, instead of the grub screen showing instantly. How long should I wait? I tried remaining the file to both Shell.efi and Shellx64.efi. I just copied the file to the root of the FAT32 usb stick. Did I do something wrong?

@RogueDragon - No, you do not create new boot type. Yes, if you see option disable secure boot control. Leave CSM enabled

It should be instant to grub, few seconds at most. Did you try with non-bootable USB, and bootable?

If you can’t get it, follow this method - [Help needed] Hidden Advanced menu Bios HP Z1 J52_0274.BIN (2)
At this post, follow the link to other post, do step 1-2 ONLY, then come back to linked post above and setup USB just as I describe and rename files as mentioned, setup how I showed in the image.

If that still fails for you, or you can’t get it. Do this RU method to unlock BIOS Lock instead - Go to section 2.2 and make bootable USB with RU program, then read 2.3-2.5

The first two ways didn’t work for me and I have problem with the third. I will upload pictures of all my setting so you can tell me if I did something wrong. I will do it in three separate posts, one for each way.

[[File:Screenshot (4).png|none|auto]]







Screenshot (4).png

Option 2:
The HP Tool didn’t put the three files into the usb.
Tried launching shell file from filesystems, boot override to usb, and directly booting from usb from the boot menu. None worked.


Option 3:
Cant find the variables 0x16, 0x17, and 0x18 in RU. Could you tell me which ones i need to change (Specifically, which column and which row)? 05AE was 00 by defalut.[[File:Screenshot (6).png|none|auto]][[File:Screenshot (7).png|none|auto]]

RU_Screenshots.zip (35.4 KB)

@RogueDragon , please put all those BIOS images into a zip, and or resize to 800px wide at most (I’m on limited internet) - thanks!
For HP tool, unless you have "Show Hidden files and folders & uncheck “Hide Protected OS Files” in folder options, then you will not see anything on the USB once HP tool is done.
So HP tool worked, unless you had some error using it. So you can redo this method if RU doesn’t work eventually (I assume you are not in right area with this, checking it’s images next)

RU - EC87D643-EBA4-4BB5-A1E5-3F3E36B20DA9 is correct - and 16, 17, 18 are right there where you are at (near top), it’s just because you don’t know hex is why you don’t see them
5AE will be down when you start seeing 500, past 590 etc (after 599 will be 5A0 and on that line will be 5AE << This variable is not one you need to check/edit
Here, I circled 16-18 for you, line 10 >> 16, 17, 18 - you only need to change 16 + 18 5


5AE not shown, I did not give you this variable but you do have it selected in your image, see post #2 - the other variable is 6DA
So, go past 690, to 6D0 line and where you see "A" at the top of line 6D0 is 6DA - send me new image if you are not 100% sure, and do not make edit if you are not 100% sure

@Lost_N_BIOS , just to make sure, for the RU method, I only need to change 0016, 0017, 0018, and 06DA to 00, correct?

@RogueDragon - Yes, but 17 is already 00 I can’t see 6DA, so can’t comment on that one

@Lost_N_BIOS , got it, I will send new RU pics after changing the variables (before saving).

OK, good idea. Yes, send me 2-3 images, one showing what you did above, after you edit, and then one showing 6D0 area (before/after, if you edit here)

Here is the zip file.

RU_Screenshot_New.zip (28.5 KB)

@RogueDragon - Put 6DA back to 0A - This does not appear to be correct for some reason, it should have been either 00 or 01, so do not change it.
Then test and see if you can now dump biosregnew (new name) and write it back, after having change 16 and 18 only, that may be all you need

@Lost_N_BIOS , got it.

@Lost_N_BIOS , still error 167, even after restarting laptop multiple times.

You only need to restart once Now, boot back to RU and show me top area again, and 6DA
You do have secure boot disabled, and any password or encryption disabled, correct?

Go ahead and set 6DA to 00 and see if that fixes it If not, go back in there and set 0A again

You may need flash programmer here We already tested sleep bug, correct?
If not, put system to Sleep (S3, not hibernate) for 3 minutes, then wake it up and make a new BIOS region dump with new name again, and then try to write it back.

* Edit @RogueDragon - WAIT!! I see the issue, do not do anything yet, I’m writing you out new info!

@RogueDragon -
In setup, please set 16 and 18 back to 01 and if changed, set 6DA back to 0A -

You need to make these changes in PCHSetup, not setup!
Here is the correct GUID to make the changes in >> PCHSetup >> GUID: 4570B7F1-ADE8-4943-8DC3-406472842384