[Request] ASUS X79-Deluxe NVMe and Bifurcation Mod

I saw the P9X79 series of boards were modified to include NVMe and Bifurcation support but the gold version X79-Deluxe has not been requested yet. Hoping to have the most current version of that BIOS modified to include support for these two features;


Thanks in advance to this impressive community.

Will do tonight I think someone else was looking for this too, or maybe you sent me PM?

That’d be me, yea, ha!

I thought so @Xenophobian - Would you also like updated microcodes too while I do the other mods?

I am looking for this too! Very much appreciated. Can’t wait to try it out.
Personally I can use UBU to update the microcodes and stuff myself :slight_smile:

[OFFER] thread:
[OFFER] ASUS X79-DELUXE Bifurcation + uCode + Other Mods

@Deluxe - UBU may break this BIOS at uCode update, please wait. If he does not want updated microcodes too, I’ll make a second edit for you too

@Lost_N_BIOS Thanks!

Maybe the thead title is a bit misleading because the latest official BIOS version 4805 does include NVMe boot support
(I run it with a Samsung 960 Evo and a ASUS HYPER M.2 X4 MINI CARD).

And paired with these updates, it runs’ great:

Disk Controller
EFI Intel RST for SATA - ->
OROM Intel RST for SATA - -> (x79 Trim Mod)

EFI Intel PRO1000 UNDI - 5.5.23 -> EFI Intel Gigabit UNDI - 0.0.24
OROM Intel Boot Agent GE - 1.3.72 -> OROM Intel Boot Agent CL - 0.1.16
EFI Realtek UNDI Driver - 2.020 -> EFI Realtek UNDI Driver - 2.050
OROM Realtek Boot Agent GE - 2.52 -> OROM Realtek Boot Agent GE - 2.67

Other SATA Controller
EFI Marvell SATA AHCI - ->
OROM Marvell 88SE9230 - ->

MC Extractor - v1.38.0 r130 Dev

If all three PCIe x16@x16 slots could be bifurcated, that would be amazing.

@Deluxe - Yes, I see that is true, about the NVME. I wonder why it doesn’t show up at your UBU Scan? I just checked with 1.75.1 and it shows up, so that’s good. Maybe older UBU you used is why it’s not in your list, or you’re only showing updated stuff?
I’ve seen some people have better luck, speeds, compatibility if those native modules are removed and standard NVME mod done instead, but usually best to leave native support there as it should work for everyone.

Bifurcation and the menu mod is the big thing that needs done here, and yes, those slots can be bifurcated as you hoped
For one of them - x8 or x4x4
Another x16, x8x8, x8x4x4, x4x4x8, or x4x4x4x4
And final “” “” Same as above
One of them is already set to x4x4 by default

*For the x4x4x4x4, on some of the P9X79 board variants someone said it’s not working right, but I’m not sure if that is true for all models, or some issue with the PLX chipped boards, or what

I just checked UBU microcode update with this BIOS, since I had it out to see why NVME didn’t show in your details above, and I see it does possibly break this BIOS
This is due to two padding files removed, and sometimes this = brick. Sometimes it’s fine, but you don’t know until you flash BIOS, so not ideal to test like that unless you have flash programmer and backup already made/confirmed OK
Did you already try booting a BIOS with UBU edit of microcodes?

@Xenophobian must be out of town on vacation or visiting family maybe.

@Lost_N_BIOS NVMe does show up in the initial scan (AMI NVMe GUID 634E8DB5-C432-43BE-A653-9CA2922CC458) and I only showed what I already updated, sorry for the confusion.
Using UBU, it does not offer any updates to NVMe.
Yes, I do currently run the system with the above mentioned UBU edits. When I first got this board, I updated the BIOS from a very old version and it resulted in a brick.
I then bought and installed a chip with the latest BIOS already on. Since then I have flashed various UBU edits via BIOS flashback with success. The UUID/MAC stuff was lost of cause.
I do have two flash programmers now, the CH341A and the EZP2019 with all accessories but have not tried them yet.
I will try in the coming days to take a backup of the chip, just so I learn a little more before I eventually have to program it if anything goes bad.
Am I right that I don’t have to remove the chip, I can attach the test clip directly to the chip on the board?

@Deluxe - I thought so, it’s OK So, you did use UBU to update microcodes? Sorry, it’s not clear in your above info, since it does not show UBU specifically updated microcodes.
I can help you fix Serial, UUID etc if you need? No, I think for this board the BIOS is in a socket and you need to use U Type Flat IC Extractor to pull the chip and place it into programmer, clips don’t fit on those BIOS.

In a little bit, I will post Bifurcation mod BIOS + Properly updated uCode Bifurcation mod BIOS

@Lost_N_BIOS Ok. Yes I have updated all microcodes via UBU. MC extractor shows latest versions of 10 microcodes, twice.
I don’t know if I need to fix the serial etc. It would be nice but I dont want to bother you too much.
Thanks for your time and explanations. I will research for and buy the necessary extractors. No stress :slight_smile:

Twice? There should be only five actual microcodes x4 volumes, 20 total. Anyway, the main issue with UBU edit of microcodes on this BIOS is the two padding removals, but since you’ve flashed a BIOS with that in place and it booted then this model is not affected by such a change so nothing to worry about.
You don’t have to fix the serial or UUID etc, but I can help you do it if you want, I don’t mind. For that, we will have to wait until Xenophobian is back because I’ll need him to send me a FPT or AFU BIOS region dump so I can see exactly how the info foes into this model
U Type Flat IC Extractor is only $1 on ebay, let me know if you need a linked example

Here is Bifurcation Mod BIOS These are built on stock BIOS, flash via USB Flashback only
Asus X79-DELUXE-4805-Bifurcation-Mod
Asus X79-DELUXE-4805-Bifurcation-uCodeUPD-Mod-RePack << New link, if you download previously don’t use it (= brick), toss the file, and re-download.

@Lost_N_BIOS You’re right of cause, 5 microcodes x 4.
Great that we know that the padding doesn’t cause issues.
Okay, we wait for Xenophobian.
I may or may not try the Mod before I have the extractor.
I’ll update you as soon as I’ve tried the Mod(s).
Thank you so much so far!

Yes, it’s good to know which models that causes brick on and which it don’t, but I haven’t kept track of that (need to, but often you can’t always tell what caused the brick unless person only updated microcodes with UBU, or manually themselves with tools, then brick)
It happens though, but I can’t really give a guesstimate on a percentage of models I see that get affected by it. But, yes, it’s always good to know which ones it doesn’t matter on!

The bifurcation menu mod is fine/safe to use, no worries, I do that mod for people often (already did all other Asus P9X79 variants many times)
Inside Advanced you will now have new PCI Subsystem Settings submenu, and a new (different) System Agent Config submenu

You’re welcome! Yes, well have to wait for Xenophobian if you want to get your serial and UUID fixed. You’ll need to send me images of the long white sticker on side of PCB, sticker on side of 24 pin, and sticker on top/bottom side of PCI/PCIE slots

@Lost_N_BIOS Update!

I flashed your Mod with the uCode updates.
Brick :slight_smile: Fans spin for a split second and turn off in a loop.
I cleared the CMOS, flashed again, same result.

I then flashed your Mod without the uCode updates.
No brick :slight_smile: System turned on normally.

I then flashed your Mod without the uCode updates - after I updated it’s uCodes via UBU.
No brick :slight_smile: System turned on normally.

I then flashed your Mod with my uCode updates - after I updated other stuff via UBU.
No brick :slight_smile: System turned on normally.

I then flashed your Mod with the uCode updates again to confirm it bricks my system.
Brick :slight_smile:

And finally I flashed your Mod with my uCode updates and other stuff again.
No brick :slight_smile: System turned on normally.

So I guess you should remove the one with the uCode mod.

Do you mind if I create a [Offer] thread with three versions
1) your Bifurcated Mod
2) your Bifurcated Mod + my uCode Mod
3) your Bifurcated Mod + my uCode Mod + other stuff
(By other stuff I mean what UBU offers - Trim support/Network/SATA updates)

@Deluxe - Ahh! Brick, I thought maybe I should have used MMTool instead of UEFITool for that ucode file!! I knew it, but didn’t trust my gut
Yes, other one would have always been fine. Yes, I know why it bricks, thank you for checking, I assumed it would be OK since it looked fine on the things I check, but sometimes you have to use MMTool no matter what and I thought this one was OK and didn’t need it.
Now we know it does, thanks for checking and I’m glad you didn’t sweat it and knew how to recover

Yes, I will remove that ucode one, and replace with another ucode one (proper this time!) So if you want to wait, let me do that, and then you can use as base.
Or, go ahead with your own ucode update mod BIOS, it’s OK, I don’t mind. And no, I don’t care if you create an offer thread with the bifurcation BIOS by itself or used as your base to build on, all good here

@Lost_N_BIOS yes thanks to the BIOS gods for USB BIOS Flashback :slight_smile:

I will create the thread and of cause credit you for the Bifurcation mod.
I think its’ a good thing if one who actually have the hardware “maintains” the thread and keep the mods/download links updated.
Maybe I will use your new uCode version as the base - if I dare :slight_smile: haha.

@Deluxe - New link added post #13, fixed BIOS (RePack), should be OK now I used MMTool this time
Yes, Asus should put that on all boards now, the chip is in place and the USB there too, not sure why they don’t other than to make user pay more for board that offers it.

New BIOS will be OK, promise, try it out I can tell, as I mentioned I had second thoughts about that ucode first time around, and should have known to trust my gut, but I double checked and looked OK.
From now on I will trust my gut about that! It’s due to the few microcode modules in the PEI volumes, those can’t be rebuilt always properly with UEFITool, so MMTool needs to be used (not always though, so pain to keep track)

Apologies - I was out of town visiting family for the Holidays, indeed! I will be back later this evening. What would you guys like me to test? Are the two files posted above one with a simple bifurcation mod and the other has updated microcodes?