[Request] ASUS X79-Deluxe NVMe and Bifurcation Mod

I m using raid (raid zero 2X 850 Evo as a game drive)with rst software v13.2.8.1002 , I am on the latest bios since the release

edit version typo v13.2.8.1002

@guru3d :
The Intel RST Drivers & Software Set v13.2.8.1002 was a good choice!

@Kwstas :

As you can see here, the Intel RST RAID driver v13.2.8.1002 (there is a typo within guru3d’s post) and the related RST Software is running fine with an ASUS X79-Deluxe mainboard.

@guru3d - Can you confirm, last BIOS I posted, RAID was OK there too? #164
If yes, then 13.5 is fine on this model (in BIOS @Kwstas )

Kwastas there is no reason to make 13.1 or 13.2 RAID BIOS, when 13.5 works fine. Your initial request was all the latest, that is “the latest”
Plus, you were concerned about others downloading and using too, saying latest would be best for everyone, so that’s what I did and we worked long time to make it proper without breaking BIOS.
Why would you want older now? That goes against your main request of wanting all the latest Especially since you do not use RAID, no point to downgrade it now for no reason

it is fine

@guru3d - Thanks for confirmation

@Lost_N_BIOS :

You problably mean "without issue" regarding the BIOS modding procedure, but not regarding its daily usage while working with an Intel RAID array.

Just to avoid any misunderstandings:
A) Compatibility of Intel RST AHCI storage drivers with X79 chipset systems:

  • The latest Intel RST AHCI driver, which natively supports the "Intel(R) C600 Series Chipset SATA AHCI Controller" (DeviceID: DEV_1D02) is v13.1.0.1058 WHQL dated 05/02/2014.
  • All Intel RST AHCI drivers up to the v15 platform can be installed onto Intel X79 chipset systems with a DEV_1D02 Intel SATA AHCI Controller, if the installation has been forced or if the missing HardwareIDs had been manually added to the *.INF file.
  • The Intel RST driver v13.2.8.1002 dated 07/09/2015 is the latest from the v13 platform and works fine even with Intel RST SATA Controllers, which are natively not supported. According to my own tests it is the best performing Intel AHCI driver and recommended for all Intel chipsets up to 100-Series.

B) Compatibility of Intel RST/RSTe RAID storage drivers with X79 chipset systems:
  • The Win10 v20H2 in-box Intel RAID driver v15.44.0.1015 dated 02/08/2018 is currently the latest one, which natively supports all Intel RST and RSTe SATA RAID Controllers (DeviceIDs: DEV_2822 and DEV_2826).
  • Due to the not matching chipset specific internal DeviceIDs of the Intel RST/RSTe SATA RAID Controller I recommend to avoid the usage of the Win10 in-box Intel RAID driver while working with an old Intel chipset system like the X79 one.
    According to my tests with different old Intel chipset systems running in "RAID" mode the Intel RST RAID driver v13.2.8.1002 in combination with a v13.2.x.xxxx Intel RAID BIOS module seems to be a very good choice for Intel X79 chipset RAID systems.

@Fernando , yes, I only ever spoke of EFI module / Option Rom. And I mean without issue, as in I read the info and guides, and found the highest appropriate RAID modules for this chipset/board based the EFI/oRom guide info.
I never spoke of any drivers in here, other than to say same I am now >> I was never talking about drivers

So, any info similar or same as you posted above about drivers, that would be up to the user to find and see in the driver thread/guides.
I never suggest any driver versions, only tell people to check the driver threads to see what is best/suggested per their chipset/board etc

So, based on your last bold bit, do you think I should remake this BIOS for them with 13.2 instead of 13.5 modules?
That last bit may be why Kwastas was wanting one more edit package, I guess he never explained it to me where I noticed 13.2 may be better than 13.5 performance-wise
However, he’s never been after performance, and is NOT using RAID, so even if he understood 13.2 may be better for performance, it may not be better for his non-RAID issue/concern

No, the benefit for the user would be minimal and not worth to spend your additional time to downgrade the module’s version.
The sense of my last post was something else. I just wanted to repeat, what I have written very often:
The Intel RST RAID drivers and BIOS modules with the highest possible version numbers are not the best choice for older Intel chipsets.

@Fernando - Thanks for clarifying! It would not take too long to downgrade back to 13.2 from 13.5, I’d just have to make new 13.2 FFS and swap in there.
Oddly, this board, no matter how you try to edit the EFI RST module (MMtool ALL, UEFITool ALL, UBU etc), it causes various issues (failed OC, broken memory stuff, stall on POST Codes etc), unless you make or insert already made EFI FFS for RST
This also maybe applies to another EFI module too, I forget, but it’s in the edit change log.

Plus, I do need to make a final here, and remove that inserted ASMedia orom, it’s not loaded or used by anything so SoniX said no point to have in there.
So, do you think it’s best for all users that I put in 13.2, or it’s OK to leave 13.5, if/when I redo this?

It is up to you what you are doing. Additionally the specific hardware and the preferences of the users are different.

Hi everybody.

I had and have some serious trouble upgrading from my old "950 Pro" (with Legacy support) to a new NVMe (Corsair MP600).
Because my X79-Deluxe was not able to boot from it I decided to flash the Bios from Post #92. I used this, because it was the latest one i can download (the Link from Post #164 gives me "Premium Access only").

After EZ-Flash rejected this with "wrong version" I forced it using the flashback procedure … and killing my flash chip to dead :frowning:

I immediately ordered 2 new chips from an ebay seller and told him to flash one with the manufacturer image and the one from Post #92 (03.12.2020).
Today the chips arrived and my machine is running again. But the modded Bios has all kinds of issues … no overclocking … very long posts etc.
But the MP600 now appears as "PATA SS:".

Now I have some questions and hope someone can bring light into my darkness :slight_smile:

Why my EZ-Flash (Bios 0902) refused to flash the modded 4805 and why flashback killed my Bios?

After this I also tried to flashback my old 0902 which starts (Blue Blinking … reading from Stick …) but ends with a solid Blue LED (meaning wrong version) … could this indicating a faulty flash chip?

And the most important question right now is … can someone please upload the latest functioning version of the mod?

Many many thanks in advance

Never killed a SPI/Flash with Asus BFB…never take out the USB after 2 posts at least and never try access bios in first reboot of BFB, let it run freely.
Some modules r updated after first reboot even if u dont see nothing in screen, depends on model and bios.
Most models the behavior of FBF led is, blinking, increasing blink rating upon percentage done, till it stays stationary or OFF.
Had an Asus X79 (Normal) upon finishing stayed LED lit.

EDIT: As i said i’ve seen different reactions upon different models of motherboards, in both cases, i always w8 about 30s-1m, then ALL power off 5m, then restart machine, if it fails (even with new SPI chip) u may have an HW issue SPI or motherboard function. Before any flash process used, its always recommend to load default bios or reset cmos, preventing issues as u had…no need to w8 15m…that supersticious.

EZ flash utility do not accept mod bios due to security settings from ASUS
For all ASUS with BFB, this is the safest way to flash mod bios

The link was provided by Lost…is been away for some time, only others can provided the file, i do not have it.

Thanks for your answers.

Do you mean I have try to start the computer after the LED stays lit?
I have waited about 15 minutes and the machines had done nothing at all. And after i tried to start the machine nothing happend … no beep … nothing.
But when I replaced the old chip with the new one, the machine posted with a message saying "Updating 1% … 100%".
Do I have to reset the bios settings in advance to BFB because it can hangup due to overclock settings?

Please, can someone offer me a working version of this bios mod?

Could someone repost that bios from a few pages back? the link is either dead or a pay wall…


https://drive.google.com/file/d/1HzDN6A9…iew?usp=sharing @jjaomni

https://drive.google.com/file/d/1HzDN6A9…iew?usp=sharing @jjaomni
Latest working version

@guru3d : Why did you post the same link twice?
By the way - both of them do not work for me.

Could someone re-upload modded BIOS files?
Neither links in this thread nor in "OFFER-ASUS-X-DELUXE-Bifurcation-uCode-Other-Mods" work

Hey @guru3d or anyone else that has this file. If you get a chance can you re-send the link. The 2 links that were posted are to a truncated url which points nowhere.