[REQUEST] Bifurcation Asus x99-a II - 5820k

I tried to do it myself following this guide “Guide-How-to-Bifurcate-a-PCI-E-slot”(on this forum, cant post link) but the change made with ru utility doesnt seem to do anything. I’m using a “Asus hyper m.2 v2 (pcie gen3) card” with 2 sn750(tried slot 1-2 and 1-3). It’s in iou0 which is slot 2a(pcie16_3), videocard in iou1 slot 3a(pcie_16_1). When I tried to split the videocard pcie it keep showing current link width 16x in hwinfo portable. I prefer doing thing myself but honnestly I’m completly lost.

From what I understand with a 28lane cpu pcie16_1 and pcie16_4 have a shared bandwith, I need more then 8x for the videocard so I can’t use pcie16_4, pcie16_2 is not from cpu lane and is gen2 at 1x or 4x if usb3.1 is disabled, which leave pcie16_3 at 8x (16x with 40lane cpu)

I’m assuming that because I use a 28lane cpu their is a different variable to change but I couldnt find it. I’m using the onboard m.2 slot x4 + video card x16 on pcie16_1 so it shoud leave x8 for the hyper m.2 card with 2 drive in it on pcie16_3. bios 1801


those are the 4 variable I tried to change with RU utility

0x1703A Setting: IOU0 (IIO PCIe Port 2), Variable: 0x533 {05 91 BF 04 C7 04 50 02 01 00 33 05 10 10 00 FF 00}
0x1704B Default: 8 Bit, Value: 0xFF {5B 06 00 00 00 FF}
0x17051 Option: x4x4x4x4, Value: 0x0 {09 07 C8 04 00 00 00}
0x17058 Option: x4x4x8, Value: 0x1 {09 07 C9 04 00 00 01}
0x1705F Option: x8x4x4, Value: 0x2 {09 07 CA 04 00 00 02}
0x17066 Option: x8x8, Value: 0x3 {09 07 CB 04 00 00 03}
0x1706D Option: x16, Value: 0x4 {09 07 50 0A 00 00 04}
0x17074 Option: Auto, Value: 0xFF (default MFG) {09 07 76 03 20 00 FF}
0x1707B End of Options {29 02}

0x1731E Setting: IOU0 (IIO PCIe Port 2), Variable: 0x534 {05 91 C0 04 C7 04 65 02 01 00 34 05 10 10 00 FF 00}
0x1732F Option: x4x4x4x4, Value: 0x0 {09 07 C8 04 00 00 00}
0x17336 Option: x4x4x8, Value: 0x1 {09 07 C9 04 00 00 01}
0x1733D Option: x8x4x4, Value: 0x2 {09 07 CA 04 00 00 02}
0x17344 Option: x8x8, Value: 0x3 {09 07 CB 04 00 00 03}
0x1734B Option: x16, Value: 0x4 {09 07 50 0A 00 00 04}
0x17352 Option: Auto, Value: 0xFF {09 07 76 03 30 00 FF}
0x17359 End of Options {29 02}

Setting: IOU0 (IIO PCIe Port 2), Variable: 0x535 {05 91 C1 04 C7 04 79 02 01 00 35 05 10 10 00 FF 00}
0x175EF Option: x4x4x4x4, Value: 0x0 {09 07 C8 04 00 00 00}
0x175F6 Option: x4x4x8, Value: 0x1 {09 07 C9 04 00 00 01}
0x175FD Option: x8x4x4, Value: 0x2 {09 07 CA 04 00 00 02}
0x17604 Option: x8x8, Value: 0x3 {09 07 CB 04 00 00 03}
0x1760B Option: x16, Value: 0x4 {09 07 50 0A 00 00 04}
0x17612 Option: Auto, Value: 0xFF {09 07 76 03 30 00 FF}
0x17619 End of Options {29 02}

Setting: IOU0 (IIO PCIe Port 2), Variable: 0x536 {05 91 C2 04 C7 04 8D 02 01 00 36 05 10 10 00 FF 00}
0x178AF Option: x4x4x4x4, Value: 0x0 {09 07 C8 04 00 00 00}
0x178B6 Option: x4x4x8, Value: 0x1 {09 07 C9 04 00 00 01}
0x178BD Option: x8x4x4, Value: 0x2 {09 07 CA 04 00 00 02}
0x178C4 Option: x8x8, Value: 0x3 {09 07 CB 04 00 00 03}
0x178CB Option: x16, Value: 0x4 {09 07 50 0A 00 00 04}
0x178D2 Option: Auto, Value: 0xFF {09 07 76 03 30 00 FF}
0x178D9 End of Options {29 02}

@frogger - There is twelve possible changes to make, three per IIO. The IOU names and slot names in the BIOS do not correlate to the slots on the board, you need to change each possible option one at a time until you find which apply to the slot you want to use.
And anything you change with RU will be directly applied, so you’re just not changing the correct thing to affect the slot you are testing in right now

And yes, first you need to change each IIO to 28 lane CPU type (First setting inside each IIO), then reboot, and then make 12 test BIOS changing each IOU0-2 to the setting you want to try using.
To me, making 12 BIOS is easier than making 12 changes one at a time with RU, but whatever is easier for you do that way. While trying to figure out which slot is what setting in the BIOS, do not worry about what happens to USB or video card etc, focus only on what happens width-wise to the slot you are targeting
If you need me to make you 12 test BIOS so you can figure out which setting affects the slot you want to use, I can do, just let me know what bifurcation setting you want applied in each of the 12 BIOS (ie 4x4x or 4x4x4x4 etc - all should be same, and your target goal)

@ Lost_N_BIOS - Hi, thanks you! I tried again but keep failling. I’ve found this thread Asus X99-A PCIE Bifurcation only difference is I’m using a 28lane cpu and asus x99-a II. I tried like you explain in a post there but it didnt work. Starting to wonder if it’s possible with a 28lane cpu. When using a 28lane cpu the second 16x port is running at 8x instead, I assume that is what is causing the issue, or not as I tested the 12 bios I made and none of my pcie width changed. In case it was an issue with hwinfo I checked, everytime, the windows disk management too.


At this point I hope I couldnt follow those instruction correctly and would like to take your offer, that’s the bios I’ve used https://dlcdnets.asus.com/pub/ASUS/mb/LG…I-ASUS-1801.zip, I’m looking for 4x,4x or 4x,4x,4x,4x


My goal is to run a nvme drive onboard at x4, 1 video card at x16 and 2x nvme at 4x in a quad pcie card. At the moment I can’t make the second nvme drive on the quad card to be detected and the port stay at x8.

You can’t split a video card lane width? I am not familar with this board or it’s slot layout etc, I’ll have to look at all that.
But your last comment is confusing, so maybe this is the issue. First, for a quad card, you need to test all four slots on the card, or read the manual, sometimes only certain slots can be used with single card, or dual card etc, so make sure you are using the correct slot for 2 x NVME on that card.
And then to the confusing comment. When you install this card, with two NVME on it, the port will never be x8 (nor will it be x8 ever once bifurcated). The slot will be 4x4x if that is what you set/want.
And for that, 4x4x I mean, some settings may not have that as an option, or 4x4x4x4x if only option may not work on that slot either due to limited lanes/width due to CPU etc.

So, lets first rule out possible issues, and then you test your 12 BIOS again, if still fail then I will make you 12 BIOS (I assume these might be same/same, if you did things correctly)
2* When using a 28-lane CPU, the PCIe x16_3 slot support up to x8 mode.
3* The PCIe x16_2 shares bandwidth with USB 3.1 and PCIe x1_2 slot. By default, the PCIe x16_2 slot automatically runs at x1 mode. << Remove any x1 card for now, and change this setting in BIOS if there is one, so default of that x16 slot is not x1
Install only one graphics card in first x16 slot, nothing else. Then test your 12 BIOS, with dual card only and two NVME on it, in all slots for each BIOS.

what I do is open stockbios.cap in uefitool 0.21.5 > right click ami aptio capsule > extract body > save as stockbios.rom> open stockbios.rom in amibcp 5.02.0031> go to common refcode configuration - intelRcsetup - IIO - IIO 0 > set failsafe and optimal cpu type to 28lane > set x4x4 or x4x4x4x4 on only one of the port for IIO 0 to IIO 3 totaling 12 mod.rom > open stockbios.cap and the 12 modbios.rom in hxd(hex editor)> select all on 1 of the 12 modbios > copy > go to start of 800 in stockbios.cap > paste write > save to modbios1.cap to modbios12.cap > rename one of the bios at a time to X99A2.cap and copying it on a mbr fat32 usb in my flashback usb slot, stop the computer and push the flashback button and wait a couple minute for it to finish > open bios load optimised default > save exit> boot > open hwinfo and check pcie on bus0 and never see a change on anything.

according to my mb manual x16_2 is a gen2 chipset slot not a cpu one and I don’t use any x1 card, I’ll try again disabling my 3.1 usb to run the x16_2 at gen2 x4. take about 15minute per bios total so it might take a while.

@frogger - Don’t use such old UEFITool, at least it’s bootable, but that’s not good I suggest using 25.0
Do you set the bifurcation to xxx setting, for once each inside each IIO? Example IIO-0 >> IIO-0 >> IOU2 Set items = one BIOS, IIO-0 >> IOU0 Set Items = one BIOS, IIO-0 >> IOU1 Set items = one BIOS >> So three total for IIO-0?
If yes, that is how to do it, then repeat for the other three IIO’s. It may be issue with using 21.5, use 25.0 and make BIOS again.

Don’t check only PCIE Bus 0, you need to check all slots with HWINFO each BIOS, until you know what is what.
And you need to have card installed each time too, then move the card around to all slots, for each BIOS you test (test all slots with card, for each single BIOS) - Until you know what slot = what BIOS setting.
If it’s easier for you, you can use graphics card as the test item, check it’s lane width on each slot for each BIOS, once you see it’s lane width at x4, then you know it’s the bifrucated slot for that BIOS

I’ll get the last version. But i noticed that when I change iio 0 iou 0 to x4x4x4x4 it detect a diffent nvme. This behavior only happen with this one so I assume it’s the right port but i can’t get it to detect both at the same time. Without iio 0 iou 0 at x4x4x4x4 it detect the drive in card slot 1, with the setting it detect the drive in card slot 2. Will try to keep this setting and swap drive from 1 to 3 or 4 and see if it change something.

I meant pci bus 0 as its the only one with pci bus 255. But i do check all bus under it

Don’t use above 25, I’ve not tested with this BIOS, and it may cause issues, use 25.0 as mentioned
What do you mean it detected a “Different” NVME? Set that to 4x4x instead and try again. You may need VROC Key for this card and this board, I am not sure about all that.

Alright i will get the 0.25 one then.
I mean in my hyper m.2 card I had drive 1 in slot 1 and drive 2 in slot 2 slot 3 and 4 are empty. With 5 of the bios( didnt test more for now) the drive in slot 1 is listed and detected in hwinfo and disk management, with the first bios iio 0 iou0 the drive in slot 2 is listed and detected in hwinfo and disk management.


I dont think i need vroc if i want software raid or no raid. My board dont even support vroc but I’ve seen plenty of people have got this card to work with board that do not support vroc.

Thanks for explaining some, but it’s still not clear what you meant Both NVME detected with one BIOS, or no?
Also, as mentioned, read your manual for this Hyper card, with only two NVME in use you have to put them into certain slots.

There is nothing in the card manual sadly.

Only 1 drive at a time but with 1 bios it’s a different drive
--------------------

On the hyper m.2 I have disk1 and disk 2. With bios IIO 0 - IOU0, when 16_2 is at x4 because i disabled the usb3.1 and pci 1_2 , hwinfo show disk2, when 16_1 is at x1 it show disk1.


Beside that nothing change. There must be an aditionnal variable to change to make it work and see both drive at the same time.

Yes, sorry, I see that now about the manual. I assumed it was there, but maybe I was thinking about the Supermicro adapter, and Asus one you can put drives in any slot and it’s OK (I assume this, since none of the manuals mention anything about , if only 1-3 drives use xx slots)
Have you tried creating a RAID array, in any of the possible manners (In BIOS, or in Intel RAID management, or in Windows)?

With this BIOS >> IIO 0 - IOU0 << What do you have set for bifurcation? Sounds like this is working, when you disable USB 3 and PCIE x1, so if this is the slot you want to use then change this BIOS setting to what you need ie 4x4x
Or, use other slot, that is not limited/tied to USB/PCIEx1. For that, you’ll need to find which setting applies to these slots.

I did not try to create a raid before.

I’ve reset the cmos and installed a bios 2101 with IIO 0 - IOU 0 - x4x4x4x4. This is x16_3. I Only see one drive ,disk1, but with usb3.1/pcix1 disabled I still see 1 drive but it’s disk 2. With any other bios I still only see 1 drive but it’s always disk 1. it’s weird and I don’t understand. The manual say they are not related, the more a look at it the less I understand why it’s happening.

Maybe I need to manually enable port 2b or 2c to see 2 drive at a time, I think I saw this option in amibcp

The only way you can use this card is via RAID, this is mentioned in the manual. You have limited lanes, so you should only be setting 4x4x, especially if that is all you plan to use, so make new BIOS with 4x4x set and then try to create an array.
All those 2a/b/c/d etc are enabled, this is just how you’d see and possibly change something, if you had unlocked BIOS. This has nothing to do with what you need done here though.

Also, read the review comments here, as I mentioned, you need VROC key if you want to use more than one NVME and that only works on certain board with certain CPU’s etc (of which, I do not know)
https://www.amazon.com/ASUS-M-2-X16-V2-T…r/dp/B07NQBQB6Z

* Edit, I purchased one of these for testing a while back and have not played with it yet. I also have 4 NVME’s to test in it, so I will check this out on a Z490 I have on bench right now and see what I can notice.
This is not really ideal setup though, it has a Celeron CPU and limited lanes generally due to that and chipset etc. But, I’ll see what I can figure out, if anything, about what happens with 1 or 2 NVME installed.

Thanks!
I can’t see x4x4 option only x4x4x4x4 for this port(x16_3 which is IOU 0).

In manual #6 is vroc and show as optional, vroc only work with certain motherboard and only with intel ssd. You do not need a vroc key for software raid 0, I’ve seen plenty of post about people doing just that, but they all had 40lane cpu, I’m not sure it’s possible with 28lane while using 16lane for gpu.

#7 in manual does say to set raid in the bios for this pcie card but I can’t see this option, that could be the thing I need to enable, will try to find it.

edit : going to read this, seem similar How to build Multiples DATAS NVMe RAID 0 on a X99 PC (edit 2: not much help for my issue)
edit 3 : I think I need to disable auto-sensing or something like that, manual pcie bifurcation never take so something must be overiding it. I’ll try to look into that.
edit 4 : found “hardware autonomous width” that is enabled in default and optimal (appear to have no effect)

Then choose other port, otherwise you don’t have enough lanes to spare with x16 graphic card installed, unless you manually limit that slots lane width to x8
vROC is only one kind of RAID, there is several other methods, but manual says RAID must be used, and with only two cards installed I’ve seen several users only see one until they went to setup array.

Advanced >> PCH Storage >> Hyper kit Mode (Enable this)
Advanced >> Onboard devices >> Also notice the two PCIE lane settings here (PCIEX16_2 Slot Bandwidth + PCIEX16_4 Slot Bandwidth)

* Edit - @frogger - I did some testing as I mentioned I would

Z490M-Gaming-X + G5900 Celeron 16 lane CPU, onboard graphics used and Hyper in main PCIE x16 slot
Hyper V2 + 2x Intel SSDPEKKF256G8L (Enterprise 760p)
“RAID” mode not set in BIOS, AHCI is used
Bifurcation set to 8x4x4x or 8x/x8 (only options in this BIOS as it is)

So, it seems RAID is not a must! But, it IS about what slot you use on the card, as well as what bifurcation options are applied to the PCIE slot being used!

NVME in Hyper slot 1+2 from top, only one NVME visible in BIOS/OS >> w/ either 8x4x4x or 8x8x set
NVME in Hyper slot 1+3 from top, both NVME visible in BIOS/OS w/ either 8x8x or 8x/4x/4x
NVME in Hyper slot 1+4 from top, both NVME visible in BIOS and OS ONLY w/ 8x4x4x - with 8x8x set only one NVME visible in BIOS/OS, same as if slot 1+2 is used

If you need me to re-check with non-intel NVME’s to confirm they act same, let me know

4x4x4x4x may have different results than my above testing scenarios, or things may also be different with other CPU’s w/ more lanes avaiable, I am not sure.
But, seems to me, at least for two NVME, set 4x4x if possible or 8x8x, or 8x4x4x and use slot 1+3 or 1+4. You may need to find which slot 3/4 works best for your second drive, with whatever bifurcation setting works there to make both appear.
Seems 1+3 is best choice, at least that slot worked best for me with two drives and the limited lanes and bifurcation options I tested with.

Also, it’s probably best due your limited lanes as well, to find which slot has most available lanes to you, or which has enough for what you need, that also offers 4x4x only, 8x8x, or 8x4x4x etc, so lanes are not wasted.
Ideally, find which slot works with IOU2 from each IIO, because that one offers 4x4x and that is all you need here.

* Edit - Follow up RAID creation testing - I tested, and seems I can only create an array within the BIOS with Intel branded drives, other brands only one shows up so can’t create array (no matter the BIOS config)
I did not test in OS. So, VROC Ket may be required to RAID non-Intel drives, I am not sure.

Thanks for that, it helped me understand more about the subject.

I’ve tried everything I could find and think of and nothing work so I’ll just wait and upgrade to a 40lane cpu if I can find an affordable option.

@frogger - You’re welcome! Yes, it could be due to CPU limited lanes and how they are laid out on the board. So, no cheap x40 lane Xeon or regular for x99 yet?

need decent single thread performance so I was looking at 5930k or similar. Cheapest I could find on ebay or localy is around 300$ cad for a 6850k. Good thing about 40lane is I could get 2 more drive, but I’m not sure, will think about it.

Wow, yes, that is still high prices for such older CPU’s, I can’t believe their prices are still this high!!

Checkout Xeon’s in Server and main CPU desktop area of ebay, sometimes these are much cheaper than regular CPU