[Request] BIOS extract and flash by EFI Shell Acer SF315-52

Hello!
I have Acer Swift SF315-52 with board ER5EA, BIOS 1.08.
Unfortunetly after Windows Update to new build system has been corrupted and wont boot. Any repair by sfc, dism, rollback’s etc didnt helped because registry are corrupted and latest Windows 10 dont have automatic backups of registry. For some reason, when i tried to boot Windows installation media (CD/USB) and any other USB boot tools (this model has only UEFI boot, no CSM), with and without secure boot enabled and with reset to defaults BIOS but all that fails. When attempted to boot any bootx64.efi there is half second black screen and go back to boot menu.
So i deattached SSD M.2 NVMe, placed there Windows 10 Pro in “To Go” version and tried again to boot.

For now if i dont enter to boot menu by F12 (there is on the list Windows Boot Manager on that SSD) laptop automatically wont try to boot and enter to BIOS settings (AMI Aptio) like there is no disk.

When try to boot from F12 even from that internal M.2 SSD is same black screen for half of second like from other boot devices earlier.
For now only thing that boot’s is EFI Shell from USB, DLC Boot but only menu and linux Acronis True Director but only this, other hangs when try boot.
It looks like BIOS corrupted for some reason.

With using efi shell bootx64.efi and start from there afuefix64.efi i managed to dump bios. I have dump from working laptop of my friend with afuwin but when i try to flash back with /p /n /b or /recovery i have error for example:
18 - Error: Secure Flash Rom Verify fail.

Can somebody please help me with that? Way to force flash of this BIOS from other one? Maybe other way to do that from efi shell or something?
If not please help me extract clean bin from update package. Unfortunetly this update packages are different from other Acer laptops because it’s AMI acer flash tool, not insyde which is easy to decompress.
I have programmer TL866A but with clip wont read from this board. I don’t wont to desolder this one because its on Warranty (not Acer Warranty), if i must i will send for that warranty but they will refund. For that refund i will not buy even close to this laptop now in time of COVID-19 :(.
Please help. Probably i described too much, sry for that and my english.

@fauxkalel - You don’t want to use your friend’s BIOS, then you will loose your serial, UUID, and possibly MAC ID too (as well as Windows key)
To me, sounds like you need to format your drive and reinstall windows, this is not BIOS related. It’s normal for system to go direct to BIOS if HDD/SSD is not there.

I would do below with Win10 installer on USB - Make USB with this, ignore sys requirements, it works for Win7-10 >> https://www.microsoft.com/en-us/download…s.aspx?id=56485
Then do the following - You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Or from repair/troubleshoot options in the installer/setup. Remove all other drives, so you have only USB and target win10 drive. Then from CMD prompt do the following

1. Diskpart
2. List Disk << Here, identify what your target disk is by size/name etc, and make note of it’s #, you will use it’s # next - (If in windows, these #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
3. select disk # << Here, instead of #, put target disk #, example >> select disk 0
4. clean
5. Exit

Reboot and run the installer again, then point it at the raw/blank drive, do not load any drivers or create any partitions etc, just select drive and click next

Please link me to your stock BIOS download page *not the BIOS direct link, but the page you download it from.
Or confirm the link below is correct. Since I am not 100% sure if this is your model, it’s the only one I see SF315-52G
https://www.acer.com/ac/en/US/content/su…roduct/7630?b=1

Then I can give you the stock BIOS rom + the included command switch it uses (not same as you mentioned above)
This will retain your system specific info. But, as mentioned, I do not see a BIOS issue here, or any reason to want or need to reflash the BIOS.
When you update BIOS, does it update right then in windows, or does it reboot first and then perform the update?

As for programmer, some systems need main battery and or power cable connected before you can read chip, some need both removed.
Some need one or the other connected, or both, or neither, so keep trying if you want, it’s rare that you’d have to desolder chip.

First there is no problem to replace s/n etc. in bin file, especially when it will start run fine.
Windows key is not placed in bios, laptop was bought without os.

Second, laptop shouldn’t enter bios, when disk is placed (like i said before), probably only when all internal disks are removed, so it is not working properly. I tried put disks into 2,5" sata, m.2 with nvme and both -no change, still entering bios.
Any formating or cleaning disks with diskpart not change this. Again like i said before, usb created with Windows Media Creation tool or manually wont boot to start installation of windows (even from original usb attached to original windows license).

I can’t boot any windows, even mini windows (PE) from any media i tried.
It looks like exacly bios problem.
Few months ago all that tools was booting fine on this laptop.
All sugested steps if possible have been tried. Your post looks like you didn’t read properly what i posted or you misunderstand me (maybe my fault).
Again i add here that i have even tried clean internal ssd nvme with diskpart and maked windows to go bootable disk that is working ok on other pc (ofc maked on other pc), thia result in properly recognised windows boot manager in bios on that drive but still no boot.
I was making it with rufus for example. Do you now what is windows to go and how it works?

It looks like this corrupted uefi can boot only small bootx64.efi files like efi shell or ntfs4uefi.
From efi shell when i tried boot Windows bootx64.efi from boot partition resulted exactly same black screen for half of second and back to efi shell.
You choosed wrong model, my is without “G” which is often in acer for dedicated graphics models.
acer.com/ac/pl/PL/content/support-product/7629?b=1

So product id in url 7629 not 7630.
Thanks for trying help.
Can you tell me how you extract/get this update file from this ami flasher?
Sometimes when started its decrypted/extracted all in temp path but i dont see any this time.

@fauxkalel - There will be SLIC key in BIOS, and matching OA3 as well, which may differ if you use another systems BIOS.
Not coming with windows does not matter in regards to this, but if you install a non-OEM windows it may be OK ?

Yes, that’s what I meant, with disks removed (as you mentioned), it enters BIOS. And you can enter BIOS normally, all seems fine with BIOS to me, redo the original OS drive.
Hmm, what you say about that now, just sounds like incorrect BIOS settings per your windows install attempt method (Disk initialization, if not RAW, needs to be GPT, same for USB)
Yes, I did read what you said, a few times, but maybe as you mention I did not understand exactly how you were outlining things?

Rufus causes many issues in regards to this, I see this often, that is why I said use USB/DVD tool

Before you formatted the original drive, did you look at it for hidden partitions? Sometimes systems come with hidden partition that is meant to be booted to first, especially if system has eMMC drive anywhere

Thanks for link, as I said, I could not find model without the “G” Turns out the use the exact same BIOS file/package anyway
Here is the extracted exe file contents, this is done with AMI BIOS creation package tool called AMIUCP - http://s000.tinyupload.com/index.php?fil…545874034256184
I assume you’ll only be able to use the rom since you can’t get into windows, but do check out the CMD text for default command line used with the EXE

Be careful due to if boot guard is enabled, drop BIOS into UEFITool Alpha NE version 51 or above, anything you see colored Yellow, Cyan, or Red you cannot touch/edit.

I’m sorry for a long time with no response but I got covid myself.
Please tell me which bios (dump or unpacked update) to put into UEFITool? I have version 58 and I see ambiguous information about boot guard in various places.
Second thing, is it possible to program the unpacked bin using some EFI shell tools? From what I remember, the contents of the BIOS (6MB dump and unpacked 8MB) are similar, so it is possible to determine where to cut the file?
Won’t boot guard allow me to flash BIOS from update package? Theoretically, such a package probably has a clean ME region? If not, maybe it is enough to clear the ME region? Well, unless it’s something completely different. I have fallen out of circulation a bit, and a lot has changed over the past 8 years.
Best regards and thank you for your help so far.

@fauxkalel - Sorry to hear you ran into covid!! Great to hear you made it through OK

In regards to Boot guard, I can’t comment anything about that until we check to see if it’s active at the chipset level.
And I can’t advise you how to do that until you tell me what ME FW version you have? If boot guard is active at chipset level, I will have to do all BIOS work for you or you will end up with bricked BIOS.
Nothing in Cyan, Yellow, or Red can be touched/modified if Boot Guard is active, so you can’t mod BIOS in a normal way for many thi8ngs, all must be done very carefully via hex.

I looked back up at your inital info again, and I still say 100% this is not a BIOS issue, you can enter BIOS, so BIOS is fine.
This is a BIOS settings issue you need to sort, and or resort your HDD/SSD properly. For that, you may need to speak with Acer and ask them if the disk needs setup some certain unusual way.
Did you test BIOS boot settings set both ways, UEFI and or legacy? Depending on your graphics, you may need to use one way or the other, this may be cause of the black screen.
And SSD needs to be “initialized” a certain way for UEFI (GPT) or legacy (MBR), otherwise you can’t install windows or boot windows properly etc.

OK, I see you say UEFI only here. So test, Secure boot disable, make SSD RAW or at least initialized as GPT NOT MBR first, then do a clean windows install
Don’t say “This fails” that tells me nothing, you must explain how it fails, where it fails, what it says etc.

I can make you a new BIOS, if you send me your dumped BIOS. But as I Mentioned, I don’t think this is needed and wont change anything, but we can try if you want.
You personally should not do anything with the extracted BIOS file, it’s in a capsule, contains EC FW, and is only partial BIOS “update” not a complete BIOS at all.
+ If Boot Guard is active you can brick the system if even one byte is wrong

What is your BIOS chip ID? Read it with your eyes, do not rely on software to tell you because that’s not always correct.

Read/programming wont working with soldered chip, so i desoldered, make dump, and programmed with dump from internet. Now laptop working again. Then Windows TO-GO from internal pcie booted no problem, windows USB install disk too. Dump was with older bios so when i booted updated it and reconfigure bios again (update restored default).
All is working 100%.
I was doing this in the middle of night and i even do not remember if i cleaned ME region in this dump, but looks like i do because i didnt observed any problems.

I have question about update package:
1. It is more than 8MB file but i find that 6MB dump with afuefi was starting with other hex. So i cut it to this offset (it was capsule header and/or maybe checksum), but this update even if it is builded with parts of BIOS must have this parts. How it can be decrypted to bin needed to programm with programmer? Must be some easy way to do this.

Beside that: I know everything about GPT/MBR. And is not true that UEFI can’t boot from MBR. UEFI usually dont have driver for NTFS FS, but only for fat32 so there must be boot partition on every disk with FAT32 with file to boot for EFI like fs0:\BOOT\EFI\bootx64.efi (or other boot*.efi for current cpu architecture).


ME inside dump with programmer:
Firmware Version 11.8.50.3470
Firmware Size 0x1BF000
Power Down Mitigation No (NPDM)

For everyone trying fix this platform i attached many files i find and modded myself to work:
SF315-52_BIOS&ME_Dump+Update+MEregion+Info


Archive content:
Folder “FinalWorkingBIOS”:
8MB_programmer_SF315-52DumpOK + ME 11.8.50.3470 - 11.8.50.3470_CON_LP_C_NPDM_PRD_RGN
8MB_programmer_SF315-52DumpOK.BIN
mod_without_capsule_Update1.08_BIOS.ROM

Folder “MEregionClean+BIOSinfo+dumps+corrupt”:
6MB_afuefi_SF315-52DumpOrgCorrupt.bin
6MB_afuwin_sf315-52dumpOK.rom
8MB_programmer_SF315-52DumpOrgCorrupt.BIN
BIOS_info_and struct.txt
ME from bios 8MB_programmer_SF315-52DumpOK.BIN
ME_info.txt
Update1.08_BIOS.ROM

Nice to hear you have it working again now, good job!

6MB AFU Dump is BIOS region only. I’d have to see a dump of your original BIOS before I could tell you what the missing 2MB is here, stock BIOS does not contain everything and may also contain some stuff that does not get written to chip.
FD, ME, and possibly other regions are missing from stock rom, and it’s also encapsulated.
So to answer your general question, you can’t use stock BIOS to program to chip, you can only use some parts of stock BIOS (certain volumes etc) + some parts of a dump, to compile your own new clean BIOS to program to chip.

Thanks for the info, I was not aware of that about MBR and UEFI.
I guess I only know what is “generally” possible, for average user with no skills to do, and that = don’t try to boot or install UEFI mode on MBR, usually this is an issue with users new to using NVME where it needs to be GPT as well…

Thanks for posting your files for others