[Request] Bios Hidden Menu Unlock and SATA controller mode unlock - Imedia S1800 - P01.A4

I have a Packard Bell Imedia s1800.
Would anyone be able to unlock the hidden menus along with the greyed sata controller option?
What I request is that I want to change the SATA controller mode to ahci but it is greyed out. If possible, please unlock the hidden menus and options within the bios.
I am new to bios modding.
I believe I have attached the bios with this post but if not, extract the zip file.
This is for the P01.A4 BIOS.

Thanks and Regards, InfernoWolf19

BIOS_PackardBell_P01.A4_A_A.zip (1.59 MB)

@InfernoWolf19 - Please link me to the BIOS download page, thanks

We’ll have to see if it’s possible to flash mod BIOS without flash programmer. What type of CPU is used here, and if Intel, what is the chipset?
It may work with the included DOS flash tool, have you tried to flash mod BIOS with the stock included AFUDOS before?

For menu unlock, I need images of your current BIOS, ALL pages you can see, show all root level, and submenu contents as well, ALL Settings you see.
I do not need to see their variables, only every setting. Except for the SATA setting you want changed, show me all options you see for this setting.
Please put these into a MAX compressed zip, and if you know how, please resize them first, 800-1000px wide is more than plenty.

@Lost_N_BIOS - Thanks for the reply

For the download page, head over to this link: https://www.packardbell.com/pb/en/GB/content/download. In the site, click “Select my product from a list”, then click “Desktop” under category group, then select “iMedia” under category series, then select “iMedia (PT.U59-PV.U59)” under category products. Lastly, head over to subsection “BIOS/Firmware” underneath and then click download next to version P01.A1

Regarding your question of what CPU I am using, this pc is using an Intel Celeron E3300 Wolfdale CPU with Intel G41 Express Chipset

Also, I have never tried to flash a mod bios with afudos tool. I flashed the stock bios with “WINflash.bat” which executes AFUWIN.exe. This is my first trime trying to make and flash a mod bios.

Lastly, I can’t attach the zip file with all images of my BIOS including menu and submenu contents along with all of the viewable settings because zip file after ultra compression is more than 6 MB. Instead, could you please download the BIOS Images of Settings ZIP file from this link -

Thanks and Regards, InfernoWolf19

@InfernoWolf19 - Thanks! That site does not work for me, once I click anything it errors out, before that, it’s all messed up too, tried multiple browsers.
Is the above attached file the full package or EXE etc, exactly how it’s offered at their site?

Thanks for the images, but please resize them, I am on limited internet and don’t want to download 50MB for something I only need to look at for a few seconds.
If you do not know how to resize images, there is many batch image resize websites where you can select all, upload, and resize to 800-1000px wide, you could use one of those if you need it done for you. Thanks

Since this is Intel, lets try this way first, then if all fails, we’ll try the AFUDOS >>

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )


Firstly, yes the above attached file is the full bios package with ROM and executable. I have compressed all of the images to 3.25 MB. This is fine right? I have attached the zip file with all images along with the bios package. Thanks and Regards, Gregory Binu.
The First Zip contain all images and second zip contains all bios files.

BIOS All Menus, Submenu Contents and All Settings.zip (3.62 MB)

Yes, 3.5MB sounds much more ideal, thank you! I just need to look at these images for a second each, so 2-5K image is not needed at all
So, why did you attach BIOS again, is the one above different than what’s in first post?

No its not different. just for your ease :slight_smile:

OK, thanks, then no need

Please also tell me if its possible to change the splash screen logo.

@Lost_N_BIOS - Any thoughts, ideas or progress?

@InfernoWolf19 - Sorry, always loose things and get buried here!
Yes, usually I can change logo for you if you want - Send me image. For best chance of success, unless you have flash programmer and are ready to recover, make image 8bit, indexed BMP, and if needed I may further adjust
This is this the one you are wanting to change, correct? >>


Before I try to do anything >> On BIOS MAIN Page, press Control+F1, screen will flash, then go into sections, do you now see more settings, if yes, do you see things you needed access to?
If screen does not flash or nothing new, go back to MAIN, and try ALT+F1, then check, if nothing, try SHIFT+F1