[Request] BIOS mod for Acer Aspire One D270 with InsydeH2o 3.5 BIOS 1.10

Hello and good day,

I’m in need for a BIOS Mod for an InsydeH20 3.5 Bios running on an Acer Aspire One D210 with N2800 Atom CPU. What I mainly need is to get the Advanced Menu Unlocked which is hidden right now, to be able to adjust the VGA Memory and more.

The Netbook is already on the latest available original BIOS v. 1.10 from Acer Link: https://global-download.acer.com/GDFiles…C=ACER&SC=AAP_7. The installed OS is Windows 10 Pro 1903 and the Netbook works well with 4GB of Ram on its Atom N2800 Dual Core CPU with 2x1.86GHz.

Thanks in advance for any help.
Please, are there any info, etc??

Edit by Fernando: Thread title customized and shortened

Please edit your post if you need to add more thoughts and no one has replied yet, thanks

Do you just need to adjust DVMT or video memory size etc, or do you want unlocked BIOS? It may be easier and quicker/safer to just change the settings you want changed instead of flashing in a mod BIOS.

As I’m looking for some reliable answer, which may only some Expert and/or BIOS Modder could give, I was thinking that the only Person which could give that answer is you. I’m maybe wrong? It just looks like that you’re the only one on this forum, who’s online the last few days.

I’ve got a similar problem on the Bios-Mods Forum where that Mdder BDMaster seems to be off duty since last year and questions about an InsydeH2o BIOS for Acer Aspire One D270 to unlock didn’t get answered.

For more than 3 weeks I’m now looking to find a way to get things done. I got 2 different modded BIOS Fils, but no info on the How Too…! Emails to Insyde didn’t get answered at all!

I’m lost now!

Sorry if I bother someone and you. Thanks.

There is a few BIOS mod guys here, but yes I think I do try to help in most all threads I can. Yes, Insyde will never help with mod BIOS questions.

So you have two mod BIOS already? If yes, what is the issue, do they both fail and don’t unlock, or you can’t flash them or what?

No bother at all!! However, Insyde BIOS is a pain in my rear

If you just need to change a few settings, I can help you do that without BIOS mod, either using H20UVE or grub/setup_var

If you need help to flash the mod BIOS you already have x 2, please show me image of the errors you get when you try to flash and then from each package (if different) upload the iscflash.dll for me to modify for you.
But, this should already be done if you have a proper modified unlocked BIOS package from someone.

@Lost_N_BIOS :

Sorry to answer late I had just to go to a hospital for ti visit my son.

The story of this netbook is: I just got it repaired from Mainboard damage which needed 1.5mth. because I was not able to get the damages CHIP Set in Thailand. That also needed to replace the original BIOS Chip too! OK, that’s all done and everything is working fine in Standard Configuration. This Netbook is used mainly by a friend who has disabled both legs and one and a half arm, he lives in my house too. He’s used to controlling the Netbook with Voice Control, and a stick attached to his arm stump or with the moth.
Now he got from a University in Bangkok a new Voice-Control App in 64bit and min. Graphics Memory of 128MB for to test and like to use that. The Netbook could in Standard Settings only use 8MB Video RAM, which could not be changed: it’s locked!

Here I try to help to get the Netbook to run with maybe 256MB Video Ram and will install Windows 10 in 64bit upfront. The N2800 Atom CPU is working with 64Bit and I’ve already installed the 4GB of conventional RAM, which works very well, even in W10 better than in W7!

I got the following 2 BIOS Modes: 1. ZE7_110W.rar and 2. ZE7IA32_110_SLIC.exe

For the 1. I got the following instruction:

I followed that instruction many times already with no success, it ended all times to just look at the USB-Flash Drive for 10-15sec. and after that booted to Windows, no changes are done. I tried with a just FAT32 formatted USB Flash Drive as well as with a FAT32 formatted Flash drive bootable with FreeDOS. That don’t work either.

The 2. BIOS Mod didn’t have any instruction and I don’t know its Windows or DOS related.

Both of those 2 files should be already unlocked!

I can upload that 2 files to you if you give a working link so you could take a close look at that.

If you could help me that way, I would really appreciate that very, very much. Thanks a lot. Please let me know what I could do further.

Edit: The link in that quoted info didn’t work anymore, I downloaded the file from another account. Thanks.

OK, I uploaded the 2 files to My Google Drive: ZE7_110W.rar https://drive.google.com/open?id=1pChCVs…Ki3Xdh4ph4qd9no and ZE7IA32_110_SLIC.exe https://drive.google.com/open?id=1IfleJ8…ueAbMDfSScgSsK7

Viola! BIOS is unlocked now.

How does that happen? From an Acer Technician, I got another BIOS Mod unlocked with the same name and size as the 1. in my post above. I compared the 2 files and found that the checksum was different. The procedure is slightly different, or better said: more precise and I used that to try to re-flash the BIOS again and this time it simply worked.

Therefore I changed the file I uploaded to my Google drive to the working and tested one already!!

Now the complete Advanced Menue is up and accessible. I’d set the Graphic to 256MB now, just got a problem with the driver from Acer for the Video. I’ll download the latest Driver from Intel for the GMA3600/3650 and, if available, for 64 bit later. Right now I’m on installing Windows 10 Pro 64bit on that Netbook.

Tomorrow I plan to write a short Tutorial about How Too… for this working BIOS Mod and will post it on this forum.

Sorry for the maybe trouble I started at this forum. And thanks for those very friendly words.

Best Regards from Thailand

Good Morning.

After I’m finished to install Windows 10 Pro 64bit last night, I was astonished that from the available 4GB of RAM just 2.99GB was available for work in Windows 10 Pro 64bit. Therefore I’m now back to reinstall Windows 10 Pro 32bit which worked just fine. I also realized that the Install of the 32bit is ways faster compare to the 64bit!

Question: As the file name of that BIOS Mod is ZE7IA32_110.fd, mean that, that this BIOS Mod is for 32bit only and the 3GB Memory Limit for 32bit OS applies to a 64bit install as well?

Also, the max available VRAM after the BIOS Mod is limited to 64MB only, while for the GMA3600/3650 that limit is 384MB (AFAIK).

@Lost_N_BIOS : is it possible for you to change that VRAM limit to at least 128MB? As I wrote that I’d set the VRAM limit to 256MB in my older post above, I was wrong, I later realized that was not related to the VRAM, to another use instead.

Thanks a lot for any help.

You didn’t start any trouble buddy, and no need to apologize!! Thanks for sharing your method, once you have time [thumbs-up<br />Happy to hear you now have unlocked BIOS! Sounds like good files in first package probably, just poor instructions on how to get it flashed in properly

I doubt 32Bit BIOS, you probably only had 3GB usable in the x64 OS due to shared memory and the OS allowed to use more to share with GFX than the limited to 4GB total 32bit system (So it only allow lesser shared memory). Also, in the stock package exe there is only a single BIOS file
However, it may be possible, you need to find 64 BIOS, and I can apply same mod to that for you and then you can test.

You should find both of these options in your BIOS now, in regards to video memory size (There is no option to limit to 384MB on anything, that is a windows/32bit imposed limit due to the lesser available shared memory)
IGD - DVMT Size, Variable: 0xED[1] {05 09 ED 00 01 4D 01 4E 01}
Option: 128MB, Value: 0x1 {09 09 4F 01 01 00 01 00 00}
Option: 256MB, Value: 0x2 {09 09 50 01 02 00 00 00 00}

Setting: IGD - Pre-Allocated Memory, Variable: 0xEE[1] {05 09 EE 00 01 44 01 45 01}
Option: UMA = 1MB, Value: 0x1 {09 09 46 01 01 00 00 00 00}
Option: UMA = 4MB, Value: 0x2 {09 09 47 01 02 00 00 00 00}
Option: UMA = 8MB, Value: 0x3 {09 09 48 01 03 00 01 00 00}
Option: UMA = 16MB, Value: 0x4 {09 09 49 01 04 00 00 00 00}
Option: UMA = 32MB, Value: 0x5 {09 09 4A 01 05 00 00 00 00}
Option: UMA = 48MB, Value: 0x6 {09 09 4B 01 06 00 00 00 00}
Option: UMA = 64MB, Value: 0x7 {09 09 4C 01 07 00 00 00 00}


I have just purchased the same machine and wish to change the bios to allow 4Gb of ram to be installed.

Current bios is 1.10, a 4Gb module is installed but will only show in windows a 2.99.

Would you share this modded bios with me?

Kind regards


I have just purchased the same machine and wish to change the bios to allow 4Gb of ram to be installed.

Current bios is 1.10, a 4Gb module is installed but will only show in windows as 2.99.

Would you share this modded bios with me?

Kind regards

You’ll see the 4GB only if you run Windows (and other OS) as 64bit!

To change the BIOS to an unlocked one is a bit tricky and has to be done with a lot of caution! for to get that BIOS please ask Lost_N_BIOS to send it to you.

I Need a BIOS for 64bit ze7
Where i can found?

I’m not sure that 64bit BIOS exists for the ZE7 at all! I locked for that one too and did not find any. Unfortunately, the user Lost_N_BIOS did not access this forum for near a year already, so, no help from his side. Anywhere, the max of RAM Module you could take into the ZE7 is 4GB. How much you’ll be able to use for Windows is depend on the amount of Memory you’d set the internal graphic card to, deducted from the Windows max 32bit use of 3.3GB! A third which is also cut from Memory is the used CPU too!

I got on the ZE7 a max of 3.05GB while the graphic was set to 256MB Memory!

If your ZE7 uses an N2800 Atom CPU, it will be with that memory still better and faster as on my AO722 with AMD C60 CPU 2x1GHz 2 Core and 8GB RAM!

And I would suggest that you use a LITE version of Windows 11 to get the most out of it! There are several Win11 Lite versions on the Net already for free download! Another way would if you didn’t those Lite versions, to install the full version of Windows 11 Pro and download a program called itself: “ThisIsWin11” from here: https://github.com/builtbybel/ThisIsWin11! Use this app, you could adjust Windows 11 to how you like it! The best tool for such work I’ve found till now is special for Windows 11 only!

i bought this aspire one in 2013, atom 2800, win 7 enterprise 64bit and 4gb ram. unfortunately, a few months ago it no longer turned on.
I replaced the mainboard with an identical one, but the graphics driver no longer works and only recognizes 2.99 gb ram. the microsoft base driver is really bad.
a few years ago I had installed win10 64bit minimal customized
Before, everything was working correctly! what can I do to at least fix the graphics?
Thanks in advance

Here in Thailand, it’s quite easy to solve such problems. There are a lot of small shops which doing such repairs, for a quite low cost with 2. Hnd. stuff.

And that seems to be the only solution for you: find such a service! Or get another Mainboard!

If you still have your old Mainboard, take that to the service to exchange the Graphic Processor and maybe others!

the old motherboard must have had a power problem.
Bios has been unsoldered and put on a socket for reading, but it does not communicate with any eeprom editor program.
Cpu is dead and the vrm exploded
Wifi module not working and I replaced it.
Ssd and ram have been put into the new mb. Ram has been tested with memtest86 and it’s ok, I also tried another one without success.
… A disaster!
I would like to try to convert win to uefi, but I don’t know if it can work.
In Italy Is expensive repairing mb

After trying various eeprom programmers, with an electrical engineer friend of mine, we were able to partially read the bios of the faulty mainboard
The bios was ZE764_109W.FD
Now I have the ZE7IA32_110_SLIC.FD
some idea?

The BIOS of your old MB was a real 64bit BIOS, what you use right now is a 32bit BIOS!

What you could do is the following:
1. get a CH341A Programmer with SOIC SOP8 Test Clip for E$E$PROM 93Cxx, 25Cxx, 24Cxx
2. buy a new EEPROM, same as the one which is on your working Mainbaord
3. unsolder the old EEPROM from MB and keep it as spare in case of problems
4. solder the newly burned BIOS back on MB

In the CH341 Programmer, you could burn the new BIOS. If the already captured 64bit BIOS is still ok, you could capture the full BIOS Code with the CH341 Programmer.

Be aware that you could not re-burn a new 64bit BIOS over an existing 32bit BIOS.

The CH341A Programmer could be bought very cheaply over the Internet for below 10USD! Take a look at the picture of the whole needed Programmer Set:

Hope that will help you. And if you didn’t mind, please send me the BIOS ZE764_1.09W.FD attached by email/PM. Thanks a lot.

unfortunately the reading always stops at 41%
we will try again

Where i can download a 64 BIOS on internet?

I couldn’t find that, that’s why I asked you to send me your old one!