[REQUEST] Dell 7820 EFI Bios modification

Hi everyone!

I recently bought a DEll 7820 workstation but it came with a Xeon Bronze 3104 cpu so i looked online for a better one to replace it. Most were way above my budget so i tried one of these Engineering sample xeons as it worked in some previous generation dell workstations. Unfortunately it did not boot but maybe the bios only needs to be slightly modified to whitelist this cpu!



https://www.dell.com/support/home/ca/en/…820-workstation

Intel Xeon Gold 5117 ES QL1J 1.8GHz 14C 19.25M LGA3647(Socket P) Skylake-SP



If someone could take a look at it and give me their opinion on if it is feasible it would be very much appreciated!
Willing to flash modified EFI Bioses(it seems to have ways to revert bad flashes)

Please be kind as i did read the FAQ and the rules that i could find and did not see anything banning discussions about this subject.

Thank you!

@ohlongjohnson - This system may have BootGuard enabled, so no modding of most of the BIOS, however you will have to check this from your end and see first. If it’s not enabled, then you’ll have to dump current BIOS via FPT and send to me, unless you know how to flash HDR, FPT will be easier
Please download ME System Tools V11 from section C in this page - Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find MEInfo folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and show me an image of the end of the output (or you can check too) >> MEInfowin.exe -verbose

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges

What you want to check at the end of the MEinfowin -verbose output is Measured Boot & Verified Boot - on the Left/FPF side, is either enabled?
If yes, then BIOS edit may cause brick (sometimes that may mean programmer only recovery, do not rely on “BIOS recovery jumpers or outlined procedures by Dell”)
Microcode is in a yellow protected range, not as bad as Cyan or Red, so it may be OK, only a test will tell, if BootGuard is enabled. If it’s not enabled, then no issues.

And in the end, putting back in 50652 microcode may not allow the CPU to work anyway, it could require an older BIOS, or an older ME FW etc (Which I have no idea what version BIOS or ME FW might allow this)
Link me to the very first BIOS you can find for this system and I will see if the microcode is even in that one, if not, possibly no luck playing around here, but we can try.

EFI 2.0.5 https://justpaste.it/2xp25

Earliest i could find https://www.dell.com/support/home/ca/en/…?driverid=wtkmy
http://oi67.tinypic.com/kbt6k4.jpg

I was not able to flash directly to it yet as it showed unsupported downgrade.
I tried a few later ones with same result, it seems to require downgrading gradually(from the one before latest and down).
I do not have enough time this morning, will try it out after work.

I can see online a lot of info about flaws in Intel Bootguard or ways to bypass it, there might be a way even though it seems to be enabled on oldest bios.
This link has a picture of the motherboard, willing to buy tool to flash the chip directly if necessary.
https://www.ebay.ie/itm/Genuine-Dell-Pre…2-/332897304398
Mine may be slightly different and i can take a better picture of a specific area if needed.

I have the same issue.
I analyzed some bios versions for this board and found, that the microcode for the ES CPUs (50652, 50651) are present in the older versions.
Here is the extracted full stock bios that has the ucodes for ES:
https://drive.google.com/file/d/1gdi1DUn…iew?usp=sharing

Does that mean that the old BIOS supports booting with ES, or it can be that it’s still blocked nevertheless?
I’d like to know how can I extract the assembly code of the part that’s managing the allowed CPU IDs…

Thank you!

Any experts saying a yes/no/maybe would be much appreciated.
Could it be that a specific stepping/cpuid is blacklisted in bios while the microcode is still present in stock bios?

The furthest I could go without knowing how to reverse engineer the hdr, is that I searched for ‘52 06 05’ and it is present outside the microcode area in the new 2.0+ 7x20 BIOS versions, but it is only present in the microcode area in the older versions.
Does that imply there is no cpuid check in the pre-2.0 BIOS (that also contains 50652 microcode)?