[Request] Dell Inspiron 3551 - Missing Battery + BIOS hidden features unlock

I cannot update bios because of missing battery, can anyone help, please?

edit:some more info-> Dell Inspiron 3551 laptops have this thing that for a regular bios update via .exe file the AC should be plugged in AND the battery should be at least 15% or 20% (as i ve heard from extensive googling). As i don’t have a working battery ( battery dead) i get an error message like this: [[File:Screenshot (7).png|none|auto]]
I have tried many solutions … /forceit, installed windowsPE, i can’t even remember any more, it’s been a grudge match, so, i kindly ask someone to, maybe mod the bios installer so it wouldn’t check for the battery? I m so noob with hexeditor and in general…

dell.com/support/home/en-lv/drivers/driversdetails?driverid=157t7&oscode=wt64a&productcode=inspiron-15-3551-laptop

EDIT by Fernando: Thread title customized/specified

Screenshot (7).png

Hi friend,
sure the Battery control can edit by AMIBCP Aptio V :
https://www.mediafire.com/file/qep847m27…020023.rar/file

Follow this Guide :
https://www.bios-mods.com/forum/Thread-G…res-UEFI-Aptio4

https://www.youtube.com/watch?v=aISCfhK05Rk

If your CPU is intel you can use fptw tool to make a bios backup and reflash back after edit, if not , then use Afuwin or Afudos.
Regards

P.S. normally the Battery check is into EC , but may be here is into bios.

Thanks a lot for Your answer and help! I will get right into it!

Happy 1st of May!

EDIT 1:
Right away i notice that both guides You linked need USB Flash, but i don’t have one. What about fptw tool? I do have Intel. Right now i am googling fptw tool…

EDIT 2:
looks like it does need USB flash, does it?

EDIT 3:

When looking through biosupdate.rom file with AMIBCP i did not find an entry similar to battery check, also when accessing bios on my laptop, there is no such entry.
It’s gotta be somewhere else. I have tried to search for files created in all TEMP folders when opening biosupdate.exe to change platform.ini entry “battery check=0” (as per some Youtube guides), but it does not create any files in any of TEMP folders, it creates only file “amifldrv64.sys” in the same folder i try to run my biosupdate.exe from.

Hope this info helps to get to the bottom of this. Thank You!

EDIT by Fernando: All 4 subsequent posts merged (to save space and for better readability

@RefleXx :

No, there are other ways to get a modded BIOS properly flashed. For details please look into the start post of >this< thread.

When reading “Intel (Converged Security) Management Engine:Drivers, Firmware and Tools” which I found in @Fernando ‘s linked thread, section “Flash Programming Tool (FPT)” , I did not find “Motherboard > Intel ME > Intel ME Version” of my system, at which time i started questioning, if my CPU is actually Intel. My HWiNFO64 page:
[[File:Screenshot (17).png|none|auto]]
As You see, under CPU I have Intel Pentium N3450, yet under System > System Manufacturer (also Mainboard > Mainboard Manufacturer) I have Dell Inc., and… no Intel ME Version here anywhere, so I guess, I don’t have Intel CPU…? Maybe… It’s the motherboard manufacturer that determines what’s what?

Since I did not find Intel ME Version, I am thinking Flash Programming Tool (FPT) is not viable to flash my BIOS, right?

Continuing on=>

Through downloading and installing UBU tool from the same thread (1st post, section “Guide for ASRock mainboardswith an AMI Aptio UEFI BIOS”) (BIG Thank You to @Fernando for making it easier for newbies like me), I have found that my Bios Platform is AMI Aptio 5
[[File:3451a07(1).png|none|auto]]
…which is great, because 1) i did not know that 2) I do have Aptio V Firmware Update Utility!

But, since I don’t have a working battery (the culprit of my problem), I am guessing I should run Aptio V Firmware Update Utility through command prompt to enable “/JBC” parameter which interprets as “Don’t Check AC adapter and battery”, correctomundo? (I did not find an option to disable battery check in GUI version of AfuWin64 (AFUWINGUIx64.EXE))
Yet another problem arises => when trying to open AFUDOS.exe, I get error like this:
[[File:Screenshot (18).png|none|auto]]
When trying to Run as Administrator, error like this:
[[File:Screenshot (19).png|none|auto]]
When opening AFUWINx64.EXE, it opens and closes immediately, when Running as Administrator i get a window like this:
[[File:Screenshot (20).png|none|auto]]
I cannot type any command here, any key i press gives me more info about commands (which i can’t use, grr), 2 more times until the window closes.

That’s how far I’ve got. Any ideas?

Thanks for Your help, I guess I will be using this forum more to unlock my BIOS later when(gotta believe) I deal with this “Cannot update BIOS because of missing battery” issue , since this forum is poppin’

Screenshot (17).png

3451a07(1).png

Screenshot (18).png

Screenshot (19).png

Screenshot (20).png

@RefleXx :

Your Dell Inspiron 3551 notebook definitively has an Intel CPU.
Proof (found it >here<):

Dell Inspiron 3551.png

I can’t find the Intel ME version, i might have deleted the supporting drivers at some point when trying to maximize performance by deleting from the app directory. ( I know…)
[[File:Screenshot (23).png|none|auto]]
And now i don’t know which drivers to install
Can’t I use UBU Tool to flash my BIOS? Does it have a “Disable Battery Check” option somewhere, somehow?

EDIT: just FYI, i don’t have a working battery and I don’t have a USB stick ( I know…). or maybe another utility can do the trick?
Thank You

Screenshot (23).png

Hi, @RefleXx !
How are things going? If you just need to update the BIOS, then I can help you. I already did the same for DELL L702X (see attachments). It’s simple, just let me know you’re ready.

Dell L702X deleted request original content.txt (1.04 KB)

Private Message of Re L702X.zip (3.5 KB)

@Sweet_Kitten

Thanks, I’ve been trying to update BIOS for a couple of weeks now, would be great if You could help!

What info or files do You need from my system, if any? But You will really have to Eli5 because of my newbness. Thanks!

EDIT: Also I am preety sure my AC Adapter is not original (along with the missing battery issue). I hope that cannot brick my system…

@RefleXx : The tool named "UEFI BIOS Updater" (UBU) can update UEFI BIOSes, but not flash them.

No files or info required, I’ve already modified the original installer.
New 3451A07.exe.

@Fernando
Got it, dude, thanks. I guess the flashing part is my main concern for now. Now after I see what does the latest BIOS version offer, I might decide to update it, to unlock some extra features for optimizing my machine. Am I correct in this terminology?

@Sweet_Kitten

that was quick, Thank You!

Ok let me reboot and try to update BIOS with GSet Bios Flash Update, since I have heard it is the safest way. (Really don’t want to brick anything, this is my first time. Nerves… )
EDIT: Actually what am I talking about, I cannot update from GSet Bios Flash Update because it knows I don’t have a battery. I will just do it from Windows OS. Wish me luck. Thanks!


EDIT: SUCCESS!!! Thank You @Sweet_Kitten

Now let me dive into my latest BIOS settings so I can Optimize my System’s Performance, which has been subpar imho - cannot watch twitch.tv on 1080p resolution, CPU goes to 100% and every 3-5 seconds i get a lag spike. No bueno. Gotta find a solution, hopefully in my latest bios version A07 for Dell Inspiron 3551.

Good day, gents!


EDIT 2: lol it is the same. completely the same! that’s a turn… what should i do now? I guess I do need to mod the BIOS for additional parameters to be available…

Master @Sweet_Kitten could You, by any chance, do something like that? I am too newb.

@Fernando
So now if I want new options available in my BIOS, should i use UBU Tool? Cause that’s what it means - updating ?

@RefleXx : If you want to know the options of the UBU tool, you should better read the start post of >this< thread.

Ok friend, the tool AMIBCP is above into the reply (meidafire.com) , but you can find more googling :wink:
Look this guide :

https://octoperf.com/blog/2018/11/20/asu…/#bios-settings

[Info Request] Unlock All Menu Ami Aptio V Bios

[Guide] Manual AMI UEFI BIOS Modding

[Tool Guide+News] “UEFI BIOS Updater” (UBU)

BIOS Modding: Introduction and Preparations

[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization

Let me know, if you have all to modify your bios backup and then reflash it again, cause you have to do whitout battery !
Regards

Thanks, @BDMaster !

I will try… to add some modules to my BIOS.

Cheers!

Whilst going through all of the info, i seriously got a headache. I am so noob, i don’t understand every other word in these guides.

Maybe one of You guys @BDMaster @Sweet_Kitten unlock this bios? 100% unlocked - the more options, the better. I don’t think i am at the point of extracting and adding modules yet, the complete default unlock would be great!

And since I don’t have a battery, an executable like Sweet Kitten made in post #11, which worked to perfection, would be greatly appreciated!

Please

Attached is my current bios dump (if needed for mod) using AfuWinGUIx64.exe from AMI Aptio 5 Firmware Update utility (button “Save”) and zipped to upload to win-raid.com

Thanks!

EDIT: Should I be considering BIOS updates like Microcodes, ME firmware as well? Just something I bump into, when browsing this vast ocean. Do they affect computer performance at all or maybe offer some new options to have in BIOS?

EDIT2: Can i just change EACH and EVERY possible Access/User value from Default to User in AMIBCP v5.02.0023 and call it a 100% unlocked bios image?

@Sweet_Kitten Would that be usable bios.rom file to make it back to .exe with battery check disabled?
(The attached BIOS is not modified)


EDIT3: I spent most of the wee hours of the weekend in here. Just to confirm my newbness. For example I realized i had deleted Intel Management Engine drivers to gain system performance because i thought that there were just too many programs running, tht’s just got to be the reason why my system is so slow sometimes. HOW YOU LIKE THEM @pples?
But just hours ago I used mbr2gpt.exe in cmd prompt to go from Legacy BIOS to UEFI . I am very impressed with the result! Tardiness (slowess, laginess) feel to my system reduced by 25% and it does not get slow when running for a long time. (up for 12 hours searching and multitasking watching Youtube and streaming sports). I did switch off legacy option ROMs in Bios setup, maybe that helps too, idk.
All I know is I would suck a dick for my unlocked BIOS (no homo) . Can You please I just wanna play CS:GO, i’m no mod - genius!