[REQUEST] Dell T3610 to use multiple NVME on Asus Hyper m.2 x16

Hi friend, a working mod is possible to get following this guide :

Steps :

1. Inside MMTool, locate the module CSMCORE
2. Browse and locate the module SAMSUNG_M2_DXE.ffs inside the Modules folder
3. Change Insert FFS Options to Insert Compressed, then press Insert
4. Locate newly the module CSMCORE select it
5. Repeat the previous steps for Nvme.ffs, NvmeSmm.ffs, and NVMEINT13.ffs modules
6. Look all modules are there
7. Save new Bios Mod and exit

If ROM space it’s not enogh then CodeRush said :


Show info
You can safe remove all network-related drivers from DpcDxe to Udp6Dxe if you don’t use UEFI network boot.

Delete these Mosdules :



If you don’t know how to make i will make for you …
Let me know

Files :


^^ Thanks will read up on it!

Hello there,

I am interested in how can i make my bios to see my kingston a2000 nvme ssd. I have a Dell Precision T3610 with the latest A19 bios version. I saw that you successfuly did it and i wonder if you can help me do it myself

Hello there Lost_N_BIOS!

i have a dell precision t3610 with latest a19 bios version and i am interested in installing windows 10 on my nvme ssd Kingston A2000 1 TB. From what i read i need to mode my bios for bios detecting my nvme. Can you tell me please exactly what to do? I saw that you’re kind of the expert in this area and i will really enjoy the help to can use my nvme on my dell workstation. Thank you in advance

Hey buddy…easy on the posting… this is not a 24h TI real time support.
Do u read only the topic??? No care for learning and do it urself?
Post#41 ring a bell? Start reading backwards and ull see the answers.

Hey buddy!

First of all i did not squeeze anybody’s balls to answer me in the very next second and i did not come here because i am a lazy person.

Second, it does not help to read it all backwards. It really not helping. I ask here because the answers are spread over multiple threads and i don’t know the correct order of what to do, otherwise I WILL do it myself.

I don’t know how to find exact ME of bios to know if have that guard (jumper) and if i need to do or not do something on my motherboard. I don’t know how to export my bios image and read it after. There are no specific answers in a specific order. Further more i do not understand what i need to mod into my bios, a module or a driver? where i can get these modules or drivers. Is a module for generic nvme or every producer has it’s own driver or module? What is the exact order to succeed to mod my bios to be able to boot from Nvme ssd and install windows 10 on it.

if i knew all of this because is there somewhere written in an understandable order i will do it my self. Keeping in mind that is very easy to brick your bios i want a detailed explanation and order from somebody who know exactly what he’s doing.


Well im so sorry… if reading all the posts in this topic u didnt learn the answer to ur doubts, i must advise u that its better to stay put as u may not have the abilities to do it in a safe way, as i not wish u a broken system.
Now…u can address to a specific user by using "@user_name" and maybe some one can give u his final work, in witch u then may engage in the operation at ur own risk, good luck buddy!

@MeatWar Hey buddy!

like i said i have very hard times to done what i want because after ai read a lot of threads here im stuck at the point where i try to flash back the bios to verify everything is ok. I can backup bios region without any problem but i can’t flash it back because its says: “Error 280: Failed to disable write protection for the BIOS space!” I have tried so far to put jumper in service mode, i restarted 3 times but when i try to flash bios back i gate same error not matter if i try with FPTw or FPTw64. I have Dell A19 latest bios available. Please help me or point me in the right direction cause i have just a little bit and my head will blow.

[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

[GUIDE] Grub Fix Intel FPT Error 280 or 368 - BIOS Lock Asus/Other Mod BIOS Flash

Also there is a Service jumper on the motherboard… u must read about this, its described in a post, dont remember #, in this topic.

Thanks @MeatWar

I finally did it. Your link helped me because i was a little confused by the fact that for Dell Precision T3610 there is a jumper for PSWD ( resetting the password for bios, tpm etc) and there is 5 cm aside from that jumper another one with name SERVICE MODE. I have to unplug the jumper from PSWD and plug into SERVICE MODE jumper. I power on, get into windows, go to fptw provided by LOST_N_BIOS windows x86 version (folder windows simple not windows 64) and make a backup of biosreg which was successfully. The flash back was also successfully and than i know that i’m gonna succeed. I used MMTool cause is more easy to find/delete/insert module with it.
I first deleted udp6dpe or something like that cause i did not have enough space.
After that i scrolled down to CSMCORE, i installed modules from UEFI64MOD posted by user with C…, and after that i saved image in windows x86 folder and i flashed back to bios with fptw. After i saw that inclusive verifying passed ok. I rebooted, i press F2 to enter BIOS and i saw imediatelly UEFI: Kingston A2000 as boot sequence.

I saved, shutdown my computer. Removed jumper from service mode and plugged into PSWD jumper, powered up my machine, and in seconds booted from kingstone nvme.

Thank you again to you, to LOST_N_BIOS and all other users who posted materials and their experiences!

I am happy now!

Glad u made it… as u can see a bit of reading gave u some knowledge for future endeavours in bios mod area… none always have the same, always expect to be different.
This is always my first initiative, as i did with u, to encourage users too find by themselves/read/learn, because its the user in front of his machine, its not our machine and ur not there to see the actions.
Besides our help and maybe provided mod bios files, we cannot be responsible for any damage, but of course we dont like to hear that something went wrong.