[Request] Dell XPS 9370 BIOS Issue

Dear All,

I have an XPS 9370 which is not turning on. All i can reach is the display test.
I think it has bios issue.
I have dumped my BIOS with CH341 Programmer.
My main goal is to fix my laptop.
I don’t even know is it possible to unlock some useful things in the bios.
I have seen posts about unlocking things.
That’s secondary but if anybody can show some light thatsbreally appreciated.

If anybody can please have a look at my dump if possible tell me how to clean/fix it.
Here is my dump

Thank you if anybody can help.

Kind regards

Did you try the recovery procedure ?

1) Format a USB stick as FAT32

2) Copy the latest BIOS file to the USB stick (the complete exe file)

3) Rename the file to "BIOS_IMG.RCV" It is CRITICAL that you have "hide file extensions for known types" unchecked, or edit the name in a command prompt.
Otherwise the file will be named BIOS_IMG.RCV.EXE and the process will not work

4) Shut down the laptop completely

5) Unplug the power cord if plugged in

6) Hold down the control - escape on the keyboard while plugging in the power cord.

7) The laptop should turn on. After several seconds (~10?) you should be taken to a BIOS recovery screen and can begin flashing.

Note: If you receive three orange and three white flashes of the LED, that means the file could not be located :
Make sure you named it correctly, and that the USB stick is FAT32 formatted, with the file in its root directory.


I have tried that.
Nothing if i do as younwrote the LED shows onlybone white sign. After that nothing happens.

The current state of the laptop is powering on keyboard light comes on (for like 20seconds) and the led light shows one long white light aroung 4 seconds. And nothing after this.

Thank you.
Ibhave tried the guide from the forum how co clean Intel Management Engine but i had no success.
I have made the clean ME bios image. Flashed it to the chip but the laptop does not boot. Actually no change.
If i power on pressing D the displaybtest comes on and shows the color screens

Any idea?

Withbthe cleaned ME content the laptop shows 2x amber and 1x white lightcode.
That means cpu issue if i am not mistaken.
But with the original content it did not show that.

So i have reflashed the cleaned bin and did cmos battery remove replug.
Power on - Keyboard light comes on for ~20sec then light goes away except capslock light.
No Amber and white LED flash codes.
Any idea somebody?

Dear All,

I have fixed my laptop! :smiley:
So if it helps for anybody with future problems here is what i have done:
I have built a new image with flash image tool like the clean ME but i also replaced the bios region as well extracted from latest official bios updater from dell.
And the laptop booted to an error the service tag is missing then to bios so i had to enter my service tag and then restore default and voila system booted.
Windows reinstalled and all looks ok.

Thank you for guides and help.

Kind regards

It’s not only service tag, but maybe Windows license information, MAC address, serial.

Yes i know but i will check tomorrow the other things.

The main point it is live.
The clean me did not help for some reason so i had the idea to do the above as i have not found anybother guide.

ME will normally not prevent from boot, but give other symptoms like shutdown after 30 min…

Try the attached file. Your original dump was 100% identical to stock bios 1.6.3 regarding the static parts, meaning the last 4 volumes. In the beginning of the bios regiosn there’s one empty NVRAM region, an empty volume where the second NVRAM volume would be and thereafter it’s a little different. Machine specific information seems to sit in one Non-UEFI-data block, missing in stock, expanded on the right side.


So keeping your system from booting isn’t done by corruption in the static bios code, but has to be either NVRAM or the machine specific block. That attached file has the two NVRAM volumes emptied to stock, I think that should work.

Which bios version did you use for replacing? Bios version in your dump and in modiified file is 1.6.3.

Please make a backup of your bios region before flashing and post/attach it, it’ll be interesting how your stock bios will lock after some boots.

corr_NV12.zip (4.49 MB)

Well i have downloaded the 1.13.1 latest bios update from dell support site.
Extracted that and used the bios region and me region.
The freshly installed windows says activated.(without entering any key)
MAC address i have as i have network also.
In bios the express service tag is same as on the back cover. I have just entered normal service tag.
So after it came back to life i have done e full bios update to 1.13.1 which updated all part.
To be honest it looks good. No bsod no issues yet.

Here is the dump from the current state.


Can you check if it looks ok?
Also is it possible to check where wind key /serial/mac is in bios dump?
I would like to compare the original broken o e with the current

If it looks ok i would not solder the wires again :grinning: for flashing.
But i will defo keep that bin if some issues would come.

I prefer to work on the same bios version, as you can see there are different controllers that were updated from 1.6.3, so this might raise other problems


Information has been partly restored, but structure isn’t completely restored, and some information seems is missing. Do you use a local logon for windows or are you logged in with a MS account?



There’s no ME region in the extracted update file normally, these are unconfigured ME versions that have to be configured?

Previously i don’t know probably was a local account and some domain accounts.
I have bought the laptop in the dead state.
Now i just have a local account.

So is it possible to put those machine related data to my latest working bios?
Also any other method to flash than to solder again?

Normally one can use an SOIC8 clip like this togehter with a CH341 programmer?

At least backups of the bios region can normally be made by software:
- Download CSME System Tools v11 r38 - (2021-02-12) here (section C2):
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

Unpack it, go to the folder Flash programming tool, choose the folder corresponding to your OS, open a command prompt as administrator in this folder, run
fpt(w(64)) -bios -d biosreg.bin

It might be possible to overwrite the region of intereset, it’s maybe not protected

Try to dump the region from 1110000 to 1160FFF by running
fptw64 -A 0x1110000 -L 0x51000 -d pireg.bin

Post the file.

I have CH341a Thats how i made my dumps, but i need to solder to the chip as clip does not reach the legs. It is WSON package not SOIC.
So worst case i can solder back and reprogram.

OK here is the file dumped with FPTW

pireg.zip (2.47 KB)

OK, thanks. You could try to flash just this area of the bios region. File is in the attached zip, the command would be:

fptw64 -A 0x1110000 -L 0x51000 -f pireg_own.bin

You’ll have to be absolutely correct with the numbers, otherwise you’ll overwrite somthing you’d need!

Three things can happen

1.) Brick
2.) You’re not allowed to write to that area with fptw64
3.) It works

I can’t guarantee for anything here, in addition you have an partially updated firmware. I’d run that last Dell update once again anyway just to try to update these other firmwares.

pireg_own.zip (6.51 KB)

Oh at least i have the ch341 to get back from brick.
Ill try the file and report.

OK it does not work: ( Write protected

Error 368: Failed to disable write protection for the BIOS space.
FPT Operation Failed.

I did the latest bios update again.


restarted nicely and updated.

Thanks for the feedback. I think I’d call it a day if I were you, If you don’t have any problems with serials or Windows activation I’d just be happy to have it running again and leave it as it is. Just keep the bios dumps. I attach the bios region 1.13 with your machine specific region and NVRAM emptied just in case. But keep the other file with old bios version (from #8), too.

1.13.1_OWN_DVAR_bios.zip (4.57 MB)

Can i just flash this with flashrom or any other programmer with ch431 as it is?
I mean do i need to specify this is just a region or flahsrom will just see that goes to that region?

You have triggered my OCD with serials etc. :grinning: So i might solder again and reflash.
Ill give it a few days to test anyways

This is just the bios region, for use with a hardware programmer you have to combine it with Descriptor, GbE, ME, EC regions to a full 32 MB image.

You might use UEFItool 0.25, open your own last dump, right click on Bios region, replace as is, choose the file unzipped from attachement in #18