[Request] FTPM support for AMD NUC (HC HCAR357-MI)

I recently picked up a Ryzen 3550H based ‘NUC’ like machine - Specs here valid.x86.fr/t5xw5 but its ungooglable, and I have no idea who the ‘real’ manufacturer is. It should have fTPM support in the processor but it seems to be hidden in the bios menu.

I’d like to have the firmware modded so I can turn on fTPM support

AMIBCP seems to have it listed in bios strings i.stack.imgur.com/EVCHv.png but Its not in setup configuration. The 3550H should have a fTPM and I’d like to enable it for windows 11 compatibility. I’ve managed to dump out the rom, but I’m unsure on how to edit the rom (and I’ve not gotten to the point where I’ve looked into flashing it). I’ve attached a zipped copy of the firmware I dumped for reference, its too large to upload otherwise

Edit by Fernando: Thread title shortened

AmericanMegatrendsInc.-AR357V3P01.zip (3.96 MB)

Looks like the minisforum AF5NV403 is suspiciously similar to my system, and they’re looking at adding fTPM support to their firmware. I might get lucky and either be able to get what I need from their update or even just flash that on my system. I’d link the respective forum posts but the system needs me to post three times before I do

bbs.minisforum.com/threads/tpm-2-0.1800 Thread about TPM here
bbs.minisforum.com/threads/minisforum-support-what-is-current-bios-for-dmaf5.1625 Firmware for that system here

Hi @jmg1138 !
I seem to have the same machine - in my case sold as T-BAO MN35. Even in the AMI Bios flasher, the signs are looking good with the MinisForum BIOS release. But I just cannot press the flash button without knowing it will work 100%, or at least there’s a way back to restore the old bios if it fails.

My System current Firmware ID: 1AVSZ011
ROM from Minisforum ID: 1AVSZ017

Firmware GUID is the same on both files too.

Did you succeed? Thanks for an update!

i too have a t-bao MN35 and it would be great to know if there is a way to enable fTPM option on our bios , just wondering why we haven’t such an option …
PSP bootloader & secureos version both as stated in bios details , so the support is present even in bios , IMHO , we just have to enable it

i think we can dump the rom and then open a request here to modify the extracted rom : .win-raid.com/f54-BIOS-Modding-Requests.html

i haven’t dumped any modern pc bios and don’t know if a copy is (officially or not ) available somewhere , just to be sure to have the correct image to flash back .

in the past i relied on official images released , modified them , and then flashed them on pc .

now i used Aptio V AFUWIN just to have a backup but i don’t think i have the guts to reflash back without proper verification

i’m updating this thread posting MMTool 5.02_patched reports file for AF5NV403-FAN and tbao mn35 (HCAR357-MI)

the are looking a bit different (firmware volume 1 is absent and all others are consequentially remapped ) don’t know if it’s safe to flash even if the specs appeared the same

is there anyone who can help us?

EDIT: after some more detailed analisys went all-in and flashed bios file from minis forum to mn35 , it worked after flash , however after a couple hours i reflased back to its original bios .

AF5NV403 rom failed to recognize internal nvme ssd(even if Nvme drivers are present ) , so i have booted from an uefi win10 usb3 flash drive ,all other things seemed working.

However can’t find anywhere secure boot option or fTPM in BIOS CPU configuration , so win10 can’t find any TPM to rely on (i have CSM disabled of course ).

With default settings Mn35 tempetatures are sensibly higher due to PWN set to 1 instead of 2

Below some pictures about AF5NV403-FAN rom running on Mn35 , just in case you’ll spot something interesting .

I reflashed original rom updating all drivers(GPU, broadcom, realtek as shown in picture) using ubu and seems that at least on idle mode Mn35 is running with lower temperatures (4-6°C lower , while writing this post I’m having 46°C Cpu with over 30°C room temperature )

reports.zip (27 KB)












Hi Matt! Great work so far! Thank you for trying out!

Just one observation: When I was looking into the scripts from minisforum update, the flasher takes care of three parts of the bios, not only the main (means Boot Block, NVRAM). You probably did check these too, right?

Also, they on the minis-forum had two releases of the bios, the first had issues with storage as far as i remeber.

Thanks for your research!!

Here is my version comparison:

…edit: not possible since three posts are requied to share a link/image
I am looking at the rar file from 7/27 if that helps. Looks i can try to flash that too, since you found a way to revert.

hello Moritz,
yes i’ve checked all 3 parts and proceeded flashing ,
i was unaware of the different releases and the storage problem regarding minis forum rom , i’ve used the link from the OP ( bbs.minisforum.com/threads/minisforum-support-what-is-current-bios-for-dmaf5.1625 )
i’ll run the same analysis with this new version and i’ll let you know :slight_smile:

@ ChuKy thank you !

Very Good news here ! :smiley:

managed to flash succesfully both the original AF5PN01 (from here bbs.minisforum.com/threads/tpm-2-0.1800)
and the one with updated drivers with ubu (AF5PN01 _mod GPU & realtek ) as in picture & zip attached.

BIOS is a bit different but it HAS TPM subsection & secure boot !!!

working flawlessly & immediately recognized as a suitable tpm device!

However do not straight enable secureboot otherwise w10 fails to boot , secure boot isn’t supported by the original bios ;

you have to solve it if you want to leave it enabled, repairing the EFI partition with recovery environment (i used this for w10 /neosmart.net/wiki/fix-uefi-boot/ )

i also encountered the issue about envirtahci.sys not having the expected signature so i simply moved it away , later on i’ll reinstall chipset drivers .

After all this journey i finally have UEFI & Secure boot with (f)TPM 2.0 correctly recognized :smiley:


TPM subsection.jpg

AF5PN01_mod.zip (4.24 MB)


Matt - Thanks so much!

I flashed the bios and got all green lights in WhyNotWin11. Yey! CSM off, UEFI boot only. I also restored factory keys.

I did activate the beta insider channel and updated, but for some reason the first update (W10 H2 something…) broke my windows update service completely, I was not able to start the service again. It looks like some certs became invalid I guess. So after one hour of trying to restore, I decided to fdisk an reinstall fresh (a Win11 ISO i created).

Everything runs smoothly, with TPM being fine and no driver missing after installing the full(!) AMD Radeon package.

The only thing I tried to get rid of was the Minisforum bootlogo, but I did not succeed with some AmiLogo tool. It replaced some BMP, but still shows the Minisforum logo (which is… not too beatufiul :slight_smile: ). I will keep trying with other tools.

So, thank you very much again for this mod! Excellent!

@Moritz i’m happy that everything went smootly :slight_smile:
if you manage to get rid of that logo and replace with a cooler one that would be great! (i disabled quiet boot and i’m not seeing it anymore, only windows boot logo )

Are you sure you have the MN35 with Ryzen 3550H? we tested the BIOS only for that model ! Do not proceed further if you have another model , there are many things that can go wrong !
The first thing you have to know is that there are some risk involved in flashing , they’re minimal because we’ve analysed compatibility and flashed this bios before you , so they’re tiny but still present, we’re not responsible if anything goes wrong, which may render your system unusable.
It is vital while flashing bios that the t-bao remains powered on otherwise in case of blackout or similar , you know, your t-bao may became a very exprensive paperweight.

All you need is in the package attached , the flash utility and the bios rom with updated drivers i made (AF5PN01_mod.rom) , otherwise the original AF5PN01 rom is here ( bbs.minisforum.com/threads/tpm-2-0.1800)

run AFUWINGUIx64.EXE open AF5PN01_mod.rom or AF5PN01.rom and then from the setup tab select “program all blocks” and then press the Flash button , then press ok at the prompt to continue (it is vital to keep powered the pc until flash is done and you see all green blocks , with few grey blocks that remained untouched , it is normal )

after that shutdown the pc clear cmos (via jumper or software using load defaults from bios setup) and you’re done tpm should be recognized straight away (however you must have uefi & secure boot in bios to be w11 compatible, but that’s another story, very simple to do that if you can reinstall the system from scratch )

if you’re unsure of what to do READ VERY WELL all the post above,the tutorials present in the forum and ASK before doing anything if unsure

AF5PN01_mod.zip (4.21 MB)

00AfuWin64.zip (1.8 MB)

Melvin, i’m glad you flashed without issues and have a working TPM 2.0 !
I’m Matt by the way XD

To be good for w11 you should go to bios setup and :
disable CSM
enable UEFI boot
enable Secure boot
in the attachment pics you’ll find where they are located, you have to reboot at least twice to set all things as needed

However if you do all these things your preexisting windows installation may fail to boot ,because secure boot isn’t supported by the original bios and you may have an MBR scheme rather than a GPT one, for that reason do a backup first ;

you can boot your old installation again reverting these changes.

Complete reinstall is way simpler , if you can’t I suggest you repair the EFI partition with recovery environment (i used this for w10 /neosmart.net/wiki/fix-uefi-boot/ )

i also encountered the issue about envirtahci.sys enabling secureboot not having the expected signature so i simply moved it away , later on i’ll reinstall chipset drivers .






no i don’t have this error , dont’ know if moritz has it , but i’m running windows 10 not 11 so it might be related with unstable drivers or such , try using w10 for some time and see if the error pops up again , also do a memtest (RAM)

don’t know can be from multiple causes, can also be ram involved , the best approach is trying to isolate components and software , change power adapter, run a single ram slot etc

we may begin to be a bit OT here , but briefly i tell you that i too had problems with MN35, in the form of random freezes & reboots after few months i received it ;
thought of a faulty power adapter,used another one (hp with exact out spec ) ,
but found out after few hours that one ram bank(ASint) is working bad intermittedly, using only the good one i had no problems in either mn35 ram slot ,
using only bad one the issues come again , certain times also freezing at boot or not completing bios POST at all .

Heard of terrible bangood customer support and decided to buy a used crucial ddr4 2400 cl19 1.2v bank from ebay, issue gone

however in the attachments label of the power adapter that came with mn35

MN35 power adapter.jpg

matt I have been experiencing a problem similar to the one you describe, so before buying another power supply I asked for an 8gb ram in amazon to test since my pc only has one it may be that it is bad And according to what he explains to me, your problem was that I bought a ram, I do not know if they will be good, it is only to test if the problem is solved


Hello, after following the procedure and installing the Rom, a different processor appears.
( Ryzen 5 3550u) . I have an MN35

Hi, Matt, i have flashed the bios mod in my machine (a Chatreey MN1) that have a HCAR357-MI with a Ryzen 3550H to enable TPM, but something went wrong: the BIOS flashed ok, but when i restart the machine, i only get a black screen and can’t access to the BIOS or boot. The fan spins a bit and then stops. Whay can i do? I have backed up the original BIOS. Is there a way to reflash the BIOS?

Can anybody help me?


P.D: To clear the CMOS do i have to change the position of the jumper or i have to remove it?

hello chucky , first time after reflash can happen , you have to reset the cmos by changing jumper position, wait a few minutes then change it back and power on .

if nothing happens i would try a more determined approach : unplug the battery connector, wait 10 minutes just to be sure , then power on without the battery connected;
after several seconds it should come back to life , you may see leyboard led , fan patterns changing etc , before the screen comes back to life.

changing subject: i personally don’t know any confortable way for the end user to reflash the original bios without the pc booting , i’m afraid…

Have you compared the two Bios before flashing (firmware ID / GUID above all ) ?

@Moreno : mine is telling the same 3550H code as before , it can’t physically change ;
which tool are you using to assess the cpu model? Have you seen it in windows summary ? i’d try HWiNFO64