[Request] GA-X79-UD3 Rev1.0 modded Bios with NVMe Support

thank you to Lost_N_BIOS, I’ve succesfully updated BIOS and my Samsung 970EVO has recognized as PATA.
But unfortunately when I installed windows 10 Pro:
although Win10Pro recognize the NVME, but Windows stated that windows couldn’t be installed on that drive.

Hi @Lost_N_BIOS , tried the link in post #9 but it seeems to be dead. Would you be so kind in reupping the file? Thanks!

@Zhuge_Liang - You need to follow step #4 in the “This is what you should do” section of this guide
[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

USB w/ install media on it should be initialized as GPT, best to use Microsoft USB/DVD tool to make your install USB
And NVME should be RAW (best) or Initialized as GPT. Here’s how to make RAW - You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Or from repair/troubleshoot options in the installer/setup. Remove all other drives, so you have only USB and target win10 drive. Then from CMD prompt do the following

1. Diskpart
2. List Disk << Here, identify what your target disk is by size/name etc, and make note of it’s #, you will use it’s # next - (If in windows, these #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
3. select disk # << Here, instead of #, put target disk #, example >> select disk 0
4. clean
5. Exit

Reboot and run the installer again, then point it at the raw/blank drive, do not load any drivers or create any partitions etc, just select drive and click next

@Crinson - Thanks! Yes, sadly, it looks like Tinyupload may be dead (down for nearly two weeks now )
Mirror added at post #9

Thanks @Lost_N_BIOS you saved my rig, It’s working flawlessly. Booting from NVME is at least 40% faster than with my previous 8 year old SSD :slight_smile:

@Crinson - You’re welcome! Great to here all is working smoothly

@Lost_n_bios: thank you for guidance. when you haven’t replied yet, I’ve succeed in installing windows to SSD (non NVME) by setting the boot sequence to UEFI DVD-ROM Drive, not legacy DVD-ROM Drive as before. Then I cloned the non-NVME SSD to NVME
After set boot sequence to NVME, the NVME could do UEFI booting.
BTW next time I’ll try your suggestion.
thank you

@Zhuge_Liang - I replied above Thanks for your posted info though, I assume most use USB to install, so had not considered if you used DVD that you need to choose UEFI DVD not legacy, thanks for pointing that out it may help others who use DVD

Hi @StormRaider

I am new here and I do not know much about modding.
Can you tell me do you use asus hyper m.2 V2 card on your gigabyte x79-ud3 motherboard? I would like to know if it works. Because in my case when the hyper m.2 V2 is with/without nvme ssd on it is installed on motherboard, I turn on pc but before post it crash and never boots only crashing. I put asus hyper card in different pci express slots but it do the same. Pci lanes should be enough. I try with this modded bios but no different. I have no idea what to do. Is it possible that need to be added bifurication in bios?
The asus hyper m.2 V2 is working, I test it on other pc.

Hello! @Lost_N_BIOS
Is it possible to update the links? They are all dead(((

Lost_N_BIOS is been away since the beginning of the year, do the mod yourself, address it to a specific user in this thread still active that can share it.

U can use MMTool method and Q-Flash.
[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS
[Guide] How to flash a modded AMI UEFI BIOS

2 posts were split to a new topic: [Request] GA-X79-UD3 Rev1.0 BIOS with Bifurcation Support

I installed the mod bios (from Gantrithor) to my GA-X79-UD3. I also got the boot failure detected as my board is Ver 1.0. I already had my EVO970 plus installed and working just not booting. I disconnected all my drives and successfully installed win 10 on the EVO but IMEI would not install properly in windows showing a yellow warning on PCI communications device. it did not boot that fast (my ssd was faster) even though aida64 showed read speeds at 2,500 +

I plugged in my previous drives and booted back into my intel UEFI RAID GPT dual boot 2 partition SSD with Win 10 and Win 7, along with 4 more drives, 2 on intel raid 1 and 2 on marvell raid 0. All raids working properly but in win 10 it has a error with IMEI cannot start. Win 7 has the same error. Both booted up slowly.

I put the old bios, F20, back in and tried it again one more time making sure there was no presence of my raids. Boot failure detected once again and same problem booting to the Win 10 NVME, IME interface was the issue again. I did not try booting into or hooking up my old SSD.

I reinstalled the F20 bios once again, hooked up my SSD and my raid drives, setting the bios accordingly and booted into Win 7 with no issues, I even have a NVME driver for win 7 and runs at 2500 + and left it installed. I rebooted the computer and tried booting into win 10 and got a BSOD (kmode exception not handled) rebooted and tried a startup repair recovery and BSOD. Rebooted again and tried all other repairs including booting into safe mode (BSOD) and no go. It will not even boot up on a UEFI USB without the same BSOD. Boots into WIN 7 no problem except for some chkdsk’s had to run first.

It seems that the UEFI boot to any win 10 device will not work but no problem into UEFI Win 7 on same SSD. I also tried a legacy boot to a win 10 USB and it will let me go froward right to the advanced setup screen but will not allow me to install to the old win 10 install as it is a GPT disk.

I did a memtest86 and it had several errors. Reinserted it and same thing. Took it out and installed other memory and no errors, so I thought the memory was the problem. Put the “bad” memory in another machine and ran memtest86 and no problems found. Board with new memory still has the BSOD going into any UEFI Win 10 including trying a win 10 install from a UEFI DVD player.

After all BSOD’s it usually has to run a chkdsk when going into Win 7, other then that Win 7 works perfect other then a IRST verify on my Intel raid1 once.

I have been going nuts trying to figure this out, I even did a dual bios recovery (went to F16) and still no luck. Win 7 is my main operating system and has been for ages as Win 10 will not run a PC anywhere host. I need win 7. As far as I can tell there must be a problem with the Roms in the bios (UEFI RAID, UEFI AHCI, IRST, IME??) but I just don’t know how to fix it. it would have been great to boot with my NVME, I even had a boot USB made up with Win 7 NVME drivers that I almost had working when the mod bios was in. I could not find lost_n_bios 1.0 mod version.

If there is anybody that can help with my issue it would be great, I have built at least 10 computers in my life and troubleshooted many more but Im in a little over my head with the bios mods. :thinking: :thinking:

Intel ME has nothing to do with the “base” NVMe mod that users do according Fernando’s guide.
NVMe mod works in AHCI or RAID mode.
A standard Win 10 installation method on the NVMe drive is pretty easy and have been done by hundreds of users on this forum with X79 boards…no special issues reported.
Bios set to PURE UEFI, AHCI mode (or when setting RAID, Samsung Magician will not work), GPU UEFI compat., USB UEFI x64 OS, single NVMe drive only connected when installing and upon OS Setup, on drive destination the NVMe will be visible, and finish the installation, the system will reboot now from the newly UEFI OS from the NVMe drive. Reconnect other drives later on.
Dont know who is “Gantrithor” or the source of the file…not going to loose time on it…

Steps and guidance on Fernando’s guide, point #4: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Intel MEInterface driver for windows here in point#D1: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools - Special Topics / Intel Management Engine - Win-Raid Forum (level1techs.com) MEI Drivers and Software v11.0.6.1194 includes MEI v11.0.5.1189


Thanks for your response

To summarize my problem After installing mod bios, with a bios hardware boot error screen, I did successfuly install Win 10 to my NVME drive the first try using a UEFI USB stick but I had a PCI simple communications device error with new win 10 install. I booted into my old drive that has a UEFI dual boot win7 and win10. Both OS’s had an Intel Management Engine Interface error cannot start. I Uninstalled mod bios back to my backup F20 and reinstalled mod bios and the same error on NVME drive.

I reinstalled F20 bios and can no longer boot to a UEFI Win 10 device including my UEFI Win10 SSD, a UEFI Win10 USB or a UEFI Win10 CD without a quick BSOD (kmode exception not handled). I also changed my bios battery.

I can however boot to my UEFI SSD Win 7 with no problems. I don’t know if this is related to IME or my bios or not but I cannot figure out whats wrong, it’s not a windows error, I just can’t boot a UEFI Win10 device without 2 seconds of spinning blue circle followed by BSOD.

If in the regular OEM bios or the mod (Even with defaults loaded), you cant boot a USB UEFI OS installer, then something is not correct in OS image or USB preparation, besides that i cant see any other issue, or an HW issue if the system runs stable on your old windows 7 OS, regarding hw like gpu, ram or disks health.
An MEi issue in low level hw usually as a symptom of non-displaying ME version in bios, if its showing the version then its ok.

1 Like


Thank you for your help, you are correct. I checked my UEFI USB installer and all is fine. I set the Intel SATA mode to none in the bios and I could boot to the UEFI USB. If I set the Intel SATA to either RAID or AHCI, with my dual boot drive attached the installer gets a BSOD within a few seconds. I then disconnected my drive and left Intel SATA (RAID or AHCI) on and The USB boots fine. The UEFI USB installer must take a quick look at something on the OS drive (Win10 bootloader?) and doesn’t like it.

Previous to my bios mods and Win10 install to my NVME I would boot up to an option screen for Win10 or Win7(default) with a 3 second delay. The option screen is still in place but no go for Win10. Something I did changed that.
As I cannot get to a Windows Recovery Environment to attempt to fix the bootloader, with my OS drive attached, do you know if I can attempt repairs to the Win 10 partition while in a Win 7 dos prompt diskpart. My Win10 partition is very clear in Win7, they switch drive letters with drive C being the current OS I am in. I could even delete the Win10 partition while in Win7 but I have never done that in reverse. I created the partition with a Win7 install first and then a shrink volume to create space for a Win10 install. I don’t want to lose my Win7 install right now but I don’t care about losing Win10 and reinstalling it.

Ok but i dont know what disk you have for all that…win7 and 10, or multiples disks, how was set before, as RAID as IDE as SATA AHCI, as MBR or GPT, legacy or uefi bios settings, then upon selection made the windows drivers are not the same and then the system gets BSODs, etc…a mess, this is all small but critical details that matters about in all your attempts, success and fails and how a user intends to have is system. Its too much details for give a full description in all situations and possible configurations.
The problems you have in OSes its the consequences of having multiple OS on the same disk, not recommended as you can see now.
General recommendation is Win 10 OS in NVMe, and other OSes and storage in separate disks so each OS have their own partitions to manage and not interfere with OSes present.

any chance some can upload the v1.0 bios mod please

The BIOS for the GA-X79-UD3 Rev. 1.0, which had been modded by Lost_N_BIOS and uploaded in September 2019, is not available anymore and cannot be recovered.
Since our retired BIOS Guru Lost_N_BIOS has not been online for a very long time, I have modded the original F20 BIOS myself by inserting the NVMe module named NvmExpressDxe_5.ffs.

You can flash the attached BIOS at own risk by following >this< Guide. Good luck!
To be able to get Win10/11 installed onto an NVMe SSD, please follow “Step4” of >this< Guide.
X79UD3F20_modbyfern.rar (3.6 MB)

Thank you very much this worked great and booting from my nvme no problems

1 Like