[Request] Gigabyte G5 KC Bios Unlock/ Mod

Thanks for replying, unfortunately i do not have other WinPE. So i guess i will have to wait until you figure out how to proceed? Or if you’d like to interact in real time, i have Discord:
AugustinGamarra#2762 and you can Remote View or something like that. I’m usually available at 18:00 GMT+7

It’s unlikely to happen in the near future. Having an only smartphone as primary device remote view is not a good idea. The screen is too small.

I’d suggest to try entering the command from your last screenshot manually and see if UEFIPatch generate a modified file.
I’ll send you a Discord message what else could be done. This thread getting floody.

Hello, I’m sorry to resurrect an old post, I wanted to know if it’s possible to use this Mod for G5 KE 12500h rtx 3060. I tried to use it but it says “You ought to flash the Mod manually by some SPI prog. tool”. All good? Thanks in advance.

That’s right, for new Gigabyte laptops with 12 gen CPU, the script is only capable of generating a “MOD.bin” file.

Gigabyte G5 is a Clevo barebone device. And they don’t allow to install customized BIOS anymore. I think that some register of PCH (platform controller hub) blocks operations with SPI, if CPU is NOT in SMM state. There’s no solution to this yet, unless you’re willing to help.

Thanks for the answer, I have never modified any bios, so where I can I would gladly help.

I’d need only a little of info to say whether we have a chance or not.

First of all search for the PCH SPI Flash controller in Device manager. It may be named differently depending on the chipset.
If it’s displayed there it’s great. Then download RWEverything and try finding the controller as one of PCI devices in RWE. If you do this miraculously, select it from the drop-down menu and make a screenshot for me.

The only thing named SPI controller I found is this:

I tried to open RWEverything but it says Driver cannot be loaded.

Ok, I disabled core isolation and set to zero a key in regedit and now it works, A windows 11 problem. Now I have a white page on RWE. What I have to do?


I send you all of them, I can’t seem to find it.
Screenshot 2023-08-04 190815

I think it’s device 1F, function 5. Could you show it to me?

Thanks. Device ID on the summary screen confirms that it’s the SPI controller.
It’s a step futher. Now we know what blocks writing operations, at least. This topic helped much to acquire the problem. Next, gotta find out which way to change the value on offset 0xDC.

/// PCH BIOS Spec Flash Security Recommendation
BIOS needs to enable the BIOS Lock Enable (BLE) feature of the PCH by setting SPI/eSPI/LPC PCI offset DCh[1].
When this bit is set, attempts to write the Write Protect Disable (WPD) offset DCh[0] in PCH will cause a SMI which will allow the BIOS to verify that the write is from a valid source. When this bit (BLE) is set BIOS Lock Enable feature, EISS is locked down.
BIOS needs to enable the “Enable in SMM.STS” (EISS) feature of the PCH by setting SPI PCI offset DCh[5].
When this bit is set, the BIOS region is not writable until SMM sets the InSMM.STS bit, to ensure BIOS can only be modified from SMM.

But I not sure what to do with the other bits, reset or leave as is. Will let you know when I come up with something.

1 Like

Sure, Thanks for the help :slight_smile:

Thus bit 0 has to be set, bits 1 and 5 cleared. Value AAh become 89h. BIOS Control (BIOS_SPI_BC) – Offset dc - 1.2 - ID:615146 | Intel® 400 Series Chipset On-Package Platform Controller Hub

But here’s the catch… bit 1 can’t be cleared until the “PLTRST#” (total reset) event is occured. And this bit doesn’t allow to clear bit 5.
The main question is how to perform the total reset without the laptop being shut down? If the laptop is restarted, the BIOS will lock itself again. Sad to admit, but the answer is nohow. The BIOS region is not writable until the CPU enters the SMM state, which occurs when official update starts.

So, no point going any further? This laptop it’s not usable… I will just sell it and buy a desktop

Sorry for being off topic.
I was just wondering where i could find and download official BIOS versions for Gigabyte G5 KC (rtx 30) (specifically older ones) because on the official website, only one version (prolly the latest) is listed.

Also, I have never manually updated or downgraded my BIOS before. What do I need to watch out from so that I dont get my laptop bricked. (Cuz the stories i hear bout bricked laptops are scary ^^')

Thanks in advance,

@Sweet_Kitten Do you still do requests? if so, can you mod my gigabyte G5 GD Bios? the version is FB10 I extracted it directly from the ch341a programmer.


i too would like to have an unlocked bios for a g5 gd i am currently running fb08