[REQUEST] Gigabyte Z87X-UD3H HPET option

Hello everyone. I would like to request (if possible) an HPET on/off option for my custom z87x-ud3h bios

i would be eternaly grateful for this

@pepeo - This is bad mod, are you sure you want me to edit on top of badly modified BIOS? One padding file removed, 2 x alignment issues, all due to microcode edit incorrectly
If you’ve already flashed this BIOS, and it boots OK, then those things may be fine for this BIOS. Could cause issues later, but not sure, usually would = bricked BIOS if it’s going to be a problem.
If that is all you modified in this BIOS, then I will redo using stock F11c, and update the microcodes properly myself.

As for the HPET request, do you have to have this visible, or would hard disable be OK? hard disable is easy for me to do, takes about 15 minutes
But if you want this visible it will take me a few hours to do, because I will have to replace some setting which you do not currently use, or one you cannot see, with the High Precision Timer setting.
If you must have it visible, please show me image of root of “Advanced CPU Core Settings” page top to bottom, you can use F12 to screenshot to USB, then put in max compressed zip. I think I can find setting on this page that is hidden from you, to swap in setting.
Just in case there is not ideal choice there, please also include screenshots of “BIOS Features” page top to bottom

Hey thank you very much for your anwser. The bios was not moded by myself, i actually just got it from the offer section, because i needed the nvme boot functionality. If im not asking much, if i upload a stock f11 bios, could you put the nvme boot functionality and the HPET on off toggle option? you dont need to replace microcode or anything, i would even preffer if you let it the old stock ones because of the (even if minimal) performance hits.

Thank you again, is there any way i could repay you? donation, steam gift, whatever, i really am very grateful for this

@pepeo - I have stock BIOS, I will make you proper NVME mod BIOS + Update microcodes myself, that way I’m not editing on top of badly modified BIOS
Ohh, you want stock microcodes, OK, I will do just NVME edit + the setting swap. Please put those images into a max compressed zip, thanks!
Yes, thanks for asking, I will shoot you a PM

Love this BIOS GUI!!! Makes me miss using my Z87MX-D3H


bios_settings.zip (1.93 MB)

@pepeo - Thanks. You can delete those if you want, saves some space on the server
Zip can be uploaded and attached here, but it has to be under 6MB
* Edit, Ohh, I see the issue! Yes, .7z can’t be uploaded, I use it too, that would need to be renamed extension is all

* Edit - @pepeo - OK, I will put HPET at the following location >>
Advanced CPU Core Settings >> Will replace hidden option and then make the setting visible >> Real-Time CPU Ratio Control In OS

Thats awesome, i didnt even know those mobos had hidden options lol

Yes, often lots hidden, but in Gigabyte not too much usually (at least not too much that’s worth using anyway)

@pepeo - Sorry for the delay, this kind of setting swap around edit takes some time to do as I mentioned initially
Flash via Qflash - http://s000.tinyupload.com/index.php?file_id=03382849365243149209 << Nuke this, missed an unsuppression I blame the >>

Thats awesome, thank you very much. I will be running some hpet tests later today.

I flashed the bios and everything is fine, but theres no hpet option on the CPU advanced tab. Is there something i need to to to show it?

@pepeo - You’re welcome, and sorry about that! As soon as you mentioned I immediately knew what happened!
I worked so hard on doing the setting swap in one module, I forgot to unsuppress it in setup as I did the setup swap edits!
Here you go, fixed - http://s000.tinyupload.com/index.php?fil…290163874143212

Just an update, i flashed the bios now and i still cant see the option, maybe you uploaded the wrong file?

@pepeo - Sorry, let me check again! The issue may be something else, such as wrong page ID (I stalled on this for a second, wasn’t sure if needed changed) I’m used to swapping in menus/submenus this way, not often "settings"
Just to be sure, while I looked this over and make new edit possibly. Please reflash both BIOS I sent you, one at a time, and after each flash >>
Shut down, clear CMOS, boot back to BIOS, load optimized defaults, save/apply/reboot back to BIOS, then look in Advanced CPU Core Settings and see if you see “High Precision Timer”

Thanks, will do now, will report in few mins

Sorry! If I can’t sort in next few edits, I will get out my Z87MX and do same edit, so i can get it sorted on my end

Hey no problem, sorry about the incovenience. I tried the instructions you posted above and no luck, both bios, both clear cmos from cold boot, 2 times each to make sure, still cant see it.

@pepeo - No need to apologize, at least for you, but there is for me!! Sorry about this, I will get it sorted out one way or another!
The issue is I rarely do this swap, maybe only a few times, I’m usually swapping in an entire menu or submenu, instead of a single setting (from the hidden debug area at that too)
So things are a little bit different for that and I need to remember which specific things need swapped for setting move and which do not.
As I mentioned, if I don’t get it for you shortly, I will do on my end and then I will be able to quickly figure out via a bunch of test edits without hassling you to do that
The hard thing about sorting this one out is with simple setting swap vs a menu, I can’t see it fail in AMIBCP when using that to double check (it all looks correct, even ones I checked initially that I did not send your way)

Here, I think one of these is the answer
Clear CMOS after each flash, load optimized, save/apply/reboot, then check.
You only need to do that once, and no need for cold boot test, it should be there instantly once edit is 100% correct.

Please test both, even if 2a works, test 2b, and let me know outcome, thanks!

Thanks, youre the best. I will test later today, after i get back from work.

You’re welcome, and thank you!
If neither of the above get it, then I’ll get out my Z87MX-D3H and get to the bottom of this for you on my end, then there wont be any issues after that

Ok so i got back and tested both but still no luck. I did like you said, clared cmos, then load optimizated settings, save/apply reboot, and still cant see it.

@pepeo - Sorry Hmm, lets test the basic thing (correct access level or not) here before I dig out my board (I think I have to recover it’s BIOS first too)
Can you see RealTime CPU multi in BIOS with this - https://ufile.io/mjpdqvgk

If you can’t see it, then this may be simple mistake I was doing (+access level Super) that’s causing all edits after this to fail, and I may need to use Access Level User instead (or default/ie no change to access level)
If you can see it, then the issue is with the actual setting swap edit and not this basic thing of making that setting visible in that position. I’ll have to get my board out, unless you do not care, and don’t mind continuing more tests?
Sorry I’ve already had you test so many BIOS, usually this is an easy thing for me, although it takes forever to do it’s usually not an issue (but, as mentioned, I usually swap in entire menu)

* Edit - Yippee! I found my notes on a similar “settings” only swap around - for this board/mod - [Request] Gigabyte OEM Z370-HD3P - Option “HPET” missing in updated bios
So go ahead and test above so we’re sure that is OK, and then I am 99% sure once I have a second to redo this edit it will be proper