[Request] H61H2-CM UEFI Support and ECS H110H4-EM NVME Support

Hello, could you please help me to get a modified bios for the H61H2-CM motherboard so that it has UEFI support and ECS H110H4-EM bios that has NVME support.

Modified for what? Original product bios file website? Original current dump/backup of the system bios… this are things that it may be handy in order to users help you, agree?
The bios is Legacy or UEFI, it cannot be re-coded.

EDIT: If its a based ECS H61H2-CM, both bios 4.6.4 and later one 4.6.5 are UEFI, the later on adds CSM sub-menu.

For NVMe mod on both models, follow the guide: [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

the H61H2-CM not support uefi (the option is locked in the bios 4.6.4 and 4.6.5) and the ECS H110H4-EM not support M.2 NVME only Sata M.2

I tried to install windows 10 UEFI on an H61H2-CM with bios 4.6.5 and I couldn’t because the UEFI boot option is not active in the bios

Ok, both 4.6.4 and 5 are UEFI and lost my time to check it, so stay with your thoughts.
Not gonna loose time now checking the H110, seems your up to date with it, but you maybe out of luck with (as you already know), no PCIe bus connection only to SATA from PCH.
Which M.2 SSD with the H110H4-EM motherboard? (computers, technology, games and gaming) (gutefrage.net)
Latest MEDION H110H4-EM v1 W0X.105 bios has the AMI NVME module in it, no mod need to it.
Good luck.

You didn’t understand me, I just want UEFI support on the H61H2-CM, since when trying to install windows 10 in UEFI mode it just stays on a black screen

for the ECS H110H4-EM board I just wanted to know if it has NVME support

I did… now as i dont know your IT knowledge i have to ask you, did you made or do you know how to make a USB OS ISO boot UEFI, correctly?
Does the motherboard has F12 or similar boot device selection, does it show a simple USB RUFUS UEFI GPT boot drive.
NVMe drives/PCIe M.2 adaptors and NVMe mods aside…
The bios verified has UEFI support, now i dont have any board of that model here to see the menus inside the bios (what is visible or not) or to test anything else.
There is UEFI BBS strings inside the bios code on both AMI IV 4.6.4 and later 4.6.5 (H61H2-CM A001 02/28/2013) has even more


Im i clear now… or should i go take some lessons?

EDIT: Whats the GPU, does it supports UEFI, if not you cant do a UEFI OS installation? iGPU can do it.
I dont need no video or time to watch it… this is not a repair shop.
Nothing more to add, Over_n_Out

It is strange because if it has a boot menu it even shows the usb as UEFI but when I boot from the usb prepared with rufus in uefi mode the screen stays black

I currently have that board with windows 10 installed without UEFI because of that error

I have already installed windows 10 in UEFI mode many times but on that board it shows this error

and in the H110H4-EM I installed windows 10 with UEFI without any problem

In case you have any doubts, I can give you a video of the error that occurs when trying to install Windows 10 in UEFI mode.

Unplug all drives when installing Windows you can connect them back after

now presents the following

and in the bios it only shows this about the UEFI there are no more options

Imagen de WhatsApp 2023-01-03 a las 15.32.08

here the boot menu

Again, its GPU or iGPU?
You made the RUFUS as UEFI GPT correct? If so its prepared for UEFI boot
The bios has a locked string (Not visible) called CSM parameters, in capture already posted, with the fowling options:

LAUNCH CSM - Failsafe: AUTO and Optimal: Always
So try loading the FAILSAFE general settings to bios and the USB must show in boot menu, because the filter is set by default to load UEFI first then Legacy.
Besides the 2 HDDs the USB must show in the list, ensure that you try different USB ports.

And the advice from Kuri0 is also valid for debug purposes.

It does not have an integrated one since the processor it has is a xeon E1230 V2 but the graphics card it has is a geforce 730 100% compatible with UEFI

rufus is well prepared (I have already installed a lot of windows in UEFI mode) and I did a bios reset but it’s still the same

for some reason the card has UEFI disabled and it’s not just with this one I’ve seen 2 others that have the same problem

I already tried what Kuri0 said but it didn’t work for me

could you dump your 730 vbios here?

Nvidia Geforce 730 GT 2 GB GDDR5 GK208

might not be useful but here is the vbios with the latest GOP:
73038.zip (125.3 KB)

Also, you cant see any possble toggle for CSM to be turned off or even “OS Version” option, in my H61H2-MV i have the option to choose windows 10 or 8/7 (i kinda forgor), and i could boot pure uefi with that one. Unless you understand, you could try to disable CSM through this guide(same method, just different varoffset, also start from step 5), might need to extract setup.ffs or use ubu to extract the setup and see which variable that CSM use.

I have the same motherboard. I sort of solved the issue by flashing the bios file from the Ecs h61h2-m6 motherboard. Legacy UEFI capable at the same time. Support for 2/3 th intel cpu

In the end, I left it without UEFI, it is better to change that board for another one

It’s ok. I just want you guys to know that there’s a solution