[request help] 2500k OC on ASUS p8p67 m

first,sorry in advance for my bad english,i’m not a native speaker of it. :slight_smile:

i have fully working asus p8p67 m with 2500k,nice air cooler and 2400mhz ddr3 ram on a latest 3703 bios. as you know,asus disabled OC on p/z sandy boards with ME 8.xxx. i would like to enable it, but i’m hesitant to go back to latest me 7 bios image (that would be 1701) because i have r9 280x and if i recall it right,p67 had problems with 2xx cards on old bios images,and i don’t have much trust in my bios flashing skills and old bios flashing tools like afu and FTK.i did mod vbios of my 280 with vbe to disable UEFI part of vbios,to make it work on a z68 board with ME 7.xxx that i had.

my question is,can i just flash ME region from 1701 bios image using FTK and count on having a working OC (multipliers) and it working with my 280x or can i mod latest 3703 bios image with ME 7.xxxx modules using MMtool or UBU/UefiTool to have overclocking and working GPU?

again,i’m very sorry for my bad english,and thanks very much in advance for any help and/or input!

To do the ME backflash stuff, you have to either have flashback on your board, or first flash one modified old BIOS with ME Reflash enabled via mod edit, then flash newly edited old BIOS again with old ME in it. Best to not use new BIOS with old ME, it may not work due to changes in the BIOS, so yes, that may cause issues with your graphics card too as you mentioned.

Best thing for you to do now, before anything else, is order a CH341A flash programmer so you can recover from any bad BIOS flash. This will also allow you to program any BIOS/ME you want into the chip, without having to dance around trying different flash methods to try and get mod BIOS flashed in or old ME in there etc.

CH341A flash programmer is only $2.50-3.00 on ebay.

thanks for reply!

as i said,problem with going back to old version is gpu,i’m 99,9999 certain that it would not work with 280x,and it’s the only one i have.and as you know,p67 doesn’t have iGPU,so i would be stuck…i can try to find bios chip and leave the one in the MB as a backup.so the question is,can i hotswap chips in DOS mode?

P67 has Internal graphics and so does your CPU, but yes I see your board model does not And yes, you can hotswap in DOS, be careful not to bend the rom legs, they bend very easy.
Maybe get it half way out, or all the way out with it off, then put ribbon or tape under middle of chip coming out both sides or some kind of wrap around from underneath to top, so you can pull up easy from both sides at once or from top all at once, then carefully put in the other while in DOS.
It’s not in use while in DOS, but I think Vcc/GND still live.

Hot swap wont help with the ME flashback though, you will need to do BIOS mods as I mentioned, unless it will let you straight flash back to older version of BIOS. Sounds like your card should be OK with ME7 since you used on Z68
If you need mod BIOS with ME-reflash enabled I can make for you, but you first have to get older version flashed in I think.
Or maybe you need ME refash enabled both times for the reflash to older, I can’t remember on boards without flashback, AI Suite may do the flash to older for you itself and redo the ME, but usually Asus BIOS do not contain the ME inside BIOS.

i was unsuccessful in the past with afu and ai suite tools,as with EZ flash in the bios,because i have latest bios all other images asus tools render as obsolete.i did flash it at local service with initial (release) bios but it didn’t display image with 280x and other i think nvidia uefi vbos card that guy had. so,as you can see why i’m hesitant to go to earlier bios images.

so there’s no safe way to reflash just ME sector of bios with software tools?and it isn’t guarantee to let me OC the cpu/ram and work with gpu?is ME sector that determines what generation of gpu will work?

But you modified your card, to work on Z68, so should work on here too now. No, there’s no way to flash ME backwards while staying on new BIOS, many other modules are updated in BIOS when they move from ME7 to ME8, so to use ME7 you have to be on the old BIOS with ME7.
You can find newest BIOS that has ME7, and use that instead of super old one. Download all the ones leading up to “Added Ivy support” and check them with ME Analyzer, drag and drop BIOS onto ME Analyzer, it will show you what ME is in there (if any) Change probably at 1701 to 3602 as you suspected.
Maybe none contain ME except that one that adds Ivy support, and the original flashed in your board at factory with ME7. I will download them and check for you now

edit, yes both BIOS include ME and ME change is at 1701 to 3602 - ME7 to ME8 - so you need to program in 1701 BIOS, backflash ME like that is not possible I think.
You can try mod BIOS with ME-Reflash enabled, and it may work OK since you are using Sandy Bridge ME messed up for a minute will be OK, flash once will get BIOS and then reflash again should do ME.
Give me a few minuets and I will post a BIOS for you with ME-Reflash enabled.

No, I cannot guarantee anything to you about overclock or GPU, I can only try to help you do what you wanted to do Yes, in this case ME controls what Gen CPU work OK. Ivy only ME8 or above, Sandy either is OK

You may have to have programmer, due to hotswap wont help with dump complete BIOS needed to flash back older version BIOS + old ME at same time. But above method may work
CH341A flash programmer is what you need, it’s only $2.50 on ebay but long 3-5 weeks shipping, or you can usually buy locally (I mean PC hardware store you buy stuff from, like Newegg, Amazon etc) for $8-12

Edit 2- I checked, there is no ME Re-Flash setting in this BIOS, so you have to either try and see if it will let you and if it fails (likely due to ME rules) you will need flash programmer, or you can try this method which many had success with

if i can’t get it to work through software i’ll buy flasher and a spare bios chip to mess around,no point i messing with a working one as chip alone is like 15 cents. i’ll get some cheap 1155 board to have a backup before messing with this. :slight_smile:

so,if i get it right my options are:

1.flash 1701 and hope it will work with my gpu.
2.flash modded 3703 with me 7 (what tool and ME source should i use?)
3.flash modded 1701 (just update ME to latest ME or update all i can with UBU and UefiTool?)

i did inspect 3703 bios image with AMIBCP and OC features are still present and enabled by default,so i suspect that ME is what disables them (turbo ratio and multiplier).


i did a little investigating the whole ME issue - 1701 has me 7.0.4.xxx version,that msi board that i’ve used had me 7.10.xxx version. so, if i get it correctly - there’s no point in flashing 1701 version…

edit 2:

here’s a paste from ME tab of hwinfo:

ME Host Status
ME Current Working State: Normal
Manufacturing Mode: Active
ME Current Operation Mode: Normal

Intel Manageability Engine Features
Intel ME Version: 8.0, Build 1410, Hot Fix 2
Intel ME Recovery Image Version: 8.0, Build 1410, Hot Fix 2
Intel ME FITC Version: 8.0, Build 1410, Hot Fix 2

ME Firmware Capabilities
Full Network Manageability: Not Capable
Standard Network Manageability: Not Capable
Manageability (AMT): Not Capable
Small Business Advantage: Not Capable
Manageability Upgrade: Not Capable
Intel Anti-Theft: Not Capable
Capability Licensing Service: Capable
Virtualization Engine: Not Capable
Power Sharing Technology (MPC): Capable
ICC Over Clocking: Capable
Protected Audio Video Path (PAVP): Not Capable
Identity Protection Technology (IPT): Not Capable
Remote PC Assist (RPAT): Not Capable
IPV6: Not Capable
KVM Remote Control: Not Capable
Outbreak Containment Heuristic (OCH): Not Capable
Virtual LAN (VLAN): Capable
Cipher Transport Layer (TLS): Not Capable
Wireless LAN (WLAN): Not Capable
Platform Trust Technology (PTT): Not Capable
Near Field Communication (NFC): Not Capable

ME Firmware Feature State
Full Network Manageability: Disabled
Standard Network Manageability: Disabled
Manageability (AMT): Disabled
Small Business Advantage: Not Capable
Manageability Upgrade: Not Capable
Intel Anti-Theft: Disabled
Capability Licensing Service: Enabled
Virtualization Engine: Disabled
Power Sharing Technology (MPC): Enabled
ICC Over Clocking: Enabled
Protected Audio Video Path (PAVP): Disabled
Identity Protection Technology (IPT): Not Capable
Remote PC Assist (RPAT): Disabled
IPV6: Disabled
KVM Remote Control: Disabled
Outbreak Containment Heuristic (OCH): Disabled
Virtual LAN (VLAN): Capable
Cipher Transport Layer (TLS): Disabled
Wireless LAN (WLAN): Disabled
Platform Trust Technology (PTT): Disabled
Near Field Communication (NFC): Disabled

ME Firmware Platform Type
Platform Target Usage Type: Desktop
Platform Target Market Type: Consumer
SKU: Regular SKU
ME Firmware Image Type: 1.5MB Firmware
Platform Brand: None

Host ME Region Flash Protection Override (HMRFPO) Status: Disabled

edit 3:

just upraded ME to latest with FWupdate,it shows accurate version in bios and hwinfo,but still no OC options…

Yes, you can get sets of 3-5-10 chips very cheap

1. Yes, this is suggested
2. Not an option, at all, you cannot put ME7 into BIOS originally containing ME8 (Same applies in reverse as well)
3. That will be fine too, but first #1 to make sure it’s OK with your GPU, if not borrow another GPU from something and reflash back to latest BIOS

What you see in AMIBCP has nothing to do with what’s enabled in BIOS always, only what you see in BIOS is enabled. If you see something in AMIBCP but not in BIOS, it has to first be enabled/made visible to you to be active, by a BIOS Mod.

But yes, what you mentioned is somewhat responsible for the overclock locking with certain CPU’s, it’s usually ME+CPU microcode that does this.
I have never heard of Asus disabling overclocking with P67 and ME8, nor have I experienced this myself, but I can’t remember testing Sandy on there with ME8, maybe that is the issue, I do remember them saying stay on ME7 for Sandy and ME8 for Ivy (Many brands said this)

i don’t think my bios/me region is locked,i just flashed latest me with FWupdate.with what tool should i replace me region in 1701,as modded 1701 seems like safest bet?and with what tool should i flash it?ftk8 in dos?flash programming tool?

See my reply above #2 - I did not say your ME region was locked, which it likely is, but that is beside my point.
Updating with ME FW Update tool does not mean ME region is unlocked, to check if ME region is locked you have to try to dump ME via FPT (fptw.exe -me -d -me.bin)
If you get error ME is locked by the FD, if no error and a full ME dump is output then ME is unlocked (check file in hex or notepad to make sure it’s not empty/all FF’s).
You can also check with MEinfowin, see >> Host Read Access to ME / Host Write Access to ME, if enabled then great your FD has ME unlocked, that only makes what you want to do more dangerous since you have ability then (It is possible to force, several ways, but don’t)

What I said in #2 has nothing to do with ME locked or unlocked or whether you can update it or not ect.
ME8 BIOS has many edited modules in it only compatible with ME8, same for ME8, you can’t switch ME8 with ME7 (Or reverse) by yourself, only the manufacturer can do that because to many other modules need edited, updated, changed etc.
If you still do not believe me and try to flash in an ME edited BIOS, it will fail anyway, but if you forced via some random method and succeeded, then be ready to recover with flash programming tool because the board will be bricked.
FW Update tool, or FPTw, neither will backflash ME V7 from ME V8, due to several rules set in both tools. The only way that could even be attempted would be via edited BIOS, which will fail to flash and if programmed in with programmer will fail to boot.

If you are into taking risks like you keep wanting to do, then do as you suggested in post #7 step #1, that is my suggested move for you and what you initially requested, then if all goes well you can do what you mentioned in post #7 step #3

i already did dump with fpt,no problems.i’ll find and post findings of meinfowin.

so,there’s no way to go back to me v7 from me v8?not even with hardware flasher?how’s that possible,if me is stored in bios chip and SPI flasher first erases whole chip than writes all of the image?also,they say on pages of FTK and flash programming tool that it first erases whole image or region and flashes new,sector by sector,so i don’t know what difference would be what is flashed after what,so if you would be so kind and explain that to me it would be greatly appreciated. :slight_smile:

i will not flash anything that’s not somewhat safe (like that me8 to latest me 8 update) without further research and instructions.

edit - screenshot of meinfowin64:


i reflashed latest 3703 using ftk in dos (ftk 8 for DOS,usb prepared with rufus/freedos,3703 bios image renamed as bios.bin and used reflash command,then ‘poweroff’ command as described in ftk guide) just to see can i even flash it and voila,OC is back! :slight_smile: now running 4,5ghz and 2133mhz ram no problem,ftk transffered my win activation,apsolutely no problems.

so,i don’t know how this helped,on all of internet there’s countless posts and reports of me8 breaking OC and ram speeds on p67/z68 boards,guides on how to restore it by flashiung ME,downgrading etc…the cure was simply to erase and reflash latest bios,at least in my case.

so,if anybody have similar problems on this old boards,i suggest before buying hardware flasher,old gpu’s and backup boards to check are their bios is unlocked,and to reflash latest bios image with ftk.tomorrow i’ll run some more test and recount what i did in more detail.

thanks to @Lost_N_BIOS for help,guidance and wise words!

Yes, there is a few ways to go back to ME7, only with old BIOS though, you cannot use ME7 on new BIOS that original had ME8 in it. Thanks for MEinfo, you are correct, your ME is unlocked in the FD

Yes, FPT (What’s used in FTK, along with FW Update tool for some actions) can update ME, or BIOS, or both at once etc.
Flash programmer can write anything you want to the chip, but as I said being a bootable BIOS is another story. You cannot rename bios.cap to BIOS.bin, you are lucky the program batch files you are using from FTK remove the capsule for you creating a .rom BIOS before flashing!

Great you have your overclock back! Looks like your BIOS or ME was possibly messed up before, or you needed to reset ME state from some previous action you did, cool it’s all working for you now!
I thought removal of OC by Asus for ME8/SB CPU didn’t sound right as soon as you mentioned it, glad you were able to fix the system without having to flash back to old BIOS.

funny thing is that i already flashed initial bios (no out with some more recent nvidia GPU the guy had to test) and 3703 at local service with spi programmer and stil didn’t had OC and ram speeds past 1333mhz.sadly,it didn occur to me to flash 1701 then…

asus p/z67 boards don’t come encapsulated,they are in native .rom ami format and don’t have to be modified to flash with ftk/flash programming tool or SPI programmer,that begin with native me8 boards because of problems with me v7 to v8 upgrades…that info i found on asus forums,and on more places on the net.and,as you said,ftk extract them,i’ve used ftk because i have legit win activation on that board (one of the reasons why i tried this hard to restore it,other being having nice 2500k that i’ve got for dirt cheap :slight_smile: ) and ftk automatically transfers it to new bios image.

thanks to @CodeRush for this nice software if he’s still active here! :slight_smile:

my theory is that there’s more steps in restoring me than simply flashing,maybe me is restoring itself from some backup on the board so when you flash it like 2 or 3 times you flash it over…that is of course simply my speculation,i’ve honestly no idea why this time worked.


is there any real world benefit of updating cpu microcodes either by software and/or bios modding?i suppose there’s none in updating ME and as we saw this board has problems with it…so should i just stop tweaking further and be happy or thinker it further?i already disabled metdown and spectre with InSpectre v8,because performance on this system is most important,it’s cheap little gaming box that i’ve haphazardly assembled from spare parts laying for years around,so i’m not that concerned of messing it up. :slight_smile: and i’m thinking of dualbooting macOS and win…

Probably ME reset was needed, with FPTw -greset, without that is was messed up and somehow broke the OC. You are right, I just noticed that earlier about the .rom/.cap on these BIOS too, sorry about that!

Yes, especially now, updating CPU microcodes fix huge security risk holes (Spectre and Meltdown hacks most recently as you mentioned) If you are using Win10, then that can be done on the OS level, because win10 will load it’s own microcodes now to override any old ones in the BIOS. But yes, you can update them to latest if you want.

can you be so kind and please mod the latest 3701 bios image with all,microcodes,rst oprom,me, i tried it myself but didn’t had any luck either with UBU or UefiTool…i’ve read all the guides but either it gives some error,or as in case of UBU just hangs…thanks in advance!

RST I can do, but you need to tell me specifically and exactly which you want, it’s not something I normally update so I don’t know what to pick for you. Run your BIOS through UBU and see what all it shows you, then tell me which you want updated to what, for RST I mean.

Rest I can easily do, so yes no problem, I will wait on your reply about the RST. There is a guide here for RST roms and what’s best to use for what situations AHCI & RAID ROM Modules and Intel EFI “RaidDriver” and “GopDriver” BIOS Modules

Also, I am leaving now, so don’t get in hurry and force a bad flash or something while you wait on me, thinking I stopped helping. I’ll be back in here in about 15 hours from now.

no problem,i’m not ina hurry myself,l’ll wait until all research and info is done…ubu just says there’s nothing to update.here’s a screenshot of a ubu screen,but i don’t know why and how you can’t just see it by yourself,it’s a stock bios image from asus support page,3703 (latest version):

and here’s 3703 bios image from official support page on asus site:

p8p67 m


just a thought,i had celeron in when i’ve flashed with spi flasher at local service,maybe that had something to do OC not showing after flashing when i came home and begin thinkering myself?but i’m 100 percent certain all started when i got 2500k,putting it in,reseting the bios with unplugging the board and battery and leaving it for about 10 minutes and tapping a power button a couple of times and still no oc and ram speeds…who know,maybe it’s a combination of all of the above…

celeron is SB one,g530 or something like that.

I only wanted you to check with UBU, like you show above, to see what current version you have, then read the guides to help you pick the best version for your situation. Probably ME was reset, either by the 10 minutes without power, or a -greset after one of your flashings?
Back to UBU, you can update 3, 4, 5 with UBU if you wanted, as for 1 and 2, see below.

For 1, you have to do many steps manually using the vBIOS update guide, then put the file in correct UBU folder, then it will let you update #1 too.
For #2, that has to be selected via the guides I gave you links to, and then put in the correct UBU folder too, and then it will let you update #2 as well.

So in summary, yes all of that can be updated, by hand with other tools, or with UBU/combo of manual edit files put into UBU.

What all do you really need updated, I can do for you by hand. I will do microcodes by default ME is updated on your end already.
For stuff you don’t use then we don’t really need to update, like RealTek Boot Agent (Boot from LAN), or onboard graphics (vBIOS), do you use that or a PCIE card?
If you want iRST updated please check this link and see which is best for you, then tell me version or post link to download here

p67 doesn’t have onboard graphics video outs,so i have to use my 280x with modded vbios to disable uefi part of vbios.i guess i now can flash back stock vbios,since it’s on more recent me…

no,me is not updated, 3703 bios image has 8.0.2.xxx me,i did previously flash latest 8.1.x.xxx to see if me is unlocked and will it help,then reflashed whole 3703 bios image thus ME was reset to 8.0.2.xxx.

edit: i didn’t use -greset function while flashing anything,first time i hear about that function.when i updated me only i was using fwupdate tool from latest ME system tools v8 r3,and when i reflashed back the latest bios image i’ve used ftk8 and ‘reflash’ and then ‘poweroff’ functions.

i guess i can use:

as instructed by @Fernando.

P67 does, just your particular motherboard model does not. Yes, you may be able to use stock vBIOS now! If not, you can recover/reflash vBIOS back on another system

That’s what I meant, about the ME, you already know how to update it, and it has to be done on your end since ME is not part of the actual BIOS unless you send me a full 8MB Dump.

I think maybe FW Update tool can reset ME State by itself, without having to use FPTw -greset, but that may depend on how it’s used, what you are flashing etc, I am not sure. Power off does = greset so that probably same thing.

Thanks for your choice on RAID rom, I will do tonight. Please clarify which, I assume one of the TRIM modified versions, last one correct?
◦>Intel RST(e) RAID ROM v12.9.0.2006< (>MIRROR<) Thanks to Pacman for offering the source file.

Here are some slightly modified variants of this Intel RAID ROM module:1.>“Universally TRIM modified” Intel RST(e) RAID ROM v12.9.0.2006 with TRIM in RAID0 support< (>MIRROR<)
Note: This modded OROM is designed for DEV_2822/282a Intel RAID Controllers. For details look look >here<. Credits go to CPL0 aka Dufus for having developed this special OROM modification.

2.>Especially modified Intel RST(e) RAID ROM v12.9.0.2006 with TRIM in RAID0 for X79 systems< (>MIRROR<)
Note: This ROM is designed for DEV_2826, usable instead of the RSTe RAID ROM v3.x, credits go to Nodens for his work on the v11.6.0.1702 ROM.