[Request] How to Boot XP on a 64 bit EFI System (HP Prodesk 600 G1 Twr)

Hi I was saying if I could actually boot a 32 bit windows xp on 64 bit efi since I almost have been testing on vmware for almost 3 weeks or more to get windows xp sp2 x64 working no matter how I tried it gave me different error codes but when I get windows xp sp3 it works perfectly fine if so can I run windows xp sp3 on a 64 bit efi system @Fernando thanks

Edit: internet doesn’t work on win xp sp2 x64 so that’s also why I want to run windows xp sp3

Edit by Fernando: Thread title shortened and customized


not winXP 32bit, winXP 64bit might work but its a complicated process to setup and there is no guarantee it’ll work.

yes you’re right in the post Boot WinXP 32-bit/64-bit on UEFI 32-bit/64-bit I have posted a lot of posts I also done some bcd editing and I get error code 0xc0000225

a grub efi loader can load a 32 bit efi on 64 bit efi am I right? my system is also a uefl class 2 system since it gives the option for legacy boot

waiting for a response…


If you have legacy boot as an option you can save yourself alot of headaches by just using that to boot XP instead.

can’t do that since I dualboot windows 10 and 11 in uefi GPT then I can’t install windows xp on gpt also I don’t have a secondary hard drive to install on also I’m not trying to risk my machine to convert to mbr since the last time I converted to gpt after that the power went out thank goodness the power didn’t cut during the conversion so I’m scared if this happens during the conversion (sorry for bad english)

With some work,
I think you can boot XP from GPT also

ok so how will I do that?
I saw a custom grub bootloader made by AIOBOOT on youtube and it allows to boot from gpt partitions in legacy mode I can also install that bootloader onto a usb flash drive then change in bios settings from uefi to legacy boot and I can boot windows 10 from a gpt partition in legacy boot

also I think I will need to put the legacy boot files in the esp (EFI system partition) then I can boot from the usb then boot into windows 10 in legacy boot

but how will I do it for windows xp? if I can… my system has 8 gigs of ram!!
that’s a problem

also for @infuscomus where is the option in XP2ESD that allows me to boot from (bcd & winload.efi)

EDIT: paragon GPT loader may get windows xp working on gpt disks

Guess what guys I found that my system is a UEFI class 3 system since when I try to boot windows 7 install usb in UEFI it’s stuck on the “Starting Windows” screen


you need UEFIseven


wait hold on can the uefiseven fix the windows xp not booting on uefi? this error code I mean

Windows Boot Manager
windows failed to start. A recent hardware or software change might be the
cause. To fix the problem:
1. Insert your windows installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer."
If you do not have this disc, contact your system administrator or computer
manufacturer for assistance.
File: \WINDOWS\system32\winload.efi
Status: 0xc0000225
Info: The selected entry could not be loaded because the application is
missing or corrupt.

@Geilp any help please I want to boot windows xp x64 uefi on my machine sad because I want to get windows xp sp2 x64 bit uefi working on my machine

Oh sorry, you said windows 7 install usb in UEFI I assumed you were installing windows 7.

my goal is to boot windows xp x64 in uefi right now I just want to fix the error I gave @Geilp


any tips to help @windows2.0uefi boot XP x64 in UEFI?


no way about this this is so shocking https://ibb.co/BTsfjCG the grub bootloader could load DOS too in uefi csm disabled

it’s just like UEFI duet which emulates x64 uefi firmware under a legacy bios machine but this is opposite so it emulates legacy bios under uefi with csm off

I know about uefi duet but I didn’t know about the grub loader

This is the first time I’ve heard of anything like that.

I’m a bit skeptical that it’ll boot DOS on 64-bit UEFI without CSM.

I think you should read this XP/W2k3 x86 on Modern Hardware (126)

XP/W2k3 x86 on Modern Hardware (127)


oh and this


I need help with this error I managed to get to auora screen (which is good news) but now I get this