[Request] How to get XP x64 installed onto an NVMe SSD?

I’ve got an install with XP64 - It’s been tough which I’ll mention later on but it’s a good install, however there are some troubles.
I’ll keep it brief with just one problem at a time will be mentioned - I’ve tried to get system restore working but there is an error message please see below
>>>> "the ordinal 324 could not be located in the dynamic link library SHDOCVW.dll <<<<<<<<
This is more a niggle but I don’t have a clue how to fix this so some detailed simple instructions will be needed and much appreciated if there could be some assistance with this otherwise this won’t get sorted out - Thanks

EDIT - Exactly the same error has occurred after installing the Storport NVME driver - as there is a yellow exclamation mark against the driver install.
>>>> "the ordinal 324 could not be located in the dynamic link library SHDOCVW.dll <<<<<<<<
This is very close to please assist if possible thank you.

Edit by Fernando: Since fraz’s problem obviously has been caused by the OS XP x64 and has nothing to do with his/her specific mainboard ASRock X99 Extreme 4, I have generalized the title to open this thread for users with another mainboard/chipset with native NVMe support.

I’ve read that KB932755 is a needed update for XP64 or similar - It isn’t on Microsoft download anymore - Are there other links to this file?
I’ve tried this again and the files have been removed from Microsoft website.

The 1.5 Mini Storport driver 1.5 has installed but not properly as there is a yellow exclaim mark against the install of the driver.
If someone has links to ALL necessary XP / Server 2003 updates - (if they are needed) this would be massively helpful.

Thanks in advance

I’ve got the Community OFA NVMe 1.5 Storport by Schtrom - But it won’t quite install correctly.
I’ve tried the KB943545 update but the system will not boot after this has been installed.

Is KB932755 needed here? - Please mention - Thanks
Samsung 970 Evo Plus is connected right now - Does this one work with XP64?

@fraz :
According to the Readme.txt file, which is within Schtrom’s latest OFA NVMe driverpack, you have to install a specific storport.sys driver before starting with the NVMe driver installation.
Good luck!

Hello Fernando,

The text file you refer to mentions installing KB943545 which contains an updated version of the Storport driver - This has been installed - Then I try to install the INF for the 1.5 Schtrom driver which doesn’t install properly. Then with the NVME inserted into PCI-e slot it does not boot XP as it freezes

@fraz :
You should ask Schtrom how he got the OFA driver properly installed and working.
By the way - as far as I remember he made his tests with Windows Server 2003 x64 and not with Windows XP x64.

Hello again,
Where would Schtrom be contacted? - I’m stuck on this big time - I did read somewhere that KB932755 is an updated improved update after KB943545 (but I’m not 100% sure) but I can’t get KB932755 it has been removed from Microsoft website and the link was dead.

Do you happen to have KB932755 in your backups?

Alright @fraz i gotcha, it comes as a .exe file as it was the only version of the update I had on my backup drive (apologies)

I have 3 mirrors for the download, pick whichever one you prefer


Since Schtrom is a member of this Forum (look >here<), you can send him a PM.


Simply got every needed standalone drivers here

Edit by Fernando: Link removed due to a violation of the Forum Rule Nr. 17

Alright @fraz i gotcha, it comes as a .exe file as it was the only version of the update I had on my backup drive (apologies)
I have 3 mirrors for the download, pick whichever one you prefer

OK Aquavision - This is very helpful indeed - I don’t know for sure if KB 932755 will be the needed update to make the difference between NVMe working and not working - I do know the KB943545 made the system freeze on boot (s_sata_0) after this KB with the PCI-e card with NVME in system (non_boot) - I’ll try this out now - It’s good I’ve got Macrium Reflect to restore an image after this ! - Its been needed!

@Aquavision :
OK - Lets take this steady

The KB has been applied and now I’ve got both KB’s 932755 & 943545 - Then I proceed to install Schtrom NVMe V 1.3_20180719 or V 1.5_20180719 - A box flicks up in XP64 saying:
The file 'nvme.sys" on NVMe installation disk is needed - There is the usual browse box to locate to this file
Is this the .sys file from Schtroms driver? or is this the .sys file from XP64 OS?
>>> I did take a look @ C:Windows\System32\drivers\storport

Edit - An update was done to IE (Internet Explorer 8) via an XP update package (total) that was downloaded a year or two ago.
When I navigated to NVMe .sys file (presumably from Schtroms driver) the driver installs but has a yellow exclaimation mark against it and XP signifies a problem has occurred and the driver is not installed correctly. I’ll read a post from George King and see if there is anything there.
I’ll contact Schtrom if this is possible - Thanks for now

EDIT - Then after the NVME driver was applied with PCI-e riser card installed with NVME’s the system hung on boot of XP64 - Then the PCI-e riser card removed and then XP64 boots up again.
Something else needs to be done - If anyone has other ideas please menton them - I’ll try to contact Schtrom if possible - Thanks

Edit by Fernando: Unneeded fully quoted post replaced by directly addressing (to save space)

Right OK,
The best that can be done is to install the driver but with a code 10 error - The device manager clearly shows the Community OFA NVMe driver but with a yellow exclamation mark against the device manager entry.
This is after installing IE8, KB943545 & KB932755 - I don’t know what else can be done

I don’t know how to contact Schtrom either.
If a re-start was now attempted the XP64 would hang @ boot splash screen XP64 logo - Unless there is a solution found soon I’ll have to forget about NVMe drive on XP64 - Thanks


As you can see >here<, our Forum member schtrom has been online here today. What about tagging him by using the @schtrom option?

Thank you for the strom link to send him a PM - I had no idea he was on this forum - Thanks

I’m going to be really honest here; I don’t know who Schtrom is, so I cant really help here. I like to take it vanilla (if any way possible).
If you need any sort of NVMe driver don’t be afraid to drop me a message.

Schtrom (his nickname is schtrom) is a member of the Win-RAID Forum and has much experience with the OS Windows Server 2003 x86 running on an NVMe SSD. For this purpose he has built specific W2k3 compatible 32/64bit OpenFabrics Alliance (OFA) NVMe drivers v1.5.1200.
The problem is, that schtrom obviously had only tested the 32bit variant with the OS W2k3 x86, whereas the thread opener fraz wants to run XP x64 and gets an error message, when he tries to install schtrom’s modded 64bit OFA NVMe driver.
That is why fraz is searching for an other or better XP x64 compatible NVMe driver.

Alright @Fernando , thanks for the info!

Hello again,

I’ll chip in here - It’s great to be able to install XP - This is getting easier now I’ve got the hang of it - By the way I’m not looking a better NVME driver - I was sort of hoping for an update that would make the driver work !

It looks like I’ll forget the idea of NVMe on XP if this is not possible - XP64 can be booted from S-Sata 0 or Sata 0 but would only install on S-Sata 0 with DVD optical drive also in an S-Sata port - Using Sata ports installation of XP64 did not work.

Like I mentioned XP64 boots in S-Sata 0 which is in AHCI mode only but the Intel Sata ports work in RAID 0 mode and this works great from what I’ve seen so this could be useful (possibly).

AsRock X99 Extreme 4 has two SATA controllers - One for the S-Sata ports (4) and another for the main SATA ports (6) - The weird thing here is that Fernado’s IRST MSM console works on the S-Sata ports only but ALL 10 SATA ports work with XP64 !

Getting NVME to work would be great icing on the cake - !

Hello folks,

for some time I have followed schtroms driver releases for NVMe Driver for XP64. Altough there is a modded Bios available to boot from NVMe for my sacred Asrock z77 Extrem 4 I am not able to succesful install schtroms driver. The SSD is recognised as Strom OFA device but the system freezes while installing the driver. I have used different NVMe drives to no avail. The required patches storport are installed. Therefore I would love to solve the issue but no idea how to. Anyone here to lend a hand ?