[Request] HowTo RollBack to an older HP Insyde BIOS

Hp 15da1018ne
Intel 8th Gen core i5
16Gb Ram DDR4
15’’ Display

I Got issues after Upgrading my bios from F16 to F19 version. now i want to rollback to previous one F16, so Anyway to RollBack To the previous Official Hp Insyde Bios RSA Signed !! I Have the the bios unencrypted F16.bin and F16.s12 file too? i tried to make flash stick with the bios and press window key+b but it’s not working. only working with the latest version F19 so Please Help Me.

Edit by Fernando: Thread title shortened

@Zeca123 - Unencrypted helps nothing here, you already know it’s RSA signed, so no need to unencrypt anything you can’t modify it. What issues are you having anyway?

Show me image of the error you get, and link me to the stock exe for F19 and F16. I may be able to modify the flasher for you, but I need to see the exact error you get when you try to flash back using standard flashing method with F16 (not the recover method you mention)

C:\Users\mhmdn\Downloads\Flash Programming Tool\WIN64>fptw64 -f 08532.bin
Intel (R) Flash Programming Tool Version:
Copyright (C) 2005 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

Error 167: Protected Range Registers are currently set by BIOS, preventing flash access.
Please contact the target system BIOS vendor for an option to disable
Protected Range Registers.

FPT Operation Failed.

C:\Users\mhmdn\Downloads\Flash Programming Tool\WIN64>fptw64 -i
Intel (R) Flash Programming Tool Version:
Copyright (C) 2005 - 2019, Intel Corporation. All rights reserved.

Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q128FV ID:0xEF4018 Size: 16384KB (131072Kb)

— Flash Image Information –
Signature: VALID
Number of Flash Components: 1
Component 1 - 16384KB (131072Kb)
DESC - Base: 0x00000000, Limit: 0x00000FFF
BIOS - Base: 0x00300000, Limit: 0x00FFFFFF
CSME - Base: 0x00001000, Limit: 0x002FFFFF
Master Region Access:
BIOS - ID: Read: 0x000B, Write: 0x000A
CSME - ID: Read: 0x000D, Write: 0x000C
GbE - ID: Read: 0x0009, Write: 0x0008
EC - ID: Read: 0xFFFF, Write: 0xFFFF

Total Accessible SPI Memory: 16384KB, Total Installed SPI Memory: 16384KB

FPT Operation Successful.

the stock flasher hide the update button when i tring to flash the F16. but when i try to flash F19 as the current bios it always be active and i can update.
the problem with the certification i think.

Thank you for all of you efforts to helping me. this is the stock bios exes which you requested for F16 and F19 link in mediafire:


My Model is 08532

@Zeca123 - First, I meant I wanted to see the official HP error, using it’s stock flash files. FPT Error 167 is a pain sometimes, other times you can get around it easily.
When it’s a pain, nothing will get you around it except a pinmod or flash programmer. When it’s easy, it’s simple, put system to sleep (S3) for one minute, reboot and try to FPT flash again.

Please do keep in mind, NEVER flash stock BIOS or stock BIOS region with FPT. Only flash a dumped BIOS region with FPT, so in this case you cannot, unless you dumped your BIOS region from F16 before you flashed F19.
If you did, then great, try to proceed forward, if you did not make a FPT backup of your BIOS region while you were on F16 BIOS then stop now, FPT is not something you should be trying to resolve this issue from here on out.

Thanks for explaining about what happens with stock files. So to clarify, when you run F16’s exe the update button is gone?
Please link me to the BIOS download page so I can grab these exe files from HP

First thank you very much about you time and helping.
Unfortunately i did’t dump the F16 bios before upgrading.
And Yes when I trying to run F16 update the button of the update has gone. Disappeared.
For some reson Hp has removed F19 from its website and only F16 available but i have a copy of both F16 & F19 uploaded to mediafire above.

Yes, I assumed you didn’t dump BIOS region with F16, that’s why I added all that bold info above. Maybe they removed F19 to fix it, allow flashing older, or fix the issues you were having, you may not be alone. What issues are happening anyway?
Please link me to the F16 from HP site then for now, I will check it out. Never mind

Thank you again for the fast reply…
The F16 link from Hp:
And i olso upload the both F16 & F19 to mediafire and the links above in the comments.
Maybe you are right about removing the F19 from the website thats I’m not alone, the issue was A huge battery drain, unstable wifi, And finally my hackentish wont boot any more after updating, I got acpi error and i’m sure its a bios related issue.
Unfortunately hp doesn’t allow the F16 after removing F19 :frowning: .
My model is 8532

Thanks - here, try this, and let me know what exact error you get if any - http://s000.tinyupload.com/index.php?fil…469726675916535
Yes, maybe they will either fix F19 BIOS, or put new older F16 if that’s last previous, you’ll have to keep watching the site, or email them and see what’s going on.
* edit - sorry, forgot to mention what to do >> Extract archive, then run Insydeflash.exe and then show me image or tell me exact error you get, if any

Thank you again, when i run InsydeFlash.exe i got this screens attached.
As you see update button is hidden, i have no choice to do except i can extract bin files or recovery mode
the last which is not working for F16 but working for F19.
i tried to make a trick, to delete bin files from the F16 folder and replaced them with F19 version in the same F16 folder. the update button return back working and i can update but to the same F19. that is meaning the problem in the .bin file itself or .s12 file !!



@Zeca123 - Is this from the package I sent you?? .s12 is the RSA signature only, anytime you change xx BIOS for xx BIOS also switch that .s12 file to it’s original to match too.
Anyway, is the above images after you run Insydeflash.exe directly from the package I sent you? If yes, lets enable logging so we can see what’s stopping it from offering the update, since I already removed BIOS version compare and some other changes as well.

If you did not try Insydeflash directly from the folder I sent you please do that. If those images are from what I sent, there here is two platform.ini files, inside folder one is same as what you have now, but with log file enabled.
Using the package of files I sent you - Please replace platform.ini with file from folder 1 and then run insydeflash again and send me the log it creates once done (InsydeFlash.Log).
Once you do this, delete that log file, and replace platform.ini again with file from folder two, run insydeflash and if still no update allowed send me that log.

Yes sure the screens from the package you sent me.
I will do the tutorial and back to you again

log file when using folder 1 :
but update still unavailable after replacing from folder 2
log file when using folder 2 :

Please delete all temp files and folders, then try again w/ #3 (If #3 fails to allow UI to open, delete and use 3a instead)

If that fails, in folder 4 is a modified file (remove the M from name if you use, in case it matters), up to you if you want to try, if so use #3a platform.ini above.
I used EZH2O to change this file to version F.20, so it’s “Newer” version, checksum and signature still same so I think it can still use same RSA signature file.

Also, you can try, open command prompt from the folder of files I sent you (select that folder itself, hold shift and press right click, choose open command window here - not power shell) Then run this command >> insydeflash.exe 08532.bin -forceit

If all those platform.ini’s fail (up to #3a) then I think it may be reading some platform.ini from current on board BIOS, overriding the platform.ini we’re editing, the log shows it’s found and used, but you know that might not be final thing it’s using.
Send me new logs from 3/3a if they fail

* Edit - see also, 4th reply here and try that method if you have not already (use the extracted F.16 08532.bin file, and put the s12 file on there too)

This method may be required instead of the above HP provided crap, and be sure to label the FAT32 volume as HP_TOOLS when formatting (RSA.Sig file is your .s12 file)

Thank you. Thank you Thank you
I don’t find a word to thank you.
It works
Finallllllly it works
Now i’m on F16

@Zeca123 - Sweet, happy I could help! You’re welcome! So I know next time around, which method finally worked?

I put the the modified bios biosm.bin + bios.s12 into a usb flash stick and make a recovery. A strange message appears for the first time for me “flashing boot block” and a loading screen appears below, Then the loading suddenly stopped in the middle and the laptop restarts again. after restart the laptop boots normally. then i go to the original F16 flash folder and run insydefladh.exe. The update button return be active again do not how. After i clicked update i got a new warning message that you are trying to flash older bios F16 ok?. I clicked ok to proceed, the bios flashed back to F16 normally. Thank you again for all of your time.

Thank you

Hello everyone,
I am having the same problem of @Zeca123 but a different hp laptop (15-ah150na); I want to downgrade my bios because the last update badly messed the dsdt. I tried to follow the procedure @Lost_N_BIOS suggested in post #13 and modified the bios version, but I keep getting the same "signature not found" error. Since I am not very familiar with insyde bios modification, could you explain me, or point me to where I learn, how to modify the bios version without changing the checksum of the file?

Mod is not possible with RSA Signed BIOS. You’re only option is to dump the BIOS with flash programmer and modify that, and that may also fail to boot.
You certainly can’t use anything posted in previous replies here, since you do not have the same laptop!!!

I can make you mod BIOS like I did for Zeca123, but he was lucky it didn’t brick, and recovered, you may not get so lucky so maybe get CH341A programmer + SOIC8 test clip with cable first.

You should try method linked last at post #13 while you wait on programmer to arrive.

Thanks, for you reply. For some reason I don’t know HP emergency recovery doesn’t work on my laptop. Probably programmer and clip is the best solution at this point, I have never used it before, but I imagine there is a first time for everything.