[Request] HP Envy 3290nr BIOS with Enabled iGPU

I’m new to the forum and I’m just wondering if anyone can help me enabling the onboard graphics and disable the dedicated graphics.
I’ve been having issues with the dedicated lately show no display at times so I’m hoping using the onboard will add some life to my laptop.
link to the bios: sp60458.exe on hp website. and it’s the 01853.fd when I tried to hexedit the backup I made.

Thank you in advance.

Edit by Fernando: Thread title simplified and customized

Without having an SPI chip programmer you can not really do anything with this BIOS.

Hi Sweet Kitten, thank you for the reply. I’m actually thinking about doing it, I have the programmer but I read it somewhere there may be some checks and may get stucked on boot loop. Is there any specifics when flashing it via programmer? Thanks again.

Yes, everything is right, unless you take measures to disable checks. But this is a common practice with HP laptops. I can easily do this.

Thanks again, I appreciate it if you could maybe make it or if possible to share how you’re going to do it?

here’s what I tried but no luck after saving the changes and flashing it through dos environment.
I’ve used phoenix tool which decrypted the bios file and loaded it through H2OEZE-W

I will be editing two BIOS modules. Find out what, starting from post 19 in this thread.

Thank you I appreciate it. When you get a chance, do you mind editing this bios file?

That post is very informative however I’m still trying to wrap my head around it lol.
I was trying to extract the menu information for unlocking too if possible but the ifr extractor quits before saving the information.

Anyhow I’ll probably be ok with just getting the dedicated graphics disabled and just use the integrated graphics if possible.

By loading the 01853.fd file into SPI flash memory you will lose your system information.

Can you help with me with this bios for spi flash? I believe the edit I made here is fine https://ibb.co/JjVwq1q

I tried looking for the signature check hoping this is the right one

I search for the signature HSS$ and found 4 places, I extracted the body on the first result as well as the last TE Image

Here’s what I found in ida when I searched for the hex of $HSS inverted

Should I follow the jump or go back up and bypass this call?, looks very different from the screenshots I’ve seen here

this is the other one on the DXE PEI

I read it on other threads to just find the caller of this subroutine and bypass this call totally?

I also notice on the UEFI Tool, I don’t have the option to replace

Also if all edits are good, is it just a matter of loading the edited bios file to spi programmer and flash it?
You mention loading the said file

will lose system information? are you referring to info like the S/N?

Thanks again for the help.

Just upload your BIOS backup and I’ll edit it.


here it is:

if you could please disable the dedicated graphics, I just need the integrated.

Thanks again.

It is 01853.fd -> BIOS from support page. Not a dump or backup of any sort.

Hi, yes that is from the official HP support page https://ftp.ext.hp.com/pub/softpaq/sp60001-60500/sp60458.exe

So, why do I need this file? You will lose your S/N flashing it.

oops sorry my apologies, I misread your previous reply about the back up

here’s the backup https://drive.google.com/file/d/1IAPjJF7g6HSYHAqzXwHOwZ2qWrbYoBAg/view?usp=sharing

this came from the output of insyd flash tool ran from dos

I haven’t remove the bios chip yet for reading but let me know if you need the reading from the full bios chip

- just in the process of disassembling at the moment.

Thanks again

BIOS mod: rhein021.bin.

Thank you very much! I will flash this using the programmer and I will update with results.
THanks again for you patience

OK. I ask you in advance not to rush to assemble the device. First, see if the device boots.

Ok so I it flashed, powered on but still no display. The dedicated gpu seems to be heating fast so that might be the problem.

Thank so much for your time. I really appreciate it so as this forum.

Thanks again.

Yeah, that’s cause I messed up disabling protection. Thus, try this one.