[Request] Intel HD Graphics 530 Driver for Vista 64bit

Is there a modded driver for this igpu to work under Vista? I couldn’t even get the igpu running using the most oldest driver from 2015 and I’m already trying to modify the inf file but still not working

CPU: Intel i5-6600
iGPU: Intel HD Graphics 530

Edit by Fernando: Thread moved into the “Operating Systems” Category and thread title customized

Welcome to the Win-Raid Forum!
Which driver version have you already tried to install (the normal way or by using the “Have Disk” button)?
By the way - if you want to get a modded driver for a specific device (here: Intel HD Graphics 530), you should mention its HardwareIDs (VEN_XXXX&DEV_XXXX).
Good luck!
Dieter (alias Fernando)

1 Like

I’m installing my modified driver using have a disk button and my hardware id is PCI\VEN_8086&DEV_1912

Does this mean, that you got your modded driver properly installed? If yes, which driver version did you use?

Yes the driver is installed but it giving a warning sign in the device manager and sometimes a blue screen appeared after rebooting and I’m using the driver version and v15.

I repeat my question: Which specific driver version did you install?
Which kind of error messages do you see within the Device Manager?

The error is the device cannot started and the error code is 10 and sometimes is 39 and sometimes is just blue screen

https://www.intel.com/content/www/us/en/support/articles/000090440/graphics.html try drivers for win7

I’m already tried to modify the win7 driver but still not working

Try isntal older drivers since its windows vista, or you can use update driver tool “Snappy Driver Installer”
This tool updated Windows xp drivers on my not designed to xp.os laptop so there is chance

I already tried using snappy driver installer the lite version but when I try to download only the index the downloading process is not starting it just stuck at 0 MB

Download indexs is the first thing what you need to download in this tool.

But when I tried to download the index it just stuck on 0 MB

these are stricte to your integrate graphic card:

I already tried using the driver from your links and modified the inf but still not working

Have you tried installing the driver with the Extended kernel?

I already tried to install driver with extended kernel installed but still not working

You can try to delete “Snappy Driver Installer” from your PC and all realted files mean “folder wher you installl it”, unizip it again i and give it a try to download index.

I already tried your suggestions but the snappy driver is still giving the same issue as before

Also have you tried installing the driver by going to Device manager, installing legacy hardware option, selecting the Inf file for the HD graphics, and installing the driver that way?