[Request] Lenovo IdeaCentre Y910 Mod SkyLake to KabyLake

Hi! I just need someone to insert 7th Gen microcode for my bios (it’s AMI Aptio V).
I was trying but what I got was a black screen.
I have programmer.
Thanks in advance.

Biosy910-original1.zip (4.17 MB)

Please, someone could give me a tip? I tried this ways:
1º With MMtool64, erasing the original microcode 506E3 and inserting the 906E9 (only I can set one microcode due to the was not enought room on the image). I got Black Screen.
2º With UefiTools following the @davidm71 tutorial, getting the same result, Black Screen.
3º With UBU in olders versión, changing microcode. Result: Black Screen.
4º With UBU in last version updating the microcode but changing the 906E9 name for 506E3 name getting Black Screen.

I suppose that there is some problem with the microcode size and perhaps with the modules location.
I’m a begginer, so please, help.

Edit: I checked my dumpedbios.bin file from my bios and I got wit ME Analyzer a lot of red lines like this:

Error: MFS Data Page 26175 > Chunk 2238 CRC-16 is INVALID!

I suppose that the problem could be for this reason. I will do all the process again.
I hope this is the problem.

Edit1: No lucky, that was no the reason.
Help!! ;-(

Ok. Now I understand that I have to do more things, not only change the microcode.
I was looking online and I didn’t find any information about adding 7th gen support.

Any clue?

@Lestero - What is old CPU model, and what is the new CPU model (7th Gen) you’re trying to do this for?
Simply saying 7th gen doesn’t help me to know your goal here. What you want may or may not be possible, but I need more info before I can comment further on that.

What is your BIOS chip ID, read it with your eyes, do not rely on software to tell you.
And what software/version did you make the dump in post #1 with, and have you programmed that back to the board and it booted successfully or not?

Also, please link me to the stock BIOS download page (not directly to BIOS), and tell me what BIOS version you are using.

First of all, thank you for answering.

My original CPU was an I5-6500 but I upgraded to an I7-6700. Now I have an I7-7700. I flashed a GA-H170N-WIFI bios (with 7th gen support) to my pc just to try and it worked with my I7-7700 processor but without sound and other things.
My BIOS Chip ID is: Windbond 25Q64FVS1Q - 1634 I did the dump with CH341A Programmer v1.29
The stock bios page is: https://support.lenovo.com/es/es/downloads/ds118645
There is only one version for the bios v28. I use this for my bios.

I want to say thank you again. I was feeling alone ;-).

You’re welcome! So, this is SKY >> Kaby mod What is your motherboard chipset?

For W25Q64FV you should use 1.30 or 1.34 and W25Q64BV ID - Or Colibri (all included here)
I am not sure if 1.29 can read or write to this chip, and or if you need to use BV ID like 1.30/1.34
If you cannot program back your original dump with 1.29, or the info above, then that is a bad dump and 1.29 should not be used here.

What!? So you flashed some Gigabyte BIOS to this board?? If yes, why, what made you think to do that??

So, clear things up for me. Can you put back in your old CPU now, and program back in your original BIOS dump, and all is OK?
If yes, great, please send me new dump, made after you confirm that, using the info above and one of those programs/versions.

Yes, much more than microcodes needs changed here, you also have to update ME FW to certain version, vBIOS and GOP need updated as well, and microcodes
I think that is all, I don’t do it often, but I’ll look it up up and do it once I get started

You’re welcome!!! I try to help as many users as I can, but I can never keep up with everything.
Other users help here too, but not too many are familiar with messing around in OEM BIOS like this, so probably not too many peeked in here to see what you needed.

Here I’m again!!

My motheboard chipset is a H170.
I put back again my old I7-6700 CPU and I flashed my original bios (updated with ubu) and all works perfectly. I switch off my pc and I did a dump for you with Colibri and I leave the file attached.

Yes, why not? I looked for a mainboard with almost the same caracteristics (same bios size, same chipset, same processors, and 7th gen microcode). I’m brave and I have a programmer :-).

Thank you again.

@Lestero - Did you use BV ID?? If yes, maybe only FV works OK in Colibri?
That is bad dump, try again with 1.30 and W25Q64BV << This ID and version confirmed only working way by me personally for this chip, with 1.30 or 1.34 (I did not test Colibri, but others have, but I didn’t keep in my notes what ID they used with it)
You should have noticed, when zip was under 700kb


Yes I used BV ID with Colibri, but now I realized (thanks to you) that the first dumped file was wrong. Using HxD I compared yesterday’s file with today’s dumped files (with CH431A programmer v1.30-v1.34 and Colibri FV and BV) and are not the same (all the dumped’s files today with differents programs was the same).
I’m sorry, it was my fault for non checking the yesterday dump was not ok.
This is the correct dump file (I did it with CH431A Programmer 1.30 BV ID) - 4.1mb compressed file ;), Thanks again!!:

Now I realized that something is wrong because I have one SO-DIMM slot that is not working (I have two).
When I put a memory module the pc begins to beep, I don’t know why.

Pd: Ok. Forget it. It was some false contact in the pins. I will check it deeply because seems to not be well solded some pin.

LenovoIdeacentrey910bios130BV.zip (4.1 MB)

@Lestero - Blow out the memory slots, and clean memory contacts, may just be a bad contact (or may just have needed a re-seating of the memory stick)
Yes, your ME FW is messed up (unconfigured + Incorrect PCH strap length, so possibly corrupted as well) Looks like you updated it incorrectly somehow. Is your fans running at 100% now?
I will fix with copy from stock BIOS and send you this, before we do anything about this mod, that way you have a good copy of this BIOS as it should be
Here is your dump with fixed ME FW, that I then updated to latest version (, and unlocked FD - no other edits - https://ufile.io/5jqp2cs3

Now, I will work on your mod BIOS request, please wait

Hi Again!
My Pc lately sometimes was doing some strangers things, I’m sure because what you said. My fans works normally.

I downloaded and flashed my bios with your files and everythings looks ok.
I had problems with my device programmer when I’m flashing disconects from my Pc with Colibri, Programmer 1.34 and Programmer 1.30. (with BV and FV ID). I had to do it with Programmer 1.29 FV ID. It seems that my programmer is special or have something wrong.
Talking about my failing Memory Slot I continue with the issue. I cleaned up my pins with a brush and isoprophilic alcohol and the beeps continues. I will look for more solutions, like take a magnifier and check all pins weldings. I hope I will find the problem.

Thank you for your BIOS file and your interest in fix and develop my bios. It is great to meet people like you.

Yes, probably due corrupted and or unconfigured ME FW.
Disconnects are not due to software or versions, simply cable moved most likely. But if 1.29 works and boots properly after you write, and you can now see ME FW version in BIOS Main page (if shown) and with HWINFO64, and it looks proper (not N/A or then all OK

You’re welcome!!
I am working on mod BIOS you wanted, but had to ask for help with VBT issue, will get your mod done as soon as I get help with that (since you need UEFI boot to use NVME, this module is critical to the mod/update, vBIOS and GOP already OK for SKY/Kaby)
So, your mod BIOS needs >> update VBT (Orig is Sky only), downgrade ME FW, and swap in microcode >> on this, only room for one at a time, even if entire volume is manipulated, not enough room in free space even to make room for both

I’m looking for the trouble with my ram slot. I checked all slot pins with the magnifier and seems to be ok. Also I checked my CPU socket and I found some pins blended (2) and I puted it in his position. Checked pc again, but it continuos with the beep.
The slot 1 works perfectly, the slot 2 not.
The Pc beeps if I not put any memory or if I put the memory on the slot 2, it doesn’t matter If I put the other ram in the slot 1.
I’m thinking that weeks ago I used the Intel Extremme Utility and I was touching on the parameter of the ram, like latency, tCL, tRCD and other things but not voltage, trying to get the best performace for my ram and booting sometimes with beeps.

I was thinking…Could be saved on my bios one of this forced parammeters and do my memory slot 2 not work?

Anyway I will continue looking for something wrong (broken path or some capacitor).

Thanks again for all.

If you have bent CPU socket pins, this is very often the cause of messed up memory slots.
Be VERY careful with CPU socket pins, sometimes you can bend back with metal barrel tipped pencil (without lead inside), but be careful, move lightly and don’t break off tip of pin
Maybe best to leave as it is, and live with this damaged, before you make it worse!!! If you break off pin, sometimes can kill the board! And often when trying to fix, if you are not familiar with doing, you may end up damaging other pins too.

No, BIOS settings would not cause that generally, if you think so, reset BIOS to optimal defaults, but I assume above (especially since you mentioned already)

Thank you for the advice!!

I think I’m going to leave as is. Everything is working except this memory slot. I was seeking through the board but I found nothing. It’s a pitty I loose dual channel.

Talking about Reset BIOS I have a question. My mainboard has (like other mainboards) printed the words “clear CMOS” but I don´t know were. What I do is to disconnect the battery and wait.

Do you know where I have to close the weldings-pins? (see the attached picture).

Thank you again!!!


You don’t need to clear CMOS, you can just load optimized defaults, that would = same/same. But, no, I don’t know where the pins or tiny gold circle with line through it is on this system, if it even has either one.
If removing the battery does reset the BIOS, you can just do that, press and hold the power on button for 10-15 seconds to drain all power (main battery and PSU cable removed, assumed here) and then wait however long you’ve noticed that it takes to reset

You didn’t tell me that, besides the uncofigured ME FW you flashed in, that you also flashed in updated incorrect GOP, which is now included in your dump
I realized when other member here I asked to help about GOP told me different version was in stock BIOS. Next time you need help with BIOS, please always flash in stock BIOS first, then make any requested dumps
And or let person know what you have already modified up front, otherwise it leads to issues down the line when you don’t mention all this kind of stuff.

I will now swap back in correct GOP, and do the requested SKY/Kaby mods, please wait…
And don’t further break the system by messing around in there!! Yes, terrible you lost dual channel, might want to look for replacement board on ebay now!

Ok. Sorry for my mistakes. I will try to keep my hands on my pocket .
I’m waiting for the BIOS and thank you again for everything.
Perhaps, in a future I will think about buying another mainboard.

@Lestero - It’s not mistakes, well it is in general, but it’s more something you should tell person helping you up front so they know what you already did to BIOS.
So they can either proceed w/ file as is, or ask you to reflash stock BIOS instead first. And that is ideally is what you should do using stock method, then dump and send to me.
This will not fix ME FW area, but it will fix anything you changed in the BIOS region.

Is the two things I mentioned the ONLY things you changed in the BIOS before you dumped it and send to me? >> ME FW and GOP?
If not, and you made other changes too, please reflash stock BIOS using stock method, then dump BIOS again and send to me.
This way I’m not doing edits on top of failed edits, at least for the BIOS region anyway.
Stock update wont fix ME FW for you, only programmer or unlock FD and then other ways, but you already programmed in fixed ME FW now, so will be OK about that.

Yes, since CPU and GPU can be removed on this model, you can probably get board fairly cheap on ebay, then you would have dual channel again.

Hi @Lost_N_BIOS !!!

I was extracting and writting so many times that I’m not sure about what finally did. I have so many files that dumped and flashed that I’m not sure of anything.
The file that I gave you was updated by UBU (I think) with all the options updated.
Now I took all the files that I have and ordered per date and I attach for you the oldest file that I have dumped from my computer (that I suppose is the more original bios files that I have).

If this file is wrong or you prefer I flash again, tell me an I will do it.

Thank you.

PD: I’ve got Good News!!! I recoverd my Dual Channel Memory!!! It was fault of my socket pins. I took a very big magnifier and look at every pin. All seems to be ok but some just a very little misalinged. I put the cpu again and it works!!!
I will try not to touch too much.
Now I’m happy

Biosy910-original1.zip (4.07 MB)

Yes, since you are not sure, it would be best for both of us, if you flash stock BIOS again using stock method (ie run the exe to update), then dump with programmer and send to me.